アドインを追加または削除する

アドインは、Microsoft Excel にオプションのコマンドと機能を追加します。Excel の既定では、アドインはすぐには使用できません。まずアドインをインストールし、必要に応じて有効にする作業が必要です。

目的に合ったトピックをクリックしてください

アドインについて

Excel アドインを追加または削除する

COM アドインを追加または削除する

オートメーション アドインを追加または削除する

アドインについて

ソルバーや分析ツールなど、いくつかのアドインが Excel に組み込まれています。その他のアドインは Office.com のダウンロード センターから入手できますが、まずダウンロードしてインストールする必要があります。さらに、組織のプログラマやソフトウェア ソリューション プロバイダーなどのサード パーティが作成したアドインとして、Office.comCOM アドイン、Visual Basic for Applications (VBA) アドイン、DLL アドインなどもあります。これらのアドインも、使用するにはインストールする必要があります。

ほとんどのアドインは、次の 3 種類に分類できます。

  • Excel アドイン    これらのアドインには、通常は Excel アドイン (.xlam) ファイル、Excel 97-2003 アドイン (.xla) ファイル、または DLL アドイン (.xll) ファイルが含まれているか、オートメーション アドインです。ソルバーや分析ツールなど、一部の Excel アドインは、Excel または Microsoft Office のインストール後に使用できます。通常、これらのアドインを使用するには、有効にするだけで済みます。

  • ダウンロード可能なアドイン    その他の Excel 用アドインは、Office.com の「ダウンロードのホームページ」からダウンロードしてインストールできます。たとえば、Excel の [はじめに] タブをダウンロードしてインストールできます。このタブには、Excel で作業を開始するためのトレーニング、デモ、およびその他のコンテンツへのリンクが表示されます。このアドインをインストールした後、Excel を再起動するとリボンにタブが表示されます。Excel リボンからこのタブとそのコマンドを削除するには、コントロール パネルを使用してプログラムをアンインストールします。

  • カスタム アドイン    通常、開発者やソリューション プロバイダーはカスタムの Office.comCOM アドイン、オートメーション アドイン、VBA アドイン、および XLL アドインを設計します。これらのアドインを使用するにはインストールする必要があります。

アドインをインストールするか有効にすると、アドインとそのコマンドが次のいずれかの場所で使用できるようになります。

  • [データ] タブ。分析ツール アドインとソルバー アドインをインストールして有効にすると、[分析] で [データ分析] と [ソルバー] を使用できます。

    Excel のリボンの画像

  • [数式] タブ。ユーロ通貨対応ツールをインストールして有効にすると、[ソリューション] に [ユーロ換算] および [ユーロ書式設定] が表示されます。

    [数式] タブの [ソリューション]

  • [アドイン] タブ。その他のアドインは [アドイン] タブに追加できます。[アドイン] タブに表示される最初のアドインをインストールして有効にすると、このタブがリボンに追加されます。[アドイン] タブが表示されない場合は、Excel を終了して再起動する必要があります。

[はじめに] タブなど、その他のアドインは、Excel の他の場所 (リボンのタブなど) で使用したり、マクロやユーザー設定のメニューを介して使用できます。

ページの先頭へ

Excel アドインを追加または削除する

重要    ソフトウェア開発者は、作成したアドインのインストール プログラムや削除プログラムを設計する前に、以下の手順でオートメーション プログラムのインストールや削除ができます。

Excel アドインを有効にするには    

  1. [ファイル] タブをクリックし、[オプション] をクリックして、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。[アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、有効にするアドインの横のチェック ボックスをオンにして、[OK] をクリックします。

有効にするアドインが [有効なアドイン] ボックスに表示されない場合は、インストールする必要があります。

Excel アドインをインストールするには    

  • ソルバーや分析ツールなど、通常は Excel と共にインストールされるアドインをインストールするには、Excel または Microsoft Office のセットアップ プログラムを実行し、[変更] をクリックしてアドインをインストールします。Excel を再起動すると、アドインが [有効なアドイン] ボックスに表示されます。

  • 一部の Excel アドインはコンピューターに保存されており、[アドイン] ダイアログ ボックスの [参照] をクリックしてアドインを探し、[OK] をクリックすることでインストールまたは有効にすることができます。

  • 一部の Excel アドインにはインストール パッケージが必要です。インストール パッケージ (通常は .msi 拡張子のファイル) をコンピューターにダウンロードまたはコピーして実行することが必要な場合があります。

  • コンピューターで使用できないその他のアドインは、Office.com の「ダウンロードのホームページ」、またはインターネット上の他のサイトや組織内のサーバーから Web ブラウザーを介してダウンロードおよびインストールできます。必要に応じて、ダウンロードのセットアップで表示される手順に従って操作します。

Excel アドインを無効にするには    

  1. [ファイル] タブをクリックし、[オプション] をクリックして、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。

  3. [有効なアドイン] ボックスで、無効にするアドインの横のチェック ボックスをオフにして、[OK] をクリックします。

    多くの場合、アドインを無効にするとリボンのグループから削除されます。場合によっては、リボンからアドインを削除するために Excel を再起動する必要があります。

    メモ    アドインを無効にしても、コンピューターからアドインは削除されません。コンピューターからアドインを削除するには、アドインをアンインストールする必要があります。

Excel アドインを削除するには    

重要    ネットワーク ファイル サーバーまたは共有フォルダーから Excel アドインをセットアップした場合は、そこからアドインを削除する必要があります。CD-ROM から Excel アドインをセットアップし、アドインのインストール後に CD-ROM ドライブを新しいドライブ文字に割り当てた場合は、CD-ROM からアドインを再インストールします。CD-ROM から Excel アドインを実行している場合は、Excel アドインをアンインストールした後、CD-ROM から再インストールします。

  1. Excel を終了します ([ファイル] タブをクリックし、[終了] をクリックします)。

  2. Windows Vista で、 ボタンの画像 ([スタート] ボタン) をクリックし、[コントロール パネル] をクリックします。次に、[プログラム] をクリックし、[プログラムと機能] をクリックします。

    Windows XP の場合は、[スタート] ボタンをクリックし、[コントロール パネル] をクリックします。次に、[プログラムの追加と削除] をダブルクリックします。

  3. 次のいずれかの操作を行います。

    • Excel を Microsoft Office の一部としてインストールした場合は、インストールされているプログラムの一覧で [Microsoft Office] をクリックし、[変更] をクリックします。

    • Excel を個別にインストールした場合は、インストールされているプログラムの一覧で目的のプログラム名をクリックし、[変更] をクリックします。

    • Office.com のダウンロード センターからダウンロードしたアドインをインストールした場合は、インストールされているプログラムの一覧で目的のプログラム名をクリックし、[アンインストール] をクリックします。

  4. インストール プログラムに表示される指示に従って操作します。

ページの先頭へ

COM アドインを追加または削除する

重要    ソフトウェア開発者は、作成したアドインのインストール プログラムや削除プログラムを設計する前に、次の手順でオートメーション プログラムのインストールや削除ができます。開発者以外のユーザーには、次の手順は必要ありません。インストールや削除についての情報が必要な場合は、アドインのシステム管理者に問い合わせてください。

COM アドインを追加する

  1. [ファイル] タブをクリックし、[オプション] をクリックして、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの [COM アドイン] をクリックし、[設定] をクリックします。[COM アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、インストールするアドインの横のチェック ボックスをオンにして、[OK] をクリックします。

    ヒント    [使用できるアドイン] ボックスの一覧に目的のアドインが表示されない場合は、[追加] をクリックしてアドインを検索します。

COM アドインを削除する

  1. [ファイル] タブをクリックし、[オプション] をクリックして、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの [COM アドイン] をクリックし、[設定] をクリックします。[COM アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、削除するアドインの横のチェック ボックスをオフにして、[OK] をクリックします。

    メモ    アドインがメモリから削除されますが、有効なアドインの一覧にはその名前が残ります。この操作を行っても、アドインはコンピューターから削除されません。

  4. 有効なアドインの一覧から COM アドインを削除し、コンピューター上からアドインを削除するには、[使用できるアドイン] ボックスの一覧でアドイン名をクリックし、[削除] をクリックします。

ページの先頭へ

オートメーション アドインを追加または削除する

重要    ソフトウェア開発者は、作成したアドインのインストール プログラムや削除プログラムを設計する前に、次の手順でオートメーション プログラムのインストールや削除ができます。開発者以外のユーザーには、次の手順は必要ありません。インストールや削除についての情報が必要な場合は、アドインのシステム管理者に問い合わせてください。

  1. [ファイル] タブをクリックし、[オプション] をクリックして、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。[アドイン] ダイアログ ボックスが表示されます。

  3. オートメーション アドインをインストールするには、[オートメーション] をクリックし、[有効なオートメーション サーバー] ボックスで目的のアドインをクリックします。

    ヒント    登録するアドインが一覧に表示されていない場合は、[参照] をクリックしてアドインを検索し、[OK] をクリックします。

  4. オートメーション アドインを削除するには、レジストリから削除する必要があります。詳細については、システム管理者に問い合わせてください。

ページの先頭へ

適用対象: Excel 2010



この情報は役に立ちましたか?

はい いいえ

どのようにしたら改善できるでしょうか?

255 残りの文字数

お客様のプライバシーを保護するため、フィードバックには連絡先情報を含めないでください。 レビューしてください プライバシー ポリシー

ご意見をいただきありがとうございます。

サポート リソース

言語の変更