読み取り専用ビューをデザインする

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft Office InfoPath では、同じフォーム テンプレートのさまざまなビューを作成できます。ビューは、フォーム テンプレートにデータを表示する別の方法です。フォーム テンプレートに基づくフォームに入力するときは、ユーザーがフォームに表示されるデータの量を選択するビューを切り替えることができます。たとえば、ステータス レポート フォーム テンプレートでビューの概要ビューをデザインできます。ユーザーは、どのような種類の情報を必要に応じて、確認する必要があるビューを選択できます。

ここでは、ユーザーが編集できないビューをデザインする方法について説明します。また、動作規則を使用して、ユーザーが編集可能なビューでボタンをクリックしたときに、フォームの読み取り専用ビューに自動的に切り替える方法についても説明します。

目的に合ったトピックをクリックしてください

読み取り専用ビューをデザインする

編集可能なビューと読み取り専用ビューを切り替えるボタンを挿入する

ユーザーがフォームを送信した後に読み取り専用ビューに切り替えるボタンを挿入する

読み取り専用ビューをデザインする

読み取り専用ビューは、ユーザーのためにフォーム データを集計し、そのデータが誤って変更されないようにする場合に便利です。たとえば、ユーザーがフォームを Web サービスに送信した後、そのデータを変更できないようにするとします。ユーザーがフォームの [送信] をクリックしたときに、フォーム テンプレートがデータの編集可能なビューから読み取り専用ビューに切り替わるように設定できます。これにより、ユーザーは送信したデータを確認できますが、データを変更することは回避するようにできます。

  1. [表示] メニューで、ビューの管理] をクリックします。

  2. [操作] の [新しいビューの追加] をクリックします。

  3. [ビューの追加] ダイアログ ボックスにビューの名前を入力し、[OK] をクリックします。

  4. ビューにレイアウト テーブルとコントロールを追加して、デザインします。

    ヒント: 既存のビューに基づいて新しいビューをデザインするには、既存のビューを開き、Ctrl キーを押しながら A キーを押してビューの内容をすべて選択します。次に、Ctrl キーを押しながら C キーを押して、選択した内容をクリップボードにコピーします。[ビュー] タスク ウィンドウで、新しいビューに切り替えます。次に、Ctrl キーを押しながら V キーを押して、選択した内容を新しいビューに貼り付けます。このとき、不要なコントロールまたはレイアウト要素を新しいビューから削除できます。

  5. [ビュー ] 作業ウィンドウで、プロパティを表示する] をクリックします。

  6. [全般] タブをクリックします。

  7. [ビューの設定] の [読み取り専用] チェック ボックスをオンにして、[OK] をクリックします。

  8. ビューが読み取り専用かどうかをテストするには、[標準] ツールバーの [プレビュー] をクリックします。

  9. [プレビュー] ウィンドウで、フォームにデータを入力できないことを確認します。

  10. デザイン モードに戻るには、[標準] ツールバーの [プレビューを閉じる] をクリックします。

ページの先頭へ

編集可能なビューと読み取り専用ビューを切り替えるボタンを挿入する

通常、ビューはボタンおよび動作規則と連携して動作するようにデザインされているため、フォームに入力するユーザーが開始したイベントや操作に応じて、フォーム テンプレートでの特定のタスクを自動化できます。たとえば、フォーム テンプレートにボタンを挿入し、そのボタンがクリックされたときにビューを切り替える動作規則を作成できます。次の例では、[動作規則] ダイアログ ボックスで、フォーム デザイナにより、読み取り専用のサマリー ビューに切り替える動作規則が作成されています。この動作規則は、ユーザーがフォームでボタンをクリックするたびに実行されます。

[動作規則] ダイアログ ボックスの一部

ビューを切り替えるボタンを挿入する

  1. [表示] メニューで、ビューの管理] をクリックします。

  2. [ビューの選択] で、ボタンを追加する編集可能なビューをクリックします。

  3. [コントロール] 作業ウィンドウが表示されていない場合は、[挿入] メニューの [コントロールの選択] をクリックするか、Alt キーを押しながら I キー、C キーの順に押します。

  4. フォーム テンプレートで、ボタンを挿入する位置にカーソルを置きます。

  5. [コントロールの挿入] の [ボタン] をクリックします。

  6. フォーム テンプレートで、挿入したボタンをダブルクリックします。

  7. [全般] タブをクリックします。

  8. [操作] ボックスの一覧で、[動作規則とユーザー設定コード] をクリックします。

  9. [ラベル] ボックスに、ボタンに表示するテキストを入力します。

  10. [動作規則] をクリックします。

  11. [動作規則] ダイアログ ボックスで、[追加] をクリックします。

  12. [名前] ボックスに動作規則の名前を入力します。

  13. [動作の追加] をクリックします。

  14. [操作] ボックスの一覧で、[ビューを切り替える] をクリックします。

  15. [表示] ボックスの一覧で、切り替えるビューをクリックし、[OK] をクリックします。

  16. 開いているダイアログ ボックスをすべて閉じるには、[OK] をクリックします。

  17. 変更内容をテストするには、[標準] ツール バーの [プレビュー] をクリックするか、Ctrl キーと Shift キーを押しながら B キーを押します。

  18. [プレビュー] ウィンドウで、ボタンをクリックします。

    手順 15. で指定したビューが開きます。

  19. デザイン モードに戻るには、[標準] ツールバーの [プレビューを閉じる] をクリックします。

  20. ユーザーが編集可能なビューに戻ることができるように、読み取り専用ビューに 2 番目のボタンと動作規則を追加するには、読み取り専用ビューを開き、手順 3. ~ 19. を繰り返します。

ページの先頭へ

ユーザーがフォームを送信した後に読み取り専用ビューに切り替えるボタンを挿入する

次の手順は、送信されたデータの読み取り専用ビューを表示するフォーム テンプレートにボタンを追加する方法を示しています。業務報告書フォームで、ユーザーが既定のビューからフォーム データの読み取り専用のサマリー ビューに切り替えられるようにする場合などに、この手順を実行します。

注: この手順を実行できるのは、フォーム データを送信するための既存のデータ接続がフォーム テンプレートに含まれている場合だけです。送信データ接続を設定していない場合は、この手順を完了する前に設定しないと、後続の手順を実行できません。データ接続の詳細については、「参照」セクションのリンク先を参照してください。

  1. [表示] メニューで、ビューの管理] をクリックします。

  2. [ビューの選択] で、[送信] ボタンを挿入するビューをクリックします。

  3. [コントロール] 作業ウィンドウが表示されていない場合は、[挿入] メニューの [コントロールの選択] をクリックするか、Alt キーを押しながら I キー、C キーの順に押します。

  4. フォーム テンプレートで、ボタンを挿入する位置にカーソルを置きます。

  5. [コントロールの挿入] の [ボタン] をクリックします。

  6. フォーム テンプレートで、挿入したボタンをダブルクリックします。

  7. [全般] タブをクリックします。

  8. [操作] ボックスの一覧で、[送信] をクリックします。

  9. ボタン ラベルとして "送信" 以外のテキストを表示するには、[ラベル] ボックスにテキストを入力します。

  10. [送信オプション] をクリックします。

  11. [送信オプション] ダイアログ ボックスで、[ユーザーによるこのフォームの送信を許可する] チェック ボックスがオンになっていることを確認します。

  12. [動作規則を使用してユーザー設定操作を実行する] をクリックし、[動作規則] をクリックします。

  13. [フォームを送信するための動作規則] ダイアログ ボックスで、[追加] をクリックします。

  14. [名前] ボックスに動作規則の名前を入力し、[動作の追加] をクリックします。

  15. [操作] ボックスの一覧で、[ビューを切り替える] をクリックします。

  16. [表示] ボックスの一覧で、切り替える読み取り専用ビューをクリックし、[OK] をクリックします。

  17. 開いているダイアログ ボックスをすべて閉じるには、[OK] をクリックします。

  18. 変更内容をテストするには、[標準] ツール バーの [プレビュー] をクリックするか、Ctrl キーと Shift キーを押しながら B キーを押します。

  19. [プレビュー] ウィンドウで、フォームの送信に使用するボタンをクリックします。

    読み取り専用ビューが開きます。

  20. デザイン モードに戻るには、[標準] ツールバーの [プレビューを閉じる] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×