複数の InfoPath フォームを結合する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

InfoPath Forms Servicesサーバー テクノロジ、 Microsoft Office Forms Server 2007およびMicrosoft Office SharePoint Server 2007、 Microsoft Office InfoPath 2007フォームに入力する代わりに、または他に、Web ブラウザーを使用してユーザーをできるようにする] で使用できるはOffice InfoPath 2007クライアント プログラム。このテクノロジーによりより前のバージョンの Microsoft Office InfoPath でフォームへのアクセスを広くします。

この記事では、InfoPath Forms Services を実行しているサーバー上で、Office InfoPath 2007 フォームを結合する方法について説明します。

この記事の内容

概要

ライブラリ内の複数の InfoPath フォームを結合します。

概要

ライブラリは、チーム メンバと共にファイルの作成、収集、更新、および管理を行うことができる、サイト上の場所です。各ライブラリにはファイルの一覧が表示されます。また、ファイルを共同作業で使用する際に役立つ、ファイルに関する重要な情報も表示されます。

ライブラリに InfoPath フォームを保存することで、フォームを簡単に共有および追跡できます。たとえば、チームの進捗レポート フォーム用のライブラリを作成できます。フォーム テンプレート作成者がフォーム テンプレートのフォーム結合オプションを有効にしている場合は、ライブラリ内のフォームを結合することもできます。フォームの結合を使用すると、同じフォーム テンプレートに基づく複数の異なるフォームのデータを結合できます。フォーム データの結合は、複数のフォームのデータを比較または集計する場合に便利です。たとえば、進捗レポートを週に 1 回記入することになっているチームのマネージャは、複数のフォームのデータを結合して、マネージャ用の 1 つのサマリー フォームにまとめることができます。フォームを結合しても、元のフォームのデータは削除されません。ユーザーは、各フォームを個別に開くことで、元のデータを引き続き参照できます。

ライブラリ内のフォームを結合するには、そのライブラリの [表示] メニューの [ドキュメントの結合] を使用します。このコマンドは、フォーム テンプレート作成者が Microsoft Office InfoPath から新しいライブラリにフォーム テンプレートを発行したときに、ドキュメント ライブラリの [表示] メニューに追加されます。また、フォームの結合をサポートするサイト コンテンツ タイプが既存のライブラリに追加されたときにも追加されます。

[ドキュメントの結合] が使用可能になったら、ファイルを開かなくても、結合するファイルを選択できます。[ドキュメントの結合] を使用して InfoPath フォームを結合すると、InfoPath が起動して、選択したフォームから結合されたデータを含む新しいフォームが表示されます。フォームがブラウザー対応フォーム テンプレートに基づいている場合でも、新しいフォームは InfoPath で開きます。新しいフォームを元のフォームと同じライブラリに保存すると、そのライブラリ内の他のフォームと同様にブラウザ対応になります。

注記: 

  • ブラウザ対応フォーム テンプレートが常にブラウザで開くようにするには、ライブラリの [詳細設定] ページで [Web ページとして表示する] をクリックする必要があります。

  • 既定では、複数のフォームを 1 つのフォームに結合するときに結合されるデータは、繰り返しテーブルまたは繰り返しセクションに含まれるデータか、リスト コントロールまたはリッチ テキスト ボックス コントロールに関連付けられたデータだけです。ただし、フォーム テンプレートのデザイン時に、他の種類のコントロールのデータも結合されるように指定できます。

ページの先頭へ

ライブラリ内の複数の InfoPath フォームを結合する

ドキュメント ライブラリに格納されている複数のフォームを結合するには、次の操作を行います。

  1. まだライブラリが開いていない場合は、サイド リンク バーでその名前をクリックします。

    目的のライブラリの名前が表示されない場合は、[すべてのサイト コンテンツの表示] をクリックして、ライブラリの名前をクリックします。

  2. [表示] メニューの [ [表示] メニュー には、ドキュメントの結合をクリックします。

  3. [結合] 列で、結合するフォームの横にあるチェック ボックスをオンにします。

  4. [リスト] ツールバーで、[選択したドキュメントを結合] をクリックします。

    InfoPath が開いて、同じフォーム テンプレートに基づき、結合されたデータを含む新しいフォームが表示されます。

    注: ユーザーが InfoPath 電子メール フォームを結合するとき、繰り返しコントロールを基に結合されたデータには空白行が含まれる場合があります。たとえば、3 つの経費報告書フォームを結合する場合に、それぞれの繰り返しテーブル内に費用の行が 1 つ含まれているとします。これらの 3 つの経費報告書フォームをユーザーが結合すると、結合したデータを含む InfoPath 電子メール フォームの繰り返しテーブルには空白行が含まれている場合があり、その後に他の InfoPath 電子メール フォームそれぞれのデータ行が 3 つ続くことになります。

  5. 結合したデータを含むフォームを保存するには、[ファイル] メニューの [名前を付けて保存] をクリックし、フォームの保存先になる場所を指定して、[保存] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×