既存のデータベースからデータベース モデルへのリバース エンジニアリングを行う

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Visio Pro for Office 365、Microsoft Visio Professional、Microsoft Visio Premium エディションのリバース ​​エンジニアリング ウィザードでは、既存のデータベースまたは Microsoft Excel ブックからデータベース モデルを作成できます。データベース モデルはデータベースの構造をグラフィカルに表示するものです。テーブルやビューなど、データベース要素が互いに関連付けられるしくみを実際のデータなしで確認できます。新しいデータベースを効率的に作成することが可能になります。既存のデータベースの構造を理解できます。

この記事の内容

Visio Pro for Office 365 のデータベース モデリング機能を利用するには

リバース エンジニアリング ウィザードで抽出されるものを確認する

ウィザードを開始する準備を行う

既存のデータベースにリバース エンジニアリングを行う

Visio Pro for Office 365 のデータベース モデリング機能を利用するには

Visio Add-in for Database Modeling を利用することで、既存のデータベースからデータベース モデルを作成できます。このアドインは Visio Pro for Office 365 でのみご利用いただけます。ご利用中の Visio のバージョンは、[ファイル]、[アカウント]、[Visio のバージョン情報] の順にクリックすると確認できます。Visio のサブスクリプション バージョンの詳細については、「Visio Pro for Office 365」を参照してください。

Visio Add-in for Database Modeling をダウンロードする

  1. このアドインはここからダウンロードできます。

  2. ダウンロード ページで言語を選択し、[ダウンロード] をクリックします。

  3. 64 ビット (x64) 版または 32 ビット (x86) 版を選択します。ご利用中の Visio Pro for Office 365 のバージョンと同じものを選択してください。セットアップ手順を含む PDF ファイルのダウンロードも選択できます。[次へ] をクリックし、コンピューターまたはデバイスにファイルをダウンロードします。

  4. Visio を開いている場合、次の手順に移る前に Visio を閉じます。

  5. ダウンロードした MSI インストール ファイルを見つけ、ダブルクリックしてセットアップを開始します。メッセージが表示されたら [インストール] をクリックし、インストール画面でクリックを続け、インストール プロセスを完了します。

  6. これで、ご利用中の Visio Pro for Office 365 サブスクリプション プログラムでデータベース モデル図を利用できます。

リバース エンジニアリング ウィザードで抽出されるものを確認する

ウィザードによって抽出されるスキーマ定義情報は、DBMS (データベース管理システム) や ODBC ドライバーの機能など、いくつかの要因の組み合わせによって異なります。ウィザードには抽出できるすべての要素が表示されます。必要な要素を選択できます。たとえば、10 個あるテーブルから 5 個だけ選択したり、4 個あるビューから 2 個だけ選択したりできます。

ウィザードの実行中、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

ターゲット DBMS から利用できる範囲内で、次のアイテムを抽出できます。

  • テーブル

  • ビュー

  • 主キー

  • 外部キー

  • インデックス

  • トリガー (コードを含む)

  • チェック句 (コードを含む)

  • ストアド プロシージャ (コードを含む)

ウィザードを開始する準備を行う

Excel ブックをリバース エンジニアリングする場合、ウィザードを開始する前に、ブックを開き、列見出しを含むセルのグループ (または範囲) に名前を付ける必要があります。複数のワークシートを使用する場合、各ワークシートの列セルのグループに名前を付けます。ウィザードでは、この範囲がテーブルとして扱われます。セル範囲に名前を付ける方法については、Microsoft Office Excel のヘルプをご覧ください。

最良の結果を得るために、リバース ​​エンジニアリング ウィザードを実行する前にリバース エンジニアリングするターゲット データベースに既定のドライバーを設定してください。それにより、ウィザードはネイティブのデータ型を正しくマッピングできます。ウィザードにより抽出されるすべてのコードが [コード] ウィンドウに正しく表示されます。

  1. [ファイル] タブをクリックし、[新規作成] をクリックし、[テンプレート] をクリックし、[ソフトウェアとデータベース] をクリックし、[データベース モデル図] をダブルクリックします。

  2. [データベース] タブの [管理] グループで [データベース ドライバー] をクリックします。

  3. [ドライバー] タブで、Visio 提供のドライバーを選択します。ご利用中の DBMS に合わせて選択します。たとえば、Access データベースを設計している場合、Microsoft Access を選択します。

    Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

  4. [セットアップ] をクリックします。

  5. [ODBC ドライバー] タブで、ベンダー提供のドライバーをご利用中の DBMS に合わせて選択します。チェック ボックスにチェックを入れてください。たとえば、Access データベースを設計している場合、[Microsoft Access ドライバー (*.mdb, *.accdb)] チェック ボックスを選択します。

  6. 各ダイアログ ボックスで [OK] をクリックします。

ベンダー提供 32 ビット ODBC ドライバーは、バージョン 2.0 以降の ODBC データ アクセス パックのものをご利用ください。また、ODBC レベル 1 以上に準拠している必要があります。ベンダー提供 OLE DB プロバイダーは、OLE DB バージョン 1.0 以降の仕様に準拠している必要があります。

ページの先頭へ

既存のデータベースにリバース エンジニアリングを行う

  1. データベース モデル図の [データベース] タブで、[リバース ​​エンジニアリング] をクリックします。

  2. リバース エンジニアリング ウィザードの最初の画面で、次の操作を行います。

    1. ご利用中の DBMS (データベース管理システム) に合わせて Microsoft Visio データベース ドライバーを選択します。Visio データベース ドライバーを特定の ODBC データ ソースにまだ関連付けていない場合、[セットアップ] をクリックし、関連付けてください。

      Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

    2. 更新するデータベースのデータ ソースを選択します。既存のデータベースにデータ ソースをまだ作成していない場合、[新規作成] をクリックし、作成します。

      新しいソースを作成すると、その名前が [データ ソース] リストに追加されます。

    3. 設定に問題がなければ、[次へ] をクリックします。

    4. ドライバー固有のダイアログ ボックスがあれば、その指示に従います。たとえば、[データ ソースに接続] ダイアログ ボックスにユーザー名とパスワードを入力し、[OK] をクリックします。データ ソースがパスワード保護されていない場合、[OK] をクリックします。

  3. 抽出する情報の種類を選択し (チェック ボックスにチェックを入れる)、[次へ] をクリックします。

    ウィザードで抽出できる要素はシステムによって異なります。一部のアイテムが淡色表示されている場合があります。

  4. 抽出するテーブル (とビュー) のチェック ボックスを選択するか、すべて抽出する場合は [すべて選択] をクリックし、[次へ] をクリックします。

    Excel ワークシートをリバース エンジニアリングするとき、この一覧に何も表示されない場合、おそらく、スプレッドシートの列見出しを含むセル範囲に名前を付ける必要があります。

  5. 手順 5 で [ストアド プロシージャ] チェック ボックスを選択した場合、抽出するプロシージャを選択するか、すべて抽出する場合は [すべて選択] をクリックし、[次へ] をクリックします。

  6. リバース エンジニアリングしたアイテムを現在のページに自動追加するかどうか選択します。

    ウィザードでは、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

  7. 選択内容を見直し、必要な情報が抽出されることを確認し、[完了] をクリックします。

ODBC 汎用ドライバーを使用する場合、リバース エンジニアリングした情報が不完全である可能性を示すエラーが表示されることがあります。ほとんどの場合、これは問題ではありません。[OK] をクリックし、ウィザードを続行してください。

ウィザードは選択した情報を抽出し、抽出プロセスに関する注意を [出力] ウィンドウに表示します。

ページの先頭へ

Visio 2016 がリバース エンジニア リング ウィザードをサポートしていません

リバース エンジニア リング ウィザードでは、Visio Professional 2016 または Visio 標準 2016年で使用できません。データベース モデリング機能を使用するためには、Visio Pro for Office 365 へのアップグレードを検討してください。

新しいバージョンの Outlook​​ を試してみる

Visio 2013 では、リバース エンジニアリング ウィザードをご利用いただけません

リバース エンジニア リング ウィザードでは、Visio Professional 2013 または Visio 標準 2013年で使用できません。データベース モデリング機能を使用するためには、Visio Pro for Office 365 へのアップグレードを検討してください。

新しいバージョンの Outlook​​ を試してみる

この記事の内容

リバース エンジニアリング ウィザードで抽出されるものを確認する

ウィザードを開始する準備を行う

既存のデータベースにリバース エンジニアリングを行う

リバース エンジニアリング ウィザードで抽出されるものを確認する

ウィザードによって抽出されるスキーマ定義情報は、DBMS (データベース管理システム) や ODBC ドライバーの機能など、いくつかの要因の組み合わせによって異なります。ウィザードには抽出できるすべての要素が表示されます。必要な要素を選択できます。たとえば、10 個あるテーブルから 5 個だけ選択したり、4 個あるビューから 2 個だけ選択したりできます。

ウィザードの実行中、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

ターゲット DBMS から利用できる範囲内で、次のアイテムを抽出できます。

  • テーブル

  • ビュー

  • 主キー

  • 外部キー

  • インデックス

  • トリガー (コードを含む)

  • チェック句 (コードを含む)

  • ストアド プロシージャ (コードを含む)

ページの先頭へ

ウィザードを開始する準備を行う

Excel ブックをリバース エンジニアリングする場合、ウィザードを開始する前に、ブックを開き、列見出しを含むセルのグループ (または範囲) に名前を付ける必要があります。複数のワークシートを使用する場合、各ワークシートの列セルのグループに名前を付けます。ウィザードでは、この範囲がテーブルとして扱われます。セル範囲に名前を付ける方法については、Microsoft Office Excel のヘルプをご覧ください。

最良の結果を得るために、リバース ​​エンジニアリング ウィザードを実行する前にリバース エンジニアリングするターゲット データベースに既定のドライバーを設定してください。それにより、ウィザードはネイティブのデータ型を正しくマッピングできます。ウィザードにより抽出されるすべてのコードが [コード] ウィンドウに正しく表示されます。

  1. [ファイル] タブをクリックし、[新規作成] をクリックし、[ソフトウェアとデータベース] をクリックし、[データベース モデル図] をダブルクリックします。

  2. [データベース] タブの [管理] グループで [データベース ドライバー] をクリックします。

  3. [ドライバー] タブで、Visio 提供のドライバーを選択します。ご利用中の DBMS に合わせて選択します。たとえば、Access データベースを設計している場合、Microsoft Access を選択します。

    Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

  4. [セットアップ] をクリックします。

  5. [ODBC ドライバー] タブで、ベンダー提供のドライバーをご利用中の DBMS に合わせて選択します。チェック ボックスにチェックを入れてください。たとえば、Access データベースを設計している場合、[Microsoft Access ドライバー (*.mdb)] チェック ボックスを選択します。

  6. 各ダイアログ ボックスで [OK] をクリックします。

ベンダー提供 32 ビット ODBC ドライバーは、バージョン 2.0 以降の ODBC データ アクセス パックのものをご利用ください。また、ODBC レベル 1 以上に準拠している必要があります。ベンダー提供 OLE DB プロバイダーは、OLE DB バージョン 1.0 以降の仕様に準拠している必要があります。

ページの先頭へ

既存のデータベースにリバース エンジニアリングを行う

  1. データベース モデル図の [データベース] タブで、[リバース ​​エンジニアリング] をクリックします。

  2. リバース エンジニアリング ウィザードの最初の画面で、次の操作を行います。

    1. ご利用中の DBMS (データベース管理システム) に合わせて Microsoft Visio データベース ドライバーを選択します。Visio データベース ドライバーを特定の ODBC データ ソースにまだ関連付けていない場合、[セットアップ] をクリックし、関連付けてください。

      Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

    2. 更新するデータベースのデータ ソースを選択します。既存のデータベースにデータ ソースをまだ作成していない場合、[新規作成] をクリックし、作成します。

      新しいソースを作成すると、その名前が [データ ソース] リストに追加されます。

    3. 設定に問題がなければ、[次へ] をクリックします。

    4. ドライバー固有のダイアログ ボックスがあれば、その指示に従います。たとえば、[データ ソースに接続] ダイアログ ボックスにユーザー名とパスワードを入力し、[OK] をクリックします。データ ソースがパスワード保護されていない場合、[OK] をクリックします。

  3. 抽出する情報の種類を選択し (チェック ボックスにチェックを入れる)、[次へ] をクリックします。

    ウィザードで抽出できる要素はシステムによって異なります。一部のアイテムが淡色表示されている場合があります。

  4. 抽出するテーブル (とビュー) のチェック ボックスを選択するか、すべて抽出する場合は [すべて選択] をクリックし、[次へ] をクリックします。

    Excel ワークシートをリバース エンジニアリングするとき、この一覧に何も表示されない場合、おそらく、スプレッドシートの列見出しを含むセル範囲に名前を付ける必要があります。

  5. 手順 5 で [ストアド プロシージャ] チェック ボックスを選択した場合、抽出するプロシージャを選択するか、すべて抽出する場合は [すべて選択] をクリックし、[次へ] をクリックします。

  6. リバース エンジニアリングしたアイテムを現在のページに自動追加するかどうか選択します。

    ウィザードでは、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

  7. 選択内容を見直し、必要な情報が抽出されることを確認し、[完了] をクリックします。

ODBC 汎用ドライバーを使用する場合、リバース エンジニアリングした情報が不完全である可能性を示すエラーが表示されることがあります。ほとんどの場合、これは問題ではありません。[OK] をクリックし、ウィザードを続行してください。

ウィザードは選択した情報を抽出し、抽出プロセスに関する注意を [出力] ウィンドウに表示します。

ページの先頭へ

この記事の内容

リバース エンジニアリング ウィザードで抽出されるものを確認する

ウィザードを開始する準備を行う

既存のデータベースにリバース エンジニアリングを行う

データベース モデリング機能が見つかりません

ご利用中のエディションの Visio にその機能が含まれていない可能性があります。ご利用中の Visio のエディションを確認するには、[ヘルプ] メニューの [バージョン情報] をクリックしてください。ダイアログ ボックスの一番上のテキスト行にエディションの名前が表示されます。

  • Microsoft Office Visio Standard にはデータベース モデル図テンプレートがありません。

  • Microsoft Office Visio Professional の場合、データベース モデル図テンプレートのリバース エンジニアリング機能を備えていますが (既存のデータベースを利用し、Visio でモデルを作成する)、フォワード エンジニアリング (Visio データベース モデルを利用し、SQL コードを生成する) には対応していません。

  • Visio for Enterprise Architects の場合、完全なデータベース モデリング機能をご利用いただけます。リバース エンジニアリングとフォワード エンジニアリングの両方が含まれています。Visio for Enterprise Architects は MSDN Premium Subscription に含まれています。このサブスクリプションは Visual Studio Professional エディションと Visual Studio Team System ロールベース エディションでご利用いただけます。

リバース エンジニアリング ウィザードで抽出されるものを確認する

ウィザードによって抽出されるスキーマ定義情報は、DBMS (データベース管理システム) や ODBC ドライバーの機能など、いくつかの要因の組み合わせによって異なります。ウィザードには抽出できるすべての要素が表示されます。必要な要素を選択できます。たとえば、10 個あるテーブルから 5 個だけ選択したり、4 個あるビューから 2 個だけ選択したりできます。

ウィザードの実行中、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

ターゲット DBMS から利用できる範囲内で、次のアイテムを抽出できます。

  • テーブル

  • ビュー

  • 主キー

  • 外部キー

  • インデックス

  • トリガー (コードを含む)

  • チェック句 (コードを含む)

  • ストアド プロシージャ (コードを含む)

ページの先頭へ

ウィザードを開始する準備を行う

Excel ブックをリバース エンジニアリングする場合、ウィザードを開始する前に、ブックを開き、列見出しを含むセルのグループ (または範囲) に名前を付ける必要があります。複数のワークシートを使用する場合、各ワークシートの列セルのグループに名前を付けます。ウィザードでは、この範囲がテーブルとして扱われます。セル範囲に名前を付ける方法については、Microsoft Office Excel ヘルプの「名前付きセルの参照または範囲を定義する」関連のトピックを参照してください。

最良の結果を得るために、リバース ​​エンジニアリング ウィザードを実行する前にリバース エンジニアリングするターゲット データベースに既定のドライバーを設定してください。それにより、ウィザードはネイティブのデータ型を正しくマッピングできます。ウィザードにより抽出されるすべてのコードが [コード] ウィンドウに正しく表示されます。

  1. [データベース] メニューで [オプション] をポイントし、[ドライバー] をクリックします。

  2. [ドライバー] タブで、Visio 提供のドライバーを選択します。ご利用中の DBMS に合わせて選択します。たとえば、Access データベースを設計している場合、Microsoft Access を選択します。

    注: Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

  3. [セットアップ] をクリックします。

  4. [ODBC ドライバー] タブで、ベンダー提供のドライバーをご利用中の DBMS に合わせて選択します。チェック ボックスにチェックを入れてください。たとえば、Access データベースを設計している場合、[Microsoft Access ドライバー (*.mdb)] チェック ボックスを選択します。

  5. 各ダイアログ ボックスで [OK] をクリックします。

注: ベンダー提供 32 ビット ODBC ドライバーは、バージョン 2.0 以降の ODBC データ アクセス パックのものをご利用ください。また、ODBC レベル 1 以上に準拠している必要があります。ベンダー提供 OLE DB プロバイダーは、OLE DB バージョン 1.0 以降の仕様に準拠している必要があります。

ページの先頭へ

既存のデータベースにリバース エンジニアリングを行う

  1. [ファイル] メニューで、[新規作成] をポイントし、[ソフトウェアとデータベース] をポイントし、[データベース モデル図] をクリックします。

  2. [データベース] メニューで、[リバース エンジニアリング] をクリックします。

  3. リバース エンジニアリング ウィザードの最初の画面で、次の操作を行います。

    • ご利用中の DBMS (データベース管理システム) に合わせて Microsoft Office Visio データベース ドライバーを選択します。Visio データベース ドライバーを特定の ODBC データ ソースにまだ関連付けていない場合、[セットアップ] をクリックし、関連付けてください。

      注: Excel ワークシートをリバース エンジニアリングしている場合、ODBC 汎用ドライバーを選択します。

    • 更新するデータベースのデータ ソースを選択します。既存のデータベースにデータ ソースをまだ作成していない場合、[新規作成] をクリックし、作成します。

      新しいソースを作成すると、その名前が [データ ソース] リストに追加されます。

    • 設定に問題がなければ、[次へ] をクリックします。

    • ドライバー固有のダイアログ ボックスがあれば、その指示に従います。たとえば、[データ ソースに接続] ダイアログ ボックスにユーザー名とパスワードを入力し、[OK] をクリックします。データ ソースがパスワード保護されていない場合、[OK] をクリックします。

  4. 抽出する情報の種類を選択し (チェック ボックスにチェックを入れる)、[次へ] をクリックします。

    注: ウィザードで抽出できる要素は DBMS によって異なります。一部のアイテムが淡色表示されている場合があります。

  5. 抽出するテーブル (とビュー) のチェック ボックスを選択するか、すべて抽出する場合は [すべて選択] をクリックし、[次へ] をクリックします。

    注: Excel ワークシートをリバース エンジニアリングするとき、この一覧に何も表示されない場合、おそらく、スプレッドシートの列見出しを含むセル範囲に名前を付ける必要があります。

  6. 手順 5 で [ストアド プロシージャ] チェック ボックスを選択した場合、抽出するプロシージャを選択するか、すべて抽出する場合は [すべて選択] をクリックし、[次へ] をクリックします。

  7. リバース エンジニアリングしたアイテムを現在のページに自動追加するかどうか選択します。

    注: ウィザードでは、リバース エンジニアリングしたアイテムを [テーブルとビュー] ウィンドウに一覧表示する以外に、図を自動的に作成するように選択できます。図を自動作成しない場合、[テーブルとビュー] ウィンドウからアイテムをドラッグし、データベース モデルを手動で組み立てることができます。

  8. 選択内容を見直し、必要な情報が抽出されることを確認し、[完了] をクリックします。

注: ODBC 汎用ドライバーを使用する場合、リバース エンジニアリングした情報が不完全である可能性を示すエラーが表示されることがあります。ほとんどの場合、これは問題ではありません。[OK] をクリックし、ウィザードを続行してください。

ウィザードは選択した情報を抽出し、抽出プロセスに関する注意を [出力] ウィンドウに表示します。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×