新しい SharePoint ライブラリに発行されたフォーム テンプレートを移動します。

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

この記事の内容

概要

始める前に

フォーム テンプレートの作業のコピーを取得します。

手順 1: 新しいドキュメント ライブラリにフォーム テンプレートを発行します。

手順 2: コピーし、既存のフォームに再リンク

概要

ユーザーの入力用にフォーム テンプレートをドキュメント ライブラリに発行した後、そのフォーム テンプレートを別のドキュメント ライブラリに移動する必要が生じる場合があります。たとえば、さらに多くのユーザーが同時にフォームに入力できるようにするため、フォーム テンプレートを容量の大きいサーバーに移動する場合です。ユーザーによっては、元のドキュメント ライブラリに保存されているフォーム テンプレートに基づいたフォームに既に入力していることが考えられます。フォーム テンプレートを新しいドキュメント ライブラリに移動するとき、通常は、これらの既存のフォームも移動します。以前のドキュメント ライブラリをアーカイブするか削除する前に、既存のフォームが新しいドキュメント ライブラリでも機能することを確認する必要があります。

ヒント: 発行済みフォーム テンプレートを新しいドキュメント ライブラリに移動する前に、フォームが新しいドキュメント ライブラリに移動されたことをユーザーに通知するなどの計画を立てます。ユーザーには、新しいドキュメント ライブラリを使用して新しいフォームを保存したり既存のフォームを変更したりしてもらう必要があります。計画には、元のドキュメント ライブラリをアーカイブまたは削除する作業も含める必要があります。

フォーム テンプレートとその既存のフォームを新しいドキュメント ライブラリに移動するには、最初に、フォーム テンプレートの作業用コピーを新しいドキュメント ライブラリに発行する必要があります。作業用コピーは作業中のコンピュータまたは Microsoft Visual SourceSafe のようなバージョン コントロール プログラムに保存されています。

ヒント: フォーム テンプレートの作業用コピーがないときは、フォーム テンプレートのコピーを元のドキュメント ライブラリからコンピュータに保存して、作業用コピーとして使用することができます。

作業用コピーを新しいドキュメント ライブラリに発行した後、以前のドキュメント ライブラリにあるフォームはすべて新しいドキュメント ライブラリにコピーし、新しいドキュメント ライブラリのフォームを、新しく発行されたフォーム テンプレートに再リンクする必要があります。

フォーム テンプレートを移動したことにより、変更を加える必要が生じた場合は、フォーム テンプレートを発行する前に変更します。たとえば、フォーム テンプレートを移動したことで、このフォーム テンプレートに基づいたフォームで使用されている外部データ ソースの場所が変わることもあります。この場合は、フォーム テンプレートを発行する前に、フォーム テンプレートのデータ接続を外部データ ソースの新しい場所に変更する必要があります。データ接続の変更の詳細については、[参照] に掲載されているリンクを参照してください。

注: フォーム テンプレートを発行することと、フォーム テンプレートを保存することは同じではありません。フォーム テンプレートを発行すると、発行ウィザードは発行場所と処理命令をフォーム テンプレートに追加して、ユーザーがこのフォーム テンプレートに基づくフォームを開けるようにします。フォーム テンプレートを保存すると、コンピューターにファイルを保存するときと同様に、フォーム テンプレートのコピーを保存します。フォーム テンプレートにユーザーが記入できるようにする場合には、必ず、発行ウィザードを使用する必要があります。

ページの先頭へ

始める前に

フォーム テンプレートと、そのフォーム テンプレートに基づいた既存のフォームを新しいドキュメント ライブラリに移動するには、次のものが必要になります。

  • フォーム テンプレートの作業用コピー    変更を加えた後新しいドキュメント ライブラリに発行するフォーム テンプレートのコピーです。作業用コピーは作業中のコンピュータまたは Visual SourceSafe のようなバージョン コントロール プログラムに保存されています。

  • 新しい外部データ ソースの場所    フォーム テンプレートに基づいたフォームで使用している外部データ ソースが変更されている場合は、外部データ ソースの新しい場所が必要になります。その外部データ ソースを使用するための適切な許可を持っていることを管理者に確認します。フォーム テンプレートでデータ接続ファイルの設定を使用して外部データ ソースに接続している場合は、そのデータ接続ファイルが外部データ ソースの新しい場所で更新されていることを確認します。

  • Windows SharePoint Services 3.0 を実行するサーバー上での適切な権限    フォーム テンプレートを発行し、既存のフォームを以前のドキュメント ライブラリから新しいドキュメント ライブラリにコピーするには、サーバー上での適切な権限が必要になります。適切な権限を持っていることをサーバー管理者に確認します。

ページの先頭へ

フォーム テンプレートの作業用コピーを取得する

ドキュメント ライブラリまたは共有ネットワーク フォルダに発行されているフォーム テンプレートを変更する場合に、フォーム テンプレートの作業用コピーがないときは、フォーム テンプレートの作業用コピーを発行場所からコンピュータに保存できます。

ヒント: フォーム テンプレートの作業用コピーを管理するには、Microsoft Visual SourceSafe のようなバージョン コントロール プログラムを使用することもできます。

フォーム テンプレートのコピーをドキュメント ライブラリからコンピュータに保存する

  1. Web ブラウザーでは、フォーム テンプレートが発行されたドキュメント ライブラリを開きます。

  2. [設定] メニューの設定] をクリックし、[フォーム ライブラリの設定] をクリックします。

  3. [全般設定] で [詳細設定] をクリックします。

  4. [ドキュメントのテンプレート] の [テンプレートの編集] をクリックします。

    Microsoft Office InfoPath では、フォーム テンプレートが開きます。

  5. [Microsoft Office InfoPath] ダイアログ ボックスの [はい] をクリックします。

  6. [ファイル] メニューの [名前を付けて保存] をクリックします。

  7. Microsoft Office InfoPath ] ダイアログ ボックスで、[ OK] をクリックします。

  8. [名前を付けて保存] ダイアログ ボックスで、フォーム テンプレートのコピーを保存する場所を指定し、[保存] をクリックします。

フォーム テンプレートのコピーを共有ネットワーク フォルダからコンピュータに保存する

  1. [ファイル] メニューには、フォーム テンプレートのデザインをクリックします。

  2. [フォーム テンプレートを開く] の [自分のコンピュータ上] をクリックします。

  3. 発行済みフォーム テンプレートの共有ネットワーク フォルダーを参照して、フォーム テンプレート] をクリックし、[開く] をクリックします。

  4. [ファイル] メニューの [名前を付けて保存] をクリックします。

  5. Microsoft Office InfoPath ] ダイアログ ボックスで、[ OK] をクリックします。

  6. 名前を付けて保存] ダイアログ ボックスで、以外の元のフォーム テンプレートの作業のコピーを保存する場所を公開して、[保存] をクリックする場所を選びます。

ページの先頭へ

手順 1: フォーム テンプレートを新しいドキュメント ライブラリに発行する

  1. フォーム テンプレートの作業用コピーをデザイン モードで開きます。

  2. [ファイル] メニューの [発行] をクリックします。

  3. 発行ウィザードの [InfoPath Forms Services をインストール済み/未インストールの SharePoint サーバーへ] をクリックして、[次へ] をクリックします。

  4. [SharePoint サイトまたは InfoPath Forms Services サイトの場所を入力してください] ボックスに、フォーム テンプレートの移動先とする新しいドキュメント ライブラリのある SharePoint サイトの場所を入力し、[次へ] をクリックします。

  5. ウィザードの次のページの [ドキュメント ライブラリ] をクリックし、[次へ] をクリックします。

  6. [新しいドキュメント ライブラリを作成する] をクリックして、[次へ] をクリックします。

  7. ウィザードの次のページで、新しいドキュメント ライブラリの名前と説明を入力して、[次へ] をクリックします。

  8. ドキュメント ライブラリの既定のビューの列として表示するフォーム テンプレートのフィールドを選択します。

    方法

    1. [追加] をクリックします。

    2. ドキュメント ライブラリで列として追加するフィールドを選択し、次のいずれかの操作を行います。

      • 列名] ボックスで、[列の名前を入力します。

      • サイト列グループ] リストで、サイト内の列を選択し、列名] ボックスの一覧で名前を選択し、[ OK] をクリックします。

        注: ドキュメント ライブラリでのデータを表示する繰り返しフィールドを選択した場合、関数リストで値をクリックして、ドキュメント ライブラリでフィールドを表示する方法を定義できます。すべての値を結合するかどうか、フィールド、フィールド、またはすべてのフィールドのアイテムの数の最後の値の最初の値を表示するかどうかを選択できます。

    3. [OK] をクリックします。

    ドキュメント ライブラリの列にデータを表示する方法については、[参照] に掲載されているリンクを参照してください。

  9. [次へ] をクリックします。

  10. ウィザードの次のページで、表示される情報が正しいことを確認して、[発行] をクリックします。

  11. ドキュメント ライブラリを開いて、フォーム テンプレートに基づいたフォームに入力する処理をテストするには、[このドキュメント ライブラリを開く] チェック ボックスをオンにして、[閉じる] をクリックします。

    ドキュメント ライブラリがブラウザで開きます。リスト ツールバーの [新規] をクリックすると、このフォーム テンプレートに基づいたフォームが Microsoft Office InfoPath で開きます。

フォーム テンプレートを新しいドキュメント ライブラリに発行した後、以前のバージョンのフォーム テンプレートに基づいた既存のフォームを、以前のドキュメント ライブラリから新しいドキュメント ライブラリにコピーすることができます。既存のフォームをコピーした後は、既存のフォームを新しいバージョンのフォーム テンプレートに再リンクできます。既存のフォームを再リンクしないと、既存のフォームをユーザーが開けなくなる可能性があります。

ページの先頭へ

手順 2: 既存のフォームをコピーし再リンクする

ここでは、両方のドキュメント ライブラリが Windows SharePoint Services 3.0 を実行するサーバーにあることを前提としています。

  1. Web ブラウザで以前のドキュメント ライブラリを開きます。

  2. [表示] メニューの [エクスプローラ ビュー] をクリックします。

  3. Ctrl キーを押しながら、移動する各フォームを選択し、フォームの 1 つを右クリックします。

  4. [Internet Explorer] ダイアログ ボックスの [はい] をクリックして、ショートカット メニューの [コピー] をクリックします。

  5. 新しいドキュメント ライブラリを開きます。

  6. [ビューの選択] の [エクスプローラ ビュー] をクリックします。

  7. フォルダ ウィンドウの空白領域を右クリックします。

  8. [Internet Explorer] ダイアログ ボックスの [はい] をクリックして、ショートカット メニューの [貼り付け] をクリックします。

  9. [表示] メニューの [ドキュメントの再リンク] をクリックします。

  10. [再リンク] 列で、新しいフォーム テンプレートにリンクする各フォームのチェック ボックスをオンにします。

  11. リスト ツールバーの [選択したドキュメントを再リンク] をクリックします。

既存のフォームを新しいフォーム テンプレートに再リンクした後、ユーザーは、新しいドキュメント ライブラリにコピーした既存のフォームを変更することや、新しく発行されたフォーム テンプレートに基づいた新しいフォームに入力することができます。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×