新しいデータベースを変更する方法について

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

Microsoft Office Access 2007に含まれているすべてのテンプレートは、あらかじめ定義されたテーブル、フォーム、レポート、クエリ、マクロ、およびリレーションシップを含む完全な管理アプリケーションです。これらのテンプレートは、すばやくをテンプレートに基づく新しいデータベースを作成できるようにする、すぐに役立つの「-組み込み、設計されていますいます。ただし、ことも、新しいデータベースを変更するときなどを追加またはフィールドの名前を変更する、またはレポートを変更します。

この記事では、テンプレートから作成されたデータベースに適用する最も一般的な変更を行う方法について説明します。特定の領域の詳細についての記事へのリンクを参照してください。

目的に合ったトピックをクリックしてください

テーブルとフィールドの基本を理解します。

テーブルにフィールドを追加します。

テーブルからフィールドを削除します。

フィールドまたはテーブルの名前を変更します。

フィールドをフォームまたはレポートに追加します。

ドキュメント、ファイル、または画像を格納するフィールドを追加します。

フィールドの表示方法を変更します。

テーブルとフィールドの基本を学習する

テーブルのデータを格納するデータベースを作成するときに、件名に基づく行と列のリストです。フィールド (列とも呼ばれます) を追跡する情報の項目を格納します。たとえば、連絡先] テーブルでは、姓、名、電話番号、およびアドレスのフィールドを作成することがあります。製品テーブルの場合、製品名や製品 ID、価格のフィールドを作成することがあります。

慎重にフィールドを選択することが重要です。たとえば、通常は計算結果の値を格納するフィールドを作成することをお勧めします。ほとんどの場合は、 Office Access 2007ことが必要な場合に値を計算することができます。フィールドを選択するとき便利な最小限の単位で情報を格納してください。たとえば、1 つのフィールドを完全な名前ではなく [名と姓を個別に格納する検討してください。通常、レポート、並べ替え、検索、または情報の項目で計算を実行する必要がある場合に入れるフィールドを単独します。

データベースの設計およびフィールドの選択の詳細については、「データベース設計の基本」を参照してください。

フィールドには、特定の特性があります。たとえば、すべてのフィールドでは、テーブル内のフィールドを一意に識別名があります。フィールドには、情報を保存すると一致するように選択されているデータ型もあります。データ型は記憶域の量を確保し、各値を設定する領域に格納できる値、およびこれらの値で実行できる操作をも決定します。すべてのフィールドは、関連付けられたフィールドの表示や動作の特性を定義するプロパティの設定のグループにもあります。たとえば、[書式] プロパティがフィールドの表示レイアウトを定義、つまり、どのように表示表示されているとき。

ページの先頭へ

テーブルにフィールドを追加する

データシート ビューでテーブルにフィールドを簡単に追加することができます。デザイン ビューでテーブルにフィールドを追加することもできます。データシート ビューでは、[新しいフィールドの追加] 列見出しの下のセル内にデータを入力してフィールドを追加します。

[新しいフィールドの追加] 列のある Access のデータシート

1: 新しい、空白のフィールドです。

データシート ビューでフィールドを追加する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、新しいフィールドを追加するテーブルをダブルクリックします。

    テーブルがデータシート ビューで開きます。

  4. [新しいフィールドの追加] 列見出しの下のセル内にデータを入力します。

    テーブルに多数のフィールドがあり、[新しいフィールドの追加] 列見出しが表示されていない場合は、右にスクロールします。

新しい列にデータを入力すると、 Office Access 2007は、フィールドの適切なデータ型を認識するように入力した情報を使用します。たとえば、1/1/2007 など、列の日付を入力する日時を設定する日付/時刻フィールドのデータ型として入力した情報を認識Office Access 2007します。Access のないからデータ型を決定する内容を入力するには、十分な情報は、データ型がテキストに設定されています。

場合は、明示的にデータを入力し、そのOffice Access 2007を設定するフィールドの書式設定、[データシート] タブで、データの型と書式設定のグループのコマンド] をクリックして実行することができます。

データ型を明示的に設定する

  • [データシート] タブの [データの型と書式設定] で、データ型] の横にあるドロップダウン リストで矢印をクリックし、[データ型を選択します。 [データ型と書式設定] グループの Access のリボンの画像

  • 設定するデータ型をクリックします。

書式を明示的に設定する

  1. [データシート] タブの [データの型と書式設定] で、書式設定] の横にあるドロップダウン リストにある矢印をクリックし、[形式を選択します。 [データ型と書式設定] グループの Access のリボンの画像

  2. 設定する書式をクリックします。

新しいフィールドの追加] 見出しの下のセルに情報を入力してフィールドを追加するときにOffice Access 2007は自動的のフィールドに名前を付けます。次の名前では、最初のフィールドでは、2 番目のフィールドでは、Field2 フィールド 1 から開始してなど。わかりやすいフィールド名を使用することをお勧めします。フィールドの名前を変更するには、その見出しを右クリックし、ショートカット メニューの [列名の変更] をクリックします。

に加えて、データシート ビューでフィールドを追加すると、デザイン ビューでフィールドを追加することができます。データシート ビューでは、最も一般的なフィールド プロパティのみを設定することができます、ために、データシート ビューではないプロパティを設定するデザイン ビューを使用する必要があることがあります。

デザイン ビューでフィールドを追加する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、新しいフィールドを追加するテーブルを右クリックし、ショートカット メニューの [デザイン ビュー] をクリックします。

    デザイン ビューでテーブルが開きます。

  4. [フィールド名] 列で、最初の空白行を選択し、新しいフィールドの名前を入力します。

  5. [データ型] 列の隣のセルをクリックし、一覧からデータ型を選択します。

  6. 変更内容を保存するには、クイック アクセス ツールバーの [上書き保存] をクリックします。

新しいフィールドを追加する方法の詳細については、挿入、追加、またはテーブルに新しいフィールドを作成する」を参照してください。

注: テーブルに新しいフィールドを追加しても、そのフィールドは既存のフォームおよびレポートに自動的に追加されません。新しいフィールドが既存のフォームおよびレポートに表示されるようにするには、そのフィールドをフォームおよびレポートに手動で追加する必要があります。

ページの先頭へ

テーブルからフィールドを削除する

可能であれば、しないようにから提供されたテンプレートのいずれかの生成されたデータベースからフィールドを削除する: フォームおよびレポートなどの他のデータベース オブジェクトのフィールドを使用する可能性があります。したがって、フィールドの削除が作成されます結果フィールドを使用するその他のデータベース オブジェクトを使用しようとしたときに、データベース オブジェクトは、期待どおりに動作しません。すべてのことを正常に動作するその他のオブジェクトの順序で使用するオブジェクトからフィールドへの参照を削除する必要があります。

テンプレートを基にして生成されたデータベースからフィールドを削除する必要がある場合は、データシート ビューまたはデザイン ビューで削除することができます。削除したフィールドを他のデータベース オブジェクトが参照している場合は、そのオブジェクトを編集して参照を削除する必要があります。たとえば、削除したフィールドに連結されているコントロールを含むレポートを実行すると、フィールドのデータが検出されないため、エラー メッセージが表示されます。

フィールドを削除すると、そのフィールドに格納されていたすべての情報が永久に削除されます。したがって、フィールドを削除するときは、細心の注意を払ってください。また、フィールドを削除する前にデータベースのバックアップ コピーを作成することをお勧めします。

フィールドを削除するには、前に、すべてのテーブルのリレーションシップに含まれていないことを確認する必要があります。リレーションシップが存在するフィールドを削除しようとすると、リレーションシップを削除する必要があります最初を警告する Access が表示されます。テーブル リレーションシップを削除する方法の詳しい手順については、「テーブルのリレーションシップを削除する」を参照してください。

データシート ビューでフィールドを削除する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、フィールドを削除するテーブルをダブルクリックします。

    テーブルがデータシート ビューで開きます。

  4. 削除するフィールド (列) を選択します。

    ヒント: フィールド (列) を選択するには、フィールド セレクタ (列見出し) をクリックします。

  5. Del キーを押します。

    または

    [データシート] タブの [フィールドと列] で、[削除] をクリックします。

注: データシート ビューでは、テーブルの主キーの一部であるフィールドを削除することはできません。主キー フィールドを削除するには、デザイン ビューを使用する必要があります。

主キーの詳細については、追加する、設定、変更、または主キーを削除する」を参照してください。

デザイン ビューでフィールドを削除する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、フィールドを削除するテーブルを右クリックし、ショートカット メニューの [デザイン ビュー] をクリックします。

    デザイン ビューでテーブルが開きます。

  4. 削除するフィールド (行) を選択します。

    ヒント: 行を選択するには、行セレクタをクリックします。

  5. Del キーを押します。

    または

    [デザイン] タブの [ツール] グループで、[行の削除] をクリックします。

  6. 変更内容を保存するには、クイック アクセス ツールバーの [上書き保存] をクリックします。

フィールドを削除する前に、テーブル リレーションシップがフィールドに設定されていないことを確認する必要があります。テーブル リレーションシップが設定されているフィールドを削除しようとすると、リレーションシップを最初に削除する必要があることを示すメッセージが表示されます。テーブル リレーションシップを削除するには、次の操作を行います。

テーブル リレーションシップを削除する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. テーブル リレーションシップが設定されているテーブルが開いている場合は、閉じます。開いているテーブル間に設定されているテーブル リレーションシップは、削除することができません。

  4. [データベース ツール] タブの [表示/非表示] で [リレーションシップ] をクリックします。

  5. テーブル リレーションシップが設定されているテーブルが表示されていない場合は、次の操作を行います。

    1. [デザイン] タブの [表示/非表示] グループの [テーブル名] をクリックします。

    2. テーブルの表示] ダイアログ ボックスで、追加の追加] をクリックし、[閉じる] をクリックしてテーブルを選択します。

  6. 削除するテーブル リレーションシップをクリックして選択します (選択したリレーションシップは太字で表示されます)。次に、Del キーを押します。

ページの先頭へ

フィールドまたはテーブルの名前を変更する

可能であれば、しないようにから提供されたテンプレートのいずれかの生成されたデータベースのテーブルのフィールドの名前を変更する: フィールドまたはテーブルは、フォーム、レポートなどの他のデータベース オブジェクトの使用可能性があります。したがって、フィールドまたはテーブルの名前を変更することができます作成結果フィールドまたはテーブルを使用して、その他のデータベース オブジェクトを使用しようとしたときにします。前の名前を参照してかどうかを想定どおりに、他のオブジェクトが機能しないことができます。正常に動作するその他のオブジェクトの新しい名前を元の名前を変更する必要があります。名前の自動修正を行う] チェック ボックスは、 Access のオプション] ダイアログ ボックスの [カレント データベース] カテゴリで選択されている場合は、この作業の多くを行いますが自動的にします。

データシート ビューで列見出しに表示されるテキストを変更することがあります。フィールド名を変更しなくても行うことができます。列見出しのテキストのみを変更するフィールドの名前を変更したくない場合は、列見出しに表示されるテキストを変更するセクションを参照してください。

必要に応じて、ナビゲーション ウィンドウ内のテーブルの名前を変更またはデータシート ビューまたはデザイン ビューでフィールドの名前を変更できます。これを行う前に、オンになってされていない場合、[名前の自動修正オプションを有効にするを検討してください。

名前の自動修正オプションを有効にします。

フィールド、テーブル、フォーム、レポートなど、データベース オブジェクトの名前を変更する場合は、データベース全体に伝達する名前の変更は、通常します。それ以外の場合、期待どおりに元の名前を参照しているオブジェクトは使用できません。Office Access 2007には、名前の変更が反映される名前の自動修正機能が用意されています。既定では、名前の自動修正が有効でOffice Access 2007内のすべての新しいデータベースの。ただし、オフになっているが場合、は、オンにするには、次を行うことができます。

名前の自動修正オプションを有効にします。

  1. Microsoft Office ボタン Office ボタンの画像 をクリックし、[Access のオプション] をクリックします。

  2. [Access のオプション] ダイアログ ボックスの左側のウィンドウ枠で、[カレント データベース] をクリックします。

  3. [名前の自動修正オプション] で、[名前の自動修正情報をトラックする] チェック ボックスをオンにしてから [名前の自動修正を行う] チェック ボックスをオンにします。

  4. 名前の自動修正により実行されるすべての変更を記録するテーブルを保持する場合は、[名前の自動修正の変更を記録する] チェック ボックスをオンにします。

  5. [OK] をクリックします。

  6. 変更内容を保存するには、クイック アクセス ツールバーの [上書き保存] をクリックします。

注: 名前の自動修正機能は、オートコレクト機能と同じではありません。名前の自動修正機能は、オブジェクト間の参照を修正します。オートコレクト機能は、よく間違った綴りで入力される語句を修正します。

データシート ビューでフィールドの名前を変更する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、名前を変更するフィールドが含まれているテーブルをダブルクリックします。

    テーブルがデータシート ビューで開きます。

  4. 名前を変更するフィールドの列見出しを右クリックし、ショートカット メニューの [列名の変更] をクリックします。

  5. フィールドの新しい名前を入力し、Enter キーを押します。

デザイン ビューでフィールドの名前を変更する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、名前を変更するフィールドが含まれているテーブルを右クリックし、ショートカット メニューの [デザイン ビュー] をクリックします。

    デザイン ビューでテーブルが開きます。

  4. 名前を変更するフィールドの [フィールド名] 列のセルをクリックします。

    ヒント: フィールド名全体を選択するには、名前の最初の文字の左側にポインタを移動し、ポインタが矢印に変わったら、クリックします。

  5. テキストを編集してフィールドの名前を変更します。

  6. 変更内容を保存するには、クイック アクセス ツールバーの [上書き保存] をクリックします。

テーブル名を変更する

ナビゲーション ウィンドウでは、テーブルやその他のデータベース オブジェクトの名前を直接変更することができます。

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、名前を変更するテーブルを右クリックし、ショートカット メニューの [名前の変更] をクリックします。

    注: テーブルの名前を変更する前に、そのテーブルを参照するオブジェクトが開いていれば、すべて閉じます。

  4. 新しいファイル名を入力し、Enter キーを押します。

  5. 変更内容を保存するには、クイック アクセス ツールバーの [上書き保存] をクリックします。

列見出しに表示されているテキストを変更する

図表番号をタイトル、見出しをフィールドのプロパティを設定して、フィールドに割り当てることができます。図表番号は、フィールド名に関係なく、すべてのフィールドはフィールド名と、キャプションこともできます。たとえば、埋め込みのスペースを入れずに 1 つの単語を使用するフィールド名したい場合があります。プロパティは、スペースを含んだわかりやすい名前を作成するのには、[使えます。データシート ビューで、クエリ、フォーム、およびレポートの見出しラベルにフィールド名の代わりに、キャプションが表示されます。

キャプションのプロパティを設定しない場合、フィールド名が既定で使用します。

データシート ビューで列見出しに表示される名前を変更する場合は、これを行う、フィールドのプロパティを設定して、フィールド名を変更せずにします。フィールドのプロパティを変更するには、次の操作を行います。

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、標題を変更するテーブルを右クリックし、ショートカット メニューの [デザイン ビュー] をクリックします。

    デザイン ビューでテーブルが開きます。

  4. タイトルプロパティを設定するフィールドのフィールド名] 列のセルをクリックします。

  5. 下部のセクションで、[フィールド プロパティ] の下にある [全般] タブの [標題] をクリックします。

  6. フィールドの新しい標題を入力します。

  7. 変更内容を保存するには、クイック アクセス ツールバーの [上書き保存] をクリックします。

次回データシート ビューでテーブルを開くとき、フィールド名ではなく標題が列見出しに表示されます。

ページの先頭へ

フォームまたはレポートにフィールドを追加する

テンプレートに基づくするデータベースを作成するときに、データベースには組み込み、デザイン済みのフォームとレポートをすぐに使用できるの数値が含まれます。立つ、ただし、フォームまたはレポートにフィールドを追加することです。フォームまたはレポートにフィールドを追加すると、コントロールと呼ばれるを作成します。

コントロールについて

コントロールは、オブジェクトをデータを表示、操作を実行し、ラベルや画像など、ユーザー インターフェイスを強化するための情報を表示および操作できます。コントロールのバインドされている、非連結、および計算します。

  • 連結コントロール   これは、テーブルまたはクエリのフィールドをデータ ソース コントロールです。データベースのフィールドの値を表示するのにには、連結コントロールを使用します。テキスト、日付、数値は、"はい/いいえ"の値を画像、またはグラフに値。テキスト ボックスは、連結コントロールの最も一般的な種類です。たとえば、従業員の姓を表示するフォームのテキスト ボックスでは、[姓] フィールドで、[従業員] テーブルからこの情報を入手することがあります。

  • 非連結コントロール   この種類のコントロールには、(フィールドまたは式) のデータ ソースが利用されていません。非連結コントロールを使用すると、情報、線、四角形、および画像を表示できます。たとえば、フォームのタイトルを表示するラベルは、非連結コントロールです。

  • 演算コントロール   これは、フィールドではなく、式は、データ ソース コントロールです。コントロールの値を指定するには、コントロールのデータのソースとしてを定義します。式は、演算子を組み合わせて ( =などと+ )、名、フィールド名、1 つの値、および定数値を返す関数を制御します。たとえば、次の式は、定数値 (0.75) で、[単価] フィールドに値を乗算して 25% 割引したアイテムの価格を計算します。

= [単価] * 0.75

式では、フォームの基になるテーブルやクエリ内のフィールドのデータ、またはフォームのコントロールのデータを使用できます。式の詳細については、この記事の「関連項目」のリンクを参照してください。

テキスト ボックスを連結コントロール、非連結コントロールの場合、または演算コントロールを使用できます。連結、非連結に使用するフォームを作成する場合、演算コントロールを追加して、最初に、すべての連結コントロールを配置する最も効率的な可能性がありますフォーム上のコントロールの大部分を構成する場合に特にします。[デザイン] タブの [デザイン ビューで [コントロール] で、ツールを使用してデザインを実行するバインドされていないと演算コントロールを追加できます。

テキスト ボックス コントロールを連結するには、コントロールにデータを提供するフィールドを特定します。選択したフィールドに連結されたコントロールを作成するには、[フィールド リスト] ウィンドウからフォームにフィールドをドラッグします。[フィールド リスト] ウィンドウには、レポートの基になったテーブルまたはクエリのフィールドが表示されています。[フィールド リスト] ウィンドウを表示するには、[デザイン] タブの [ツール] で [既存のフィールドの追加] をクリックします。既定では、[フィールド リスト] ウィンドウからフォームのデザイン グリッドにフィールドをドラッグすると、自動的にテキスト ボックスが挿入されます。

または、コントロールまたはコントロールのプロパティ シートのコントロール ソース値] ボックスで、フィールド名を入力して、フィールドをコントロールにバインドできます。プロパティ シートでは、[コントロール] の名前などの特性をデータや、その形式のソースを定義します。

連結テキスト ボックスは、[フィールド リスト] ウィンドウを使用して作成することをお勧めします。その理由は次の 2 点です。

  • 連結テキスト ボックスのラベルには、既定によりフィールド名 (または基になったテーブルやクエリに定義された、そのフィールドを表す名前) が表示されるので、手動で名前を入力する必要がありません。

  • バインドされたテキスト ボックスは、多くの基になるテーブルまたはクエリを (書式設定特に定型入力] プロパティなど) で、フィールドと同じ設定を継承します。このため、フィールドには、これらのプロパティがそのままこと、同じフィールドにバインドされているテキスト ボックスを作成するときにいつでも確認できます。

既に作成した非連結コントロールをフィールドにバインドを場合は、フィールドの名前をコントロールのControlSourceのプロパティを設定します。

レイアウト ビューでフォームまたはレポートにフィールドを追加する

フォームまたはレポートを作成した後、レイアウト ビューでのデザインを微調整できます。実際のライブ データ ガイドとして使用すると、フィールドの幅を調整し、フィールドを配置できます。フォームまたはレポートに新しいフィールドを追加し、フォームやレポートのコントロールのプロパティを設定できます。

ナビゲーション ウィンドウで、レイアウト ビューに切り替えるには、フォームまたはレポートを右クリックし、ショートカット メニューの [レイアウト ビュー ] をクリックします。または、Access ステータス バーの [レイアウト ビュー ] ボタンをクリックするか、フォームまたはレポートのドキュメント タブを右クリックし、ショートカット メニューの [レイアウト ビュー ] をクリックすることができます。

レイアウト ビューに切り替える

  • ナビゲーション ウィンドウで、フォームまたはレポートを右クリックし、ショートカット メニューの [レイアウト ビュー] をクリックします。

    または

    Access ステータス バーの [レイアウト ビュー ] ボタンをクリックします。

    または

    フォームまたはレポートのドキュメント タブを右クリックし、ショートカット メニューの [レイアウト ビュー] をクリックします。

フォームまたはレポートがレイアウト ビューで表示されます。

プロパティ シートを開く

  • [整列] タブの [ツール] で [プロパティ シート] をクリックします。

    ショートカット キー F4 キーを押します。

デザインを基になるテーブルまたはクエリからフィールドを追加するのには、[フィールド リスト] ウィンドウを使用できます。[書式] タブの [コントロール] グループで、フィールド リスト] ウィンドウを表示するには、既存のフィールドの追加をクリックします。[デザインにフィールド リスト] ウィンドウから直接フィールドをドラッグできます。

[フィールド リスト] ウィンドウを表示する

  • [書式] タブの [コントロール] グループで [既存のフィールドの追加] をクリックします。

[フィールド リスト] ウィンドウからフィールドを追加する

  • 1 つのフィールドを追加するには、[フィールド リスト] ウィンドウからフォームまたはレポート上のフィールドを表示するセクションにフィールドをドラッグします。

  • 複数のフィールドを同時に追加する場合は、Ctrl キーを押しながら、追加するフィールドをクリックしていきます。その後、選択したフィールドをフォームまたはレポートにドラッグします。

フィールドをドロップすると、フィールドごとに連結テキスト ボックス コントロールが作成され、各フィールドの横にラベル コントロールが自動的に配置されます。

フォームおよびレポートの詳細については、「フォーム ツールを使用して、フォーム作成すると、単純なレポートを作成する」を参照してください。

ページの先頭へ

ドキュメント、ファイル、またはイメージを格納するフィールドを追加する

Office Access 2007を使用すると、1 つ以上のドキュメント、ファイル、または画像を保存するのに添付ファイル データ型のフィールドを追加します。1 つのフィールドで複数のファイルを保存するのに添付ファイル フィールドを使用することができます。そのフィールドには、複数の種類のファイルを保存することもできます。たとえば、雇用候補データベース] の各連絡先のレコードを 1 つまたは複数の履歴書と写真を割り当てることができます。

テーブルに添付フィールドを追加する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、フィールドを追加するテーブルを右クリックし、ショートカット メニューの [デザイン ビュー] をクリックします。

    デザイン ビューでテーブルが開きます。

  4. [フィールド名] 列で、最初の空白行を選択し、新しいフィールドの名前を入力します。

  5. [データ型] 列の隣のセルをクリックし、一覧から [添付ファイル] を選択します。

  6. 変更内容を保存するには、クイック アクセス ツールバーの [上書き保存] をクリックします。

    テーブルの保存後、変更を元に戻すことはできないというメッセージが表示されることがあります。承諾した場合、フィールドのデータ型の変更はできなくなります。なんらかのミスでフィールドのデータ型を変更する必要が生じた場合に、そのフィールドを削除するしかありません。

  7. [はい] をクリックして、変更内容を確認します。

添付ファイル フィールドをテーブルに追加したら、[添付ファイル] ダイアログ ボックスを使用して、ドキュメント、ファイル、またはイメージをレコードに追加できます。

フィールドに添付ファイルを追加する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、添付ファイルを追加するテーブルをダブルクリックします。

    テーブルがデータシート ビューで開きます。

  4. テーブル内の添付ファイル フィールドをダブルクリックします。

    [添付ファイル] ダイアログ ボックスが表示されます。

  5. [追加] をクリックします。

    [ファイルの選択] ダイアログ ボックスが表示されます。

  6. [ファイルの場所] ボックスから、レコードに添付するファイル (複数可) を選択し、[開く] をクリックします。

    サポートされている任意のデータ型のファイルをいくつでも選択できます。

  7. [添付ファイル] ダイアログ ボックスの [OK] をクリックして、ファイルをテーブルに追加します。

    フィールドにファイルが追加され、添付ファイルの ID 番号が大きくなります。

  8. ここまでの手順を繰り返して、テーブル内の現在のフィールドまたはその他のフィールドに必要なファイルをすべて追加します。

添付ファイル フィールドの詳細については、「ファイルを添付して、データベースのレコードにグラフィック」を参照してください。

ページの先頭へ

フィールドの外観を変更する

フィールドが表示されているを表示する方法をカスタマイズできます。たとえば、フォームやレポートで、またはデータシート ビューでテーブルを開いたときに、データベース全体など、使用する表示形式を設定できます。表示形式を設定するには、フィールドの [書式] プロパティを設定します。フィールドの [書式] プロパティは、新しいフォームを自動的に継承しされ、レポートを作成することです。

データシート ビューで表示形式を設定する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウでは、[形式を設定するフィールドが含まれているテーブルをダブルクリックします。
    テーブルがデータシート ビューで開きます。

  4. 表示形式を設定するフィールドをクリックします。

  5. [データシート] タブの [データの型と書式設定] で、書式設定] の横にあるドロップダウン リストにある矢印をクリックし、[形式を選択します。 [データ型と書式設定] グループの Access のリボンの画像

    フィールドが新しい表示形式で表示されます。

デザイン ビューで表示形式を設定する

  1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、表示形式を設定するフィールドが含まれているテーブルを右クリックし、ショートカット メニューの [デザイン ビュー] をクリックします。

    デザイン ビューでテーブルが開きます。

  4. 表示形式を設定するフィールドをクリックします。

  5. [フィールド プロパティ] の下にある [全般] タブの [書式] ボックスをクリックします。

  6. ドロップダウン リストをクリックし、表示形式を選択します。

  7. 変更内容を保存するには、クイック アクセス ツールバーの [上書き保存] をクリックします。

フィールドの外観を変更する方法の詳細については、「行と列のデータを書式設定」を参照してください。

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×