接続ライブラリ内の設定を使用してデータ接続を追加する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

この記事の内容

概要

始める前に

クエリ データ接続を追加する

送信データ接続を追加する

概要

ようなデータ接続を使用して複数のフォーム テンプレートをデザインする場合は、フォーム テンプレートごとに外部データ ソースへのデータ接続を作成するのではなくデータ接続ファイルの使用を検討してください。これにより、一連の関連するフォーム テンプレートのデータ接続情報が変更されたときに、1 つだけのデータ接続ファイルを更新する必要があります。たとえば、テスト ネットワークから、フォーム テンプレートを運用ネットワークに移動するときに、データ接続の設定は 1 回のみでフォーム テンプレートのデータ接続を更新するのではなく接続ライブラリを更新する必要があります。データ接続ファイルを使用するフォーム テンプレートに基づくフォームは、データ接続を使用しているときに、データ接続は、新しい設定で自動的に更新します。

データ接続ファイルは、1 つの外部データ ソースの接続情報を含む入ったファイル拡張子の XML ファイルです。このファイルは、 Microsoft Office SharePoint Server 2007を実行するサーバー上のデータ接続ライブラリに保存されます。開発者または既存のフォーム テンプレートで、データ接続がデータ接続] ダイアログ ボックス ([ツール] メニュー)に変換] をクリックしてデータ接続ファイルに変換して、データ接続ファイルが作成されます。

データ接続ファイルを使用する利点は次のとおりです。

  • 複数のフォームは、同じデータ接続ファイルを使用して、ので、フォーム テンプレートごとに最初から同じデータ接続を作成する必要はありません。

  • 外部データ ソースの場所または接続設定を変更する場合、各フォーム テンプレートではなくデータ接続ファイルを更新するだけで済みます。

  • データ接続ファイルには、Web ブラウザーを使って、ユーザーがフォームに入力するときに、サーバーで使用できる代替の認証情報を含めることができます。

  • ブラウザーで入力するブラウザー互換フォーム テンプレートに基づくフォームは、データ接続ファイルを使用してデータ接続のみを別のドメインのサーバーに接続できます。

注: Microsoft Office InfoPath では、次のデータ接続をどこからでもバージョン 2.0 ファイル形式のデータ接続ファイルを使用します。このバージョンは、Microsoft Office と Microsoft Office Excel で使用されるバージョン 1.0 のファイル形式のスーパー セットです。InfoPath では、バージョン 1.0 のファイル形式でのデータ接続ファイルを使用できません。

データ接続ライブラリ内の設定を使用してフォーム テンプレートにデータ接続を追加する場合は、そのフォーム テンプレート内にセカンダリ データ接続を作成します。このデータ接続は、データベース、Web サービス、またはデータ接続ライブラリ内の設定に基づくフォーム テンプレートをデザインするときに作成したメイン データ接続とは異なります。メイン データ接続を使用してデータを取得または送信できない場合にのみ、セカンダリ データ接続を追加します。

ページの先頭へ

始める前に

データ接続ライブラリに保存されている設定を使用してフォーム テンプレートにデータ接続を追加するには、サイト管理者から次の情報を入手する必要があります。

  • Microsoft Office SharePoint Server 2007 を実行しているサーバーの場所 (データ接続ライブラリを含むサイトが格納されている場所です)

  • データ接続ライブラリ内の、使用するデータ接続ファイルの名前

  • データ接続ファイルに含まれている設定がクエリ データ接続用であるか、送信データ接続用であるか

  • 設定がクエリ データ接続用である場合は、クエリ結果をオフラインで使用するためにフォームに安全に保存するようにフォーム テンプレートを構成できるかどうか

ページの先頭へ

クエリ データ接続を追加する

接続ライブラリ内の設定を使用してフォーム テンプレートにデータ接続を追加するには、次の手順を実行する必要があります。

  1. フォーム テンプレートにセカンダリ データ接続を追加します。

  2. セカンダリ データ ソースのクエリ フィールドおよびデータ フィールドにコントロールをバインドします。

  3. 動作規則またはボタンを使用して、データ接続を使用するようにフォーム テンプレートを構成します。

手順 1: セカンダリ データ接続を追加する

  1. [ツール] メニューの [データ接続] をクリックします。

  2. [データ接続] ダイアログ ボックスで、[追加] をクリックします。

  3. データ接続ウィザードで、[Microsoft Office SharePoint Server 上で接続を検索] をクリックし、[次へ] をクリックします。

  4. ウィザードの次のページの [サイト] ボックスの一覧で、Office SharePoint Server 2007 を実行している、接続ライブラリが格納されているサイトの名前をクリックします。

    目的のサイトが一覧にない場合

    目的のサイトを一覧に追加するには、次の操作を行います。

    1. [サイトの管理] をクリックします。

    2. サイトの管理] ダイアログ ボックスで、[追加を] をクリックします。

    3. [URL ] ボックスで、データ接続ライブラリの場所を入力します。

    4. 表示名] ボックスで、データ接続ライブラリの名前を入力します。サイトリストのデータ接続ウィザードでこの名前が表示されます。

    5. [OK] をクリックします。

    6. [閉じる] をクリックします。

  5. データ接続ライブラリの名前をクリックしてデータ接続ファイルの一覧を表示し、このデータ接続に使用するデータ接続ファイルの名前をクリックします。次に、[次へ] をクリックします。

  6. データ接続ファイル内の接続設定によっては、ウィザードの次のページで、各パラメータのサンプル値を指定するように求められることがあります。

    サンプル値を指定するには?

    1. パラメーターの表にパラメーターを選択し、[サンプル値の設定] をクリックします。

    2. サンプル値] ボックスに、ユーザーが、このフィールドを使用して、[ OK] をクリックしてことも、値を入力します。

    3. パラメーターの表に、各パラメーターの次の手順を繰り返して、[次へ] をクリックします。

    技術情報

    データ接続ウィザードで、[Web サービスへのデータ接続を構成すると、Microsoft Office InfoPath は Web サービスに接続して、Web サービス記述言語 (WSDL) ファイルを要求します。WSDL ファイルには、Web サービスで使用されるスキーマが含まれています。Web サービスは、InfoPath にこのファイルを送信して要求に応答します。InfoPath では、このファイル内の情報を使用して、フォーム テンプレートのセカンダリ データ ソースに適切なフィールドとグループを追加します。InfoPath では、WSDL ファイルで、不明な要素のタイプが検出されると、InfoPath はサンプル データを使用して、不明な要素の種類の定義を決定し、セカンダリ データ ソースには適切なフィールドおよびグループを追加します。

  7. フォームがネットワークに接続されていないときにクエリの結果を使用できるようにするには、[フォーム テンプレートのデータのコピーを保存する] チェック ボックスをオンにします。

    セキュリティに関するお知らせ : このチェック ボックスをオンにすると、クエリ結果がフォーム テンプレートに保存されます。データがフォーム テンプレートに保存されるため、コンピュータがネットワークに接続されていない場合でも、ユーザーが入力するフォーム内でデータを使用できます。このデータ接続から機密データを取得している場合は、コンピューターの紛失や盗難に備えて、この機能を無効にすることができます。

  8. [次へ] をクリックします。

    ウィザードの次のページに、このデータ接続の設定の概要が表示されます。

  9. データ接続のわかりやすい名前を入力します。この名前は、[データ ソース] 作業ウィンドウの [データ ソース] ボックスの一覧に表示されます。

  10. このフォーム テンプレートに基づくフォームを開くときにこのデータ接続が使われるようにするには、[フォームを開くとき自動的にデータを取得する] チェック ボックスをオンにします。

ページの先頭へ

手順 2: ユーザーにデータを表示するためのコントロールを追加する

  1. [コントロール] 作業ウィンドウが表示されていない場合は、[挿入] メニューの [コントロールの選択] をクリックするか、Alt キーを押しながら I キー、C キーの順に押します。

  2. コントロールをフォーム テンプレートにドラッグします。

  3. [コントロールのバインド] ダイアログ ボックスで、コントロールのバインド先となるフィールドを選択し、[OK] をクリックします。

手順 3: データ接続を使用するようにフォーム テンプレートを構成する

ユーザーによるこのデータ接続からのデータ取得がフォームを開いた後に行われるようにするには、特定の条件の下でデータ接続を使用する動作規則をフォーム テンプレートに追加するか、ユーザーがクリックしてデータ接続を使用できるボタンをフォーム テンプレートに追加します。

動作規則を追加する

動作規則に関する基準が満たされた場合はクエリ データ接続を実行するように、フォーム テンプレートの動作規則を追加できます。次の手順では、フォーム テンプレートにクエリ データ接続を作成し、データ接続のデータを表示するコントロールをフォーム テンプレートに構成したと想定しています。

  1. 複数のビューを持つフォーム テンプレートの場合、[表示] メニューの [ビュー名] をクリックして、セカンダリ データ ソースのデータを表示するコントロールがあるビューに移動します。

  2. 動作規則を追加する対象のコントロールをダブルクリックします。

  3. [データ] タブをクリックします。

  4. [入力規則と動作規則] の [動作規則] をクリックします。

  5. [動作規則] ダイアログ ボックスで、[追加] をクリックします。

  6. [名前] ボックスに動作規則の名前を入力します。

  7. 動作規則を実行する条件を指定するには、[条件の設定] をクリックして条件を入力します。条件が満たされると、動作規則が実行されます。条件を設定しない場合は、ユーザーがコントロールの値を変更した後、そのコントロール以外へカーソルを移動するたびに動作規則が実行されます。

  8. [動作の追加] をクリックします。

  9. [動作] ボックスの一覧で、[データ接続を使用してクエリを送信する] をクリックします。

  10. [データ接続] ボックスの一覧で、使用するクエリ データ接続をクリックし、[OK] をクリックして各ダイアログ ボックスを閉じます。

  11. 変更内容をテストするには、[標準] ツール バーの [プレビュー] をクリックするか、Ctrl キーと Shift キーを押しながら B キーを押します。

クエリ データ接続を使用するボタンを追加する

フォーム テンプレートに基づくフォームへの入力時にクリックできるボタン コントロールをフォーム テンプレートに追加することができます。このボタンをクリックすると、クエリ データ接続からデータを取得できます。

  1. 複数のビューを持つフォーム テンプレートの場合、[表示] メニューの [ビュー名] をクリックして、セカンダリ データ ソースのデータを表示するコントロールがあるビューに移動します。

  2. [コントロール] 作業ウィンドウが表示されていない場合は、[挿入] メニューの [コントロールの選択] をクリックするか、Alt キーを押しながら I キー、C キーの順に押します。

  3. ボタン コントロールをフォーム テンプレートにドラッグします。

  4. フォーム テンプレートに追加したボタン コントロールをダブルクリックします。

  5. [全般] タブをクリックします。

  6. [操作] ボックスの一覧で、[更新] をクリックします。

  7. [ラベル] ボックスに、フォーム テンプレートのボタンに表示するボタンの名前を入力します。

  8. [設定] をクリックします。

  9. [更新] ダイアログ ボックスで、[1 つのセカンダリ データ ソース] をクリックします。

  10. [セカンダリ データ ソースを選択してください] ボックスの一覧で、クエリ データ接続に関連付けられたセカンダリ データ ソースをクリックします。

  11. [OK] をクリックして、開いている各ダイアログ ボックスを閉じます。

  12. 変更内容をテストするには、[標準] ツール バーの [プレビュー] をクリックするか、Ctrl キーと Shift キーを押しながら B キーを押します。

ページの先頭へ

送信データ接続を追加する

データ接続ファイルに送信データ接続用の設定が含まれている場合は、ユーザーがこのデータ接続を使用してフォーム データを送信できるようにフォーム テンプレートを構成することができます。ユーザーによるフォームのデータの送信を許可するようにフォーム テンプレートを構成すると、[標準] ツールバーに [送信] ボタンが追加され、フォームの [ファイル] メニューに [送信] コマンドが追加されます。[送信オプション] ダイアログ ボックス ([ツール] メニュー) で、フォーム テンプレートの送信オプションを構成できます。送信オプションの構成は、送信データ接続であるセカンダリ データ接続を追加した場合と同じ方法で行います。フォーム テンプレートに送信データ接続を追加する方法の詳細については、[参照] セクションのリンクを参照してください。

  1. [ツール] メニューの [データ接続] をクリックします。

  2. [データ接続] ダイアログ ボックスで、[追加] をクリックします。

  3. データ接続ウィザードで、[Microsoft Office SharePoint Server 上で接続を検索] をクリックし、[次へ] をクリックします。

  4. ウィザードの次のページの [サイト] ボックスの一覧で、接続ライブラリが格納されているサイトの名前をクリックします。

    目的のサイトが一覧にない場合

    目的のサイトを一覧に追加するには、次の操作を行います。

    1. [サイトの管理] をクリックします。

    2. サイトの管理] ダイアログ ボックスで、[追加を] をクリックします。

    3. [URL ] ボックスで、データ接続ライブラリの場所を入力します。

    4. 表示名] ボックスで、データ接続ライブラリの名前を入力します。サイトリストのデータ接続ウィザードでこの名前が表示されます。

    5. [OK] をクリックします。

    6. [閉じる] をクリックします。

  5. データ接続ライブラリの名前をクリックしてデータ接続ファイルの一覧を表示し、この送信データ接続に使用するデータ接続ファイルの名前をクリックします。次に、[次へ] をクリックします。

  6. 設定が Web サービスへの送信データ接続用である場合は、データを受信できる Web サービスのパラメータが InfoPath によって検出されます。送信データ接続は、フォーム テンプレートのすべてのデータまたは一部のデータを送信するように構成できます。

    操作方法

    1. [パラメータ] ボックスの一覧で、フォームのデータを受信するパラメータをクリックします。

    2. ルート要素および処理命令を含めて、フォームにあるこのパラメータのデータをすべて送信するには、次の操作を行います。

      1. [フォーム全体 (処理命令を含む XML ドキュメント)] をクリックします。

      2. データを文字列として送信するには、[データを文字列として送信する] チェック ボックスをオンにします。通常、このチェック ボックスは、デジタル署名したデータを送信する場合にオンにします。ほとんどの場合はこのチェック ボックスをオフにします。

    3. このパラメータにフィールドまたはグループを指定するには、次の操作を行います。

      1. [パラメータ オプション] の [フィールドまたはグループ] をクリックします。

      2. [データ ソース] ボタン変更] をクリックします。

      3. [フィールドまたはグループの選択] ダイアログ ボックスで、送信するデータが含まれるフィールドまたはグループをクリックし、[OK] をクリックします。

      4. [含める] ボックスの一覧で、[テキストと子要素のみ] をクリックし、フィールドまたはグループの内容のみを送信するか、[選択した要素を含む XML サブツリー] をクリックし、フィールドまたはグループの内容と選択したフィールドまたはグループの両方を送信します。

    4. 各パラメータについて、これらの手順を繰り返します。

  7. [次へ] をクリックします。

  8. ウィザードの次のページで、[このデータ接続の名前を入力してください] ボックスに、この送信データ接続のわかりやすい名前を入力します。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×