外部データ ソースをピボット テーブルを作成します。

すべてのデータを分析できると、より的確なビジネス上の意思決定を行うことができます。ただし、何から始めればいいかわからない場合があります。特に、Microsoft Access または Microsoft SQL Server データベースや、オンライン分析処理 (OLAP) キューブ ファイルなど、Excel 以外に大量のデータが格納されている場合です。その場合は、外部データ ソースに接続し、ピボットテーブルを作成してデータの集計、分析、調査、プレゼンテーションを行います。

ここでは、既存の外部データ接続を使用してピボットテーブルを作成する方法を説明します。

  1. ワークシートで、セルをクリックします。

  2. [挿入]、[ピボットテーブル] の順にクリックします。

    [挿入] タブの [ピボットテーブル] ボタン

  3. [ピボットテーブルの作成 ] ダイアログ ボックスで、[分析するデータを選んでください。] の下にある [外部データ ソースを使用] をクリックします。

    選択されている外部データ ソースを使用してピボット テーブル] ダイアログ ボックスを作成します。

  4. [接続の選択] をクリックします。

  5. [接続] タブの [表示] ボックスで、[すべての接続] が選択されたままにするか、接続先のデータ ソースが含まれる接続カテゴリを選びます。

既存の接続を再利用または共有するには、[このブック内の接続] から接続を使います。

  1. 接続のリストで、目的の接続を選んで [開く] をクリックします。

  2. [ピボットテーブル レポートを配置する場所を選んでください。] で、場所を選びます。

    • 新しいワークシートのセル A1 を先頭とするセル範囲にピボットテーブルを配置するには、[新規ワークシート] を選びます。

    • 作業中のワークシートにピボットテーブルを配置するには、[既存のワークシート] を選び、[場所] ボックスに、ピボットテーブルを開始するセルを入力します。

  3. [OK] をクリックします。

    Excel では、空のピボット テーブルを追加し、できるようにフィールドを表示して配置を変更したり、独自のレイアウトを作成するのには、フィールド リストを表示します。

    外部データ フィールドが表示されたフィールド リスト

  4. フィールド リスト セクションで、フィールド名の横のボックスをオンにして、[フィールド リスト] の領域セクションの既定の領域にフィールドを配置します。

    通常は、数値以外のフィールドは [] 領域に追加され、数値フィールドは [] 領域に追加され、日時フィールドは [] 領域に追加されます。必要に応じて、フィールドを別の領域に移動できます。

    ヒント:  また、フィールド名を右クリックし、[レポート フィルターに追加]、[列ラベルに追加]、[行ラベルに追加]、または [値に追加] を選んで、領域セクションのその領域にフィールドを配置したり、フィールド セクションから領域セクションの領域にフィールドをドラッグしたりすることもできます。

    領域セクション内のフィールドを右クリックし、目的の領域を選択し、または領域セクションの領域間でフィールドをドラッグして、さらにピボット テーブルのデータを並べ替えるには、フィールド リストを使用します。

新しい外部データ ソースに接続する

SQL Server への新しい外部データ接続を作成し、データを Excel にテーブルまたはピボットテーブルとしてインポートするには、次の操作を行います。

  1. [データ]、[その他のデータ ソース] の順にクリックします。

[データ] タブの [その他のデータ ソース] ボタン

  1. 目的の接続をクリックします。

    • [SQL Server] をクリックして、SQL Server テーブルへの接続を作成します。

    • [Analysis Services] をクリックして、SQL Server 分析キューブへの接続を作成します。

  2. [データ接続ウィザード] で、接続を確立する手順を実行します。

    • 1 ページ目では、データベース サーバーを入力し、サーバーへのログオン方法を指定します。

    • 2 ページ目では、目的のデータが含まれているデータベース、テーブル、またはクエリを入力します。

    • 3 ページ目では、作成する接続ファイルを入力します。

Access データベースへの新しい接続を作成し、データを Excel にテーブルまたはピボットテーブルとしてインポートするには、次の操作を行います。

  1. [データ]、[Access データベース] の順にクリックします。

[データ] タブの [Access データベース] ボタン

  1. [データ ソースの選択] ダイアログ ボックスで、接続先のデータベースを見つけて [開く] をクリックします。

  2. [テーブルの選択] ダイアログ ボックスで、目的のテーブルを選び、[OK] をクリックします。

複数のテーブルがある場合は、目的のテーブルのボックスをオンにできるように [複数のテーブルの選択を使用可能にする] ボックスをオンにし、[OK] をクリックします。

  1. [データのインポート] ダイアログ ボックスで、データをブックで表示する方法と配置する場所を選び、[OK] をクリックします。

テーブルがデータ モデルに追加すると、自動的にされ、Access データベースは、ブックの接続に追加されます。

ピボットテーブルの詳細

注記: 

  • 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

  • この記事の英語版を参照するには、ここ をクリックしてください。Microsoft コミュニティの他のメンバーと一緒に、Community Translation Framework (CTF) を使ったこの記事の改善にご協力ください。記事内の文章にマウス ポインターを合わせて、CTF ウィジェットの [翻訳を改善します] をクリックしてください。CTF の詳細については、ここ をクリックしてください。CTF を使用すると弊社の サービス利用規約 に同意したことになります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×