外部データ範囲とそのプロパティを管理する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

外部データ範囲のプロパティを変更すると、データベース、Web クエリ、テキスト ファイルなどの外部データ ソースへの接続を通じてワークシートにインポートされたデータを制御できます。

目的に合ったトピックをクリックしてください

詳細については、外部データ範囲とプロパティ

外部データ範囲を検索する

外部データ範囲の名前を変更する

外部データ範囲の基になるクエリを変更する

外部データ範囲と基になるクエリをコピーする

外部データ範囲への新しいデータの追加方法を指定する

データの書式とレイアウトを指定する

外部データ範囲の拡張時に数式をコピーする

外部データ範囲内のデータを固定する

外部データ範囲のフィールド名をカスタマイズする

外部データ範囲を削除する

外部データ範囲とプロパティについて

外部データ範囲 (クエリ テーブルとも呼ばれます) は、ワークシートに取り込まれたデータの場所を定義する定義名 (テーブル名) です。Excel では、外部データに接続すると、外部データ範囲が自動的に作成されます。唯一の例外は、データ ソースに接続されたピボットテーブル レポートで、このレポートでは外部データ範囲は使用されません。Excel では、他のデータと同様に、外部データ範囲に対して書式やレイアウトを設定できるほか、外部データ範囲を計算で使用できます。

外部データ範囲のプロパティ

外部データ範囲には、接続のプロパティとは別に追加的なプロパティがあり、これらのプロパティを使用すると、セルの書式設定や列の幅を保持するなど、データの管理を行うことができます。外部データ範囲のこれらのプロパティを変更するには、[データ] タブの [接続] で [プロパティ] をクリックします。その後、次の操作を実行して必要な変更を加えます。

  • Microsoft Query およびデータ接続ウィザードで作成された外部データ範囲の場合は、[外部データのプロパティ] ダイアログ ボックスを使用します。

  • インポートされたテキスト ファイルまたは HTML データを取得する Web クエリから作成された外部データ範囲の場合は、[外部データ範囲のプロパティ] ダイアログ ボックスを使用します。

  • XML データを取得する Web クエリから作成された外部データ範囲の場合は、[XML の対応付けのプロパティ] ダイアログ ボックスを使用します。

外部データを含むテンプレートを使用する

外部データに基づいて作成された集計やレポートを共有する場合は、外部データ範囲が含まれているブックを他のユーザーに提供するか、レポート テンプレートを作成することができます。レポート テンプレートを使用すると、外部データを保存せずに集計やレポートを保存できるため、ファイルのサイズが小さくなります。外部データは、ユーザーがレポート テンプレートを開いたときに取得されます。

ページの先頭へ

外部データ範囲を検索する

  1. 外部データ範囲を検索するワークシートを選択します。

  2. 数式バーの名前ボックスの横にある矢印をクリックし、目的の外部データ範囲の名前をクリックします。

ページの先頭へ

外部データ範囲の名前を変更する

  1. [数式] タブの [定義された名前] で、[名前の管理] をクリックします。

    [数式] タブの [定義された名前] グループ

  2. [名前の管理] ダイアログ ボックスで、外部データ範囲の名前をクリックし、[編集] をクリックします。名前をダブルクリックすることもできます。

  3. [名前の編集] ダイアログ ボックスで、[名前] ボックスに参照範囲の新しい名前を入力します。

注: [名前の管理] ダイアログ ボックスの [閉じる] ボタンをクリックすると、ダイアログ ボックスが閉じます。既に行った変更は、[閉じる] ボタンをクリックしなくても反映されています。

ページの先頭へ

外部データ範囲の基になるクエリを変更する

Microsoft Query、インポートされたテキスト ファイル、Web クエリ、またはデータ接続ウィザードから作成された外部データ範囲の基になるクエリを変更できます。

Microsoft Query から作成された外部データ範囲の基になるクエリを変更する

  1. 基になるクエリを変更する外部データ範囲内のセルをクリックします。

  2. [データ] タブの [接続] で [プロパティ] をクリックします。

    Excel のリボンのイメージ

  3. [外部データのプロパティ] ダイアログ ボックスで、 プロパティ (接続のプロパティ) をクリックします。

  4. [接続のプロパティ] ダイアログ ボックスで、[定義] タブをクリックし、[クエリの編集] をクリックします。

Microsoft Query でクエリを作成および編集する方法の詳細については、Microsoft Query のヘルプを参照してください。

インポートされたテキスト ファイルから作成された外部データ範囲の基になるクエリを変更する

  1. 基になるクエリを変更する外部データ範囲内のセルをクリックします。

  2. [データ] タブの [接続] で [接続] をクリックします。

    Excel のリボンのイメージ

  3. [ブックの接続] ダイアログ ボックスで、[プロパティ] をクリックします。

  4. [接続のプロパティ] ダイアログ ボックスで、[定義] タブをクリックし、[クエリの編集] をクリックします。

  5. [テキスト ファイルのインポート] ダイアログ ボックスで、[インポート] をクリックします。

  6. テキスト ファイル ウィザードで、テキスト ファイルのインポートの設定に変更を加え、[完了] をクリックします。

    テキスト ファイルをインポートする方法の詳細については、「テキスト ファイルをインポートまたはエクスポートする」を参照してください。

Web クエリから作成された外部データ範囲の基になるクエリを変更する

  1. 基になるクエリを変更する外部データ範囲内のセルをクリックします。

  2. [データ] タブの [接続] で [プロパティ] をクリックします。

    Excel のリボンのイメージ

  3. [ブックの接続] ダイアログ ボックスで、[プロパティ] をクリックします。

  4. [接続のプロパティ] ダイアログ ボックスで、[定義] タブをクリックし、[クエリの編集] をクリックします。

  5. [Web クエリの編集] ダイアログ ボックスで Web クエリに変更を加え、[完了] をクリックします。

Web クエリを作成および編集する方法の詳細については、「Web ページから外部データを取得する」を参照してください。

データ接続ウィザードを使用して作成された外部データ範囲の基になるクエリを変更する

  1. 基になるクエリを変更する外部データ範囲内のセルをクリックします。

  2. [データ] タブの [接続] で [プロパティ] をクリックします。

    Excel のリボンのイメージ

  3. [外部データのプロパティ] ダイアログ ボックスで、 プロパティ (接続のプロパティ) をクリックします。

  4. [接続のプロパティ] ダイアログ ボックスで、[定義] タブをクリックします。

  5. 次のいずれかの操作を行います。

    • [コマンドの種類] ボックスの [テーブル] をクリックし、[コマンド文字列] ボックスの値を適切なテーブル、ビュー、またはクエリの名前に変更します。

    • [コマンドの種類] ボックスの [SQL] または [標準] をクリックし、[コマンド文字列] ボックスで SQL ステートメントを編集します。

      注: 接続の定義によっては、[コマンドの種類] ボックスが使用できない (選択不可になる) 場合があります。

ページの先頭へ

外部データ範囲と基になるクエリをコピーする

  1. 数式バーの名前ボックスの横にある矢印をクリックし、コピーする外部データ範囲の名前をクリックします。

    Excel のテーブルの場合は、範囲の名前を選択し、Ctrl キーを押しながら A キーを押して、テーブルの見出しを選択します。

    外部データ範囲に含まれていない列ラベルや数式を含める場合は、コピーする列ラベルまたは数式を含むセルを選択します。次に、数式バーの名前ボックスの横にある矢印をクリックし、コピーする外部データ範囲の名前をクリックします。

  2. [ホーム] タブの [クリップボード] で、[コピー] をクリックします。

    [ホーム] タブの [クリップボード]

  3. 外部データ範囲を貼り付けるブックに切り替えます。

  4. 貼り付け領域の左上隅のセルをクリックします。

    外部データによって既存のワークシート データが上書きされないように、クリックするセルの下や右側にデータがないことを確認してください。

  5. [ホーム] タブの [クリップボード] で、[貼り付け] をクリックします。

注: 外部データ範囲の一部のみをコピーする場合、基になるクエリいないがコピーされ、コピーしたデータを更新することはできません。

ページの先頭へ

外部データ範囲への新しいデータの追加方法を指定する

データの更新時に現在のデータ セットと大きさの異なるデータ セットが Excel に返された場合の処理方法を制御できます。

  1. [データ] タブの [接続] で [プロパティ] をクリックします。

    Excel のリボンのイメージ

  2. [外部データ範囲のプロパティ] ダイアログ ボックスの [変更されたレコード (行) のデータ更新時の処理] で、次のいずれかをクリックします。

    • [新しいデータのセルを挿入し、使用されていないセルを削除する]

      注記: 

      • データ ソースで 1 つ以上の行が追加された場合、外部データ範囲のすぐ下のセルを下へ移動し、外部データ範囲の右側のセルは移動しません。

      • データ ソースで 1 つ以上の行が削除された場合、外部データ範囲のすぐ下のセルを上へ移動し、外部データ範囲の右側のセルは移動しません。

    • [新規データの行全体を挿入し、使用されていないセルはクリアする]

      注記: 

      • データ ソースで 1 つ以上の行が追加された場合、外部データ範囲のすぐ下のセルと右側のセルを下へ移動します。

      • データ ソースで 1 つ以上の行が削除された場合、外部データ範囲のすぐ下のセルと右側のセルは移動しません。

    • [既存のセルを新規データで上書きし、使用されていないセルはクリアする]

      注記: 

      • データ ソースで 1 つ以上の行が追加された場合、外部データ範囲のすぐ下のセルを上書きし、外部データ範囲の右側のセルは移動しません。

      • データ ソースで 1 つ以上の行が削除された場合、外部データ範囲のすぐ下のセルと右側のセルは移動しません。

ページの先頭へ

データの書式とレイアウトを指定する

  1. [データ] タブの [接続] で [プロパティ] をクリックします。

    Excel のリボンのイメージ

  2. [データのレイアウト] で、次のうち、必要な操作を行います。

    • フィールド名を最初の行として含めるには、[フィールド名を含む] チェック ボックスをオンにします。

      注: このチェック ボックスは、Microsoft Office 2003 プログラムから変換された外部データ範囲、またはプログラムによって作成された外部データ範囲でのみ使用できます。

    • 行番号の列を追加するには、[行番号を含む] チェック ボックスをオンにします。

      注: このチェック ボックスは、インポートされたテキスト ファイル、XML ファイル、または Web クエリに対しては使用できません。

    • 適用したセルの書式設定を保持するには、[セル書式を保持する] チェック ボックスをオンにします。

      注: Web クエリの場合は、[オプション] ダイアログ ボックスで [HTML 形式] を選択すると、このチェック ボックスが自動的にオフになります。[オプション] ダイアログ ボックスは、[クエリの編集] ダイアログ ボックスから表示できます。

    • 設定した列の幅を保持するには、[列の幅を調整する] チェック ボックスをオンにします。

    • 適用した列の並べ替え、フィルタ、およびレイアウトを保持するには、[列の並べ替え/フィルタ/レイアウトを保持する] チェック ボックスをオンにします。

      注: このチェック ボックスは、Web クエリに対しては使用できません。

    • 適用した列のフィルタを保持するには、[列のフィルタを保持する] チェック ボックスをオンにします。

      注: このチェック ボックスは、XML データを基にした Web クエリでのみ使用できます。

ページの先頭へ

外部データ範囲の拡張時に数式をコピーする

注: 次に示す手順は、Microsoft Office 2003 プログラムから変換された外部データ範囲、またはプログラムによって作成された外部データ範囲にのみ適用されます。ユーザー インターフェイスを使用して作成される外部データ範囲は、すべて Excel のテーブルになります。これらの表は、新しい行が追加されると自動的に拡張され、計算される列には数式が設定されます。

  1. 外部データ範囲の最初のデータ行に隣接するセルに数式を入力します。

    注: 最初のデータ行とは、外部データ範囲の最初の行にヘッダーが含まれている場合は 2 番目の行、ヘッダーが含まれていない場合は最初の行です。

  2. セルを選択し、フィル ハンドルをダブルクリックして、数式を外部データ範囲のすべての行にコピーします。

  3. 外部データ範囲内のセルを 1 つクリックします。

  4. [データ] タブの [接続] で [プロパティ] をクリックします。

    Excel のリボンのイメージ

  5. [外部データ範囲のプロパティ] ダイアログ ボックスで、[データの隣接する列に数式をコピーする] チェック ボックスをオンにします。

    注: 最新の情報に更新時に外部データ範囲が拡張されると、外部データ範囲に直接隣接する数式、または外部データ範囲内の数式だけがコピーされます。

ページの先頭へ

外部データ範囲内のデータを固定する

外部データ範囲を固定した場合、データは保持されますが、基になるクエリは保持されません。したがって、固定された外部データ範囲は更新できません。

Excel のテーブルのデータを固定する

  1. データ接続を削除する Excel のテーブルが含まれているワークシートをクリックします。

  2. 数式バーで、[名前] ボックスの横の矢印をクリックし、[データ接続を削除する外部データ範囲の名前をクリックします。データの範囲が選択されます。

  3. [ツール] タブの [テーブルの外部データ] グループで、リンクの解除] をクリックします。データの範囲し、は何もの同じ名前が、接続が削除されます。

範囲内のデータを固定する

注: 次に示す手順は、Microsoft Office 2003 プログラムから変換された外部データ範囲、またはプログラムによって作成された外部データ範囲にのみ適用されます。ユーザー インターフェイスを使用して作成される外部データ範囲は、すべて Excel のテーブルになります。これらの表は、新しい行が追加されると自動的に拡張され、計算される列には数式が設定されます。

  1. [データ] タブの [接続] で [プロパティ] をクリックします。

    Excel のリボンのイメージ

  2. [クエリの定義] で [クエリの定義を保存する] チェック ボックスをオフにします。

注: ブックを保存すると、基になるクエリはブックから削除されます。ただし、保存されたデータベース クエリ ファイル (.dqy ファイルまたは .odc ファイル) は削除されません。クエリ ウィザードや Microsoft Query でクエリを作成したときにこれを保存した場合は、クエリ ファイルがコンピュータ上に保存されているため、このクエリを再度使用して外部データを取得できます。詳細については、Microsoft Query のヘルプを参照してください。

ページの先頭へ

外部データ範囲のフィールド名をカスタマイズする

注: 次に示す手順は、データ接続ウィザードまたは Microsoft Query を使用して作成された外部データ範囲 (インポートされたテキスト ファイルと Web クエリを除く)、Microsoft Office 2003 プログラムから変換された外部データ範囲、またはプログラムによって作成された外部データ範囲にのみ適用されます。ユーザー インターフェイスを使用して作成される外部データ範囲は、すべて Excel のテーブルになります。

  1. 次のいずれかの操作を行って、外部データ範囲の上に空白の行を挿入します。

    • 新しい行を挿入する位置の下にあるセルをクリックします。次に、[ホーム] タブの [セル] で [挿入] の横にある矢印をクリックし、[シートの行を挿入] をクリックします。1 つのセルを選択したので、新しい行が 1 行、現在の行の上に追加されます。

    • 新しい行を挿入する位置の下にある行の行セレクターをクリックします。次に、[ホーム] タブの [セル] で [挿入] をクリックします。1 行全体を選択したので、新しい行が 1 行、選択した行の上に挿入されます。

  2. 空白の行のセルに必要なラベルを入力します。

  3. 外部データ範囲内のセルを 1 つクリックします。

  4. [データ] タブの [接続] で [プロパティ] をクリックします。

    Excel のリボンのイメージ

  5. [外部データ範囲のプロパティ] ダイアログ ボックスで、[データのレイアウト] の [フィールド名を含む] チェック ボックスをオフにし、[OK] をクリックします。

  6. 既存のフィールド名を削除して外部データ範囲を更新するには、外部データ範囲内のセルをクリックし、 ボタン イメージ (データの更新) をクリックします。

注: データベースからデータを取得する場合は、Microsoft Query で列名を変更すると、その変更が外部データ範囲に保持されます。クエリで列名を変更する方法の詳細については、Microsoft Query のヘルプを参照してください。

ページの先頭へ

外部データ範囲を削除する

  1. 削除する外部データ範囲を含むワークシートをクリックします。

  2. 数式バーの名前ボックスの横にある矢印をクリックし、削除する外部データ範囲の名前をクリックします。

    外部データ範囲が Excel のテーブルの場合は、Ctrl キーを押しながら A キーを押して、表全体を選択します。

  3. 外部データ範囲を削除するには、Del キーを押します。

  4. 基になるクエリを削除するには、確認のメッセージが表示されたときに [はい] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×