図形間にコネクタを追加する

Office 365 サブスクリプション, Office 2019, Office 2016, Office 2013, Office 2010

Visio を使うと、図面の図形を簡単に接続できます。 オートコネクトを使って、図形を追加するときに接続したり、コネクタ ツールを使って既存の図形を接続したりすることができます。 ミニ ツール バーに表示される図形を変更したり、オートコネクトを有効または無効にしたりすることもできます。

図形を自動的に接続する

ページ上の既存の図形を接続する

別のページの図形に接続する

テーマを使用してコネクタの外観を変更する

代替コネクタ図形を使用する

オートコネクト ミニ ツール バーの図形を変更する

オートコネクトを有効または無効にする

図形を自動的に接続する

図形を接続する 1 つの方法として、図形をページに追加するときに、Visio で自動的に接続することができます。 これは、フローチャートを作成するときに特に便利です。

  1. オートコネクトがアクティブになっていることを確認します。 [表示] タブの [視覚補助] グループで、[オートコネクト] が選択されていることを確認します。

  2. [図形] ウィンドウからページに図形をドラッグします。

  3. 図形をポイントして、図形の周囲にオートコネクト矢印が表示されるまでそのままにします。

    [オートコネクト] がアクティブの場合、図形をポイントすると、接続矢印が表示されます。
  4. 図形を追加する方向の矢印をポイントします。

    [オートコネクト] 矢印をポイントすると、追加する図形のツール バーが表示されます。

    現在、[クイック図形] ステンシルにある最初の 4 個のクイック図形を含むミニツール バーが表示されます。 ツールバーの図形をポイントすると、ページにその図形のプレビューが表示されます。

  5. 追加する図形をクリックします。

  6. 続ける場合は、新しく追加した図形のオートコネクトの矢印をポイントし、別の図形を追加します。その図形は自動的に接続されます。

    新しく追加された図形をポイントすると、別の図形を追加するための [オートコネクト] 矢印が表示されます。

ページの先頭へ

ページ上の既存の図形を接続する

ヒント: [ホーム] タブの [ツール] グループのコマンドを使うと、Visio が異なる状態やモードになり、わかりにくい場合があります。 オブジェクト選択ツール オブジェクトを選ぶ (Ctrl + 1 キー) とコネクタ ボタンの画像 (Ctrl + 3 キー) ツールを簡単に切り替えるには、キーボードを使ってください。 テキスト ブロック接続ポイントなど、どのツールを使っていても、Esc キーを数回押すとオブジェクト選択ツールに戻ります。

  1. [ホーム] タブの [ツール] グループで [コネクタ] ボタンの画像 をクリックするか、Ctrl + 3 キーを押します。

  2. 図形をクリックし、コネクタを別の図形にドラッグします。

  3. 終了したら、[ホーム] タブの [ツール] グループで [オブジェクト選択ツール] オブジェクトを選ぶ をクリックするか、Ctrl + 1 キーを押します。

コネクタ ツールは、各端点にポイント接続がある図形に接続します。

または、[図形の接続] コマンドをリボンに追加し、このコマンドを使用して複数の図形を、選択した順に接続することができます。

ヒント: リボンにまだ表示されていない便利なコマンドを追加するには、[ファイル]、[オプション]、[リボンのユーザー設定] の順にクリックします。

ページの先頭へ

別のページの図形に接続する

コネクタは、同じページ上の図形の間でのみ使うことができます。 別のページ上の図形に接続するには、[外部ページ参照] 図形を使ってページ間にハイパーリンクを作成します。また、同じドキュメント内の別のページに移動できるように [ハイパーリンク] と [ダブルクリック] アクションを任意の図形に追加する方法もあります。

外部ページ参照を使用する

  1. [基本フローチャート用図形] ステンシルを開き、現在のページにある [外部ページ参照] 図形をドラッグします。

    外部ページ参照図形
  2. [外部ページ参照] ダイアログ ボックスで、[OK] を選んで、現在のページと新しく作成されるページに図形を追加します。

  3. 新しいページで、図の作成を続けます。

  4. [外部ページ参照] 図形の外観を変更するには、図形を右クリックし、[別のページへの参照]、[別のページからの参照]、[]、または [矢印] を選びます。

ページ間を移動するには、いずれかのページの外部ページ参照図形をダブルクリックします。 詳細については、「[外部ページ参照] ダイアログ ボックス」をご覧ください。

ハイパーリンクとダブルクリックを使用する

  1. 任意の図形を右クリックするか Ctrl キーを押しながら K キーを押し、[ハイパーリンク] を選択します。

  2. [サブアドレス] フィールドの横にある [参照] をクリックし、[ページ] の横のドロップダウン リストをクリックして目的のページを選択します。

    [ハイパーリンク] ダイアログ ボックス

    注: ハイパーリンクに対して、移動先ページにある図形の名前を指定することもできます。 [開発] タブをクリックし、[図形名] を選択し、[名前] フィールドの既定の名前を使用するか変更して、[OK] をクリックします。

  3. 図形のダブルクリック アクションを設定するには、[開発] タブをクリックし、[基本動作] を選択します。

  4. [ダブルクリック] タブをクリックし、[指定のページへ移動] オプションを選択し、ドロップダウン リストをクリックして目的のページを選択します。

    Visio のダブルクリック時の動作

    注: ページ名は自動的に更新されないため、ページ名を変更した場合にのみ、この操作を行ってください。

ページの先頭へ

テーマを使用してコネクタの外観を変更する

コネクタの既定の外観は単純な線となることがありますが、矢印などの装飾が追加されているテーマを使用することで、コネクタをデザインすることができます。 組み込みテーマは [デザイン] タブの [テーマ] ギャラリーから適用できます。 スタイル、色、および重みなどのコネクタの属性を変更するには、「コネクタの形状編集」を参照してください。

注: 

  • 他の装飾を表示するには、[デザイン] タブをクリックします。 [バリエーション] グループで、ドロップ ダウン矢印をクリックし、[コネクタ] を選択します。

代替コネクタ図形を使用する

[その他の図形]、[Visio エキストラ] の [コネクタ] ステンシルで提供されているようなコネクタ図形を使用すれば、既定の [動的コネクタ] 図形を使用しなくても、図形をまとめて接続することができます。 これらのコネクタ図形は、ページにドラッグ アンド ドロップすることも、[コネクタ] ツールおよび [図形の接続] ツールで使用するために選択することも、既存のコネクタを置換するためにだけ使用することもできます。

  1. 代替コネクタ図形を含むステンシルを開く

  2. ページ上で置換する既存のコネクタを選択します。

  3. [編集] グループの [ホーム] タブで、[図形の変更] をクリックして目的のコネクタ図形を選択します。

注: [図形の変更] 機能は Visio 2013 で導入されましたが、[コネクタ] ツールと [図形の接続] ツールは Visio 2007 で導入されています。

ページの先頭へ

オートコネクト ミニ ツール バーの図形を変更する

ミニ ツール バーの図形は、図の [クイック図形] ステンシルのものです。 ミニ ツール バーには、最大で 4 つの図形が表示されます。 ミニ ツール バーに表示される図形をカスタマイズすることができます。 次の手順では、例として [基本図] を使います。

  1. 既定では、ミニ ツール バーに表示される図形は、[クイック図形] ステンシルの直後にあるステンシルの最初の 4 つの図形です。 たとえば、[基本図] ステンシルではこれらが最初の 4 つの図形です。

    既定の基本的な図形を使うミニ ツール バー
  2. 特定のステンシルのミニ ツール バーに別の図形を表示するには、図形をステンシルの先頭にドラッグして順序を変更できます。 たとえば、[星 4]、[星 5]、[星 6]、[星 7] の各図形を、[基本図] ステンシルの先頭にドラッグできます。

    新しい基本的な図形のミニ ツール バー
  3. また、[図形] ウィンドウの上または下にドラッグして、ステンシルの順序を変更することもできます。 これらの図形のサブセットが、[図形] ウィンドウと同じ順序で [クイック図形] ステンシルに表示されます。 たとえば、[装飾図形] ステンシルを [図形] ウィンドウの [クイック図形] ステンシルの直後にドラッグすると、[クイック図形] ステンシルの順序が変わります。

    並べ替えて別のステンシルを使うミニ ツール バー

    注: 図をいったん閉じて再び開くと、[図形] ウィンドウ内のステンシルの既定の順序が自動的に復元され、[クイック図形] に反映されます。

  4. ミニ ツール バーの基として別のステンシルを使うには、[クイック図形] ステンシルで、ステンシルの図形のサブセットの図形を選びます。 たとえば、[グラフと数学の図形] ステンシルで [ベン図] を選びます。

    選んで新しいステンシルを使うミニ ツール バー

ヒント: ステンシル内の図形の既定の順序に戻すには、[図形] ウィンドウでステンシル名を右クリックし、[ステンシルのリセット] を選択します。

注: ミニ ツール バーで使うことができる図形が含まれないステンシルもあります。 たとえば、[矢印図形] ステンシルの図形は、ミニ ツール バーに表示されません。

ページの先頭へ

オートコネクトを有効または無効にする

現在の図面について、またはすべての Visio 図面の既定値として、オートコネクトをアクティブ化または非アクティブ化できます。

アクティブな図でオートコネクトを有効または無効にする

  • [表示] タブの [視覚補助] グループで [オートコネクト] をオンまたはオフにします。

    [表示] タブの [オートコネクト] をオンまたはオフにして、オートコネクトをアクティブまたは非アクティブにします。

[オートコネクト] チェック ボックスを使用できない場合は、次の手順どおりに行って、すべての図についてオートコネクトが無効になっているかどうかを確認します。

すべての図でオートコネクトを有効または無効にする

  1. [ファイル] タブをクリックし、[オプション] をクリックします。

  2. [Visio のオプション] で [詳細設定] をクリックします。

  3. [編集オプション] で、[オートコネクトを有効にする] をオンにし、オートコネクトを有効にします。 オートコネクトを無効にするには、[オートコネクト] チェック ボックスをオフにします。

    [オートコネクトを有効にする] をオンまたはオフにして、すべての図または図面に対してオートコネクトをアクティブまたは非アクティブにします。
  4. [OK] をクリックします。

ページの先頭へ

オートコネクトを使用して図形を接続する

図形を接続する 1 つの方法として、図形を図面に追加したときに、Visio に自動的に接続させることを挙げることができます。 フローチャートを作成するときは特に便利です。

図形を図面に追加して、Visio に既存の図形に自動的に接続させる手順は次のとおりです。

図形をページにドラッグするときにオートコネクトを使用する

  1. ステンシルから図面ページに図形をドラッグし、別の図形の近くに配置します。

    別の図形付近に配置した図形

  2. マウス ボタンを押したまま、ポインターを青い三角形のいずれかの上に移動します。 三角形が濃い青色になります。

    青い三角形の 1 つの上にポインターがあり、三角形が濃い青色になります。

  3. マウス ボタンを放します。 図形を図面ページに配置し、コネクタを追加して両方の図形に接着します。

    図形を図面ページに配置し、コネクタを追加して両方の図形に接着します。

ヒント: 図形をドラッグしない場合は、最初にステンシルで図形を選択して、図面の図形にポインターを置き、その図形の近くに表示された青い三角形のいずれかをクリックすると、同じ結果を得ることができます。

ページ上の既存の図形にオートコネクトを使用する

  1. 接続の図形の上にポインターを置きます。

    接続元の図形上にあるポインター

  2. 接続の図形に最も近い青い三角形の上にポインターを置きます。

    接続先の図形に最も近い青い三角形の上にポインターが置かれている。

    三角形が濃い青色になり、赤いボックスが接続先の図形の周囲に表示されます。

    注: 赤いボックスが接続先の図形の周囲に表示されない場合、図形が離れすぎている可能性があります。 図形を近くに移動して、もう一度お試しください。

  3. 青い三角形をクリックします。 コネクタが追加され、両方の図形に接着されます。

    図形を図面ページに配置し、コネクタを追加して両方の図形に接着します。

オートコネクトを有効または無効にする

オートコネクト機能は、すべての Visio 図面で有効または無効にしたり、現在の図面でのみ有効または無効にしたりできます。 すべての図面の場合

  1. [ツール] メニューの [オプション] をクリックします。

  2. [全般] タブをクリックします。

  3. [図面ウィンドウ] オプションで、[オートコネクトを有効にする] チェック ボックスをオンにします。

現在の図面のみの場合

  • [標準] ツールバーで、[オートコネクト] ツールをクリックします。

    注: [オートコネクト] ツールをクリックしてもオートコネクトが有効にならない場合は、[オプション] ダイアログ ボックスで [オートコネクトを有効にする] チェック ボックスがオンになっていることを確認します。

コネクタ ツールを使用して図形を接続する

コネクタを追加および接着するために最も柔軟な方法の 1 つは、標準ツール バーのコネクタ ツール ボタンの画像 を使用して描画します。

  1. [標準] ツール バーでコネクタ ツール ボタンの画像 をクリックします。

  2. 次のいずれかの操作を行います。

    • コネクタを図形の特定の点に接着されたままにするには、最初の図形の接続ポイント ( 接続ポイントの画像 - 青い X ) を 2 番目の図形の接続ポイントにドラッグします。 図形が接続されると、コネクタの端点が赤色になります。 これは、ポイント間接続と呼ばれます。 ポイント間接続では、図形の 1 つを移動する場合、コネクタは同じ接続ポイントに接着され続けます。

    • コネクタを最も近い利用可能な接続ポイントに移動できるようにするには、コネクタ ツールを赤いボックスが図形の周囲に表示されるまで、最初の図形の中央に置きます。 マウス ボタンを押しながら、2 番目の図形の中央にドラッグします。 赤いボックスが 2 番目の図形の周囲に表示されたら、マウス ボタンを放します。 これは、図形間接続と呼ばれます。 図形間接続では、図形のいずれかを移動する場合、最も近い利用可能な接続ポイントに移動することで、コネクタがそれぞれの図形に接着されたままになります。 接続ポイントが表示されない場合、コネクタは最も近い側面に移動されます。

      注: また、コネクタの一方の端が接続ポイントに接続されている図形と、コネクタのもう一方の端が図形に接続されている図形間 (逆の場合も同様です) で、接続を作成することもできます。

  3. [標準] ツール バーのポインター ツール [ポインター] ボタン をクリックして、通常編集に戻ります。

    注: 

    • 1 つの図形から複数の図形にコネクタを追加するには、複数のコネクタを追加する必要があります。"分岐" のコネクタ図形はありません。

    • ポイント間接続を作成しようとして、目的の場所に正確にコネクタを接着するのが難しい場合は、別のスナップと接着の設定を試してください。

    • [ツール] メニューの [スナップと接着] をクリックして、[全般] タブで目的のオプションを選択します。

      図形座標、図形ハンドル、または図形の頂点に接着する場合は、いずれかの接続ポイントが既に存在していなければ、自動的に追加されます。

図形とポイント接続を切り替える

ある図形のあるポイントから別の図形の別のポイントに、またはある図形全体から別の図形全体に、コネクタを接着することができます。 また、コネクタの一方の端が図形上のポイントに接着され、他の端が図形全体に接着されているコネクタを作成することもできます。

  1. 図形からコネクタの端点をドラッグします。

  2. 次のいずれかの操作を行います。

    • コネクタの端点を図形の接続ポイントに接着するには、図形の接続ポイントのいずれかに端点をドラッグして、接続ポイントの周囲に赤いボックスが表示されるようにします。

    • コネクタの端点を図形全体に接着するには、図形の中央に端点をドラッグして、図形全体が赤いボックスで囲まれるようにします。

関連項目

コネクタのテキストを追加および編集する

カスタム コネクタを作成する

コネクタを接着または接着解除する

Visio のトレーニング

Visio デスクトップ コネクタ について知っておく必要があること (Visio チームのブログ)

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×