図形データをデータベースにエクスポートする

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。簡単に参照できるように、こちらに英語の記事があります。

図形にデータが含まれている場合は、データベースエクスポートウィザードを実行して、そのデータを含むデータベーステーブルを作成できます。

[データベースエクスポート] コマンドを使用して到達したデータベースエクスポートウィザードとダイアログボックスの違いは、ウィザードを使ってレイヤー上のすべての図形をエクスポートすることを選択できることです。レイヤー別にエクスポートする必要がない場合は、[データベースにエクスポート] コマンドを使うとより効率的になることがあります。

データベースエクスポートウィザードを使用する

  1. [表示] タブの [アドオン]、[ Visio エクストラ]、[データベースエクスポートウィザード] の順にクリックします。

  2. ウィザードのページの指示に従って操作します。

    ヒント: 

    • リストに表示される図形データのセル名の前には、支柱 (プロップ) などがあります。

    • データベースエクスポートウィザードを実行して図形データをエクスポートすると、ウィザードによってエクスポート関連の情報が図面ページに保存されます。図形に変更を加え、データをもう一度エクスポートする場合は、図面ページを右クリックし、[データベースエクスポートテーブル] を選択します。

[データベースにエクスポート] コマンドを使用する

  1. [表示] タブの [アドオン]、[ Visio エクストラ]、[データベースにエクスポート] の順にクリックします。

  2. 使用するデータベーステーブルを選択します。

    • データ ソースが既定の場所以外に保存されている場合は、[参照] をクリックして、ファイルの場所を指定します。

    • 新しいデータソースを作成するには、[作成] をクリックします。[新しいデータソースの作成] ウィザードを実行します。[完了] をクリックすると、[ ODBC セットアップ] ダイアログボックスが表示されます。そこから既存のデータベースを選択するか、または新規作成することができます。後でデータベースにテーブルを作成します。

      注: 

      • Excel をデータソースとして使用している場合は、既存のブックを選ぶことはできますが、ウィザードから作成することはできません。

      • Excel ブックを選ぶ場合は、 [ブックの選択] ダイアログボックスの [読み取り専用] チェックボックスをオフにしてください。

  3. データベースが所有者をサポートしている場合は、所有者リストで、所有者名をクリックして、テーブルの所有者のリストをフィルター処理します。データベーステーブルは、データベースへのログオンに使用した名前を使用して作成されます。

  4. データベースで複数のデータベースへのアクセスが許可されている場合、[限定子] ボックスで、使用するデータベースをクリックします。

    ヒント: Access または Excel を使用している場合は、データがエクスポートされるデータベースの名前と場所がここに表示されます。

  5. [テーブル] 一覧で、使用するデータベース テーブルをクリックします。新しいテーブルを作成するには、その名前を入力します。

  6. シェイプシート セルのデータをエクスポートする方法を変更する場合は、次のいずれかの操作を行います。

    エクスポートリストにシェイプシートのセルを追加する

    1. [追加] をクリックします。

    2. エクスポートするシェイプシート セルを選択します。

    3. [評価対象] ボックスで、データベース フィールドに格納される値のデータ型を選択します。

    4. 図形データのコピー先となるデータベース フィールドを選択します。

    5. データベースのデータ型、フィールドの長さ、データベース フィールドの小数の精度を指定します。

    シェイプシートセルのデータをエクスポートする方法を変更する

    1. セル名を選択し、[変更] をクリックします。

    2. データのエクスポート方法を変更する。

    エクスポートリストからシェイプシートのセルを削除する

    セル名を選択し、[削除] をクリックします。

データベースエクスポートウィザードを使用する

  1. [ツール] メニューの [アドオン] をポイントし、[ Visio エキストラ] をポイントして、[データベースエクスポートウィザード] をクリックします。

  2. ウィザードのページの指示に従って操作します。

    ヒント: 

    • リストに表示される図形データのセル名の前には、支柱 (プロップ) などがあります。

    • データベースエクスポートウィザードを実行して図形データをエクスポートすると、ウィザードによってエクスポート関連の情報が図面ページに保存されます。図形に変更を加え、データをもう一度エクスポートする場合は、図面ページを右クリックし、[データベースエクスポートテーブル] を選択します。

[データベースにエクスポート] コマンドを使用する

  1. [ツール] メニューの [アドオン] をポイントし、[ Visio エキストラ] をポイントして、[データベースにエクスポート] をクリックします。

  2. 使用するデータベーステーブルを選択します。

    • データ ソースが既定の場所以外に保存されている場合は、[参照] をクリックして、ファイルの場所を指定します。

    • 新しいデータソースを作成するには、[作成] をクリックします。[新しいデータソースの作成] ウィザードを実行します。[完了] をクリックすると、[ ODBC セットアップ] ダイアログボックスが表示されます。そこから既存のデータベースを選択するか、または新規作成することができます。後でデータベースにテーブルを作成します。

      注: 

      • Microsoft Office Excel をデータソースとして使用している場合は、既存のブックを選ぶことはできますが、ウィザードから作成することはできません。

      • Excel ブックを選ぶ場合は、 [ブックの選択] ダイアログボックスの [読み取り専用] チェックボックスをオフにしてください。

  3. データベースが所有者をサポートしている場合は、所有者リストで、所有者名をクリックして、テーブルの所有者のリストをフィルター処理します。データベーステーブルは、データベースへのログオンに使用した名前を使用して作成されます。

  4. データベースで複数のデータベースへのアクセスが許可されている場合、[限定子] ボックスで、使用するデータベースをクリックします。

    ヒント: Microsoft Office access または excel を使用している場合は、データのエクスポート先のデータベースの名前と場所がここに記載されています。

  5. [テーブル] 一覧で、使用するデータベース テーブルをクリックします。新しいテーブルを作成するには、その名前を入力します。

  6. シェイプシート セルのデータをエクスポートする方法を変更する場合は、次のいずれかの操作を行います。

    エクスポートリストにシェイプシートのセルを追加する

    1. [追加] をクリックします。

    2. エクスポートするシェイプシート セルを選択します。

    3. [評価対象] ボックスで、データベース フィールドに格納される値のデータ型を選択します。

    4. 図形データのコピー先となるデータベース フィールドを選択します。

    5. データベースのデータ型、フィールドの長さ、データベース フィールドの小数の精度を指定します。

    シェイプシートセルのデータをエクスポートする方法を変更する

    1. セル名を選択し、[変更] をクリックします。

    2. データのエクスポート方法を変更する。

    エクスポートリストからシェイプシートのセルを削除する

    セル名を選択し、[削除] をクリックします。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×