図形を選択、移動、サイズ変更、回転する

Visio では、図形とオブジェクトを選択、移動、サイズ変更、回転するための複数のツールが用意されています。 図面上で 1 つのオブジェクト、またはすべてのオブジェクトを選択すると、それらの位置変更、拡大/縮小、左右に反転、位置の微調整を行うことができます。

お使いのブラウザーではビデオがサポートされていません。 Microsoft Silverlight、Adobe Flash Player、Internet Explorer 9 のいずれかをインストールしてください。

注: 図面ページで図形が選択できない場合は、その図形が保護されているか、ロックされたレイヤーの一部であるか、グループ化されている可能性があります。 詳細については、このトピックの「選択に関する問題のトラブルシューティング」セクションを参照してください。

図形を選択する

ほとんどの場合、図形を移動、回転、またはサイズ変更するなど、他の操作を行う前に、図面で図形を選択する必要があります。 Visio では、図形を 1 つずつ選択することも、なげなわツールを使用して領域で選択することも、ページ上のすべての図形を選択することもできます。

クイック タスク

タスク

アクション

単一の図形を選択する

  1. [ホーム] タブの [ツール] グループで [オブジェクト選択ツール] をクリックします。

  2. 図面ページで図形をポイントして、ポインターが 4 方向の矢印に変わったら、その図形をクリックします。

領域選択を使用して複数の図形を選択する

  1. [ホーム] タブの [編集] グループで [選択] をクリックし、[領域選択] を選択します。

  2. 選択する図形の左上にポインターを置き、ドラッグして図形を囲むように選択ネットを作成します。

  3. 図形を選択すると、選択した図形の周囲に青い選択ハンドルと、個々の図形の周囲にマゼンタの線が表示されます。

なげなわ選択を使用して複数の図形を選択する

  1. [ホーム] タブの [編集] グループで [選択] をクリックし、[なげなわ選択] をクリックします。

  2. 選択する図形の周りにフリーフォームの選択ネットをドラッグします。

  3. 複数の図形を選択すると、選択した図形の周囲に青い選択ハンドルが表示されます。

選択領域に部分的に含まれる図形を選択する

既定では、図形を選択するには、[領域選択] や [なげなわ選択] の両方のツールで選択ネットが各図形を完全に囲む必要があります。 より柔軟に選択したい場合、その一部しか含まれない図形も選択されるように選択ネットを広げることができます。

Visio で選択範囲内の図形を部分的に選択できるようにするには、次の操作を行います。

  1. [ファイル] タブをクリックします。

  2. [Visio] の下で、[オプション] をクリックします。

  3. [Visio オプション] ダイアログ ボックスの [詳細] タブの [編集オプション] で、[部分的に選択領域内に入る図形も選択する] チェック ボックスをオンにします。

.

キーボード ショートカットを使用してページ上の複数の図形を選択する

Shift キーまたは Ctrl キーを押した状態で図形をクリックすると、一度に複数の図形を選択できます。

ヒント: これらのキーを使用して、現在の選択範囲内に他の図形を追加することもできます。 たとえば、[領域選択] ツールを使用して作成した選択対象に図形を追加する場合は、Shift キーまたは Ctrl キーを押しながらその図形をクリックします。

図面ページ上のすべての図形を選択する

[ホーム] タブの [編集] グループで [選択] をクリックし、[すべて選択] を選択します。

特定の種類のオブジェクトをすべて選択する

  1. [ホーム] タブの [編集] グループで [選択] をクリックし、[種類によって選択] を選択します。

  2. [種類によって選択] ダイアログ ボックスで、図形、コネクタ、またはコンテナーなど、選択するオブジェクトの種類を確認して [OK] をクリックします。

1 つまたは複数の図形を選択解除する

すべての図形の選択を解除するには、次の操作を行います。

  • 図面上の空白の領域をクリックするか、Esc キーを押します。

複数の図形を選択しているときに 1 つを選択解除するには、次の操作を行います。

  • Shift キーを押しながら図形をクリックし、選択を解除します。

図形を移動する

Visio では、目的の場所に図形を正確に配置するのに役立ついくつかの方法が用意されています。

クイック タスク

タスク

操作

マウスを使用して図形を移動する

  1. 移動するすべての図形を選択します。

  2. いずれかの図形の上にポインターを置きます。 4 方向の矢印が表示されます。

  3. 新しい位置に図形をドラッグします。

    選択したすべての図形が、元の位置から同じ方向に同じ距離だけ移動します。

ヒント: 図形の移動を縦方向または横方向に制限するには、Shift キーを押しながら図形をドラッグします。 図形を図面の別のページに移動するには、図形を [ページ] タブにドラッグします。

図形を特定の距離に移動する (Visio Professional が必要)

  1. 移動するすべての図形を選択します。

  2. [表示] タブの [マクロ] グループで [アドオン] をクリックし、[Visio エキストラ] をポイントして、[図形の移動] をクリックします。

  3. [方向] で、図形の移動に使用する座標を指定します。

    • 横方向/縦方向     X-Y (デカルト積) 座標を使用して、選択範囲を移動します。

    • 距離/角度     極座標を使用して選択範囲を移動します。

  4. 選択範囲を移動する距離を指定します。

  5. 元の図形を元の位置に維持したまま、選択した図形のコピーを移動するには、[複製] を選択します。

  6. 選択が完了したら、[OK] をクリックします。

方向キーを使用して図形を微調整する

  1. 移動するすべての図形を選択します。

  2. 次の操作を行います。

    • グリッド線やルーラーの目盛りなど、スナップできる次の位置に図形を移動するには、方向キーを押します。

      図形がスナップできる位置がない場合は、方向キーを押して図形をルーラー上で 1 目盛り移動します。

    • 図形を 1 ピクセル移動するには、Shift キーを押しながら方向キーを押します。

注: 方向キーを押すと、図形が移動せずに図面がスクロールする場合は、ScrollLock キーがオンになっていないことを確認します。

図形のサイズを変更する

Visio で図形のサイズを変更するには、目的のサイズになるまで図形をドラッグするか、特定のサイズを指定します。

クイック タスク

タスク

操作

マウスを使用して 2 次元 (2-D) 図形 (四角形など) のサイズを変更する

  1. サイズ変更するすべての図形を選択します。

  2. 図形が目的のサイズになるまで選択ハンドル 選択ハンドル をドラッグします。 縦横の比率を変えずに図形のサイズを変更するには、四隅のハンドルをドラッグします。

マウスを使用して線などの 1 次元図形のサイズを変更する

  1. サイズを変更する図形を選択します。

  2. 目的の長さになるまで端点をドラッグします。

[図形サイズ/​​位置/回転] ウィンドウを使用して図形のサイズを変更する

  1. 移動するすべての図形を選択します。

  2. [表示] タブの [表示] グループで [作業ウィンドウ] をクリックし、[図形サイズ/位置/回転] を選択します。

  3. [図形サイズ/​​位置/回転] ウィンドウで、[]、[高さ]、または [長さ] のボックスに新しい値を入力します。

図形を回転または反転させる

図形は、角度を指定して回転させることも、上下または左右に反転させることも、回転ハンドルを使用して回転させることもできます。

注: テキストを回転させる方法について詳しくは、「Visio でテキストを追加、編集、移動、または回転する」を参照してください。

クイック タスク

タスク

操作

図形を 90 度回転させる

  1. 回転させる図形を選択します。

  2. 次の操作のいずれかを行います。

    • 図形を反時計回りに回転させるには、[ホーム] タブの [配置] グループで [位置] をクリックし、[図形の回転] をポイントして [左に 90 度回転] を選択します。

    • 図形を時計回りに回転させるには、[ホーム] タブの [配置] グループで [位置] をクリックし、[図形の回転] をポイントして [右に 90 度回転] を選択します。

回転ハンドルを使用して図形を回転させる

  1. 回転させる図形を選択します。

  2. 回転ハンドル Visio 2010 の回転ハンドル。 をドラッグします。

    図形がピン 回転ハンドル を中心に回転します。 ピンを移動するには、回転ハンドルにポインターを置いてから、ポインターをピンの上に移動して、ピンを新しい場所にドラッグします。

    回転ハンドルをドラッグしてカーソルを選択範囲から遠くに移動するほど、回転の増分が細かく (小さく) なります。

[図形サイズ/​​位置/回転] ウィンドウを使用して角度を指定して図形を回転させる

  1. 回転させる図形を選択します。

  2. [表示] タブの [表示] グループで [作業ウィンドウ] をクリックし、[図形サイズ/位置/回転] を選択します。

  3. [表示] タブの [表示] グループで [作業ウィンドウ] をクリックし、[図形サイズ/位置/回転] を選択します。

  4. [図形サイズ/​​位置/回転] ウィンドウで、[角度] のボックスに新しい値を入力します。

図形を上下に反転させる

  1. 反転させる図形を選択します。

  2. [ホーム] タブの [配置] グループで [位置] をクリックし、[図形の回転] をポイントして [上下反転] を選択します。

図形を左右に反転させる

  1. 反転させる図形を選択します。

  2. [ホーム] タブの [配置] グループで [位置] をクリックし、[図形の回転] をポイントして [左右反転] を選択します。

選択の問題のトラブルシューティング

図面ページで図形が選択できない場合は、その図形が保護されているか、ロックされたレイヤーの一部であるか、グループ化されている可能性があります。

図形は保護されているか

図形を選択できない場合、その図形は選択できないように保護されている可能性があります。この場合、図形を削除したり、配置、サイズ変更、書式設定、テキストの編集、または回転など、どのような変更も適用することはできません。

図形のロックを解除するには:

  1. [開発] タブで、[ドローイング エクスプローラー] を選択します。

  2. [ドローイング エクスプローラー] ツリー メニューで図面ファイル名を右クリックし、[図面の保護] をクリックします。

  3. [文書の保護] ダイアログ ボックスで、[図形] チェック ボックスをオフにしてから [OK] をクリックします。

図形は選択できるが変更を適用できない場合、その図形はまだ保護されている可能性があります。 選択した図形にグレーのハンドル バーが表示される場合、その図形はすべての変更に対してロックされています。 この場合、選択範囲からすべての図形のロックを解除することが必要になります。 これを行うには、「図形の変更を禁止または許可する」の「図形の選択をロックまたはロック解除する」セクションを参照してください。

図形がロックされたレイヤーの一部である場合

図形を選択できない場合、図形がロックされたレイヤーの一部である可能性があります。

レイヤーのロックを解除するには:

  1. [ホーム] タブの [編集] グループで [レイヤー] をクリックし、[レイヤー プロパティ] をクリックします。

  2. [レイヤー プロパティ] の [ロック] 列で、選択したい図形の種類に対応するチェック ボックスをオフにします。

図形がグループ化されている場合

図形は選択できるが、想定どおりに操作できない場合は、その図形がグループ化されている可能性があります。 グループ化された図形は、1 つのユニットとして機能します。 たとえば、図形がグループ化されている場合、それらの色を同時に変更することができます。

図形がグループ内にあるかどうかを確認するには:

  • 図形をクリックするだけです。 図形がグループ内にある場合は、図形ではなくそのグループが選択されます。 ここでもう一度図形をクリックすると、グループ内の図形が選択されます。

グループ内の図形を選択するには:

図形を選択するにはいくつかの方法があります。 詳細については、「図形選択ツール」を参照してください。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×