図形にデータを追加する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft Office Visio の図面は、単なる図ではありません。データを整理したり、レポートにデータを取得したりする手段として活用できます。

このトピックでは、選択した図形に手動でデータを追加する最適な方法、図面の複数の図形に適用できる再利用可能なデータ セットの作成方法、マスタ シェイプへのデータの追加方法について説明します。

注: 以下の手順は、Microsoft Office Visio Professional 2007 および Microsoft Office Visio Standard 2007 の両方に当てはまります。Visio Professional を使用している場合は、自動的にデータをインポートし、図形にデータを追加して、データ グラフィックを用いて図形にデータを表示することができます。Visio のエディションを確認するには、[ヘルプ] メニューの [バージョン情報] をクリックします。

目的に合ったトピックをクリックしてください

選択した図形にデータ セットを追加する

再利用可能なデータ フィールドのセットを作成する

データ フィールドをマスタ シェイプに追加する

選択した図形にデータ セットを追加する

図面では、既に図形にデータを追加するには、最初の図形にデータ フィールドを追加して、値を追加し、します。

ヒント: 以下の手順は、図形にデータを追加する最も簡単な方法です。ただし、同じデータを複数の図形に追加する場合は、このトピックの別のセクションで説明しているいずれかの方法を検討してください。

データ フィールドと値の違い

  • データ フィールドは、値を保持することができるラベルの付いたセルです。

  • 値は、データベース テーブルやワークシート、ここでは図形のセルに格納されるテキストや数値です。

フィールドを [基本フローチャート] ステンシルから [判断] 図形の値と [図形データ] ウィンドウが表示されている例を示します。この例では、フィールドは、時間単価、ネットワークのアクセスを必要に応じて、契約の期間と、値は、[はい] と [3 週間 $49.00 します。

図形データ] ウィンドウのフィールドと値を表示します。

選択した図形にデータ フィールドを追加する

  1. データを追加する図形を選択します。

  2. 選択した図形を右クリックして、ショートカット メニューの [データ] をポイントし、[図形データ] をクリックします。

  3. すぐにデータを定義するかどうかたずねるメッセージが表示されたら [はい] をクリックします。

    注: 既に図形にデータ フィールドがある場合は、このメッセージは表示されません。

  4. [図形データの定義] ダイアログ ボックスで、フィールドのラベルを入力します。

  5. 別のフィールドを作成する場合は、[新規] をクリックして、手順 4. を実行します。

  6. 必要なデータ フィールドがすべて定義できたら、[OK] をクリックします。

    [図形データ] ダイアログ ボックスが開き、定義したフィールドが表示されます。

データ フィールドに値を追加する

  1. [表示] メニューの [図形データ ウィンドウ] をクリックします。

  2. 1 度に 1 つずつ図形を選択し、[図形データ] ウィンドウのデータ フィールドに値を入力します。

    注: [図形データ] ウィンドウには、選択された図形のデータしか表示されません。

ページの先頭へ

再利用可能なデータ フィールドのセットを作成する

後で図面に追加した図形や、既に図面にある図形に適用できるデータ フィールドのセットを作成できます。

  1. [表示] メニューの [図形データ ウィンドウ] をクリックします。

  2. [図形データ] ウィンドウの任意の場所を右クリックし、[図形データ セット] をクリックします。

  3. [図形データ セット] ウィンドウで [追加] をクリックします。

  4. [図形データ セットの追加] ダイアログ ボックスで、データ セットの名前を入力します。

  5. [新しいセットを作成する] を選択し、[OK] をクリックします。

    データ セットが、[図形データ セット] ウィンドウの [名前] 列に表示されます。

    注: 既存のデータ セットを変更する場合は、その他のオプションのいずれかをクリックすることもできます。

  6. [名前] の新しいデータ セットをクリックし、[定義] をクリックします。

  7. [図形データの定義] ダイアログ ボックスで、フィールドのラベルを入力します。

  8. 別のフィールドを作成する場合は、[新規] をクリックし、手順 7. を実行します。

  9. 必要なデータ フィールドがすべて定義できたら、[OK] をクリックします。

  10. 図面で選択したデータにデータ セットを適用するには、[図形データ セット] ウィンドウでセットを選択し、[適用] をクリックします。

    ヒント: データ セットを適用した図形のうちの 1 つで新しいフィールドを確認するには、図形を選択し、[図形データ] ウィンドウを参照します。

ページの先頭へ

データ フィールドをマスタ シェイプに追加する

ある特定の図形の使用時に常に同じ図形データのセットを追加する場合は、その図形のマスタ シェイプのコピーにデータ フィールドを追加すると時間を節約できます。たとえば、名前や従業員番号を人図形のマスタ シェイプに追加できます。

  1. 図形データを追加するマスタ シェイプを右クリックし、[個人用図形に追加] をポイントして、[新しいステンシルに追加] をクリックします。

    注: 既にユーザー設定のステンシルがある場合は、新しいステンシルを作成せずに、既存のユーザー設定のステンシルにマスタ シェイプを追加することもできます。

  2. 名前を付けて保存] ダイアログ ボックスでは、新しいステンシルの名前を入力し、[保存] をクリックします。

  3. [ファイル] メニューの [図形] をポイントし、[個人用図形] をポイントして、コピーしたマスタ シェイプが含まれるステンシルをクリックします。

  4. 新しいステンシルのタイトル バーを右クリックして、ショートカット メニューの [ステンシルの編集] をクリックします。

  5. 先ほどステンシルに追加した図形を右クリックし、[マスタ シェイプの編集] をポイントして [マスタ シェイプの編集] をクリックします。

  6. 図形の編集ウィンドウで図形を右クリックし、[データ] をポイントして [図形データ] をクリックします。

  7. すぐにデータを定義するかどうかたずねるメッセージが表示されたら [はい] をクリックします。

    注: 既に図形にデータ フィールドがある場合は、このメッセージは表示されませんが、残りの処理を行います。

  8. [図形データの定義] ダイアログ ボックスで、フィールドの名前を入力し、その他の情報を指定します。たとえば、この時点でデータ型を変更したり、図形のプロンプトを追加したりできます。

  9. 別のフィールドを作成する場合は、[新規] をクリックして、手順 8. を実行します。

  10. データ フィールドがすべて定義が終了したら、[ OKを] をクリックします。

    [図形データ] ダイアログ ボックスが開き、定義したフィールドが表示されます。

    注: フィールドに変更を加える場合は、[定義] をクリックし、手順 8. を繰り返します。

  11. 図形の編集ウィンドウを閉じるには、[ファイル] メニューの [閉じる] をクリックします。

  12. 図形を更新するかどうかたずねるメッセージが表示されたら [はい] をクリックします。

  13. ステンシルに対する変更を保存するかを確認する別のメッセージが表示されたら、[はい] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×