印刷に最適化されたビューをデザインする

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

作成する Microsoft Office InfoPath フォーム テンプレートは、InfoPath 自体の中で、または Web ブラウザを使用して、オンラインで開いたり入力したりできるようにデザインされています。ただし、ユーザーは個人の記録用や保管用として、入力したフォームのコピーを印刷したいと考えることがあります。そのため、作成したフォーム テンプレートが印刷に対応していることを確認することをお勧めします。たとえば、フォーム テンプレートのコントロールが印刷したページの余白内に収まっていることや、印刷したフォーム上のテキストが読みやすいことを確認します。

さらに、[ビュー] 作業ウィンドウを使用して、印刷レイアウト表示と呼ばれる、印刷用に設計されたフォーム テンプレートの特別版を作成することもできます。

ここでは、フォーム テンプレートの印刷レイアウト表示をデザインする方法と、印刷に適したフォーム テンプレートを作成するためのその他のテクニックについて説明します。

このトピックの内容

フォーム テンプレートの印刷とフォームの印刷の違い

印刷レイアウト表示の概要

既存のビューに基づく印刷レイアウト表示をデザインする

Word 専用の印刷レイアウト表示をデザインする

フォーム テンプレートの印刷とフォームの印刷の違い

フォーム テンプレートを印刷することで、コントロールとその他のオブジェクトが印刷したページでどのように表示されるかを大まかに把握したり、ヘッダーやフッターなどの印刷設定を確認したりすることができます。デザイン モードでフォーム テンプレートを印刷すると、ボタンなど、ユーザーがフォーム テンプレートに基づくフォームを印刷したときには表示されないアイテムが、印刷したフォーム テンプレートには表示されることがあります。

ユーザーがフォーム テンプレートに基づくフォームを印刷すると、InfoPath により、フォームに調整が加えられたり、印刷物では意味を持たないアイテムが削除されたりします。たとえば、既定で繰り返しテーブルの下に表示される [項目の挿入] という説明用のテキストは、印刷したフォームには表示されません。ボタン コントロール、リスト ボックスのエントリ、スクロール バーなど、印刷したページでは意味を持たなくなるアイテムも、同じように表示されません。

ページの先頭へ

印刷レイアウト表示の概要

フォーム テンプレートはフォーム データを電子的な形式で収集するようにデザインされていますが、印刷用に特別にデザインされたビューである印刷レイアウト表示を作成することもできます。これは、ユーザーが特定のレイアウトでフォームを印刷できるようにしたり、フォームの一部のみを印刷できるようにしたい場合に便利です。

フォーム テンプレートに複数のビューが含まれている場合は、それぞれのビューの印刷レイアウト表示を作成できます。また、フォーム テンプレートのすべてのビューに適用される単一の印刷レイアウト表示をデザインすることも可能です。たとえば、フォーム テンプレートに 3 つの異なるビューが含まれている場合、それらの各ビューの主要な情報を単一の印刷ページに統合する印刷レイアウト表示を作成できます。

印刷レイアウト表示を作成して既存のビューに関連付けるには、[ビュー] 作業ウィンドウの [このビューの印刷版の作成] リンクを使用します。このリンクをクリックすると、InfoPath によって次の処理が行われます。

  • [印刷版の名前] (名前は印刷レイアウト表示の基になるビューの名前) という名前の新しい空白のビューが作成されます。

  • 印刷レイアウト表示と、印刷レイアウト表示の基になるビューが関連付けられます。この関連付けは、[ビューのプロパティ] ダイアログ ボックスの [印刷の設定] タブに記録されます。たとえば、フォーム テンプレートの [承認] ビューに基づく印刷レイアウト表示を作成したとします。ユーザーが [承認] ビューで [印刷] ボタンをクリックすると、InfoPath により、[印刷版の承認] ビューに表示されているものがすべて印刷されます。

印刷レイアウト表示を作成したら、フォームを印刷したときの表示方法を反映するように印刷レイアウト表示をデザインできます。これには通常、フォーム テンプレートの他のビューからコントロールをコピーし、印刷レイアウト表示に貼り付ける作業が含まれます。必要に応じて、特定のコントロールを印刷レイアウト表示内の他のコントロールの代わりに使用することができます。たとえば、既定でリスト ボックスのエントリが非表示になるドロップダウン リスト ボックスを、既定でエントリが表示される標準のリスト ボックスで置き換えることができます。これにより、印刷したフォームにすべてのエントリが表示されるようになります。また、[ビューのプロパティ] ダイアログ ボックスで、ヘッダー、フッター、余白などの独自の印刷オプションを指定することもできます。

ページの先頭へ

既存のビューに基づく印刷レイアウト表示をデザインする

既定では、ユーザーが特定の印刷レイアウト表示が関連付けられていないフォームを印刷すると、ユーザーのコンピュータに現在表示されているビューが印刷されます。印刷レイアウト表示を作成すると、現在のビューの代わりに印刷レイアウト表示が印刷されます。既存の任意のビューを印刷レイアウト表示として指定することが可能です。ここでは、既存のビューを印刷レイアウト表示の基盤として使用する方法について説明します。

  1. [表示] メニューで、ビューの管理] をクリックします。

  2. [ビュー] 作業ウィンドウの [ビューの選択] ボックスの一覧で、印刷レイアウト表示を作成するビューをクリックします。

  3. [操作] で、[このビューの印刷版を作成] をクリックします。

  4. [印刷版の作成] ダイアログ ボックスで、印刷レイアウト表示の名前を入力し、[OK] をクリックします。

  5. [ビュー] 作業ウィンドウで、印刷レイアウト表示をダブルクリックします。

  6. [ビューのプロパティ] ダイアログ ボックスの [印刷の設定] タブと [ページ設定] タブで目的のオプションを選択し、[OK] をクリックします。たとえば、印刷レイアウト表示の既定の余白設定を指定したり、ヘッダーまたはフッターを追加したりすることができます。

  7. 元のビューに切り替えるには、[ビュー] 作業ウィンドウの [ビューの選択] ボックスの一覧で、ビューの名前をクリックします。

  8. ビューの中にあるものをすべて選択するには、Ctrl キーを押しながら A キーを押します。

  9. 選択したものをクリップボードにコピーするには、Ctrl キーを押しながら C キーを押します。

  10. 印刷レイアウト表示に切り替えるには、[ビュー] 作業ウィンドウの [ビューの選択] ボックスの一覧で、ビューの名前をクリックします。

  11. 選択した内容を元のビューから印刷レイアウト表示に貼り付けるには、Ctrl キーを押しながら V キーを押します。

  12. 不要なコントロールまたはレイアウト要素を削除するか、他のコントロールを追加します。

    ヒント: コントロールやその他のデザイン要素が印刷したページに収まるかどうかをすばやく判断するには、[表示] メニューの [ページの幅ガイド] をクリックし、フォーム テンプレートの右側にページの幅ガイドを表示します。ページの幅ガイドは、フォーム テンプレート上に垂直の破線として表示されます。この線は、コンピュータの通常使うプリンタに基づき、印刷したページの右側の余白の場所を示します。

  13. 印刷レイアウト表示に改ページを追加するには、新しいページを開始する部分をクリックし、[挿入] メニューの [改ページ] をクリックします。

    注: フォーム テンプレートの破線の水平線として改ページが表示されます。フォーム テンプレートをプレビューする場合は表示されません。 この破線線または改ページの他のすべてを示します。改ページが印刷フォーム、フォーム テンプレートに基づくに影響を確認するには、[標準] ツールバーの[印刷プレビュー ボタンの画像 をクリックします。

ページの先頭へ

Word 専用の印刷レイアウト表示をデザインする

高度なフォーム デザイナー XML テクノロジを理解している場合は、Microsoft Office Word ベースの印刷レイアウト表示で、フォームのデータを Word から直接印刷を作成するのには印刷ビューの追加ウィザードで Word を使用することができます。Word で使用できる機能には、印刷範囲を利用できます。これを行うには、フォーム テンプレート内のデータを Word から印刷に適した形式に変換する既存の XSL 変換 (XSLT) ファイルにアクセスが必要です。ユーザーが Word ベースの印刷レイアウト表示を含むフォームを印刷する場合、その形式のデータが Word 内から直接印刷されます。Microsoft Office Word 2003 またはMicrosoft Office Word 2007を使用して、XSLT ファイルを作成する必要があります。

注: XSLT ファイルの作成の詳細についてに、Microsoft Office InfoPath 2003 ソフトウェア開発キット (SDK) を参照してください。SDK には、Word 2003、Word 2007 を使用して InfoPath フォーム データを印刷することができる Word のウィザードに InfoPath と呼ばれるツールが含まれています。InfoPath 2003 SDK を見つけるには、「参照」セクションを参照してください。

  1. [表示] メニューで、ビューの管理] をクリックします。

  2. [ビュー] 作業ウィンドウの [操作] で、[Word 印刷レイアウト表示の追加] をクリックします。

  3. Word 印刷レイアウト表示の追加ウィザードの指示に従い、Word ベースの印刷レイアウト表示で使用する XSLT ファイルを指定します。

  4. [ビュー] 作業ウィンドウの [ビューの選択] ボックスの一覧で、Word ベースの印刷レイアウト表示を指定するビューをクリックし、[ビューのプロパティ] をクリックします。

  5. [印刷の設定] タブをクリックします。

  6. [このビューを印刷するときに使用する既存のビューを選択してください] の一覧で、Word ベースの印刷レイアウト表示をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×