単一のデータ ビューで複数のソースのデータを表示する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

ほとんどの企業は、関連のあるデータを別々に保存しています。このトピックの例では、商品情報は products.xml という名前の .xml ファイルに保存し、商品区分についてのデータは categories.xml という名前の別の .xml ファイルに保存します。そして、これら 2 つのデータ ソースは、CategoryID という名前のフィールドで互いに関連付けられています。

Microsoft Office SharePoint Designer 2007 を使用すると、関連データを格納しているデータ ソースどうしを簡単にリンクして、リンクされた各データ ソースからデータを表示する単一のデータ ビューを作成できます。リンクするデータ ソースの種類は同じである必要はなく、たとえば、XML ファイルを SQL データベースにリンクすることができます。

データ ソースをリンクする場合は、他のすべてのデータ ソースと共にデータ ソース ライブラリに表示されるデータ ソースを作成します。このリンクされたデータ ソースのデータ ビューの作成は、他のデータ ビューを作成する場合とほとんど変わりません。リンクされたデータ ソースのデータ ビューを作成すると、他のデータ ビューと同様に、フィルタ、並べ替え、グループ化、書式設定などの操作を行うことができます。

この記事では、データ ソースとして使用する 2 つのサンプルの XML ファイルを作成する方法と、これら 2 つのデータ ソースをリンクする方法、およびこの 2 つのデータ ソースのデータを表示する単一のデータ ビューを作成する方法を説明します。この記事では、簡単にデータ ソースを作成し、理解できるように、データ ソースに .xml ファイルを使用しています。ただし、以下の手順は、SQL データベースを含め、他のデータ ソースに対しても適用できます。

重要: この記事では、Windows SharePoint Services 3.0 を実行するサーバー上に配置された SharePoint サイトに、データ ビューを作成する方法を説明します。サイトが Windows SharePoint Services 3.0 を実行するサーバー上に配置されていない場合は、一部の機能が利用できない可能性があります。

データ ビューの詳細については、データ ビューを作成するを参照してください。

この記事の内容

サンプル データ ソースとして 2 つの .xml ファイルを作成します。

データ ソースをリンクします。

データ ビューを作成します。

次のステップ

サンプル データ ソースとなる 2 つの .xml ファイルを作成する

Northwind Traders は、商品リストを XML 形式で管理しています。また、これとは別に商品区分リストを管理しています。これら 2 つのリストは、CategoryID というフィールドによって、関連付けられています。これら 2 つの XML ファイルをリンクし、単一のデータ ビューを作成することで、商品区分別に整理された商品リストを簡単に作成できます。

products.xml を作成する

データ ビューの作成の products.xml を既に作成した場合は、次のセクションに進んでください。

  1. [ファイル] メニューの [サイトを開く] をクリックします。

  2. [サイトを開く] ダイアログ ボックスで、SharePoint サイトを参照して選択し、[開く] をクリックします。

  3. 入力を求められたら、[接続先] ダイアログ ボックスでユーザー名とパスワードを入力し、[OK] をクリックします。

  4. [ファイル] メニューの [新規作成] をクリックします。

  5. [新規作成] ダイアログ ボックスで、[テキスト ファイル] をダブルクリックします。

  6. 次のコードを選択し、Ctrl キーを押しながら C キーを押して、これをコピーします。

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. Office SharePoint Designer 2007 で、ページの先頭にカーソルを置き、Ctrl キーを押しながら V キーを押して、コピーしたコードをこのページに貼り付けます。

  8. [ファイル] メニューの [名前を付けて保存] をクリックします。

  9. 名前を付けて保存] ダイアログ ボックスのファイル名] ボックスに、 products.xmlを入力します。

  10. [ファイルの種類] ボックスの一覧で [XML] をクリックし、[保存] をクリックします。

categories.xml を作成する

  1. SharePoint サイトを既に開いている場合は、手順 4. に進んでください。開いていない場合は、[ファイル] メニューの [サイトを開く] をクリックします。

  2. [サイトを開く] ダイアログ ボックスで、SharePoint サイトを参照して選択し、[開く] をクリックします。

  3. 入力を求められたら、[接続先] ダイアログ ボックスでユーザー名とパスワードを入力し、[OK] をクリックします。

  4. [ファイル] メニューの [新規作成] をクリックします。

  5. [新規作成] ダイアログ ボックスで、[テキスト ファイル] をダブルクリックします。

  6. 次のコードを選択し、Ctrl キーを押しながら C キーを押して、これをコピーします。

    <?xml version="1.0" encoding="utf-8"?>
    <CategoriesRoot>
    <Categories>
    <CategoryID>1</CategoryID>
    <CategoryName>Beverages</CategoryName>
    <Description>Soft drinks, coffees, teas, beer, and ale</Description>
    </Categories>
    <Categories>
    <CategoryID>2</CategoryID>
    <CategoryName>Condiments</CategoryName>
    <Description>Sweet and savory sauces, relishes, spreads, and seasonings</Description>
    </Categories>
    <Categories>
    <CategoryID>3</CategoryID>
    <CategoryName>Confections</CategoryName>
    <Description>Desserts, candies, sweetbreads</Description>
    </Categories>
    <Categories>
    <CategoryID>4</CategoryID>
    <CategoryName>Dairy Products</CategoryName>
    <Description>Cheeses</Description>
    </Categories>
    <Categories>
    <CategoryID>5</CategoryID>
    <CategoryName>Grains/Cereals</CategoryName>
    <Description>Breads, crackers, pasta, and cereal</Description>
    </Categories>
    <Categories>
    <CategoryID>6</CategoryID>
    <CategoryName>Meat/Poultry</CategoryName>
    <Description>Prepared meats</Description>
    </Categories>
    <Categories>
    <CategoryID>7</CategoryID>
    <CategoryName>Produce</CategoryName>
    <Description>Dried fruit and bean curd</Description>
    </Categories>
    <Categories>
    <CategoryID>8</CategoryID>
    <CategoryName>Seafood</CategoryName>
    <Description>Seaweed and fish</Description>
    </Categories>
    </CategoriesRoot>
  7. Office SharePoint Designer 2007 で、ページの先頭にカーソルを置き、Ctrl キーを押しながら V キーを押して、コピーしたコードをこのページに貼り付けます。

  8. [ファイル] メニューの [名前を付けて保存] をクリックします。

  9. 名前を付けて保存] ダイアログ ボックスのファイル名] ボックスに、 categories.xmlを入力します。

  10. [ファイルの種類] ボックスの一覧で [XML] をクリックし、[保存] をクリックします。

ページの先頭へ

データ ソースをリンクする

複数のソースのデータを表示する単一のデータ ビューを作成するには、まずデータ ソース ライブラリを使用してデータ ソースどうしをリンクする必要があります。ここでは、商品区分別に整理された商品リストを作成するため、products.xml ファイルを categories.xml ファイルにリンクする必要があります。

  1. [作業ウィンドウ] メニューの [データ ソース ライブラリ] をクリックします。

  2. [データ ソース ライブラリ] 作業ウィンドウで、[リンクされているソース] の隣にある正符号 (+) をクリックし、[リンクされるソースの新規作成] をクリックします。

  3. [データ ソースのプロパティ] ダイアログ ボックスで、[リンクされているソースの構成] をクリックします。

  4. データ ソースのリンク ウィザードの [使用可能なデータ ソース] で [categories.xml] をクリックし、[追加] をクリックします。次に、[products.xml] をクリックし、[追加] をクリックします。

  5. [次へ] をクリックします。

  6. [選択したデータ ソースの間の関係を最もよく表しているリンクの種類を選択してください。] の [データ ビューと、連結されたサブビューを挿入するには、データ ソースの詳細を使用して、データ ソースのコンテンツを連結します。] をクリックします。

    結合または連結のいずれかを選択できます。まったく同じフィールドを持つ個別のデータ ソースがあり、これらを 1 つのデータ ソースにまとめる場合は、データを結合します。2 つの独立したデータ ソースがあり、互いを関連付ける共通のフィールドがある場合は、データを連結します。products.xml と categories.xml は、CategoryID という共通のフィールドがある 2 つの独立したデータ ソースであるため、ここではこれら 2 つのデータ ソースを結合します。

  7. [完了] をクリックします。

  8. [データ ソースのプロパティ] ダイアログ ボックスで、[全般] タブをクリックします。

  9. [名前] ボックスに「商品区分および商品」と入力します。

  10. [OK] をクリックします。

    データ ソース ライブラリの [リンクされているソース] セクションに、カテゴリと製品という、新しいデータ ソースが表示される

    データ ソース ライブラリの [リンクされているソース] に、新たにリンクされたデータ ソースが表示されます。

ページの先頭へ

データ ビューを作成する

データ ソースをリンクできたので、次は [データ ソースの詳細] 作業ウィンドウを使用して、リンクされているデータ ソースのデータを表示するデータ ビューを作成します。

ここでは、商品区分別に整理した商品リストを作成します。これにより、categories.xml の各商品区分別に、商品を表示できます。

区分別に商品を表示するデータ ビューを作成するので、まず、categories.xml のビューを作成します。

データ ビューは、Microsoft ASP.NET 2.0 テクノロジーを基盤としています。データ ビューを作成するには、ASP.NET ページ (.aspx ファイル) を用意する必要があります。この記事の例では、新しい ASP.NET ページを作成し、その後、データ ビューをこのページに挿入します。

  1. [ファイル] メニューの [新規作成] をクリックします。

  2. [新規作成] ダイアログ ボックスで、[ASPX] をダブルクリックします。

    FORM タグが挿入されている新しいページが開きます。

    ASP.NET の form タグ

  3. [データ ビュー] メニューの [データ ビューの挿入] をクリックします。

    ページ上に空のデータ ビューが表示され、[データ ソース ライブラリ] 作業ウィンドウが開きます。

    空のデータ ビュー

    データ ビューを挿入できたので、次はデータを追加します。

  4. [データ ソース ライブラリ] 作業ウィンドウで、[リンクされているソース] の隣にある正符号 (+) をクリックし、[商品区分および商品] をクリックして、[データの表示] をクリックします。

    まず、categories.xml のデータ ビューを作成します。

  5. [データ ソースの詳細] 作業ウィンドウで、Categories フォルダの [CategoryName] をクリックします。Ctrl キーを押しながら、[Description] をクリックします。

    [データ ソースの詳細] 作業ウィンドウ内で選択されたカテゴリ フォルダの 2 つのフィールド

  6. [選択したフィールドの挿入] をクリックし、[複数アイテム ビュー] をクリックして、選択したデータをデータ ビューに挿入します。

    注: [単一アイテム ビュー] を選択した場合は、データ ビューに 1 レコードのみが表示されます。[複数アイテム ビュー] を選択した場合は、各フィールドが列に割り当てられ、各列に見出しが付けられた状態で、複数のレコードが表示されます。

    [データ ソースの詳細] 作業ウィンドウで選択したフィールドが、データ ビューに表示されます。

    categories.xml のレコードを表示するデータ ビュー

    次の手順では、products.xml のデータのサブビュー (データ ビューのセル内に表示される別のデータ ビュー) を表示する新しい列を作成します。

  7. データ ビューで [Description] 列をマウスの右ボタンでクリックし、ショートカット メニューの [挿入] をクリックして、[列 (右)] をクリックします。

  8. 新しい列の任意のセル内にカーソルを置きます。

  9. [データ ソースの詳細] 作業ウィンドウで、Products フォルダの [ProductName] をクリックします。Ctrl キーを押しながら、[UnitsInStock]、[UnitsOnOrder]、[ReorderLevel] をクリックします。

    [製品] フォルダーで、ProductName、UnitsInStock、UnitsonOrder、ReorderLevel をクリックする

  10. [選択したフィールドの挿入] をクリックし、[連結されたサブビュー] をクリックします。

    連結されたサブビューとは、共通するフィールドにより他のデータ ソースに連結されているデータ ソースのサブビューを示します。次の手順では、categories.xml の CategoryID フィールドを products.xml の CategoryID フィールドにリンクします。

  11. [サブビューの連結] ダイアログ ボックスで [Categories] の [CategoryID] をクリックします。次に、[Products] の [CategoryID] をクリックし、[OK] をクリックします。

    [サブビューの連結] ダイアログ ボックスで、CategoryID をクリックして categories.xml と products.xml を連結する

    [データ ソースの詳細] 作業ウィンドウで選択したフィールドが、新しい列に表示されます。2 つのデータ ソースの CategoryID フィールドがリンクされているため、商品が商品区分別に表示され、たとえば Beverages のリストには区分が飲料の商品のみが、Condiments のリストには区分が調味料の商品のみが表示されます。

    リストの関連カテゴリ内の製品リストのサブビューを表示するデータ ビュー

ページの先頭へ

次のステップ

データ ビューは、強力で、完全にカスタマイズ可能なライブ データのビューです。リンクされたデータ ソースのデータ ビューを作成すると、このデータ ビューを他のデータ ビューと同様にカスタマイズすることができます。ここでは、複数のデータ ソースのデータを単一のデータ ビューに表示する方法を学習しましたが、以下の操作についても学習されることをお勧めします。

  • データ ビューでデータをフィルター処理   データ ビューでデータを簡単にフィルター処理できます。詳細については、データ ビューでデータをフィルター処理を参照してください。

  • 並べ替えデータ ビューでデータをグループ化と    すばやく並べ替えるまたはデータ ビューでデータをグループ化できます。詳細については、次を参照してください。並べ替えデータ ビューでデータをグループ化とします。

  • 条件付き書式のデータ ビューに適用します。   データ ビューにデータが特定の条件を満たしている場合、データ ビューに特定書式を適用することができます。詳細については、条件付き書式のデータ ビューの適用を参照してください。

  • データ ビューで数式列を作成します。   同様に、スプレッドシートで、データの計算を実行し、別の列に、結果を表示するデータ ビューに数式を追加できます。詳細については、データ ビューで数式列を作成するを参照してください。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×