スキップしてメイン コンテンツへ
Office
以前のバージョンの Excel と互換性がある Excel ブックを保存する

以前のバージョンの Excel と互換性がある Excel ブックを保存する

新しいバージョンの Excel にアップグレードしましたが、まだアップグレードしていないユーザーとブックを共有することになったとします。 互換性チェックを実行すると、以前のバージョンで利用できない機能や情報を識別できるため、ブックの共有前に、それらの問題の一部を解決できます。

.xls 形式でファイルを保存して、互換性チェックの問題を確認する

次の手順を実行します。

  1. [ファイル>エクスポート] をクリックして、ファイルの種類を変更> ます。

    [エクスポート] タブの [ファイルの種類の変更]

  2. [エクスポート] タブの [ファイルの種類の変更]

  3. [ブック ファイルの種類] で、[Excel 97-2003 ブック (*.xls)] をダブルクリックします。

    [Excel 97-2003 ブック] 形式

  4. [名前を付けて保存] ポップアップウィンドウで、ブックのフォルダーの場所を選択します。

  5. [ファイル名] ボックスに新しいファイル名を入力します (または、既に表示されているファイル名を使用します)。

  6. [保存] をクリックします。

  7. [互換性チェック] が表示された場合は、見つかった互換性の問題を確認します。

    元のデータを忠実に再現できなくなる問題を示す互換性チェッカー

    [検索] リンクを使用すると、ワークシート内のその場所に移動します。また、この問題と可能な解決策については、ヘルプリンクを参照してください。
     

注: 

  • 新しいバージョンの Excel では、.xls 形式で保存したブックが互換モードで開きます。 このブックを、以前のバージョンの Excel で開くユーザーとやり取りする予定がある場合は、このモードで作業を続けます。

  • 下位互換性が不要になった場合は、[ファイル> >情報] をクリックして、ブックを現在のファイル形式に変換し、 Excel の新機能を活用できるようにします。

Excel 2007 以降との互換性チェックを実行する

ブックと Excel 2013、2010、2007 との互換性を確認するには、初めてブックを保存するときに、互換性チェックを手動で実行します。 次に、ブックを保存するたびに互換性チェックが自動的に実行されるように設定します。

次の手順を実行します。

  1. [ファイル]、[情報]、[問題のチェック] の順にクリックします。

    互換性を確認する

  2. [互換性チェック] を選びます。

  3. 今後は自動的に互換性をチェックするには、[このブックを保存するときに互換性を確認する] チェック ボックスをオンにします。
     

    ヒント: 互換性をチェックするときに含める Excel のバージョンを指定することもできます。 すべてのバージョンは既定でオンになっているため、除外するバージョンをオフにするだけです。

    チェックするバージョンが表示された互換性チェッカー

    問題が見つかった場合は、ワークシート内の該当する場所に移動するためのリンクが表示されます。また、この問題と考えられる解決策については、ヘルプリンクを参照してください。

Access を使用して複数のテーブルを使用するデータ機能のデータソースを結合する

注: Excel でVLOOKUP 関数を使用してこの問題に対処することもできますが、プロセスはやや複雑で、結合するデータソースの数が増えるため、複雑になります。

Excel 2010 以前のバージョンでは、複数のテーブルを分析するデータ機能がサポートされていません。これらの Excel のバージョンにはデータモデルがありません。 このような機能がブックに含まれている場合は、以前のバージョンで使用できるようにするために、機能のデータソースを1つのテーブルに結合し、その新しいテーブルをデータソースとして使用することができます。

これを行う方法の1つとして、Access を使用してデータソースを結合し、クエリとして複製して、ブックにインポートすることができます。 プロセスは次のようになります。

  1. Access で、元の各データソースを新しいテーブルとしてインポートします。

  2. Excel で、[データ > データツール > リレーションシップ] をクリックし、元のデータソースの間のリレーションシップをメモして、[リレーションシップ] ダイアログボックスを開きます。

  3. Access で、各リレーションシップを再作成します。

  4. Access で、Excel データ機能に必要なすべてのフィールドを含むクエリを作成します。

  5. Excel で、新しいワークシートにテーブルとしてクエリをインポートします。

Excel でデータを1つのテーブルに追加したら、複数のテーブルを使用していたデータ機能のデータソースとしてそのテーブルを選択するか、データ機能を再作成して、新しいテーブルをデータソースとして選択します。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

関連項目

他のファイル形式では転送されない Excel の書式と機能

ワークシートの互換性に関する問題

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×