ワークシートのデータのアウトラインを作成する

データのリストをグループ化して取りまとめる場合、各グループを 1 レベルとして、最大 8 段階のレベルのアウトラインを作成できます。アウトライン記号の中で大きい数字で表される内側の各レベルに、小さい数字で表されるすぐ外側のレベルの詳細データが表示されます。アウトラインを使うと、集計行や集計列の表示や各グループの詳細データの参照をすばやく行うことができます。作成できるアウトラインは、行のアウトライン (下の例を参照)、列のアウトライン、行と列の両方のアウトラインです。

アウトライン表示のリスト
地域と月を単位としてアウトラインを作成し、いくつかの集計行と詳細行を表示した、売上高データの行。

1.  レベルに対応する行を表示するには、適切な 1 2 3 アウトライン記号をクリックします。

2.  レベル 1 には、すべての詳細行の売上高の合計が含まれます。

3.  レベル 2 には、各地域の各月の売上高の合計が含まれます。

4.  レベル 3 には、詳細行が含まれます ( この場合は行 11 ~ 13)。

5.  アウトラインのデータを展開または折りたたむには、 プラス記号 (+)マイナス アウトライン記号をクリックします。

目的に合ったトピックをクリックしてください

行のアウトラインを作成する

列のアウトラインを作成する

アウトラインの詳細データの表示と非表示を切り替える

アウトラインのスタイルを変更する

アウトラインの詳細データをコピーする

アウトラインを非表示または削除する

グラフを使ったサマリー レポートを作成する

行のアウトラインを作成する

  1. アウトラインを作成するデータの各列の最初の行に列見出しがあること、同じ列には同じ種類のデータが入力されていること、範囲内に空白行または空白列が含まれていないことを確認します。

  2. 詳細行に集計行 (小計) も含まれていることを確認します。次のいずれかの操作を行います。

    [小計] を使って集計行を挿入する   

    • [小計] を使うと、詳細行の各グループのすぐ上またはすぐ下に SUBTOTAL 関数が挿入され、アウトラインが自動的に作成されます。SUBTOTAL 関数の使用方法の詳細については、「SUBTOTAL 関数」をご覧ください。

      独自の集計行を挿入する   

    • 詳細行の各グループのすぐ上またはすぐ下に数式を設定して、独自の集計行を挿入します。たとえば、3 月と 4 月の売上データの行の下 (または上) で、SUM 関数を使ってこれらの月の売上の小計を出します。後の表では、この例を示します。

  3. 集計行の位置を詳細行の上下どちらにするかを指定します。[データ] タブの [アウトライン] で [アウトライン] ダイアログ ボックス起動ツールをクリックします。
    アウトライン グループでダイアログ ボックス起動ツールをクリックする

  4. 集計行の位置を詳細行の上にするには、[詳細データの下] チェック ボックスをオフにします。それ以外の場合は、このチェック ボックスをそのままにしておきます。

  5. データのアウトラインを作成します。次のいずれかの操作を行います。

    アウトラインを自動作成する

    1. 必要な場合は、アウトラインを作成するセル範囲内のセルを選択します。

    2. [データ] タブの [アウトライン] で、[グループ] の下の矢印をクリックし、[自動アウトライン] をクリックします。

      [グループ] の下にある矢印をクリックして、[アウトラインの自動作成] をクリックする

    アウトラインを手動で作成する

    重要: アウトライン レベルを手動でグループ化する場合、行のグループ化でのミスを防ぐために、すべてのデータを表示することをお勧めします。

    1. 上位のグループのアウトラインを作成します。

      上位のグループのアウトラインを作成する方法

      1. 下位レベルにある集計行と、関連する詳細行をすべて選択します。

        たとえば、次のデータでは、行 6 には行 2 ~ 5 の小計が、行 10 には行 7 ~ 9 の小計が、行 11 には総計が、それぞれ含まれています。行 11 のすべての詳細データをグループ化するには、行 2 ~ 10 を選択します。

         

        A

        B

        C

        1

        地域

        売上

        2

        東部

        3 月

        \964,700

        3

        東部

        3 月

        \410,100

        4

        東部

        3 月

        \711,500

        5

        東部

        3 月

        \295,700

        6

        東部

        3 月合計

        \2,382,000

        7

        東部

        4 月

        \425,700

        8

        東部

        4 月

        \182,900

        9

        東部

        4 月

        \655,000

        10

        東部

        4 月合計

        \1,263,600

        11

        東部合計

        \3,645,600

        重要: 集計行 (行 11) は選択範囲に含めません。

      2. [データ] タブの [アウトライン] で、[グループ] をクリックし、[] をクリックして、[OK] をクリックします。

        [行] をクリックして、[OK] をクリックする

        画面のグループの上または左に、アウトライン記号が表示されます。

    2. 必要に応じて、入れ子になった下位グループ (指定したデータ セクションの詳細行) のアウトラインを作成します。

      入れ子になった下位グループ (詳細行のグループ) のアウトラインを作成する方法

      1. 入れ子になった下位グループそれぞれについて、集計行に隣接する各詳細行を選択します。

        次の例では、集計行 6 に対応する行 2 ~ 5 をグループ化するには、行 2 ~ 5 を選択します。集計行 10 に対応する行 7 ~ 9 をグループ化するには、行 7 ~ 9 を選択します。

         

        A

        B

        C

        1

        地域

        売上

        2

        東部

        3 月

        \964,700

        3

        東部

        3 月

        \410,100

        4

        東部

        3 月

        \711,500

        5

        東部

        3 月

        \295,700

        6

        東部

        3 月合計

        \2,382,000

        7

        東部

        4 月

        \425,700

        8

        東部

        4 月

        \182,900

        9

        東部

        4 月

        \655,000

        10

        東部

        4 月合計

        \1,263,600

        11

        東部合計

        \3,645,600

        重要: 集計行は選択範囲に含めません。

      2. [データ] タブの [アウトライン] にある [グループ] をクリックします。

        [データ] タブの [グループ] をクリックする

        画面のグループの上または左に、アウトライン記号が表示されます。

      3. 下位の行の選択とグループ化を続け、アウトラインに含めるすべてのレベルを作成します。

      4. 行のグループ化を解除するには、行を選択し、[データ] タブの [アウトライン] で [グループ解除] をクリックします。

        アウトライン全体を削除せずに、アウトラインのセクションのグループ化を解除することもできます。Shift キーを押しながらグループの プラス記号 (+) ボックス または マイナス記号 (-) ボックス をクリックし、[データ] タブをクリックして、[アウトライン] にある [グループ解除] をクリックします。

        重要: 詳細データを非表示にしているときにアウトラインのグループ化を解除すると、詳細行が非表示のままになることがあります。データを表示するには、まず、非表示の行に隣接して表示されている行番号をドラッグして選択します。次に、[ホーム] タブの [セル] で [書式] をクリックし、[非表示/再表示] をポイントして、[行の再表示] をクリックします。

ページの先頭へ

列のアウトラインを作成する

  1. アウトラインを作成するデータの各行の最初の列に行見出しがあること、同じ行には同じ種類のデータが入力されていること、範囲内に空白行または空白列が含まれていないことを確認します。

  2. 詳細列の各グループのすぐ右またはすぐ左に、数式を使って独自の集計列を挿入します。次の手順 4. の表に例を示します。

    注: 列単位でデータのアウトラインを作成するには、グループの各詳細列のセル範囲を参照する数式を集計列に設定します。

  3. 集計列の位置を詳細列の左右どちらにするかを指定します。[データ] タブの [アウトライン] で [アウトライン] ダイアログ ボックス起動ツールをクリックします。

    集計列の位置を指定する方法

    1. [データ] タブの [アウトライン] で [アウトライン] ダイアログ ボックス起動ツールをクリックします。

      アウトライン グループでダイアログ ボックス起動ツールをクリックする

    2. 集計列の位置を詳細列の左にするには、[詳細データの右] チェック ボックスをオフにします。集計列の位置を詳細列の右にするには、[詳細データの右] チェック ボックスをオンにします。

    3. [OK] をクリックします。

  4. データのアウトラインを作成するには、次のいずれかの操作を行います。

    アウトラインを自動作成する

    1. 必要な場合は、範囲内のセルを選択します。

    2. [データ] タブの [アウトライン] で、[グループ] の下の矢印をクリックし、[自動アウトライン] をクリックします。

    アウトラインを手動で作成する

    重要: アウトライン レベルを手動でグループ化する場合、列のグループ化でのミスを防ぐために、すべてのデータを表示することをお勧めします。

    1. 上位のグループのアウトラインを作成します。

      上位のグループのアウトラインを作成する方法 (総計以外のすべての列)

      1. 下位レベルにある集計列と、関連する詳細データをすべて選択します。

        次の例では、列 E には列 B ~ D の小計が、列 I には列 F ~ H の小計が、列 J には総計が、それぞれ含まれています。列 J のすべての詳細データをグループ化するには、列 B ~ I を選択します。

         

        A

        B

        C

        D

        E

        F

        G

        H

        I

        J

        1

        地域

        1 月

        2 月

        3 月

        第 1 四半期

        4 月

        5 月

        6 月

        第 2 四半期

        上半期

        2

        東部

        371

        504

        880

        1,755

        186

        653

        229

        1,068

        2,823

        3

        西部

        192

        185

        143

        520

        773

        419

        365

        1,557

        2,077

        4

        北部

        447

        469

        429

        1,345

        579

        180

        367

        1,126

        2,471

        5

        南部

        281

        511

        410

        1,202

        124

        750

        200

        1,074

        2,276

        重要: 集計列である列 J (総計) は選択範囲に含めません。

      2. [データ] タブの [アウトライン] にある [グループ] をクリックします。

        [データ] タブの [グループ] をクリックする

        画面のグループの上または左に、アウトライン記号が表示されます。

    2. 必要に応じて、入れ子になった下位グループ (詳細列の個々のグループ) のアウトラインを作成します。

      入れ子になった下位グループ (詳細列のグループ) のアウトラインを作成する方法

      1. 入れ子になった下位グループそれぞれについて、集計列に隣接する各詳細列を選択します。

        次の例では、集計列 E に対応する列 B ~ D をグループ化するには、列 B ~ D を選択します。集計列 I に対応する列 F ~ H をグループ化するには、列 F ~ H を選択します。

         

        A

        B

        C

        D

        E

        F

        G

        H

        I

        J

        1

        地域

        1 月

        2 月

        3 月

        第 1 四半期

        4 月

        5 月

        6 月

        第 2 四半期

        上半期

        2

        東部

        371

        504

        880

        1,755

        186

        653

        229

        1,068

        2,823

        3

        西部

        192

        185

        143

        520

        773

        419

        365

        1,557

        2,077

        4

        北部

        447

        469

        429

        1,345

        579

        180

        367

        1,126

        2,471

        5

        南部

        281

        511

        410

        1,202

        124

        750

        200

        1,074

        2,276

        重要: グループの集計列は選択範囲に含めません。

      2. [データ] タブの [アウトライン] にある [グループ] をクリックします。

        [データ] タブの [グループ] をクリックする

        画面のグループの上または左に、アウトライン記号が表示されます。

  5. 下位の列の選択とグループ化を続け、アウトラインに含めるすべてのレベルを作成します。

  6. 列のグループ化を解除するには、列を選択し、[データ] タブの [アウトライン] で [グループ解除] をクリックします。

[データ] タブで、[グループ解除] をクリックする

アウトライン全体を削除せずに、アウトラインのセクションのグループ化を解除することもできます。Shift キーを押しながらグループの プラス記号 (+) ボックス または マイナス記号 (-) ボックス をクリックし、[データ] タブをクリックして、[アウトライン] にある [グループ解除] をクリックします。

詳細データを非表示にしているときにアウトラインのグループ化を解除すると、詳細列が非表示のままになることがあります。データを表示するには、まず、非表示の列に隣接して表示されている列見出しをドラッグして選択します。次に、[ホーム] タブの [セル] で [書式] をクリックし、[非表示/再表示] をポイントして、[列の再表示] をクリックします。

ページの先頭へ

アウトラインの詳細データの表示と非表示を切り替える

  1. 1 2 3プラス記号 (+)マイナス のアウトライン記号が表示されない場合は、[Microsoft Office] ボタン Office ボタンの画像 をクリックし、[Excel のオプション] をクリックするか (Excel 2007 の場合)、[ファイル] タブをクリックし (その他のバージョンの場合)、[オプション] をクリックし、[詳細設定] カテゴリをクリックします。次に、[次のシートで作業するときの表示設定] でワークシートをクリックし、[アウトラインが適用されている場合はアウトライン記号を表示する] チェック ボックスをオンにします。

  2. [OK] をクリックします。

  3. 次の操作のいずれか、または複数の操作を行います。

    グループの詳細データを表示または非表示にする   

    • グループの詳細データを表示するには、グループの プラス記号 (+) をクリックします。

    • グループの詳細データを非表示にするには、グループの マイナス をクリックします。

      アウトライン全体の特定のレベルを表示または非表示にする   

    • 表示するレベルの 1 2 3 アウトライン記号をクリックします。クリックした記号よりも下位レベルの詳細データは非表示になります。

      たとえば、アウトラインに 4 つのレベルがある場合、 3 をクリックすると、4 番目のレベルを表示せずに、それより上のレベルの詳細データをすべて表示できます。

      アウトラインの詳細データをすべて表示または非表示にする   

    • すべての詳細データを表示するには、 1 2 3 アウトライン記号の一番下のレベルをクリックします。たとえば、3 つのレベルが設定されている場合は、 3 をクリックします。

    • すべての詳細データを非表示にするには、 1 をクリックします。

ページの先頭へ

アウトラインのスタイルを変更する

アウトラインが作成された行には、RowLevel_1 や RowLevel_2 などのスタイルが使われます。アウトラインが作成された列には、ColLevel_1 や ColLevel_2 などのスタイルが使われます。スタイルには、太字、斜体などの文字書式が使われ、他のデータから集計行と集計列が区別されます。これらの各スタイルの定義を変更し、別のテキストの書式やセルの書式を使ってアウトラインの表示を独自に設定できます。アウトラインへのスタイルの適用は、アウトラインの作成時または作成後に行うことができます。

次の操作のいずれか、または複数の操作を行います。

集計行または集計列に自動的にスタイルを適用する   

  1. [データ] タブの [アウトライン] で [アウトライン] ダイアログ ボックス起動ツールをクリックします。

    アウトライン グループでダイアログ ボックス起動ツールをクリックする

  2. [既定のスタイルを使用する] チェック ボックスをオンにします。

既存の集計行または集計列にスタイルを適用する   

  1. アウトライン スタイルを適用するセルを選択します。

  2. [データ] タブの [アウトライン] で [アウトライン] ダイアログ ボックス起動ツールをクリックします。

    アウトライン グループでダイアログ ボックス起動ツールをクリックする

  3. [既定のスタイルを使用する] チェック ボックスをオンにします。

  4. [スタイルの流用] をクリックします。

オートフォーマットを使って、アウトラインを作成したデータの書式を設定することもできます。

ページの先頭へ

アウトラインの詳細データをコピーする

  1. 1 2 3プラス記号 (+)マイナス のアウトライン記号が表示されない場合は、[Microsoft Office] ボタン Office ボタンの画像 をクリックし、[Excel のオプション]をクリックするか (Excel 2007 の場合)、[ファイル] タブをクリックし (その他のバージョンの場合)、[オプション] をクリックし、[詳細設定] カテゴリをクリックします。次に、[次のシートで作業するときの表示設定] でワークシートをクリックし、[アウトラインが適用されている場合はアウトライン記号を表示する] チェック ボックスをオンにします。

  2. 1 2 3マイナスプラス記号 (+) アウトライン記号を使って、コピーしない詳細データを非表示にします。

    詳細については、「アウトラインの詳細データの表示と非表示を切り替える」を参照してください。

  3. 集計行の範囲を選択します。

  4. [ホーム] タブの [編集] グループで [検索と選択] をクリックし、[ジャンプ] をクリックします。

    [検索と選択] をクリックして、[ジャンプ] をクリックする

  5. [選択オプション] をクリックします。

  6. [可視セル] をクリックします。

  7. [OK] をクリックし、データをコピーします。

ページの先頭へ

アウトラインを非表示または削除する

注: アウトラインを非表示または削除しても、データは削除されません。

アウトラインを非表示にする

  • (Excel 2007 の場合) [Microsoft Office] ボタン Office ボタンの画像 をクリックし、[Excel のオプション] をクリックするか、(その他のバージョンの場合) [ファイル] タブをクリックし、[オプション] をクリックし、[詳細設定] カテゴリをクリックします。次に、[次のシートで作業するときの表示設定] セクションで、非表示にするワークシートをクリックし、[アウトラインが適用されている場合はアウトライン記号を表示する] チェック ボックスをオフにします。

アウトラインを削除する

  1. シートをクリックします。

  2. [データ] タブの [アウトライン] で、[グループ解除] をクリックし、[アウトラインのクリア] をクリックします。

    [グループ解除] ボタンの [アウトラインのクリア] をクリックする

    重要: 詳細データを非表示にしているときにアウトラインを削除すると、詳細行または詳細列が非表示のままになることがあります。データを表示するには、まず、非表示の行または列に隣接して表示されている行番号または列見出しをドラッグして選択します。次に、[ホーム] タブの [セル] で [書式] をクリックし、[非表示/再表示] をポイントして、[行の再表示] または [列の再表示] をクリックします。

ページの先頭へ

グラフを使ったサマリー レポートを作成する

合計やその合計のグラフのみを表示する、データの集計レポートを作成するとします。この場合、一般に次の操作を行います。

  1. サマリー レポートを作成します。

    1. データのアウトラインを作成します。

      詳細については、「行のアウトラインを作成する」または「列のアウトラインを作成する」をご覧ください。

    2. 1 2 3プラス記号 (+)マイナス アウトライン記号をクリックして、詳細データを非表示にし、次の例の行のアウトラインのように、合計値のみが表示されるようにします。

      合計行だけが表示されたアウトライン表示のリスト

    3. 詳細については、「アウトラインの詳細データの表示と非表示を切り替える」を参照してください。

  2. サマリー レポートをグラフ化します。

    1. グラフ化する集計データを選択します。

      たとえば、吉田と西脇の合計値のみをグラフ化し、総計は除外するには、上の例に示すように、セル A1 ~ C11 を選択します。

    2. グラフを作成します。たとえば、[挿入] タブの [グラフ] で、[おすすめグラフ] をクリックするか、別のグラフの種類を選択します。

      たとえば、グラフ ウィザードを使ってグラフを作成すると、次の例のようになります。

      小計データから作成したグラフ

      アウトライン表示されたデータ リストの詳細データの表示と非表示を切り替えると、対応するグラフに表示されるデータも切り替わります。

ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×