レポートを修正、編集、または変更する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

このトピックでは、既存のレポートを変更する方法について説明します。Microsoft Office Access 2007にレポートを変更するのに使用できる 2 つのビューが用意されています。 レイアウト ビューとデザイン ビュー。任意のビューを使用は、どのような特定のタスクによって異なります。 しようとして実行します。られたりする両方のビューを使用して書式を変更します。

目的に合ったトピックをクリックしてください

レイアウト ビューについて理解する

デザイン ビューについて理解する

ビューを切り替える

レイアウト ビューでレポートを変更する

デザイン ビューでレポートを変更する

レイアウト ビューについて理解する

レイアウト ビューは、レポート変更用の最も直観的なビューであり、Office Access 2007 でレポートに対して加えるほぼすべての変更に使用できます。レイアウト ビューでは、レポートは実際に実行しているので、印刷時と同じようにデータを確認できます。ただし、このビューでレポート デザインを変更することもできます。レポートを変更しながらデータを確認できるので、このビューは、列幅の設定、グループ レベルの追加、レポートの外観や読みやすさを左右する他のほとんどのタスクの実行などを行う場合に非常に便利です。次の図は、"得意先電話帳" レポートをレイアウト ビューで示しています。

レイアウト ビューのレポート

レイアウト ビューに表示されるレポートは、印刷後のレポートとまったく同じには表示されません。たとえば、レイアウト ビューでは改ページがありません。また、列のあるレポートの書式設定に [ページ設定] を使用した場合、レイアウト ビューには列は表示されません。ただし、レイアウト ビューでは印刷後のレポートに非常に近いものになります。印刷時のレポートの外観を確認する場合は、印刷プレビューを使用してください。

特定のタスクはレイアウト ビューで実行できません。その場合は、デザイン ビューに切り替えます。状況によっては、特定の変更を行う場合にデザイン ビューを切り替えるように指示するメッセージが表示されます。

ページの先頭へ

デザイン ビューについて理解する

デザイン ビューでは、レポートの構造の詳細が表示されます。レポート、ページ、およびグループのヘッダー バンドとフッター バンドを確認できます。デザイン ビューではレポートは実際に実行していないので、作業中に基になるデータを確認できません。ただし、次の特定のタスクはレイアウト ビューよりもデザイン ビューの方が容易に実行できます。

  • 幅広い種類のコントロール (ラベル、イメージ、線、四角形など) をレポートに追加する。

  • プロパティ シートを使用せずに、テキスト ボックス自体でテキスト ボックス コントロール ソースを編集する。

  • レイアウト ビューでは操作できない特定のプロパティを変更する。

次の図は、"得意先電話帳" レポートをデザイン ビューで示しています。

デザイン ビューのレポート

ページの先頭へ

ビューを切り替える

Access には、ビューを切り替えるためのさまざまな方法が用意されています。レポートが既に表示されている場合、次のいずれかを実行することで、別のビューに切り替えることができます。

  • ナビゲーション ウィンドウでレポートを右クリックし、ショートカット メニューで目的のビューをクリックします。

  • レポートのドキュメント タブまたはタイトル バーを右クリックし、ショートカット メニューで目的のビューをクリックします。

  • [ホーム] タブの [表示] のビュー ] ボタンを使用可能なビューを切り替える] をクリックします。または、ビュー] の下の矢印をクリックして、メニューから [使用できるビューのいずれかを選択します。印刷プレビューはこのメニューにできません。

    Access のリボンの画像

  • レポート自体の空白領域を右クリックし、目的のビューをクリックします。デザイン ビューでレポートを開いている場合は、デザイン グリッドの外側を右クリックする必要があります。

  • Access のステータス バーで、小さいビュー アイコンの 1 つをクリックします。

まだレポートを開いていない場合は、ナビゲーション ウィンドウ内のレポートをダブルクリックして、レポート ビューでレポートを開きます。別のビューでレポートを開くには、ナビゲーション ウィンドウでレポートを右クリックし、ショートカット メニューで目的のビューをクリックします。

注: [ページ設定] を使用して複数の列 (宛名ラベル レポートなど) を作成した場合、このレポートを変更する際に列を表示できるのは印刷プレビューのみです。このレポートをレポート ビューまたはレイアウト ビューで表示した場合、データは 1 列に表示されます。

ページの先頭へ

レイアウト ビューでレポートを変更する

ここでは、レイアウト ビューで実行できる一般的なレポート変更について説明します。

列またはフィールドの幅を変更する

行またはフィールドの高さを変更する

フィールドを追加する

コントロール レイアウトについて理解する

フィールドまたは列を削除する

ページ設定を変更する

フィールドの書式を変更する

テキスト ボックスを別のフィールドに連結する (コントロールのコントロール ソースを変更する)

レポートのレコード ソースを変更する

フィールド内でテキストを折り返す

枠線を追加する

ロゴやその他のイメージを追加または変更する

レポート タイトルを追加または編集する

ページ番号、現在の日付、または現在の時刻を追加する

列またはフィールドの幅を変更する

  1. 調整する列の項目をクリックします。

    フィールドが選択されていることを示すために項目の周囲に罫線が表示されます。

  2. 列が必要な幅になるまで罫線の右端または左端をドラッグします。

ページの先頭へ

行またはフィールドの高さを変更する

  1. 調整する行の項目をクリックします。

    フィールドが選択されていることを示すために項目の周囲に罫線が表示されます。

  2. 行が必要な高さになるまで罫線の上端または下端をドラッグします。

ページの先頭へ

フィールドを追加する

  • [書式] タブの [コントロール] グループで、既存のフィールドの追加] をクリックします。 ボタンの画像

    使用可能なフィールドの一覧が表示されます。使用可能なフィールドが他のテーブルにある場合、そうしたフィールドは [他のテーブルで利用可能なフィールド] の下に表示されます。

  • フィールドを [フィールド リスト] からレポートにドラッグします。フィールドを移動すると、強調表示された領域に、マウス ボタンを離したときのフィールドの配置場所が示されます。

    注: 一度に複数のフィールドを追加するには、Ctrl キーを押したまま、[フィールド リスト] の必要な各フィールドをクリックします。次に、Ctrl キーを離してフィールドをレポートにドラッグします。選択したフィールドが並べて配置されます。

ページの先頭へ

コントロール レイアウトについて理解する

コントロール レイアウトを参考にしながら、コントロールを横または縦に揃えることで、レポートの外観を統一できます。コントロール レイアウトは、テーブルの各セルに 1 つのコントロールが含まれるテーブルと考えることができます。コントロール レイアウトでコントロールを追加、削除、または配置変更する手順を以下に説明します。

コントロール レイアウトには、表形式と集合形式の 2 種類があります。

  • 表形式のコントロール レイアウトでは、コントロールはワークシートのように行と列に配置され、上端にラベルが表示されます。表形式のコントロール レイアウトは、常にレポートの 2 つのセクションにわたり、いずれかのセクションにコントロールが配置され、コントロールの上のセクションにラベルが表示されます。次の図は、基本的な表形式のコントロール レイアウトを示しています。

    基本的な表形式のコントロール レイアウト

  • 集合形式レイアウトでは、コントロールは紙の用紙のように縦に配置され、各コントロールの左側にラベルが表示されます。集合形式レイアウトは、常に 1 つのレポート セクションの中に含まれています。次の図は、基本的な集合形式のコントロール レイアウトを示しています。

    基本的な集合形式のコントロール レイアウト

どちらのレポートでも、複数のコントロール レイアウトを使用できます。たとえば、表形式レイアウトを使用してレコードごとにデータ行を作成し、その下に同じレコードの追加のデータを含む 1 つまたは複数の集合形式のレイアウトを作成できます。

新しいコントロール レイアウトを作成する

次の場合は、コラム コントロール レイアウトが自動的に作成されます。

  • [作成] タブの [レポート] で ボタンの画像 (レポート) をクリックして、新しいレポートを作成する。

  • [作成] タブの [レポート] で ボタンの画像 (空白のレポート) をクリックし、[フィールド リスト] ウィンドウからレポートにフィールドをドラッグして、新しいレポートを作成する。

既存のレポートでは、次の操作によって新しいコントロールを作成できます。

  1. レイアウトに追加するコントロールを選択します。

  2. 同じレイアウトに他のコントロールを追加するには、Shift キーを押しながら、そのコントロールをクリックします。

  3. 次のいずれかの操作を行います。

    • [配置] タブの [レイアウトの調整] で [表形式] ボタンの画像 または [集合形式] ボタンの画像 をクリックします。

    • 選択したコントロールを右クリックし、[レイアウト] をポイントします。次に、 ボタンの画像 (表形式) または ボタンの画像 (集合形式) をクリックします。

コントロール レイアウトが作成され、選択したコントロールが追加されます。

表形式から集合形式、または集合形式から表形式にコントロール レイアウトを切り替える

レイアウト全体を別のレイアウトに切り替えるには

  • レイアウトの左上隅にあるオレンジ色のレイアウト セレクタをクリックして、コントロール レイアウトを選択します。

    レイアウトのすべてのセルが選択されます。

  • 次のいずれかの操作を行います。

    • [配置] タブの [ レイアウトの調整] で目的のレイアウトの種類 ([表形式] ボタンの画像 または [集合形式] ボタンの画像 ) をクリックします。

    • コントロール レイアウトを右クリックし、[レイアウト] をポイントします。次に、目的のレイアウトの種類をクリックします。

コントロールの配置が、選択したレイアウトに変更されます。

1 つのコントロール レイアウトを 2 つのレイアウトに分割する

1 つのコントロール レイアウトを 2 つのレイアウトに分割するには、次の手順を実行します。

  1. Shift キーを押しながら、新しいコントロール レイアウトに移動するコントロールをクリックします。

  2. 次のいずれかの操作を行います。

    • [配置] タブの [レイアウトの調整] で新しいレイアウトに使用するレイアウトの種類 ([表形式] ボタンの画像 または [集合形式] ボタンの画像 ) をクリックします。

    • 選択したコントロールを右クリックし、[レイアウト] をポイントします。次に、新しいレイアウトに使用するレイアウトの種類をクリックします。

新しいコントロール レイアウトが作成され、選択したコントロールが追加されます。

コントロール レイアウト内のコントロールの配置を変更する

  • コントロールを目的の場所にドラッグすることで、コントロール レイアウト内のコントロールを移動できます。フィールドをドラッグすると、水平バーまたは垂直バーに、マウス ボタンを離したときのフィールドの配置場所が示されます。

  • 同じ種類の別のコントロール レイアウトにコントロールを移動できます。たとえば、コントロールを別の集合形式レイアウトにドラッグすることはできますが、表形式レイアウトにドラッグすることはできません。

コントロール レイアウトにコントロールを追加する

[フィールド リスト] ウィンドウから既存のコントロール レイアウトに新しいフィールドを追加するには   

  • フィールドを [フィールド リスト] ウィンドウからレイアウトにドラッグします。水平バーまたは垂直バーに、マウス ボタンを離したときのフィールドの配置場所が示されます。

既存のコントロールを既存のコントロール レイアウトに追加するには   

  1. コントロール レイアウトに追加する最初のコントロールを選択します。

  2. 同じレイアウトに他のコントロールを追加するには、Shift キーを押しながら、そのコントロールをクリックします。他のコントロール レイアウトのコントロールを選択することもできます。

  3. 次のいずれかの操作を行います。

    • レポートをデザイン ビューで開いている場合は、選択したフィールドをレイアウトにドラッグします。水平バーまたは垂直バーに、マウス ボタンを離したときのフィールドの配置場所が示されます。

    • レポートをレイアウト ビューで開いている場合は、次の操作を行います。

      1. [配置] タブの [レイアウトの調整] で、コントロールを追加するレイアウトの種類をクリックします。表形式レイアウトに追加する場合は、[表形式] をクリックします。集合形式レイアウトに追加する場合は、[集合形式] をクリックします。

        新しいレイアウトが作成され、選択したコントロールが追加されます。

      2. 新しいレイアウトを既存のレイアウトにドラッグします。水平バーまたは垂直バーに、マウス ボタンを離したときのフィールドの配置場所が示されます。

コントロール レイアウトからコントロールを削除する

コントロール レイアウトからコントロールを削除すると、他のコントロールの位置に影響を与えずに、コントロールをレポートの任意の場所に配置できます。

  • レイアウトから削除するコントロールを選択します。複数のコントロールを選択するには、Shift キーを押しながら、削除するコントロールをクリックします。レイアウトのすべてのコントロールを選択するには、レイアウトの左上隅にあるレイアウト セレクタ ボックスをクリックします。

  • 次のいずれかの操作を行います。

    • [配置] タブの [レイアウトの調整] で [削除] ボタンの画像 をクリックします。

    • 選択したコントロールのいずれかを右クリックし、[レイアウト] をポイントします。次に、[削除] をクリックします。

      選択したコントロールがレイアウトから削除されます。

ヒント: ようにするためのコントロールに移動すると、コントロール レイアウトに挿入される、キーを押して、CTRL キーを押したままし、コントロールを目的の場所にドラッグします。

ページの先頭へ

フィールドまたは列を削除する

  1. 削除するフィールドまたは列をクリックするか、そのラベルまたは列見出しをクリックします。

    フィールドまたは列が選択されていることを示すために項目の周囲に罫線が表示されます。

  2. Del キーを押します。

ページの先頭へ

ページ設定を変更する

サイズ、向き、余白などを変更するには、[ページ設定] タブの [ページ レイアウト] を使用します。

  1. [ページ設定] タブをクリックします。

  2. [ページ レイアウト] の ボタン イメージ (サイズ) をクリックして、別の用紙サイズを選択します。

  3. ボタンの画像 () または ボタンの画像 () をクリックして、印刷の向きを変更します。

  4. ボタンの画像 (余白) をクリックして、レポートの余白を調整します。

ページの先頭へ

フィールドの書式を変更する

  1. 書式設定するフィールドを選択します。

  2. [書式] タブ、[フォント] グループで目的の書式を適用するツールを使います。

    Access のリボンの画像

ページの先頭へ

テキスト ボックスを別のフィールドに連結する (コントロールのコントロール ソースを変更する)

  1. コントロール ソースを変更する列またはフィールド内をクリックします。

    フィールドが選択されていることを示すためにフィールドの周囲に罫線が表示されます。

  2. 現在プロパティ シートが表示されていない場合は、F4 キーを押して表示します。

  3. プロパティ シートの [データ] タブで、"コントロールソース" プロパティを新しいフィールドに設定します。ドロップダウン リストからフィールドを選択するか、ボックスに式を入力できます。式の詳細については、[参照] セクションのリンク先を参照してください。

ページの先頭へ

レポートのレコード ソースを変更する

  1. プロパティ シートが表示されていない場合は、F4 キーを押してプロパティ シートを表示します。

  2. プロパティ シートの上部にあるドロップダウン リストで、[レポート] をクリックします。

  3. プロパティ シートで、[データ] タブをクリックします。

  4. [レコードソース] ボックスの一覧で、レコード ソースとして使用するテーブルまたはクエリをクリックするか、 [ビルダー] ボタン をクリックして、クエリ ビルダを表示します。

    注: レポートが現在テーブルに基づいている場合は、テーブルに基づいてクエリを作成するかどうかがたずねられます。[はい] をクリックしてクエリ ビルダに進みクエリを作成するか、[いいえ] をクリックして操作をキャンセルします。クエリを作成することにした場合は、新しいクエリがレポートのレコード ソースになります。このクエリは、"埋め込み" クエリとして作成されます (別個のクエリ オブジェクトとしてではなく、レポートの "RecordSource/レコード ソース" プロパティに格納されます)。

ページの先頭へ

フィールド内でテキストを折り返す

  1. プロパティ シートが表示されていない場合は、テキストを折り返すフィールドを右クリックして、[プロパティ] をクリックします。表示されている場合は、フィールドをクリックして選択します。

  2. プロパティ シートの [書式] タブで、"CanGrow/印刷時拡張" プロパティを [はい] に設定します。

ページの先頭へ

枠線を追加する

コントロールがコントロール レイアウトに含まれている場合、枠線を追加して、コントロールをわかりやすくすることができます。コントロール レイアウトの詳細については、「コントロール レイアウトを操作する」を参照してください。

  1. コントロール レイアウトの任意のフィールドをクリックします。

    フィールドが選択されていることを示すためにフィールドの周囲に罫線が表示されます。

  2. [書式] タブの [枠線] で、枠線] をクリックします。

    Access のリボンの画像

  3. 必要な枠線のスタイルを選択します。

注: コントロール レイアウトの任意のフィールドを右クリックし、[レイアウト]、[枠線] の順にポイントして、必要な枠線の種類を選択することで、枠線を追加することもできます。

ページの先頭へ

ロゴやその他のイメージを追加または変更する

ロゴ ツールを使用してレポートにロゴを追加する手順、およびイメージ コントロール自体のサイズまたはイメージ コントロール内のイメージのサイズを変更する手順を以下に説明します。

ロゴを追加する

  • [書式] タブの [コントロール] グループで、[ロゴ] をクリックします。 ボタンの画像

    [図の挿入] ダイアログ ボックスが表示されます。

  • ロゴ ファイルが格納されているフォルダに移動し、そのファイルをダブルクリックします。

    ロゴがレポートの左上隅に追加されます。

ロゴまたは他のイメージを含むコントロールのサイズを変更する

  1. イメージを含むコントロールをクリックします。

    コントロールが選択されていることを示すためにコントロールの周囲に罫線が表示されます。

  2. 罫線にポインタを置きます。ポインタが双方向矢印になると、矢印の示す方向にイメージをドラッグしてイメージ コントロールを拡大または縮小できます。

イメージの [OLEサイズ] プロパティの既定値は [クリップ] です。つまり、イメージは、イメージ コントロールの拡大率や縮小率にかかわらず同じサイズのままということです。コントロールのサイズの変更に合わせてイメージを拡大または縮小させる場合は、次の操作を行います。

コントロール内のロゴまたはイメージのサイズを変更する

  1. イメージをクリックします。

  2. プロパティ シートが表示されていない場合は、F4 キーを押して表示します。

  3. プロパティ シートの [書式] タブで、[OLE サイズ] プロパティを適切なオプションに設定します。

設定

説明

クリップ

イメージは、イメージ コントロールの拡大率または縮小率にかかわらず同じサイズのままです。イメージ コントロールをイメージより小さくすると、イメージは切り取られます。

ストレッチ

イメージは、イメージ コントロールのサイズに合わせて縦横に拡大されます。イメージの元の縦横比は保存されないので、イメージ コントロールの高さと幅を正確に設定しなかった場合は、イメージがゆがむことがあります。

ズーム

イメージ コントロールのサイズが変更されると、イメージは、イメージの元の縦横比に影響することなくできるだけ大きくなるように調整されます。

ページの先頭へ

レポート タイトルを追加または編集する

レポートのタイトルを含むラベルを追加または編集する手順を以下に説明します。

レポートにタイトルを追加する

  • [書式] タブの [コントロール] グループで、タイトルをクリックします。 ボタンの画像

    新しいラベルがレポート ヘッダーに追加され、レポート名がレポート タイトルとして入力されます。

  • ラベルが作成されると、ラベル内のテキストが選択された状態になり、テキストを変更する場合は、必要なタイトルをすぐに入力できます。

  • 入力が完了したら Enter キーを押します。

レポート タイトルを編集する

  1. レポート タイトルが含まれているラベルをダブルクリックして、ラベル内にカーソルを置きます。

  2. レポート タイトルとして使用する文字列を入力し、入力が完了したら Enter キーを押します。

ページの先頭へ

ページ番号、現在の日付、または現在の時刻を追加する

レポートにページ番号を追加する手順、および現在の日付または現在の時刻を追加する手順を以下に説明します。

ページ番号を追加する

  • [書式] タブの [コントロール] グループで、ページ番号] をクリックします。 ボタンの画像

    [ページ番号] ダイアログ ボックスが表示されます。

  • ページ番号に必要な書式、位置、および配置を選択します。

  • 最初のページにページ番号が不要な場合は、[最初のページにページ番号を表示する] チェック ボックスをオフにします。

  • [OK] をクリックします。

    レポートにページ番号が追加されます。レポートの印刷時にページ番号がどのように表示されるかを確認するには、印刷プレビューに切り替えます。

日付または時刻を追加する

  • [書式] タブの [コントロール] グループで、日付と時刻をクリックします。 ボタンの画像

    [日付と時刻] ダイアログ ボックスが表示されます。

  • 日付を含めない場合は、[日付を含める] チェック ボックスをオフにします。

  • 日付を含める場合は、使用する日付の形式をクリックします。

  • 時刻を含めない場合は、[時刻を含める] チェック ボックスをオフにします。

  • 時刻を含める場合は、使用する時刻の形式をクリックします。

    ダイアログ ボックスの [プレビュー] ボックスに、日付と時刻の例が、選択した形式で表示されます。

  • [OK] をクリックします。

ページの先頭へ

デザイン ビューでレポートを変更する

場合によっては、レイアウト ビューではレポートに対して特定の変更を行うことができないので、代わりにデザイン ビューを使用する必要があります。

行番号を追加する

  1. [デザイン] タブの [コントロール] で ボタンの画像 (テキスト ボックス) をクリックします。

  2. 表示する行番号を追加するセクションの領域をクリックします。ほとんどの場合は、[詳細] セクションになります。テキスト ボックスは、後で最終的な場所に移動します。

    レポートをクリックすると、新しいバインドされていないテキスト ボックスが作成されます。

  3. ラベル (新しいテキスト ボックスのすぐ左側) をクリックして、Del キーを押します。

  4. 新しいテキスト ボックスを一度クリックして選択し、もう一度クリックしてテキスト ボックス内にカーソルを置きます。

  5. = 1 」と入力し、ENTER キーを押します。

  6. プロパティ シートが表示されていない場合は、F4 キーを押して表示します。

  7. プロパティ シートの [データ] タブで、[集計実行] プロパティを [全体] に設定します。

    注: グループ化されたレポートで、番号付けをグループごとに 1 から始める場合は、プロパティを [グループ全体] に設定します。

  8. テキスト ボックスの幅を小さくするには、テキスト ボックスの右端のサイズ変更ハンドルをポイントして、それを左にドラッグします。このレポートで表示されると思われる最大行数に備えて十分な余裕を残してください。

  9. 必要な場合は、詳細セクションの左端にテキスト ボックスの余裕をとるために、そのセクション内の既存のコントロールを右にドラッグするか、そのセクション内の一番左のコントロールのサイズを変更します。

  10. 新しいテキスト ボックスをレポートに目的の場所にドラッグします。

  11. レポート ビュー、印刷プレビュー、またはレイアウト ビューに切り替えると、行番号が表示されます。

各ページの上部にグループ ヘッダーを表示させる

グループが複数のページにわたる場合は、データがどのグループに含まれるかをすぐに確認できるように、各ページの上部にグループ ヘッダーを表示させると便利です。レイアウト ビューでもグループ ヘッダーを選択できますが、デザイン ビューで選択する方が簡単です。

  1. グループ ヘッダー セクション セレクタ (グループ ヘッダー セクションの上にある水平バー) をダブルクリックします。

  2. プロパティ シートの [書式] タブで、[セクション繰り返し] プロパティを [はい] に設定します。

独自のデザイン ビュー ウィンドウでサブレポートを開く

レポートをデザイン ビューで表示すると、レポートに含まれるサブレポートもデザイン ビューで表示されます。ただし、各サブレポートは、個別のウィンドウとして表示されるのではなく、サブレポート コントロール内に表示されます。サブレポート コントロールは小さすぎて簡単に確認できない場合が多いため、通常は、独自のウィンドウでサブレポートを開いて編集する方が便利です。サブレポートを新しいウィンドウで開くには、次のいずれかの操作を行います。

  • サブレポートを選択し、[デザイン] タブの [ツール] で ボタンの画像 (新しいウィンドウでサブレポートを開く) をクリックします。

  • サブレポート コントロールの外側を 1 回クリックして、選択されていないことを確認した後、サブレポートの内側を右クリックし、[新しいウィンドウでサブレポートを開く] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×