レポートを使用してサイトのパフォーマンスと利用状況を測定する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

サイトの責任者であれば、サイトに関する次のような共通の質問を受けていると思われます。

  • サイトの訪問者数

  • サイトのトラフィックの時間経過による変化

  • サイトの上位ユーザー層

  • サイトのトラフィックの発信元

  • サイトで最もアクセス回数の多いページとリソース

  • 文書やその他のリソースがワークフロー プロセスのどこに位置しているかを見つける方法

また Web サイトの管理者であれば、サイト オーナーが明確な回答を要求する次のような質問を受けていることがあります。

  • サイト内の使用していない、または古くなったリソースを削除できますか

  • 利用者が気が付いて報告する前に、どのような方法でサイトの問題を見つけられますか (リンクのないファイル、ページ表示の遅さ、切断されたハイパーリンクなど)

このような質問は手に負えないように思われますが、Microsoft Office SharePoint Designer 2007 サイトと Windows SharePoint Services 3.0 サイト、または Microsoft Office SharePoint Server 2007 サイトでは、Office SharePoint Designer 2007 レポートを使用すると、このような質問に簡単に回答することができます。このトピックでは、レポートを使用してサイトのパフォーマンスと利用状況を測定する方法を説明します。

重要: Office SharePoint Designer 2007 で生成されたレポートのデータは、サイトをホスティングするサーバー上に保存されています。サーバー管理者は、これらのレポートへのアクセスを許可または拒否することができます。要求したレポートにデータが含まれていない場合は、サーバー管理者に連絡して対処してください。利用状況レポートを実行する場合は、利用状況データの表示権限が必要になり、サーバー管理者はサーバーで利用状況データの収集を有効に設定している必要があります。既定では、サーバーでの利用状況データの収集はオフになっています。

目的に合ったトピックをクリックしてください

サイトの概要のレポートを表示します。

ファイルに関するレポートの表示

共有コンテンツに関するレポートの表示

問題に関するレポートの表示

利用状況の概要のレポートを表示します。

詳細な利用状況レポートを表示します。

グラフの使用状況データの結果

レポートを並べ替える

レポートをフィルター処理します。

レポートをコピーします。

レポートを保存します。

サイトの概要レポートを表示する

サイトの概要レポートには、サイトの高レベルの概要と、より詳細なレポートへのリンクが示されます。たとえば、次の図に示すようなサイトの概要レポートを生成できます。

サイトの概要レポート

各サイトのサイトの概要レポートを生成するには

  1. レポートを作成するサイトを Office SharePoint Designer 2007 で開きます。

  2. [サイト] メニューの [レポート] をポイントして、[サイトの概要] をクリックします。

    レポートが生成されます。

注: [名前] 列でハイパーリンクをクリックすると、詳細なレポートに移動します。たとえば、[切断されたハイパーリンク] をクリックすると、[切断されたハイパーリンク] レポートに直接移動できます。

ページの先頭へ

ファイルに関するレポートを表示する

すべてのファイル、最近追加されたファイル、最近変更されたファイル、または古いファイルを表示するそれぞれのレポートを生成できます。たとえば、サイトのホーム ページ、またはサイトをプロモートするニュースレターの新しいコンテンツを強調表示する場合、最近追加されたファイル レポートを使用して、新しいコンテンツをすばやく見つけることができます。また、古いファイル レポートを使用すると、古すぎて更新または削除の予定を確認できないコンテンツを特定できます。

ファイルに関するレポートを実行する場合、まず最近のファイルと古いファイルの定義を指定し、また月別レポートに表示する期間を月数で指定します。

  1. レポートを実行する Web サイトを Office SharePoint Designer 2007 で開きます。

  2. [ツール] メニューの [アプリケーション オプション] をクリックします。

  3. [レポート ビュー] タブをクリックします。

    [レポート ビュー] タブを表示した [アプリケーション オプション] ダイアログ ボックス

  4. ["最近" 追加されたページ] ボックスに、最近のページを識別する日数を入力します。

  5. ["古い" ファイル] ボックスに、古いページを識別する日数を入力します。

  6. [表示する月数] ボックスに、月別レポートに表示する月数を入力します。

  7. [OK] をクリックします。

    これでレポートを実行できます。

  8. [サイト] メニューの [レポート] をポイントし、[ファイル] をポイントした後、実行するレポートをクリックします。

    • すべてのファイル     サイトのすべてのファイルのリストを表示します。

    • 最近追加されたファイル     手順 4. で指定した日数の期間に、サイトに追加されたファイルのリストを表示します。

    • 最近変更されたファイル     手順 4. で指定した日数の期間に、サイトで変更されたファイルのリストを表示します。

    • 古いファイル     手順 5. で指定した日数で判断された結果、「古い」と見なされるファイルのリストを表示します。

    • チェックアウトの状況     各ファイルの現在の [チェックアウトの状況] に従ってサイト内に存在するファイルのリストを表示します。(このレポートには、[チェックアウト者]、[バージョン]、[ロックされた日付] の各列のデータも含れます。)

      レポート ビューのファイルに関するレポートについて、リスト内のオプションをクリックすると、古いファイルまたは新しいファイルの設定をすばやく変更できます。

      ファイル年齢フィルタ メニューを示すレポート ビュー

ページの先頭へ

共有コンテンツに関するレポートを表示する

共有コンテンツには、マスタ ページ、サイト定義内のカスタマイズされたページとその他のページ、およびスタイル シート リンクが含まれます。Office SharePoint Designer 2007 を使用すると、共有コンテンツを簡単に見つけられます。たとえば、Web サイトのページのすべてのロゴを変更する場合、マスタ ページを使用してページの書式を制御していれば、マスタ ページ レポートを使用して、ロゴを変更するすべてのマスタ ページを見つけることができます。フォントまたは書式の変更をサイト全体に適用する必要があり、この変更に合わせて更新する必要のあるすべてのスタイル シートを見つける場合は、スタイル シート リンク レポートを使用できます。

  1. レポートを実行する Web サイトを Office SharePoint Designer 2007 で開きます。

  2. [サイト] メニューの [レポート] をポイントし、[共有コンテンツ] をポイントした後、実行するレポートをクリックします。

    • ダイナミック Web テンプレート     サイト内のすべてのページのリストを表示します。これには、ダイナミック Web テンプレートに各ページを適用するかどうかを指定する (また適用する場合は、どのページを適用するか) [ダイナミック Web テンプレート] 列も含まれます。

    • マスタ ページ     サイト内のすべてのページのリストを表示します。これには、マスタ ページに各ページを適用するかどうかを指定する (また適用する場合は、どのページを適用するか) [マスタ ページ] 列も含まれます。

    • カスタマイズされたページ     サイト内のすべてのページのリストを表示します。これには、サイト定義に基づくページがカスタマイズされているかどうかを示す [ユーザー設定] 列も含まれます。

    • スタイル シート リンク     サイト内のすべてのページのリストを表示します。これには、各ページがスタイル シートに適用されているかどうかを示す [スタイル シート リンク] 列も含まれます。

      注: 表示されるスタイル シート リンクは、静的なスタイル シート リンク (<link> タグ) です。Microsoft ASP.NET コントロールで生成されるダイナミック スタイル シート リンク (<SharePoint:CssLink> など) は、このレポートに示されません。

ページの先頭へ

問題に関するレポートを表示する

Office SharePoint Designer 2007 の問題に関するレポートは、潜在的な問題を予測し、ユーザーに影響が及ぶ前に修正するのに役立つ場合があります。たとえば、このレポートを使用して遅いページを特定したり、切断されたハイパーリンクを見つけたり、他のファイルにリンクされていないために削除の対象になっているファイルを見つけることができます。問題レポートを実行するには、まず遅いページを定義する方法について設定します。

  1. レポートを実行する Web サイトを Office SharePoint Designer 2007 で開きます。

  2. [ツール] メニューの [アプリケーション オプション] をクリックします。

  3. [レポート ビュー] タブをクリックします。

    [レポート ビュー] タブを表示した [アプリケーション オプション] ダイアログ ボックス

  4. ["表示の遅いページ" ダウンロードに] ボックスに、遅いページのダウンロードに要する時間を表す秒数を入力します。

  5. [推定の基準となる接続速度] ボックスに、平均的なユーザーの接続速度を 1 秒あたりのキロビット数 (kbps) で入力します。

  6. [OK] をクリックします。

    これでレポートを実行できます。

  7. [サイト] メニューの [レポート] をポイントし、[問題] をポイントした後、実行するレポートをクリックします。

    • リンクのないファイル     サイト内のリンクのないすべてのファイルのリストを表示します。このレポートは、サイトから削除する未使用のファイルを見つけるのに役立つ場合があります。 このレポートは、Office SharePoint Server 2007 サイトの Web パーツの目次など、ASP.NET コントロールで生成されたリンクは考慮されないことに注意してください。

    • 表示の遅いページ      手順 3. で指定した定義に該当し、手順 4. で指定した平均接続速度を下回るために読み込みの遅いページとして特定された、サイト内のすべてのページのリストを表示します。 このレポートは、ページのマークアップの読み込みに必要な時間も含まれていることに注意してください。ASP.NET コントロールで生成されたダイナミック コンテンツは含まれていません。

    • ハイパーリンク     サイト内のすべてのハイパーリンクのリストを表示します。このレポートの実行後、サイト内のハイパーリンクを検証するかどうかをたずねるダイアログ ボックスが表示されます。Office SharePoint Designer 2007 を使用して各ハイバーリンクを巡回し検証する場合は、[はい] をクリックします。このプロセスは、それぞれ [OK] または [破損] と分類されたハイパーリンクのリストを返します。切断されたリンクを編集するには、レポートでリンクをクリックし、レポート ビューの文書ウィンドウの右上隅に表示されるツールバーの [ハイパーリンクの編集] をクリックします。

      注:  [ハイパーリンクの編集] ダイアログ ボックス

    • コンポーネント エラー     インタラクティブ ボタンやヒット カウンタ (以前は一般に webbot または bot) など、現在エラーを発生しているコンポーネントのリストを表示します。Web コンポーネントのリストは、[挿入] メニューの [Web コンポーネント] をクリックすると表示されます。

ページの先頭へ

利用状況の概要レポートを表示する

サイトの利用状況レポートは、サイト オーナーからの運用するサイトに関する非常に緊急を要する問い合わせ、たとえば、サイトの利用者数、最も利用率の高いリソース、サイトを最も多く利用するユーザー、およびサイト訪問者の発信元などに応える際に役立つ場合があります。利用状況の概要レポートには、合計訪問者数、ページ ヒット数、ダウンロードされたバイト数などが表示されます。

利用状況の概要レポート

次の手順に従って、利用状況の概要レポートを実行します。

  1. レポートを実行する Web サイトを Office SharePoint Designer 2007 で開きます。

  2. [サイト] メニューの [レポート] をポイントし、[利用状況] をポイントしてから、[利用状況の概要] をクリックします。

    レポートが生成されます。[名前] 列でハイバーリンク付きのアイテムをクリックすると、詳細なレポートが表示されます。

ページの先頭へ

詳細な利用状況レポートを表示する

ユーザーがサイトにどのようにアクセスしているかの問い合わせに応える場合、詳細な利用状況レポートを実行します。たとえば、以前のセクションで生成された利用状況の概要レポートには、ページのヒット件数が示されますが、ページ ヒット数 (月単位) レポートでは、サイト内の各ページのヒット件数が詳細に示されます。次に、詳細な利用状況レポートを実行する手順を示します。

  1. レポートを実行する Web サイトを Office SharePoint Designer 2007 で開きます。

  2. [サイト] メニューの [レポート] をポイントし、[利用状況] をポイントした後、実行するレポートをクリックします。

    • 概要 (月単位)     サイトの訪問者数、件数、総ヒット数、およびダウンロード サイズを月別に要約します。

    • 概要 (週単位)     サイトの訪問者数、件数、総ヒット数、およびダウンロード サイズを週別に要約します。

    • 概要 (日単位)     サイトの訪問者数、件数、総ヒット数、およびダウンロード サイズを日別に要約します。

    • ページ ヒット数 (月単位)     Web サイトの各ページの月別の総ヒット数と件数を要約します。

    • ページ ヒット数 (週単位)     Web サイトの各ページの週別の総ヒット数と件数を要約します。

    • ページ ヒット数 (日単位)     Web サイトの各ページの日別の総ヒット数と件数を要約します。

    • 利用者     選択した月の利用者数と全体に対する率を要約します。

    • OS     選択した月の利用者のオペレーティング システムの数と全体に対する率を要約します。

    • ブラウザ     選択した月の利用者のブラウザの数と全体に対する率を要約します。

    • 参照元ドメイン     選択した月の特定のドメインからの訪問者数と、全体に対する率を要約します。

    • 参照元 URL     選択した月の特定の URL からの訪問数と、全体に対する率を要約します。

    • 検索文字列     選択した月のサイトの検索ボックスに入力された検索文字列数と、全体に対する率を要約します。

ページの先頭へ

利用状況データの結果をグラフ化する

利用状況データを示すグラフは簡単に作成できます。このグラフによりトレンドを分析し利用状況パターンを特定するのが容易になります。

  1. [サイト] メニューの [レポート] をポイントし、[利用状況] をポイントした後、実行するレポートをクリックします。

  2. 文書ウィンドウの右上隅のツールバーに表示される [グラフ] リストで、[縦棒グラフ] など作成するグラフの種類をクリックします。

    [グラフ] リストを示すレポート ビューのツールバー

    新しいウィンドウでレポートが表示されます。

    利用状況データ グラフ

    注: 既定では、グラフ データは利用状況レポートと同時に生成されます。レポートの実行を試みたときにグラフが表示されない場合、[ツール] メニューの [アプリケーション オプション] をクリックし、[レポート ビュー] タブをクリックしてから、[利用状況レポートを保存するときに、グラフを追加する] チェック ボックスが選択されていることを確認します。

ページの先頭へ

レポートを並べ替える

レポート ビューでは、列の見出しをクリックするとレポートを並べ替えることができます。

ページの先頭へ

レポートをフィルタ処理する

レポート結果を絞り込み、必要な情報のみ表示することができます。特定の列のみフィルタ処理できますが、複数の列をフィルタ処理してよりプログレッシブ フィルタを作成することもできます。

  1. [サイト] メニューの [レポート] をポイントした後、実行するレポートをクリックします。

  2. フィルタ処理する列の見出しの横の矢印をクリックし、フィルタ処理の必要なデータをクリックします。

    たとえば、ファイルの種類でフィルタ処理する場合は、[種類] 列の見出しの横の矢印をクリックし、[bmp] をクリックしてレポートにビットマップ ファイルのみ表示します。

    フィルタ メニューを示す [種類] 列

  3. 複数の列にフィルタを適用する場合は、各列について手順 2. を繰り返します。

  4. 列でユーザー設定のフィルタを作成するには、列の見出しの矢印をクリックし、[(ユーザー設定)] をクリックします。検索基準を入力し、[OK] をクリックします。

    たとえば、ユーザー設定のオートフィルタを使用すると、サイトのすべての .bmp および .gif の画像ファイルを識別できます。

    [オートフィルタの設定] ダイアログ ボックス

  5. 列のフィルタをクリアするには、該当する列の見出しの横の矢印をクリックし、[(すべて)] をクリックします。

注: 現在適用されているフィルタ設定は、サイトを閉じたときに保存されます。新しく実行したレポートにファイルが見つからない場合、前のセッションで適用したフィルタによりそのファイルが非表示になっている可能性があります。

レポートからすべてのフィルタを削除するには、いずれかの列の見出しを右クリックし、ショートカット メニューの [フィルタの削除] をクリックします。

ページの先頭へ

レポートをコピーする

レポートを実行した後、結果をコピーし、電子メール メッセージまたは別の文書 (Microsoft Office Excel ワークシートなど) に貼り付けることができます。サイトの概要レポート以外のすべてのレポートをコピーできます。

  1. 実行したレポートの列の見出しを右クリックし、ショートカット メニューの [レポートのコピー] をクリックします。

    [レポートのコピー] コマンドが選択された [名前] 列メニュー

  2. データを文書またはメッセージに貼り付けます。

ページの先頭へ

レポートを保存する

Microsoft Office Excel 2007 を使用して結果を表示および分析する場合、または結果に基づいてカスタム チャートやグラフを作成する場合は、レポートを保存します。

  1. [サイト] メニューの [レポート] をポイントした後、実行するレポートをクリックします。

  2. [ファイル] メニューの [保存] をクリックします。または Ctrl + S を押します。

  3. [ファイル名] ボックスでレポート名を入力し、[保存] をクリックします。レポートはサイトに .htm ファイルとして保存されます。

    Excel で開いたレポート

  4. レポートを開くには、ダブルクリックします。

    レポートが Office Excel 2007 に表示されます。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×