レポートの概要

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

データベースを使用して、通常は表示にすると、書式設定、データを集計するレポートを使用します。たとえば、すべての連絡先の電話番号を表示するリスト タイプ レポートまたはサマリー レポートを指定した期間に、さまざまな地域間での会社の売り上げ高の合計を作成できます。

この記事では、Microsoft Access 2010 でのレポートの概要を説明し、レポートを追加または変更された機能を紹介します。この記事では、レポートを作成する方法、並べ替え、グループ化、およびデータを集計する方法と、レポートを印刷する方法も説明します。

データベースのテーブル構造とリレーションシップのデザインが適切であれば、有意義なレポートの作成は格段に容易になります。データベースの計画とデザインの概要については、「データベース設計の基本」を参照してください。

この記事の内容

概要

新機能

新しいレポートを作成する

グループ化、並べ替え、または集計を追加する

条件付き書式を使用して値を強調表示する

テーマを使用して洗練された外観にする

イメージを追加する

レポートをプレビューまたは印刷する

概要

レポートは、データの表示や集計に使用するデータベース オブジェクトです。レポートを印刷、PDF または XPS ファイルに変換、または他のファイル形式にエクスポートして、データのスナップショットを配布または保管できます。

印刷プレビューの従業員レポート

レポートには、多数のレコード、またはその両方の間での集計結果の個々 のレコードの詳細を提供できます。差し込み印刷またはその他の目的のラベルを作成するのには、Access レポートを使用することもできます。

「バインドされていない」のレポートを表示しない]、[データを作成することは、この記事の目的で、するものと、レポートなど、テーブルまたはクエリのデータ ソースにバインドされています。

Web レポートとクライアント レポート

Access 2010 には、Access Services を実行する SharePoint サーバーに Access データベースを発行して、"Web データベース" を作成できる新機能があります。Web データベースを作成すると、Access レポートは SQL Server Reporting Services を使用してブラウザーで表示されます。この変換では、ブラウザーに表示するレポートで使用できる機能にいくつかの制限が課されます。ただし、ブラウザーでのレポート表示が重要でない場合は、Access のレポート デザイナーが提供する機能をすべて使用できます。

レポートの要素

Access では、レポートのデザインは、複数のセクションに分かれています。クライアント データベースでは、レポートをデザイン ビューで表示して、レポートのセクションを確認できます。レイアウト ビューでも、やや見分けにくなるもののセクションは存在し、[書式] タブの [選択] グループのドロップダウン リストを使用して選択できます。有用なレポートを作成するには、各セクションの機能を理解している必要があります。たとえば、演算コントロールを配置するセクションによって、どのように結果が計算されるかが決まります。次の一覧は、セクションの種類とその用途を示しています。

  • レポート ヘッダー   レポートの先頭に 1 回だけ表示されます。レポート ヘッダーには、ロゴ、タイトル、日付など、通常表紙に表示する情報を含めます。Sum 集計関数を使用する演算コントロールをレポート ヘッダーに配置すると、レポート全体の合計が計算されます。レポート ヘッダーは、ページ ヘッダーの前に表示されます。

  • ページ ヘッダー   各ページの一番上に表示されます。たとえば、ページ ヘッダーを使用して、各ページにレポートのタイトルを繰り返し表示します。

  • グループ ヘッダー   レコードの各グループの先頭に表示されます。グループ名を表示するにはグループ ヘッダーを使用します。たとえば、商品別にグループ化されたレポートでは、グループ ヘッダーを使用して商品名を表示できます。Sum 集計関数を使用する演算コントロールをグループ ヘッダーに配置すると、現在のグループの合計が計算されます。追加したグループ化のレベル数に応じて、1 つのレポートに複数のグループ ヘッダー セクションを配置できます。グループ ヘッダーとフッターの作成方法の詳細については、グループ化、並べ替え、または集計を追加するを参照してください。

  • 詳細   レコード ソースの各行に 1 回だけ表示されます。詳細には、レポートの本体を構成するコントロールを配置します。

  • グループ フッター   レコードの各グループの最後に表示されます。グループの集計情報を表示するにはグループ フッターを使用します。追加したグループ化のレベル数に応じて、1 つのレポートに複数のグループ フッター セクションを配置できます。

  • ページ フッター   各ページの最後に表示されます。ページ フッターを使用してページ番号またはページ単位の情報を表示します。

  • レポート フッター   各レポートの最後に 1 回だけ表示されます。レポート フッターを使用してレポート全体の値の合計値や、その他の要約情報を表示します。

注: デザイン ビューでは、レポート フッターはページ フッターの下に表示されます。ただしそれ以外のビュー (たとえばレイアウト ビュー、あるいはレポートの印刷またはプレビュー時) では、レポート フッターはページ フッターの上、最後のページの最後のグループ フッターまたは詳細行の直後に出力されます。

ドキュメントの先頭へ

新機能

Access 2010 でレポートの作成は、Access 2007 でレポートを作成するとよく似てプロセスです。ただし、Access 2010 では、レポートに関連するいくつかの新機能があります。

  • 共有イメージ ギャラリー    Access 2010 では、イメージをデータベースに添付して、そのイメージを複数のオブジェクトで使用できるようになりました。1 つのイメージを更新するだけで、データベースのどこであっても使用されている場所でそのイメージが更新されます。

  • Office テーマ    Access 2010 では、標準の Microsoft Office テーマを使用して、本格的なデザインのフォントと色をすべての Access フォームとレポートに同時に適用できるようになりました。

  • 機能強化された条件付き書式    Access 2010 には、レポートのデータを強調表示するためのより強力なツールが用意されています。コントロールまたはコントロール グループごとに最大 50 種類の条件付き書式ルールを追加できるほか、クライアント レポートでは、データ バーを追加してレコード間でデータを比較できます。

  • より柔軟なレイアウト    Access 2010 でのレポートの既定のデザイン方法は、レイアウトにコントロールを配置することです。これらのグリッドは、コントロールの位置合わせとサイズ調整を容易にし、ブラウザーで表示するレポートでは必須となります。レイアウト自体は Access 2010 の新機能ではありませんが、レイアウトを使用してコントロールの移動、位置合わせ、サイズ変更を行う方法には、いくつか変更が施されています。詳細については、ビデオ「フォームおよびレポート レイアウトの概要」を参照してください。

ドキュメントの先頭へ

新しいレポートを作成する

手順 1: レコード ソースを選択する

レポートのレコード ソースには、テーブル、名前付きのクエリ、または埋め込みクエリを使用できます。レコード ソースには、レポートに表示するデータのすべての行と列が含まれている必要があります。

  • 目的のデータが既存のテーブルまたはクエリに含まれている場合は、ナビゲーション ウィンドウでそのテーブルまたはクエリを選択して、「手順 2: レポート ツールを選択する」に進んでください。

  • レコード ソースがまだ用意されていない場合は、次のいずれかの操作を行います。

テーブルまたはクエリの作成方法の詳細については、「テーブルの概要」または「クエリの概要」を参照してください。

レコード ソースの作成および選択方法の詳細については、「レポートのレコード ソースを設定する」を参照してください。

手順 2: レポート ツールを選択する

レポート ツールはリボンの [作成] タブの [レポート] グループにあります。次の表で、各ツールの機能を簡単に説明します。

Web 対応のレポート

これらのツールを使用して作成されたレポートは、[Access Services に発行] 機能と互換性があり、ブラウザーで表示されます。Web 対応オブジェクトは、オブジェクトのアイコンに地球のマークが付いています。

ボタンの画像

ツール

説明

ボタン イメージ

レポート

ナビゲーション ウィンドウで選択したレコード ソース内のすべてのフィールドを含む、単純な表形式レポートが作成されます。

ボタン イメージ

空白のレポート

レイアウト ビューで空白のフォームを開き、[フィールド リスト] ウィンドウを表示します。[フィールド リスト] からフィールドをレポートにドラッグすると、レコード ソース クエリが作成されます。

Access Services に発行機能の詳細については、「Web で共有する Access データベースを作成する」を参照してください。

クライアント レポート

これらのツールを使用して作成されたレポートは、[Access Services に発行] 機能と互換性がありません。クライアント レポートを Web データベースに追加しても、データベースが発行できなくなることはありませんが、クライアント レポートはブラウザーで表示できません。ただし、データベースを Access で開いているときは、クライアント レポートを使用できます。

ボタンの画像

ツール

説明

ボタン イメージ

レポート

ナビゲーション ウィンドウで選択したレコード ソース内のすべてのフィールドを含む、単純な表形式レポートが作成されます。

ボタン イメージ

レポート デザイン

必要なフィールドやコントロールだけを追加する、空白のレポートをデザイン ビューで開きます。

ボタン イメージ

空白のレポート

レイアウト ビューで空白のフォームを開き、[フィールド リスト] ウィンドウを表示します。フィールドを [フィールド リスト] からレポートにドラッグすると、埋め込みクエリが作成され、レポートの [レコード ソース] プロパティに保存されます。

ボタン イメージ

レポート ウィザード

フィールド、グループ化/や並べ替えのレベル、およびレイアウト オプションを指定できる複数ステップ ウィザードを表示します。ウィザードでの選択内容を基にしたレポートが作成されます。

ボタン イメージ

ラベル

標準またはユーザー設定のラベル サイズ、表示するフィールド、およびフィールドの並べ替え方法を選択できるウィザードを表示します。ウィザードでの選択内容を基にしたラベル レポートが作成されます。


手順 3: レポートを作成する

  1. 使用するツールのボタンをクリックします。ウィザードが表示されたら、ウィザードの手順に従い、最後のページで [完了] をクリックします。

    レポートがレイアウト ビューで表示されます。

  2. レポートの書式を設定して、目的の体裁に整えます。

    • フィールドやラベルを選択して、目的のサイズになるまで端をドラッグすると、サイズを変更します。

    • フィールド (とラベルがある場合はラベル) を選択し、新しい場所にドラッグして、フィールドを移動します。

    • フィールドを右クリックし、ショートカット メニューのコマンドを使用してセルの分割や結合、フィールドの削除や選択、およびその他の書式設定を行います。

      また、次のセクションで説明する機能を使用して、レポートをさらに魅力的に読みやすく整えることもできます。

ドキュメントの先頭へ

グループ化、並べ替え、または集計を追加する

グループ化、並べ替え、または集計をレポートに追加する最も手早い方法は、グループ、並べ替え、または合計を適用するフィールドを右クリックし、ショートカット メニューの目的のコマンドをクリックすることです。

また、レポートをレイアウト ビューまたはデザイン ビューで開いている場合は、[グループ化、並べ替え、集計] ウィンドウを使用してグループ化、並べ替え、または合計を追加することもできます。

  1. [グループ化、並べ替え、集計] ウィンドウがまだ開いていない場合は、[デザイン] タブの [グループ化と集計] で [グループ化と並べ替え] をクリックします。

  2. [グループの追加] または [並べ替えの追加] をクリックし、グループ化または並べ替えを行うフィールドを選択します。

  3. その他のオプションを設定するか集計を追加するには、"グループ化" または "並べ替え" の行で、[その他] をクリックします。

グループ化、並べ替え、集計の詳細については、「グループ化レポートまたはサマリー レポートを作成する」を参照してください。

ドキュメントの先頭へ

条件付き書式を使用して値を強調表示する

Access 2010 には、レポートのデータを強調表示するためのより強力なツールが用意されています。コントロールまたはコントロール グループごとに最大 50 種類の条件付き書式ルールを追加できるほか、クライアント レポートでは、データ バーを追加してレコード間でデータを比較できます。

条件付き書式を追加するには :

  1. ナビゲーション ウィンドウでレポートを右クリックし、[レイアウト ビュー] をクリックして、レポートをレイアウト ビューで開きます。

  2. 条件付き書式を適用するコントロールをすべて選択します。複数のコントロールを選択するには、Shift キーまたは Ctrl キーを押しながら選択するコントロールをクリックします。

  3. [書式] タブの [コントロールの書式設定] で、[条件付き書式] をクリックします。

    [条件付き書式ルールの管理] ダイアログ ボックスが表示されます。

  4. [条件付き書式ルールの管理] ダイアログ ボックスで [新規ルール] をクリックします。

  5. [新しい書式ルール] ダイアログ ボックスで、[ルールの種類を選んでください] の値を選びます。

    • 各レコードを個別に評価するルールを作成するには、[現在のレコードの値を確認するか、式を使用する] をクリックします。

    • データ バーを使用してレコードどうしを比較するルールを作成するには、[その他のレコードと比較する] をクリックします。

注:  [その他のレコードと比較する] オプションは、Web データベースでは利用できません。


  1. [ルールの内容を編集してください] で、書式を適用する状態を決定するルールと、ルールの条件に一致したときに適用する書式を指定します。

  2. [OK] をクリックして [条件付き書式ルールの管理] ダイアログ ボックスに戻ります。

  3. このコントロールまたはコントロール セットに追加のルールを作成するには、手順 4 以降を再度実行します。追加しない場合は、[OK] をクリックしてダイアログ ボックスを閉じます。

レポートに条件付き書式を追加する方法の詳細については、ビデオ「レポートで条件付き書式を使用する」を参照してください。

ドキュメントの先頭へ

テーマを使用して洗練された外観にする

Access データベースに Office 2010 のテーマを適用して、すべての Office ドキュメントで一貫したスタイルを維持できるようになりました。

重要: Office テーマ、フォント、または色を選択すると、(作業中のフォームまたはレポートだけでなく) データベースに含まれるすべてのフォームとレポートに選択したテーマ、フォント、または色が適用されます。

  1. ナビゲーション ウィンドウでレポートを右クリックし、レイアウト ビューをクリックして、レイアウト ビューでレポートを開きます。

  2. [デザイン] タブの [テーマ] グループで、目的のテーマ、色、またはフォントを選びます。

    リボンの画像

    • 色とフォントを同時に設定してあらかじめデザインされた配色にするには、テーマ ギャラリーを使用します。

    • 色とフォントを個別に設定するには、[配色] ギャラリーや [フォント] ギャラリーを使用します。


Office テーマの使用方法の詳細については、ビデオ「Office テーマを使用して Access フォームおよびレポートの外観を向上させる」を参照してください。

ドキュメントの先頭へ

イメージを追加する

従来 Access では、イメージはフォームやレポートの個々のイメージ コントロールにバインドされていました。複数のフォームやレポートで共通で使用されているイメージを変更するには、各イメージ コントロールを手動で編集する必要がありました。しかし、Access 2010 では、イメージをデータベースに一度添付するだけで、そのイメージを複数のオブジェクトで使用できるようになりました。1 つのイメージを更新するだけで、データベース内のすべての使用箇所でそのイメージが更新されます。これは、会社のロゴや背景画像など、データベース全体で使用されるイメージに非常に便利です。

イメージを追加する

  1. ナビゲーション ウィンドウで、イメージを追加するレポートを右クリックし、[レイアウト ビュー] をクリックします。

  2. レポート上でイメージを追加する位置をクリックします。

  3. [デザイン] タブの [コントロール] で、[イメージの挿入] をクリックします。

  4. 次のいずれかの操作を行います。

    • 既存のイメージを使用する目的のイメージが既にギャラリーにある場合は、そのイメージをクリックしてレポートに追加します。

    • 新しいイメージをアップロードする   ギャラリーの下部にある [参照] をクリックします。[図の挿入] ダイアログ ボックスで、使用するイメージを参照し、[開く] をクリックします。

      選んだイメージが Access によってレポートに追加されます。

背景イメージを追加する

注:  背景イメージは Web 対応のレポートには追加できません。

  1. ナビゲーション ウィンドウで、背景イメージを追加するレポートを右クリックし、[レイアウト ビュー] をクリックします。

  2. [書式] タブの [背景] グループで、[背景のイメージ] をクリックします。

  3. 次のいずれかの操作を行います。

    • 既存のイメージを使用する目的のイメージが既にギャラリーにある場合は、そのイメージをクリックしてレポートに追加します。

    • 新しいイメージをアップロードする   ギャラリーの下部にある [参照] をクリックします。[図の挿入] ダイアログ ボックスで、使用するイメージを参照し、[開く] をクリックします。

      選んだイメージが Access によってレポートに追加されます。

ドキュメントの先頭へ

レポートをプレビューまたは印刷する

レポートをプレビューする

  1. プレビューするレポートを開くか、そのレポートをナビゲーション ウィンドウで選択します。

  2. [ファイル] タブの [印刷] をクリックし、[印刷プレビュー] をクリックします。

    レポートが印刷プレビューで表示されます。[印刷プレビュー] タブのコマンドを使用して、次のいずれかの操作を実行できます。

    • レポートを印刷する

    • ページのサイズまたはレイアウトを調整する

    • 表示を拡大または縮小する、または複数のページを同時に表示する

    • レポートのデータを最新の情報に更新する

    • レポートを別のファイル形式にエクスポートする

  3. データベース作業領域に戻るには、[印刷プレビュー] タブの [プレビューを閉じる] で [印刷プレビューを閉じる] をクリックします。

レポートを印刷する

印刷プレビューから印刷するだけでなく、プレビューせずにレポートを印刷することもできます。

  1. プレビューするレポートを開くか、そのレポートをナビゲーション ウィンドウで選択します。

  2. [ファイル] タブの [印刷] をクリックします。

    • プリンター オプションを設定せずに、レポートを通常使うプリンターに直接送信するには、[クイック印刷] をクリックします。

    • プリンターの選択、印刷部数の指定などが可能なダイアログ ボックスを開くには、[印刷] をクリックします。

ドキュメントの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×