レプリケートされたデータベースを Access 2007 形式で保存できない

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

現象

以前のバージョンの Access で作成されたデータベースを複製Microsoft Office Access 2007] で (します。新しい MDB 形式) は保存できません。ACCDB ファイル形式です。オプションが淡色データベースに名前を付けて保存] コマンドを使用しようとしたときに (使用不可) ( Microsoft Office ボタン Office ボタンの画像 ] をクリックし、名前を付けて保存の横にある矢印をクリックして)。

原因

.ACCDB ファイル形式では、レプリケーションはサポートされていません。

解決法

レプリケートされた .MDB ファイル形式のデータベースを使用する

レプリケートされたデータベースは .MDB ファイル形式のままで使用できます。.MDB ファイル形式ではレプリケーション機能が引き続きサポートされています。

Office Access 2007 ファイル形式でデータベースを手動で再作成する

レプリケーションで得られるメリットよりも、新しいファイル形式で得られるメリットの方が大きいと判断した場合は、新しいデータベースを Office Access 2007 形式で作成し、レプリケートされたデータベースを手動で再作成する方法もあります。

注: この方法は、レプリケートされたデータベースならどれでも使用できますが、レプリカ セットの他のすべてのレプリカと同期されたフル レプリカでない場合は、レプリカにまだ取り込まれていないデータおよびプロジェクトは、新しいデータベースには含まれません。

データベースの再作成を開始する前に、レプリカのすべての隠しオブジェクトおよびシステム オブジェクトが表示されていることを確認してください。これらのオブジェクトが表示されていると、データベースを再作成するときに、レプリカ固有のフィールドにアクセスできます。

  1. 変換するレプリカを開きます。隠しフィールドとシステム フィールドを表示するには、そのレプリカを作成したときと同じバージョンの Access を使用して開く必要があります。

  2. [ツール] メニューの [オプション] をクリックします。[オプション] ダイアログ ボックスが開きます。

  3. [表示] タブの [表示] セクションで、[Hidden objects] と [System objects] をクリックします。[OK] をクリックし、新しい設定を適用して [オプション] ダイアログ ボックスを閉じます。

データベースを手動で再作成する

  1. 空白のデータベースを作成し、開きます。

    注: Table1 という名前の新しい空のテーブルが作成されます。再作成を始める前にこのテーブルを削除する必要があるため、何も変更せずにすぐにテーブルを閉じます。そのテーブルのオブジェクト タブを右クリックし、ショートカット メニューの [閉じる] をクリックすると、テーブルを削除できます。

  2. 外部データ] タブの [インポート] で、[アクセス] をクリックします。

    [外部データの取り込み - Access データベース] ダイアログ ボックスが表示されます。

  3. [参照] をクリックして、レプリケートされたデータベースを見つけます。

  4. 新しいデータベースで再作成するデータベース オブジェクトが格納された、レプリケートされたデータベースをクリックし、[開く] をクリックします。

  5. [外部データの取り込み - Access データベース] ダイアログ ボックスで、[現在のデータベースにテーブル、クエリ、フォーム、レポート、マクロ、モジュールをインポートする] をクリックし、[OK] をクリックします。

  6. 新しいデータベースにインポートするデータベース オブジェクトをクリックします。すべてのオブジェクトをインポートするには、各タブの [すべて選択] をクリックします。

    重要     この段階ではテーブルは選択しないでください。テーブルは後の手順で再作成します。

  7. オブジェクトの選択を完了したら、[OK] をクリックしてインポートします。

    ウィザードの最後のページでは、このインポート手順を再び使用する場合のために、手順を保存することができます。手順を保存するには、[インポート手順の保存] チェック ボックスをオンにして適切な情報を入力し、[インポートの保存] をクリックします。

  8. レプリケートされたデータベースを Office Access 2007 で開きます。レプリケートされたデータベースの各テーブルについて、テーブル作成クエリを作成します。各クエリは、古いテーブルのすべてのデータを取得し、新しいデータベースのテーブルを同じデータで作成するものとします。

    注: s_GUID が主キーで、他のテーブルの外部キーから参照されている場合、新しいテーブルに s_GUID フィールドを含める必要があります。s_GUID フィールドを主キーとして使用していない場合は、新しいテーブルに残しておく必要はありません。s_Lineage フィールドと s_Generation フィールドは新しいテーブルにコピーしないようにします。

    既定では、s_GUID、s_Lineage、s_Generation の各フィールドは表示されません。これらのフィールドを表示するには、以下の手順を実行します。

    1. レプリケートされたデーベースで、すべてのテーブルが閉じていることを確認します。

    2. ナビゲーション ウィンドウの最上部を右クリックし、[ナビゲーション オプション] をクリックします。[ナビゲーション オプション] ダイアログ ボックスが開きます。

    3. [表示オプション] セクションで、[システム オブジェクトの表示] チェック ボックスをオンにして、[OK] をクリックします。

      方法

      1. 新しいテーブルに入力するレコードが保存されているテーブルを選択して、クエリを作成します。

        方法

        1. [作成] タブの [その他] で、[クエリ デザイン] をクリックします。

        2. [テーブルの表示] ダイアログ ボックスで、目的のデータが含まれるテーブルの一覧を示すタブをクリックします。

        3. クエリに追加するオブジェクトごとに名前をダブルクリックして、[閉じる] をクリックします。

        4. design gridの [フィールド] 行にフィールドを追加します。

        5. クエリの結果を表示するには、[ビュー] メニューをクリックし、[データシート ビュー] をクリックします。

      2. クエリのDesign viewにおいて、[デザイン] タブの [クエリの種類] で [テーブルの作成] をクリックします。[テーブルの作成] ダイアログ ボックスが表示されます。

      3. [テーブル名] ボックスに、作成または置き換えるテーブル名を入力します。

      4. [他のデータベース] をクリックし、新しいテーブルを作成するデータベースのパスを入力するか、[参照] をクリックしてデータベースを検索します。

      5. [OK] をクリックします。

      6. [デザイン] タブの [結果] で、[実行] をクリックします。これにより、新しいテーブル。

        注: 新しく作成するテーブルでは、元のテーブルのフィールドのプロパティやprimary key設定は引き継がれません。

  9. 新規のデータベースのテーブルごとに、レプリカのテーブルと同じindexおよび主キーを作成します。

    方法

    1. デザイン ビューでテーブルを開きます。

    2. ウィンドウの上部で、indexを作成するフィールドをクリックします。

    3. ウィンドウの下部で、"Indexed/インデックス" プロパティ ボックスをクリックし、[Yes (Duplicates OK)/はい (重複あり)] または [Yes (No Duplicates)/はい (重複なし)] をクリックします。

    4. 主キーを構成するフィールドを選択します。

    5. [デザイン] タブの [ツール] で、[主キー] をクリックします。

  10. 新規のデータベースのテーブルごとに、レプリカのテーブルと同じリレーションシップを作成します。

    方法

    テーブル間のリレーションシップを作成するときに、同じ名前が関連フィールドがありません。ただし、関連するフィールドは、主キー フィールドがオート ナンバー型フィールドではない場合、同じdata typeが必要です。一致するフィールドの両方の"フィールド サイズ"プロパティは、同じ場合にのみ、数値型フィールドでは、オート ナンバー型フィールドを対応付けることができます。たとえば、両方のフィールドの"フィールド サイズ"プロパティが長整数型である場合は、オート ナンバー型フィールドと数値フィールドを一致ことができます。数値フィールドでは両方のフィールドの一致する場合でも、同じ"フィールド サイズ"プロパティの設定が必要です。

    一対多の定義または一対一リレーションシップ

    1. 開いているテーブルをすべて閉じます。開いているテーブルのリレーションシップの作成や修正はできません。

    2. [データベース ツール] タブの [表示/非表示] で [リレーションシップ] をクリックします。

    3. 初めてリレーションシップの設定をする場合は、[テーブルの表示] ダイアログ ボックスが自動的に表示されます。

      関連付けるテーブルを追加する必要がある場合に、[テーブルの表示] ダイアログ ボックスが表示されていないときは、このダイアログ ボックスを表示します。それには、[デザイン] タブの [表示/非表示] で、[テーブルの表示] をクリックします。

    4. リレーションシップに追加するテーブル名をダブルクリックし、[閉じる] をクリックして [テーブルの表示] ダイアログ ボックスを閉じます。

    5. 一方のテーブルの関連付けるフィールドを、もう一方のテーブルの関連付けられるフィールドにドラッグします。

      複数のフィールドをドラッグするには、Ctrl キーを押しながら各フィールドをクリックし、ドラッグします。

      ほとんどの場合、あるテーブルの主キー フィールド (太字で表示) から、別のテーブルのforeign keyと呼ばれる同様のフィールドにドラッグします。

    6. 表示される [リレーションシップ] ダイアログ ボックスの 2 つの列に表示されているフィールド名が正しいかどうかを確認します。必要に応じて、フィールド名を変更します。

      必要に応じて、リレーションシップのオプションを設定します。

    7. [作成] をクリックしてリレーションシップを作成します。

    8. 関連付けるすべてのテーブルに対して、手順 4 ~ 7 を繰り返します。

      Relationships windowを閉じるときに、レイアウトを保存するかどうかを確認するメッセージが表示されます。レイアウトの変更を保存しなくても、作成されたリレーションシップはデータベースに保存されます。

    多対多リレーションシップを定義します。

    1. many-to-many relationshipを設定する 2 つのテーブルを作成します。

    2. 次に、リレーションシップを成立させるための中間となる (3 番目の) テーブルを作成し、多対多リレーションシップを設定する 2 つのテーブルの主キー フィールドと同じ定義を持つ新しいフィールドを追加します。3 番目のテーブルでは、主キー フィールドは外部キーの役割を果たします。ほかのテーブルと同様に、このテーブルにもフィールドを追加できます。

    3. 3 番目のテーブルで、リレーションシップを作成する 2 つのテーブルのすべての主キー フィールドを含むように、主キーを設定します。たとえば、[受注明細] テーブル (3 番目のテーブル) の場合、主キーは [受注コード] フィールドと [商品コード] フィールドで構成されます。

      方法

      1. デザイン ビューでテーブルを開きます。

      2. 主キーとして設定するフィールドを選択します。

        1 つのフィールドを選択するには、目的のフィールドのrow selectorをクリックします。

        複数のフィールドを選択するには、Ctrl キーを押しながら各フィールドの行セレクタをクリックします。

      3. [デザイン] タブの [ツール] で、[主キー] をクリックします。

        注: 複数の主キー フィールドの順序を、テーブルでのフィールドの並びと異なる順序にするには、[表示/非表示] で [インデックス] をクリックし、Indexes windowを表示します。次に、PrimaryKey という名前のindexのフィールド名を並べ替えます。

    4. 2 つの主テーブルの各と結合テーブル間のone-to-many relationshipを定義します。

  11. 新規のデータベースを保存します。

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×