リンクする、または office for Mac のデータを埋め込む

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Office アプリケーション間で情報を共有する方法はいくつかあります。 その一つは情報をコピーして貼り付けることですが、その他に、情報をリンクする方法や情報を埋め込む方法もあります。情報をリンクした場合、情報は自動更新されます。情報を埋め込んだ場合、ファイルを開いて手動で更新したときにのみ情報が更新されます。 リンク オブジェクトを使用して、ファイルの一部 (Excel シート内の一部のセル範囲など) にリンクすることもできます。

利点と欠点: リンクと 埋め込み

リンクの設定

埋め込み

情報が自動的に更新されます。

埋め込まれた情報を作成したアプリケーションを簡単に開くことができます。

ファイル サイズを小さく維持できます。

情報がリンクされたファイルよりもファイル サイズが大きくなります。

情報を表示するには、両方のファイルにアクセスできる必要があります。

情報を更新するには、両方のファイルにアクセスできる必要がありますが、情報を表示するだけならその必要はありません。

ファイルをオンラインで配布する場合には適していません。

すべての情報が 1 つのファイルに格納されるので、ファイルをオンラインで配布する場合に適しています。

Word

あるデータを Excel ファイル内に保持しており、かつ、その関連情報を Word ファイル内に保持している場合、両方の情報をリンクすると更新作業が簡単になります。 例として、最新の返品高を月次報告書にリンクしたいというケースを考えてみます。 月次報告書は Word 文書、返品高は Excel シートであるとします。 この Word 文書と Excel シートをリンクしておくと、返品高が更新されたときに月次報告書が自動更新されます。 もう一つの例として、Word 文書内の指示文を複数の Excel ファイルに挿入するというケースを考えてみます。 この場合も、リンクを使用すれば、指示文を更新したときに、その更新内容がすべての Excel ファイルに反映されます。

  1. リンクを挿入する位置をクリックします。

  2. [挿入] メニューの [オブジェクト] をクリックし、[ファイルから] をクリックします。

  3. ファイル、リンクをクリックし、[オプション] をクリックします。

  4. ファイルへのリンク] チェック ボックスを選択します。

    ヒント: アイコンだけを表示するには、[アイコンで表示] チェック ボックスをオンにします。表示されたアイコンをクリックすると、情報が表示されます。

  5. Word を使用している場合は [挿入] をクリックするか、Excel を使用している場合は、 [ok]をクリックします。

  1. [編集] メニューの [リンクの設定] をクリックします。

    [リンクの設定] コマンドが選択不可の状態である場合は、リンクされている情報がファイル内にありません。

  2. [リンク] ボックスの一覧で、リンクされているファイルをクリックし、[リンクを開く] をクリックします。

  3. 必要な変更を行います。

  4. [ファイル] メニューの [保存] をクリックして変更内容を保存し、そのアプリケーションを終了します。

    リンク元ファイルに変更内容が反映されます。

2 つのファイルを接続したままにしておきたいが、一方のファイルを更新したときにもう一方のファイルを更新したくない場合、"情報を埋め込む" という方法を使用できます。 たとえば、Excel シートが更新されたときに月次報告書を自動更新したくない場合や、指示文が更新されたときに Excel シートを自動更新したくない場合、"情報を埋め込む" という方法を使用できます。 情報を埋め込んだ場合、情報全体が 1 つのファイルに格納されるので、埋め込まれた情報にアクセスできない人にファイルのオンライン バージョンを配布する場合に便利です。

  1. ファイルを埋め込む位置をクリックします。

  2. [挿入] メニューの [オブジェクト] をクリックし、[ファイルから] をクリックします。

  3. 目的のファイルを選択し、[オプション] をクリックします。

    Excel シートを埋め込む場合、そのシートはブック内の先頭シートでなければなりません。

  4. ファイルへのリンク] チェック ボックスをオフにします。

    ヒント: アイコンだけを表示するには、[アイコンで表示] チェック ボックスをオンにします。表示されたアイコンをクリックすると、情報が表示されます。

  5. Word を使用している場合は [挿入] をクリックするか、Excel を使用している場合は、 [ok]をクリックします。

  1. 埋め込みオブジェクトをダブルクリックします。

  2. 必要な変更を行ってから保存します。

  3. [ファイル] メニューの [終了して <ファイル名> に戻る] をクリックします。

    埋め込まれているファイルに変更内容が反映されます。

ファイルの一部にリンクすることができます。たとえば、ステータス レポート、シート全体ではなく Excel シートから特定のセル範囲へのリンクすることがあります。たとえば、具体的な指示を文書全体ではなく、Word 文書にリンクすることがあります。

  1. 貼り付ける情報を選びます (例: Excel シート内の一部のセル範囲)。

  2. [編集] メニューの [コピー] をクリックします。

  3. 貼り付け先のファイルに切り替え、情報を表示する位置をクリックします。

  4. [編集] メニューの [形式を選択してペースト] をクリックし、[ペースト リンク] をクリックします。

  5. [ペーストする形式] ボックスの一覧でオブジェクトの種類 (例: [Microsoft Excel ワークシート オブジェクト]) をクリックし、[OK] をクリックします。

PowerPoint

2 つのファイルを接続したままにしておきたいが、一方のファイルを更新したときにもう一方のファイルを更新したくない場合、"情報を埋め込む" という方法を使用できます。 例として、最新の返品高を月次報告書に埋め込むというケースを考えてみます。 月次報告書は PowerPoint プレゼンテーション、返品高情報は Excel シートであるとします。 プレゼンテーションにシートを埋め込むと、この 2 つのファイルは接続されたままになります。

  1. ファイルを埋め込む位置をクリックします。

  2. [挿入] メニューの [オブジェクト] をクリックし、[ファイルから] をクリックします。

  3. 埋め込むファイルを探してクリックします。

    Excel シートを埋め込む場合、そのシートはブック内の先頭シートでなければなりません。

  4. [挿入] をクリックし、[OK] をクリックします。

    埋め込みファイル内の情報が見えない場合は、情報が見えるまでサイズ変更ハンドルをドラッグします。

  1. 埋め込まれたファイルをダブルクリックします。

  2. 必要な変更を行います。

  3. [ファイル] をクリックし、[更新] をクリックします。

  4. [ファイル] メニューの [終了して <ファイル名> に戻る] をクリックします。

    埋め込まれているファイルに変更内容が反映されます。

ファイル全体ではなくファイル内の一部を埋め込むこともできます。 たとえば月次報告書において、Excel シート全体ではなく Excel シート内の特定のセル範囲を埋め込むこともできます。

  1. 貼り付ける情報を選びます (例: Excel シート内の一部のセル範囲)。

  2. [編集] メニューの [コピー] をクリックします。

  3. 貼り付け先のファイルに切り替え、情報を表示する位置をクリックします。

  4. [編集] メニューの [形式を選択してペースト] をクリックします。

  5. [ペーストする形式] ボックスの一覧でオブジェクトの種類 (例: [Microsoft Excel ワークシート オブジェクト]) をクリックし、[OK] をクリックします。

Excel

あるデータを Excel ファイル内に保持しており、かつ、その関連情報を Word ファイル内に保持している場合、両方の情報をリンクすると更新作業が簡単になります。 例として、最新の返品高を月次報告書にリンクしたいというケースを考えてみます。 月次報告書は Word 文書、返品高は Excel シートであるとします。 この Word 文書と Excel シートをリンクしておくと、返品高が更新されたときに月次報告書が自動更新されます。 もう一つの例として、Word 文書内の指示文を複数の Excel ファイルに挿入するというケースを考えてみます。 この場合も、リンクを使用すれば、指示文を更新したときに、その更新内容がすべての Excel ファイルに反映されます。

  1. リンクを挿入する位置をクリックします。

  2. [挿入] メニューの [オブジェクト] をクリックし、[ファイルから] をクリックします。

  3. ファイル、リンク先を選択し、[オプション] をクリックします。

  4. ファイルへのリンク] チェック ボックスを選択します。

    ヒント: アイコンだけを表示するには、[アイコンで表示] チェック ボックスをオンにします。表示されたアイコンをクリックすると、情報が表示されます。

  5. Word を使用している場合は [挿入] をクリックするか、Excel を使用している場合は、 [ok]をクリックします。

  1. [データ] メニューで、 [リンクの編集] をクリックします。

    [リンクの編集] コマンドを使用できない場合は、[リンクされた情報を含まないファイル。

  2. [リンク] ボックスの一覧で、リンクされているファイルをクリックし、[リンクを開く] をクリックします。

  3. 必要な変更を行います。

  4. [ファイル] メニューの [保存] をクリックして変更内容を保存し、そのアプリケーションを終了します。

  5. リンクされたファイルをクリックします。変更内容がファイルに含まれていることを確認します。

2 つのファイルを接続したままにしておきたいが、一方のファイルを更新したときにもう一方のファイルを更新したくない場合、"情報を埋め込む" という方法を使用できます。 たとえば、Excel シートが更新されたときに月次報告書を自動更新したくない場合や、指示文が更新されたときに Excel シートを自動更新したくない場合、"情報を埋め込む" という方法を使用できます。 情報を埋め込んだ場合、情報全体が 1 つのファイルに格納されるので、埋め込まれた情報にアクセスできない人にファイルのオンライン バージョンを配布する場合に便利です。

  1. ファイルを埋め込む位置をクリックします。

  2. [挿入] メニューの [オブジェクト] をクリックし、[ファイルから] をクリックします。

  3. ファイルを埋め込む] を選択し、[オプション] をクリックします。

    Excel シートを埋め込む場合、そのシートはブック内の先頭シートでなければなりません。

    ヒント: アイコンだけを表示するには、[アイコンで表示] チェック ボックスをオンにします。表示されたアイコンをクリックすると、情報が表示されます。

  4. [ファイルにリンク] チェック ボックスをオフにします。次に、Word を使用している場合は [挿入]、Excel を使用している場合は [OK] をクリックします。

  1. 埋め込まれたファイルをダブルクリックします。

  2. 必要な変更を行います。

  3. [ファイル] メニューの [更新] をクリックします。

    埋め込まれているファイルに変更内容が反映されます。

ファイル全体ではなくファイル内の一部にリンクすることもできます。 たとえば、Excel シート全体ではなく Excel シート内の特定のセル範囲にリンクすることもできます。

  1. 貼り付ける情報を選びます (例: Word 文書内の一部の文)。

  2. [編集] メニューの [コピー] をクリックします。

  3. 貼り付け先のファイルに切り替え、情報を表示する位置をクリックします。

  4. [編集] メニューの [形式を選択してペースト] をクリックし、[ペースト リンク] をクリックします

  5. [ペーストする形式] ボックスの一覧でオブジェクトの種類 (例: [Microsoft Word 文書オブジェクト]) をクリックし、[OK] をクリックします。

Word

あるデータを Excel ファイル内に保持しており、かつ、その関連情報を Word ファイル内に保持している場合、両方の情報をリンクすると更新作業が簡単になります。 例として、最新の返品高を月次報告書にリンクしたいというケースを考えてみます。 月次報告書は Word 文書、返品高は Excel シートであるとします。 この Word 文書と Excel シートをリンクしておくと、返品高が更新されたときに月次報告書が自動更新されます。 もう一つの例として、Word 文書内の指示文を複数の Excel ファイルに挿入するというケースを考えてみます。 この場合も、リンクを使用すれば、指示文を更新したときに、その更新内容がすべての Excel ファイルに反映されます。

  1. リンクを挿入する位置をクリックします。

  2. [挿入] メニューの [オブジェクト] をクリックし、[ファイルから] をクリックします。

  3. リンクするファイルを探してクリックします。

    ヒント: アイコンだけを表示するには、[アイコンで表示] チェック ボックスをオンにします。表示されたアイコンをクリックすると、情報が表示されます。

  4. [ファイルにリンク] チェック ボックスをオンにします。次に、Word を使用している場合は [挿入]、Excel を使用している場合は [OK] をクリックします。

  1. [編集] メニューの [リンクの設定] をクリックします。

    [リンクの設定] コマンドが選択不可の状態である場合は、リンクされている情報がファイル内にありません。

  2. [リンク] ボックスの一覧で、リンクされているファイルをクリックし、[リンクを開く] をクリックします。

  3. 必要な変更を行います。

  4. [ファイル] メニューの [保存] をクリックして変更内容を保存し、そのアプリケーションを終了します。

    リンク元ファイルに変更内容が反映されます。

2 つのファイルを接続したままにしておきたいが、一方のファイルを更新したときにもう一方のファイルを更新したくない場合、"情報を埋め込む" という方法を使用できます。 たとえば、Excel シートが更新されたときに月次報告書を自動更新したくない場合や、指示文が更新されたときに Excel シートを自動更新したくない場合、"情報を埋め込む" という方法を使用できます。 情報を埋め込んだ場合、情報全体が 1 つのファイルに格納されるので、埋め込まれた情報にアクセスできない人にファイルのオンライン バージョンを配布する場合に便利です。

  1. ファイルを埋め込む位置をクリックします。

  2. [挿入] メニューの [オブジェクト] をクリックし、[ファイルから] をクリックします。

  3. 埋め込むファイルを探してクリックします。

    Excel シートを埋め込む場合、そのシートはブック内の先頭シートでなければなりません。

    ヒント: アイコンだけを表示するには、[アイコンで表示] チェック ボックスをオンにします。表示されたアイコンをクリックすると、情報が表示されます。

  4. [ファイルにリンク] チェック ボックスをオフにします。次に、Word を使用している場合は [挿入]、Excel を使用している場合は [OK] をクリックします。

  1. 埋め込まれたファイルをクリックします。

  2. [編集] メニューの [<オブジェクトの種類> オブジェクト] (例: [ワークシート オブジェクト]) をポイントし、[編集] をクリックします。

  3. 必要な変更を行います。

  4. [ファイル] メニューの [終了して <ファイル名> に戻る] をクリックします。

    埋め込まれているファイルに変更内容が反映されます。

ファイルの一部にリンクすることができます。たとえば、ステータス レポート、シート全体ではなく Excel シートから特定のセル範囲へのリンクすることがあります。たとえば、具体的な指示を文書全体ではなく、Word 文書にリンクすることがあります。

  1. 貼り付ける情報を選びます (例: Excel シート内の一部のセル範囲)。

  2. [編集] メニューの [コピー] をクリックします。

  3. 貼り付け先のファイルに切り替え、情報を表示する位置をクリックします。

  4. [編集] メニューの [形式を選択してペースト] をクリックし、[ペースト リンク] をクリックします。

  5. [ペーストする形式] ボックスの一覧でオブジェクトの種類 (例: [Microsoft Excel ワークシート オブジェクト]) をクリックし、[OK] をクリックします。

PowerPoint

2 つのファイルを接続したままにしておきたいが、一方のファイルを更新したときにもう一方のファイルを更新したくない場合、"情報を埋め込む" という方法を使用できます。 例として、最新の返品高を月次報告書に埋め込むというケースを考えてみます。 月次報告書は PowerPoint プレゼンテーション、返品高情報は Excel シートであるとします。 プレゼンテーションにシートを埋め込むと、この 2 つのファイルは接続されたままになります。

  1. ファイルを埋め込む位置をクリックします。

  2. [挿入] メニューの [オブジェクト] をクリックし、[ファイルから] をクリックします。

  3. 埋め込むファイルを探してクリックします。

    Excel シートを埋め込む場合、そのシートはブック内の先頭シートでなければなりません。

  4. [挿入] をクリックし、[OK] をクリックします。

    埋め込みファイル内の情報が見えない場合は、情報が見えるまでサイズ変更ハンドルをドラッグします。

  1. 埋め込まれたファイルをクリックします。

  2. [編集] メニューの [<オブジェクトの種類> オブジェクト] (例: [ワークシート オブジェクト]) をポイントし、[編集] をクリックします。

  3. 必要な変更を行います。

  4. [ファイル] メニューの [終了して <ファイル名> に戻る] をクリックします。

    埋め込まれているファイルに変更内容が反映されます。

ファイル全体ではなくファイル内の一部を埋め込むこともできます。 たとえば月次報告書において、Excel シート全体ではなく Excel シート内の特定のセル範囲を埋め込むこともできます。

  1. 貼り付ける情報を選びます (例: Excel シート内の一部のセル範囲)。

  2. [編集] メニューの [コピー] をクリックします。

  3. 貼り付け先のファイルに切り替え、情報を表示する位置をクリックします。

  4. [編集] メニューの [形式を選択してペースト] をクリックします。

  5. [ペーストする形式] ボックスの一覧でオブジェクトの種類 (例: [Microsoft Excel ワークシート オブジェクト]) をクリックし、[OK] をクリックします。

Excel

あるデータを Excel ファイル内に保持しており、かつ、その関連情報を Word ファイル内に保持している場合、両方の情報をリンクすると更新作業が簡単になります。 例として、最新の返品高を月次報告書にリンクしたいというケースを考えてみます。 月次報告書は Word 文書、返品高は Excel シートであるとします。 この Word 文書と Excel シートをリンクしておくと、返品高が更新されたときに月次報告書が自動更新されます。 もう一つの例として、Word 文書内の指示文を複数の Excel ファイルに挿入するというケースを考えてみます。 この場合も、リンクを使用すれば、指示文を更新したときに、その更新内容がすべての Excel ファイルに反映されます。

  1. リンクを挿入する位置をクリックします。

  2. [挿入] メニューの [オブジェクト] をクリックし、[ファイルから] をクリックします。

  3. リンクするファイルを探してクリックします。

    ヒント: アイコンだけを表示するには、[アイコンで表示] チェック ボックスをオンにします。表示されたアイコンをクリックすると、情報が表示されます。

  4. [ファイルにリンク] チェック ボックスをオンにします。次に、Word を使用している場合は [挿入]、Excel を使用している場合は [OK] をクリックします。

  1. [編集] メニューの [リンクの設定] をクリックします。

    [リンクの設定] コマンドが選択不可の状態である場合は、リンクされている情報がファイル内にありません。

  2. [リンク] ボックスの一覧で、リンクされているファイルをクリックし、[リンクを開く] をクリックします。

  3. 必要な変更を行います。

  4. [ファイル] メニューの [保存] をクリックして変更内容を保存し、そのアプリケーションを終了します。

    リンク元ファイルに変更内容が反映されます。

2 つのファイルを接続したままにしておきたいが、一方のファイルを更新したときにもう一方のファイルを更新したくない場合、"情報を埋め込む" という方法を使用できます。 たとえば、Excel シートが更新されたときに月次報告書を自動更新したくない場合や、指示文が更新されたときに Excel シートを自動更新したくない場合、"情報を埋め込む" という方法を使用できます。 情報を埋め込んだ場合、情報全体が 1 つのファイルに格納されるので、埋め込まれた情報にアクセスできない人にファイルのオンライン バージョンを配布する場合に便利です。

  1. ファイルを埋め込む位置をクリックします。

  2. [挿入] メニューの [オブジェクト] をクリックし、[ファイルから] をクリックします。

  3. 埋め込むファイルを探してクリックします。

    Excel シートを埋め込む場合、そのシートはブック内の先頭シートでなければなりません。

    ヒント: アイコンだけを表示するには、[アイコンで表示] チェック ボックスをオンにします。表示されたアイコンをクリックすると、情報が表示されます。

  4. [ファイルにリンク] チェック ボックスをオフにします。次に、Word を使用している場合は [挿入]、Excel を使用している場合は [OK] をクリックします。

  1. 埋め込まれたファイルをクリックします。

  2. [編集] メニューの [<オブジェクトの種類> オブジェクト] (例: [ワークシート オブジェクト]) をポイントし、[編集] をクリックします。

  3. 必要な変更を行います。

  4. [ファイル] メニューの [終了して <ファイル名> に戻る] をクリックします。

    埋め込まれているファイルに変更内容が反映されます。

ファイル全体ではなくファイル内の一部にリンクすることもできます。 たとえば、Excel シート全体ではなく Excel シート内の特定のセル範囲にリンクすることもできます。

  1. 貼り付ける情報を選びます (例: Word 文書内の一部の文)。

  2. [編集] メニューの [コピー] をクリックします。

  3. 貼り付け先のファイルに切り替え、情報を表示する位置をクリックします。

  4. [編集] メニューの [形式を選択してペースト] をクリックし、[ペースト リンク] をクリックします

  5. [ペーストする形式] ボックスの一覧でオブジェクトの種類 (例: [Microsoft Word 文書オブジェクト]) をクリックし、[OK] をクリックします。

関連項目

ハイパーリンクを作成、編集、または削除する

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×