リレーションシップを作成、編集、または削除する

主題ごとのテーブルをデータベースに作成したら、それぞれの情報を必要に応じて一緒に取り出すための手段を Office Access 2007 に用意しておく必要があります。 そのためには、関連のある複数のテーブルに共通のフィールドを配置して、テーブル間にリレーションシップを定義します。 この操作を行うと、複数のテーブルからの情報を同時に表示するクエリ、フォーム、レポートを作成できるようになります。

この記事では、テーブル リレーションシップの作成、編集、削除を行う手順について詳しく説明します。 ここでは、参照整合性を適用して孤立レコードの作成を防ぐ方法、結合の種類を設定してリレーションシップのそれぞれの側のどのレコードをクエリ結果に含めるかを決定する方法、そして、連鎖オプションを設定して参照の同期を保つ方法を解説します。

テーブル リレーションシップの詳細については、「テーブルのリレーションシップの概要」を参照してください。

この記事の内容

テーブル リレーションシップを作成する

[リレーションシップ] ドキュメント タブを使用してテーブル リレーションシップを作成する

[フィールド リスト] ウィンドウを使用してテーブル リレーションシップを作成する

テーブル リレーションシップを編集する

参照整合性を適用する

テーブル リレーションシップを削除する

テーブル リレーションシップを作成する

テーブル リレーションシップは、[リレーションシップ] ウィンドウで作成するか、または [フィールド リスト] ウィンドウからフィールドをデータシートにドラッグすれば作成できます。 テーブル間にリレーションシップを作成する場合、共通のフィールドには同じ名前が付いていることがよくありますが、これらの名前は異なっていてもかまいません。ただし、共通のフィールドは同じデータ型である必要があります。 ただし、主キー フィールドがオートナンバー型フィールドのときは、両方のフィールドの "FieldSize/フィールドサイズ" プロパティが一致していれば、外部キー フィールドを数値型フィールドにすることもできます。 たとえば、オートナンバー型フィールドと数値型フィールドの "FieldSize/フィールドサイズ" プロパティが両方とも長整数型であれば、これらの 2 つのフィールドを一致させることができます。 共通のフィールドがどちらも数値型フィールドである場合は、"FieldSize/フィールドサイズ" プロパティが同じ設定である必要があります。

ページの先頭へ

[リレーションシップ] ドキュメント タブを使用してテーブル リレーションシップを作成する

  1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. [データベース ツール] タブの [表示/非表示] グループで [リレーションシップ] をクリックします。

    Access のリボンの画像

  4. リレーションシップが 1 つも定義されていない場合は、[テーブルの表示] ダイアログ ボックスが自動的に表示されます。 表示されない場合は、[デザイン] タブの [リレーションシップ] グループで [テーブルの表示] をクリックします。

    リボンの [デザイン] タブの [リレーションシップ] グループ

    [テーブルの表示] ダイアログ ボックスには、データベース内のすべてのテーブルとクエリが表示されます。 テーブルだけを表示するには、[テーブル] をクリックします。 クエリだけを表示するには、[クエリ] をクリックします。 両方を表示するには、[両方] をクリックします。

  5. 1 つ以上のテーブルまたはクエリを選んで、[追加] をクリックします。 テーブルとクエリを [リレーションシップ] ドキュメント タブに追加したら、[閉じる] をクリックします。

  6. 一方のテーブルのフィールド (通常は主キー) を、他方のテーブルにおける共通のフィールド (外部キー) にドラッグします。 複数のフィールドをドラッグするには、Ctrl キーを押しながら各フィールドをクリックしてから、ドラッグします。

    [リレーションシップ] ダイアログ ボックスが表示されます。

    [リレーションシップ] ダイアログ ボックス

  7. 表示されたフィールド名が、リレーションシップを作成する共通のフィールドであることを確認します。 フィールド名が正しくない場合は、問題のフィールド名をクリックして、一覧から適切なフィールド名を選びます。

    このリレーションシップに参照整合性を適用するには、[参照整合性] チェック ボックスをオンにします。 参照整合性の詳細については、「参照整合性を適用する」を参照してください。

    さらに、「テーブルのリレーションシップの概要」も参照してください。

  8. [作成] をクリックします。

    2 つのテーブルの間に、リレーションシップ ラインが描画されます。 [参照整合性] チェック ボックスをオンにした場合、ラインの両端が太く表示されます。 また、同様に [参照整合性] チェック ボックスをオンにした場合に限り、次の図に示すように、リレーションシップの一方の太い部分の上に "1" が表示され、ラインの反対側の太い部分の上に無限大記号 () が表示されます。

1 つのテーブルから別のテーブルに一致するフィールドをドラッグする。

注記: 

  • 一対一リレーションシップを作成するには    共通のフィールドの両方 (通常は主キー フィールドと外部キー フィールド) に一意なインデックスが設定されている必要があります。 つまり、これらのフィールドの "Indexed/インデックス" プロパティが [はい (重複なし)] に設定されている必要があります。 両方のフィールドに一意なインデックスが設定されていれば、一対一リレーションシップが作成されます。

  • 一対多リレーションシップを作成するには    リレーションシップの "一" 側のフィールド (通常は主キー) に一意なインデックスが設定されている必要があります。 つまり、このフィールドの "Indexed/インデックス" プロパティが [はい (重複なし)] に設定されている必要があります。 "多" 側のフィールドには、一意なインデックスを設定しないでください。 インデックスを設定することはできますが、重複を許可する必要があります。 つまり、このフィールドの "Indexed/インデックス" プロパティは、[いいえ] または [はい (重複あり)] のどちらかに設定されている必要があります。 一方のフィールドに一意なインデックスが設定されていて、他方のフィールドに一意なインデックスが設定されていない場合、一対多リレーションシップが作成されます。

ページの先頭へ

[フィールド リスト] ウィンドウを使用してテーブル リレーションシップを作成する

Office Access 2007 では、[フィールド リスト] ウィンドウからフィールドをドラッグすれば、データシート ビューで開いている既存のテーブルにフィールドを追加できます。 [フィールド リスト] ウィンドウには、リレーション テーブルにある利用可能なフィールドに加えて、データベース内の他のテーブルにある利用可能なフィールドも表示されます。 "他" の (関連付けられていない) テーブルからフィールドをドラッグしてから、ルックアップ ウィザードを完了すると、[フィールド リスト] ウィンドウ内のテーブルとフィールドのドラッグ先のテーブルとの間に、新しい一対多リレーションシップが自動的に作成されます。 Access で作成されたこのリレーションシップには、既定では参照整合性が適用されません。 参照整合性を適用するには、リレーションシップを編集する必要があります。 詳細については、「テーブル リレーションシップを編集する」を参照してください。

テーブルをデータシート ビューで開く

  1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. ナビゲーション ウィンドウで、フィールドを追加してリレーションシップを作成するテーブルをマウスの右ボタンでクリックしてから、ショートカット メニューの [データシート ビュー] をクリックします。

[フィールド リスト] ウィンドウを開く

  • [データシート] タブの [フィールドと列] グループで [既存のフィールドの追加] をクリックします。

    Access のリボンの画像

    [フィールド リスト] ウィンドウが表示されます。

    [フィールド リスト] ウィンドウ

[フィールド リスト] ウィンドウには、データベース内のその他のテーブルがすべてカテゴリ別にグループ分けされて表示されます。 データシート ビューでテーブルを操作する場合、各フィールドは [フィールド リスト] ウィンドウの [リレーション テーブルで利用可能なフィールド] と [他のテーブルで利用可能なフィールド] の 2 つのカテゴリのいずれかに表示されます。 1 つ目のカテゴリには、現在作業中のテーブルとリレーションシップを持つテーブルがすべて表示されます。 2 つ目のカテゴリには、現在作業中のテーブルとのリレーションシップがないテーブルがすべて表示されます。

[フィールド リスト] ウィンドウで、テーブル名の横にあるプラス記号 (+) をクリックすると、そのテーブル内にある利用可能なフィールドがすべて表示されます。 テーブルにフィールドを追加するには、[フィールド リスト] ウィンドウから目的のフィールドをデータシート ビューのテーブルにドラッグします。

[フィールド リスト] ウィンドウからフィールドを追加してリレーションシップを作成する

  1. [データシート] タブの [フィールドと列] グループで [既存のフィールドの追加] をクリックします。

    Access のリボンの画像

    [フィールド リスト] ウィンドウが表示されます。

  2. [他のテーブルで利用可能なフィールド] で、テーブル名の横にあるプラス記号 (+) をクリックして、テーブル内にあるフィールドの一覧を表示します。

  3. [フィールド リスト] ウィンドウから目的のフィールドを、データシート ビューで開いているテーブルにドラッグします。

  4. 挿入ラインが表示されたら、フィールドを適切な位置にドロップします。

    ルックアップ ウィザードが起動します。

  5. 表示される手順に従って、ルックアップ ウィザードを完了します。

    フィールドがデータシート ビューのテーブルに表示されます。

"他" の (関連付けられていない) テーブルからフィールドをドラッグしてから、ルックアップ ウィザードを完了すると、[フィールド リスト] 内のテーブルとフィールドのドラッグ先のテーブルとの間に、新しい一対多リレーションシップが自動的に作成されます。 Access で作成されたこのリレーションシップには、既定では参照整合性が適用されません。 参照整合性を適用するには、リレーションシップを編集する必要があります。 詳細については、「テーブル リレーションシップを編集する」を参照してください。

ページの先頭へ

テーブル リレーションシップを編集する

テーブル リレーションシップを変更するには、[リレーションシップ] ドキュメント タブでリレーションシップを選んで編集します。

  1. マウス ポインターを慎重に移動してリレーションシップ ラインをポイントしてから、そのラインをクリックして選びます。

    リレーションシップ ラインは、選ばれると太く表示されます。

  2. リレーションシップ ラインが選ばれている状態で、そのラインをダブルクリックします。

    または

    [デザイン] タブの [ツール] グループで [リレーションシップの編集] をクリックします。

[リレーションシップ] ダイアログ ボックスが表示されます。

[リレーションシップ] ダイアログ ボックスを開く

  1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. [データベース ツール] タブの [表示/非表示] グループで [リレーションシップ] をクリックします。

    [リレーションシップ] ドキュメント タブが表示されます。

    まだリレーションシップを定義したことがなく、初めて [リレーションシップ] ドキュメント タブを開こうとした場合、[テーブルの表示] ダイアログ ボックスが表示されます。 ダイアログ ボックスが表示されたら、[閉じる] をクリックします。

  4. [デザイン] タブの [リレーションシップ] グループで [すべてのリレーションシップ] をクリックします。

    リボンの [デザイン] タブの [リレーションシップ] グループ

    リレーションシップが設定されているすべてのテーブルが、リレーションシップ ラインと共に表示されます。 ただし、隠しテーブル (テーブルのプロパティ ダイアログ ボックスで [隠しオブジェクト] チェック ボックスがオンになっているテーブル) とそのリレーションシップは、[ナビゲーション オプション] ダイアログ ボックスで [隠しオブジェクトの表示] をオンにしない限り表示されません。

    [隠しオブジェクトの表示] オプションの詳細については、「ナビゲーション ウィンドウの概要」を参照してください。

  5. 変更するリレーションシップのリレーションシップ ラインをクリックします。 リレーションシップ ラインは、選ばれると太く表示されます。

  6. リレーションシップ ラインをダブルクリックします。

    または

    [デザイン] タブの [ツール] グループで [リレーションシップの編集] をクリックします。

    [リレーションシップ] ダイアログ ボックスが表示されます。

    [リレーションシップ] ダイアログ ボックス

  7. 必要な変更を行ってから、[OK] をクリックします。

    [リレーションシップ] ダイアログ ボックスでは、テーブル リレーションシップを変更できます。 特に、リレーションシップの両側のテーブルやクエリ、または両側のフィールドを変更できます。 また、結合の種類を設定したり、参照整合性を適用して連鎖オプションを選んだりもできます。 結合の種類とその設定方法の詳細については、「結合の種類を設定する」を参照してください。 参照整合性を適用して連鎖オプションを選ぶ方法の詳細については、「参照整合性を適用する」を参照してください。

結合の種類を設定する

テーブル リレーションシップを定義すると、リレーションシップの情報がクエリ デザインに反映されます。 たとえば、2 つのテーブルの間にリレーションシップを定義した後、それらの 2 つのテーブルを使用するクエリを作成すると、リレーションシップで指定されているフィールドを基に、既定の一致フィールドが自動的に選ばれます。 この既定の初期値はクエリで上書きできますが、リレーションシップで設定された値が適切であったことに後で気づくこともよくあります。 複数のテーブルのデータを一致させて同時に取り出す操作は、ごく単純なデータベースを除くほとんどのデータベースで頻繁に実行されるため、リレーションシップを作成して既定値が設定されれば、時間を節約できて便利です。

複数テーブルのクエリでは、共通のフィールドの値を一致させて、複数のテーブルからの情報を組み合わせます。 一致と組み合わせを行う操作は、結合と呼ばれます。 たとえば、得意先の受注情報を表示する必要があるとします。 そこで、[得意先] テーブルと [受注] テーブルを [得意先 ID] フィールドで結合するクエリを作成します。 クエリ結果には、該当する一致が見つかった行についてのみ得意先情報と受注情報が含まれます。

リレーションシップごとに指定できる値の 1 つに、結合の種類があります。 結合の種類は、どのレコードをクエリ結果に含めるかを Access に指示するものです。 たとえば、[得意先] テーブルと [受注] テーブルを、得意先 ID を表す共通のフィールドで結合するクエリについて、もう一度考えます。 既定の結合の種類 (内部結合) を使用した場合は、共通のフィールド (結合フィールド) が等しい [得意先] の行と [受注] の行だけがクエリから返されます。

しかし、まだ一度も注文していない得意先も含め、すべての得意先を含めたい場合もあります。 これを実現するには、結合の種類を内部結合から、左外部結合と呼ばれるものに変更する必要があります。 左外部結合では、リレーションシップの左側のテーブルからはすべての行が返され、右側のテーブルからは一致する行だけが返されます。 右外部結合では、右側からはすべての行が返され、左側からは一致する行だけが返されます。

注: この場合、"左" と "右" は、[リレーションシップ] ドキュメント タブでのテーブルの位置ではなく、[リレーションシップ] ダイアログ ボックスでのテーブルの位置を示します。

このリレーションシップでテーブルを結合するクエリから最も頻繁に求める結果について考えたうえで、適切な結合の種類を設定する必要があります。

結合の種類を設定する

  1. [リレーションシップ] ダイアログ ボックスで、[結合の種類] をクリックします。

    [結合プロパティ] ダイアログ ボックスが表示されます。

  2. 適切なオプションをクリックして、[OK] をクリックします。

次の表は、[得意先] テーブルと [受注] テーブルを使用した場合に [結合プロパティ] ダイアログ ボックスに表示される 3 つの選択肢と、それぞれのオプションで使用される結合の種類と、各テーブルに対してすべての行、一致する行のどちらが返されるかを示しています。

選択肢

リレーショナル結合

左テーブル

右テーブル

1. 両方のテーブルの結合フィールドが同じ行だけを含める。

内部結合

一致する行

一致する行

2. '得意先' の全レコードと '受注' の同じ結合フィールドのレコードだけを含める。

左外部結合

すべての行

一致する行

3. '受注' の全レコードと '得意先' の同じ結合フィールドのレコードだけを含める。

右外部結合

一致する行

すべての行

オプション 2 またはオプション 3 を選ぶと、リレーションシップ ラインに矢印が表示されます。 この矢印の向きは、リレーションシップの一致する行だけを表示する側を指します。

[結合プロパティ] ダイアログ ボックスで変更する

  1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. [データベース ツール] タブの [表示/非表示] グループで [リレーションシップ] をクリックします。

    Access のリボンの画像

    [リレーションシップ] ドキュメント タブが表示されます。

    まだリレーションシップを定義したことがなく、初めて [リレーションシップ] ドキュメント タブを開こうとした場合、[テーブルの表示] ダイアログ ボックスが表示されます。 ダイアログ ボックスが表示されたら、[閉じる] をクリックします。

  4. [デザイン] タブの [リレーションシップ] グループで [すべてのリレーションシップ] をクリックします。

    リボンの [デザイン] タブの [リレーションシップ] グループ

    リレーションシップが設定されているすべてのテーブルが、リレーションシップ ラインと共に表示されます。 ただし、隠しテーブル (テーブルのプロパティ ダイアログ ボックスで [隠しオブジェクト] チェック ボックスがオンになっているテーブル) とそのリレーションシップは、[ナビゲーション オプション] ダイアログ ボックスで [隠しオブジェクトの表示] をオンにしない限り表示されません。

    [隠しオブジェクトの表示] オプションの詳細については、「ナビゲーション ウィンドウの概要」を参照してください。

  5. 変更するリレーションシップのリレーションシップ ラインをクリックします。 リレーションシップ ラインは、選ばれると太く表示されます。

  6. リレーションシップ ラインをダブルクリックします。

    または

    [デザイン] タブの [ツール] グループで [リレーションシップの編集] をクリックします。

    [リレーションシップ] ダイアログ ボックスが表示されます。

  7. [結合の種類] をクリックします。

  8. [結合プロパティ] ダイアログ ボックスで、いずれかのオプションをクリックしてから、[OK] をクリックします。

    [結合プロパティ] ダイアログ ボックス

  9. 必要に応じてリレーションシップに変更を加えてから、[OK] をクリックします。

ページの先頭へ

参照整合性を適用する

参照整合性の目的は、孤立レコードの発生を防ぐことと、参照の同期を保って、もう存在しない他のレコードを参照するレコードができないようにすることです。 参照整合性を適用するには、テーブル リレーションシップで参照整合性を有効にします。 いったん有効にすると、テーブル リレーションシップに設定した参照整合性に違反する操作はすべて拒否されるようになります。 つまり、参照先を変更する更新と、参照先の削除の両方が拒否されます。 参照の更新や削除を反映して、関連するすべての行が適切に変更されるようにするには、「連鎖オプションを設定する」を参照してください。

参照整合性を有効または無効にする

  1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. [データベース ツール] タブの [表示/非表示] グループで [リレーションシップ] をクリックします。

    Access のリボンの画像

    [リレーションシップ] ドキュメント タブが表示されます。

    まだリレーションシップを定義したことがなく、初めて [リレーションシップ] ドキュメント タブを開こうとした場合、[テーブルの表示] ダイアログ ボックスが表示されます。 ダイアログ ボックスが表示されたら、[閉じる] をクリックします。

  4. [デザイン] タブの [リレーションシップ] グループで [すべてのリレーションシップ] をクリックします。

    リレーションシップが設定されているすべてのテーブルが、リレーションシップ ラインと共に表示されます。 ただし、隠しテーブル (テーブルのプロパティ ダイアログ ボックスで [隠しオブジェクト] チェック ボックスがオンになっているテーブル) とそのリレーションシップは、[ナビゲーション オプション] ダイアログ ボックスで [隠しオブジェクトの表示] をオンにしない限り表示されません。

    [隠しオブジェクトの表示] オプションの詳細については、「ナビゲーション ウィンドウの概要」を参照してください。

  5. 変更するリレーションシップのリレーションシップ ラインをクリックします。 リレーションシップ ラインは、選ばれると太く表示されます。

  6. リレーションシップ ラインをダブルクリックします。

    または

    [デザイン] タブの [ツール] グループで [リレーションシップの編集] をクリックします。

    [リレーションシップ] ダイアログ ボックスが表示されます。

  7. [参照整合性] チェック ボックスをオンにします。

  8. 必要に応じてリレーションシップに変更を加えてから、[OK] をクリックします。

参照整合性を適用すると、次の規則が適用されます。

  • 主テーブルの主キー フィールドに存在しない値を、リレーション テーブルの外部キー フィールドに入力することはできません。このような操作は、孤立レコードが作成される原因となります。

  • レコードは、そのレコードと一致するレコードがリレーション テーブルに存在する場合、主テーブルから削除することはできません。 たとえば、社員レコードは、その社員が担当している受注が [受注] テーブルに存在する場合、[社員] テーブルから削除することはできません。 ただし、[レコードの連鎖削除]チェック ボックスをオンにすれば、主レコードとすべての関連レコードを 1 回の操作で削除できるようになります。

  • 主テーブル内の主キーの値は、変更すると孤立レコードが作成される結果になる場合は変更できません。 たとえば、[受注] テーブル内の受注番号は、[受注明細] テーブルでその受注に関連付けられている品目が存在する場合は変更できません。 ただし、[フィールドの連鎖更新]チェック ボックスをオンにすれば、主レコードとすべての関連レコードを 1 回の操作で更新できるようになります。

    注記: 参照整合性を有効にできない場合、参照整合性を適用するには、次の条件を満たす必要があることに注意してください。

    • 主テーブルの共通のフィールドが主キーであるか、または一意なインデックスが設定されていること。

    • 共通のフィールドが同じデータ型であること。 例外として、オートナンバー型フィールドは、"FieldSize/フィールドサイズ" プロパティが [長整数型] に設定されている数値型フィールドに関連付けることができます。

    • 両方のテーブルが同じ Access データベースに存在すること。 参照整合性はリンク テーブルには適用できません。 ただし、ソース テーブルが Access 形式の場合は、それらのテーブルが格納されているデータベースを開き、そのデータベース内で参照整合性を有効にできます。

連鎖オプションを設定する

リレーションシップの "一" 側の値をどうしても変更する必要がある状況が発生することがあります。 このような場合は、1 回の操作で、影響を受けるすべての行が自動的に更新されるようにする必要があります。 この方法であれば更新が全部完了するので、データベースに更新された行と更新されていない行が混在するような矛盾した状態になることはありません。 Access では、この問題を回避するために、[フィールドの連鎖更新] オプションがサポートされています。 参照整合性を適用して、[フィールドの連鎖更新] オプションをオンにすると、主キーを更新した場合に、その主キーを参照しているすべてのフィールドが自動的に更新されます。

また、ある行を削除したら、関連するレコードをすべて削除することが必要になる場合もあります。たとえば、運送会社のレコードを削除したら、その運送会社に関連するすべての受注を削除するなどです。 このような場合のために、Access では、[レコードの連鎖削除] オプションもサポートされています。 参照整合性を適用して、[レコードの連鎖削除] チェック ボックスをオンにすると、主キーを含んでいるレコードを削除した場合に、その主キーを参照しているすべてのレコードが自動的に削除されます。

連鎖更新や連鎖削除を有効または無効にする

  1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. [データベース ツール] タブの [表示/非表示] グループで [リレーションシップ] をクリックします。

    Access のリボンの画像

    [リレーションシップ] ドキュメント タブが表示されます。

    まだリレーションシップを定義したことがなく、初めて [リレーションシップ] ドキュメント タブを開こうとした場合、[テーブルの表示] ダイアログ ボックスが表示されます。 ダイアログ ボックスが表示されたら、[閉じる] をクリックします。

  4. [デザイン] タブの [リレーションシップ] グループで [すべてのリレーションシップ] をクリックします。

    リレーションシップが設定されているすべてのテーブルが、リレーションシップ ラインと共に表示されます。 ただし、隠しテーブル (テーブルのプロパティ ダイアログ ボックスで [隠しオブジェクト] チェック ボックスがオンになっているテーブル) とそのリレーションシップは、[ナビゲーション オプション] ダイアログ ボックスで [隠しオブジェクトの表示] をオンにしない限り表示されません。

    [隠しオブジェクトの表示] オプションの詳細については、「ナビゲーション ウィンドウの概要」を参照してください。

  5. 変更するリレーションシップのリレーションシップ ラインをクリックします。 リレーションシップ ラインは、選ばれると太く表示されます。

  6. リレーションシップ ラインをダブルクリックします。

    または

    [デザイン] タブの [ツール] グループで [リレーションシップの編集] をクリックします。

    [リレーションシップ] ダイアログ ボックスが表示されます。

  7. [参照整合性] チェック ボックスをオンにします。

  8. [フィールドの連鎖更新] チェック ボックスと [レコードの連鎖削除] チェック ボックスの一方または両方をオンにします。

  9. 必要に応じてリレーションシップに変更を加えてから、[OK] をクリックします。

注: 主キーがオートナンバー型フィールドである場合、オートナンバー型フィールドの値を変更することはできないので、[フィールドの連鎖更新] チェック ボックスをオンにしても効果はありません。

ページの先頭へ

テーブル リレーションシップを削除する

テーブル リレーションシップを削除するには、[リレーションシップ] ドキュメント タブでリレーションシップ ラインを削除する必要があります。 マウス ポインターを慎重に移動してリレーションシップ ラインをポイントしてから、そのラインをクリックします。 リレーションシップ ラインは、選ばれると太く表示されます。 リレーションシップ ラインが選ばれている状態で、Del キーを押します。 リレーションシップを削除すると、そのリレーションシップで参照整合性が有効になっている場合は、参照整合性のサポートも削除されることに注意してください。 結果として、リレーションシップの "多" 側に孤立レコードが作成されるのを自動的に防止することはできなくなります。

  1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

  3. [データベース ツール] タブの [表示/非表示] グループで [リレーションシップ] をクリックします。

    Access のリボンの画像

    [リレーションシップ] ドキュメント タブが表示されます。

    まだリレーションシップを定義したことがなく、初めて [リレーションシップ] ドキュメント タブを開こうとした場合、[テーブルの表示] ダイアログ ボックスが表示されます。 ダイアログ ボックスが表示されたら、[閉じる] をクリックします。

  4. [デザイン] タブの [リレーションシップ] グループで [すべてのリレーションシップ] をクリックします。

    リレーションシップが設定されているすべてのテーブルが、リレーションシップ ラインと共に表示されます。 ただし、隠しテーブル (テーブルのプロパティ ダイアログ ボックスで [隠しオブジェクト] チェック ボックスがオンになっているテーブル) とそのリレーションシップは、[ナビゲーション オプション] ダイアログ ボックスで [隠しオブジェクトの表示] をオンにしない限り表示されません。

    [隠しオブジェクトの表示] オプションの詳細については、「ナビゲーション ウィンドウの概要」を参照してください。

  5. 削除するリレーションシップのリレーションシップ ラインをクリックします。 リレーションシップ ラインは、選ばれると太く表示されます。

  6. Del キーを押します。

    または

    マウスの右ボタンをクリックしてから、[削除] をクリックします。

  7. "選択したリレーションシップをデータベースから削除しますか?" というエラー メッセージが Access から表示されることがあります。 この確認メッセージが表示されたら、[はい] をクリックします。

注: テーブル リレーションシップで使用されているテーブルのいずれかが、他のユーザーやプロセス、または開かれているデータベース オブジェクト (フォームなど) で使用中の場合、そのリレーションシップを削除することはできません。 リレーションシップの削除を試みる前に、該当するテーブルを使用している、開いているオブジェクトを閉じる必要があります。

ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×