リソース共有元を使用してリソースを共有する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

複数のプロジェクトに同じリソースを割り当てるか、1 つ以上のプロジェクトで共有リソースを使用した場合は、すべてのリソース情報をリソース プールと呼ばれる 1 つのファイルを組み合わせることができます。

リソース共有元を使用して、複数のプロジェクトのリソースの作業をスケジュール、別のプロジェクトでは、その割り当ての間の競合を確認してプロジェクトごとに、時間の割り当て方法を参照してください。

目的に合ったトピックをクリックしてください。

リソース プールについてください。

プロジェクト間でリソースを共有するためのリソース共有元を作成します。

共有先ファイルへの割り当てを更新して、リソース プールに変更内容を送信します。

リソースの共有を停止します。

リソース共有元について理解する

リソース共有元を使用すると、複数のプロジェクト ファイルのタスクに割り当てられている人や機材を簡単に管理することができます。リソース共有元には、リソース名、カレンダー、リソースの単位数、コスト単価表などのリソース情報がまとまって保存されています。

リソース共有元のリソースを使用するプロジェクトのことを共有先ファイルと呼びます。

ヒント: リソース情報だけのプロジェクト ファイルを新規に (別途) 作成します。これにより、共有先ファイルとリソース共有元の間で、リソース情報やタスク割り当てを簡単に管理できるようになります。

リソース プールを作成する前と後

ボタンの画像 リソース共有元を作成する前に、各プロジェクトには、独自のリソース情報が含まれています。重複または他のプロジェクトで使用される同じリソースに関する情報も競合この情報の一部可能性があります。

ボタンの画像 リソース共有元を作成すると、各プロジェクトのリソース情報、1 つのリソース プールから取得します。割り当てについては、コスト単価、およびすべてのリソースの利用可能時間は、1 つの場所に存在します。

ボタンの画像 複数のプロジェクト間での割り当てが競合する原因リソースの割り当て超過をわかりやすくもできます。

Microsoft Office Project Professional 2007 で組織のエンタープライズ リソース共有元に存在するリソースを使用する場合、リソース共有元を作成する必要はありません。エンタープライズ リソースは組織全体に対して設定されていて、[ツール] メニューの [エンタープライズからチームを作成] コマンドを使用すると利用できます。

Office Project Professional 2007 の使用中に Microsoft Office Project Server 2007 にログオンした場合、エンタープライズ以外のリソース共有元やリソースの共有は使用できません。利用できるのは、エンタープライズ リソース共有元のみです。

ただし、電子メール メッセージで自分宛てに送信されたプロジェクト ファイルで作業を行う場合などは、サーバーにログオンせずに Project を開くと、エンタープライズ以外のリソース共有元とリソースの共有を使用できます。

注: リソース共有元に編集可能モードでアクセスできる場合、リソース共有元を開いて、リソース共有元または共有先ファイルの情報を管理することができます。一方、リソース共有元に変更を加える権限がない場合には、リソース共有元または共有先ファイルは読み取り専用で開きます。共有先ファイルで作業する場合は、リソース共有元に複製された情報を参照することで、他の共有先ファイルのリソース割り当ても確認できます。

ページの先頭へ

プロジェクト間でリソースを共有するためにリソース共有元を作成する

  1. 他のプロジェクトのリソースを共有するプロジェクトを開きます。これが共有先プロジェクトとなります。

  2. 共有するリソースが含まれるプロジェクトを開きます。これがリソース共有元プロジェクトとなります。

  3. [ウィンドウ] メニューで、共有先プロジェクトをクリックします。

  4. 共有先プロジェクトの [ツール] メニューの [リソースの共有化] をポイントし、[リソースの共有] をクリックします。

  5. [指定のプロジェクトからリソースを共有する] をクリックし、[共有元] ボックスで、手順 2. で開いたリソース共有元プロジェクトをクリックします。

  6. [カレンダーやリソース情報が重複するとき] の下で、優先するプロジェクト ファイルを選択します。

    • 重複が発生したときに、共有先プロジェクトのリソース情報よりもリソース共有元プロジェクトのリソース情報を優先する場合は、[共有元のリソース情報を優先する] をクリックします。このオプションは既定で選択されています。

      たとえば、 加山弘という名前のリソースの最大単位数が共有先プロジェクトで 100%、リソース共有元プロジェクトで 75% のときに、リソース共有元プロジェクトを優先するように指定した場合、加山弘の最大単位数は 75% になります。

    • リソース共有元プロジェクトに重複する情報があるときでも、常に共有先プロジェクトのリソース情報を優先する場合には、[共有先のリソース情報を優先する] をクリックします。

      たとえば、加山弘の標準単価が共有先プロジェクトで ¥5000、リソース共有元プロジェクトで ¥4500 のときに、共有先プロジェクトを優先するように指定した場合、加山弘の標準単価は ¥5000 になります。

  7. [OK] をクリックします。

    これでリソースを作業中のプロジェクトで使用できるようになりました。プロジェクトに既にリソースを入力している場合、両方のプロジェクトのリソースが結合されます。

注: 既定では、共有先ファイルとリソース共有元の情報に矛盾がある場合、リソース共有元の情報によって共有先ファイルの情報が上書きされます。たとえば、リソース共有元にあるリソースの名前が山神祐子であるときに、共有先ファイルでそのリソース名を加山弘に変更しても、次に共有先ファイルを開いたときには山神祐子に戻っています。これにより、誤った変更によってリソース共有元が破損することを防止しています。

ページの先頭へ

共有先ファイルの割り当てを更新し、リソース共有元に変更を送信する

リソース共有元が複数のプロジェクトによって共有されている場合、共有先ファイルでの作業中にリソース共有元ファイルの割り当て情報を定期的に更新できます。リソース共有元ファイルを更新すると、ファイルを閉じる前に、他のユーザーが自分のプロジェクトに影響する変更を確認できるようになります。

  1. 共有先ファイルを開きます。

  2. 表示されたダイアログ ボックスで、[すべてのリソース共有先にある割り当てを確認できるように、リソース共有元を開く。] をクリックします。

    これにより、リソース共有元が読み取り専用ファイルとして開きます。現在の共有先ファイルのすべての割り当てだけでなく、このリソース共有元を利用する他の共有先ファイルの割り当ても、[リソース配分状況] ビューに表示されます。

  3. 現在の共有先プロジェクトのタスクおよび割り当ての進捗状況の情報を更新します。リソース配分状況] ビューまたは [タスク配分状況] ビューを使用している場合は、 時間配分または合計スケジュール済み、 実際の日数、および [残存作業時間を更新できます。

  4. [ツール] メニューの [リソースの共有化] をポイントし、[リソース共有元に変更を反映] をクリックします。

注: リソース共有元が編集可能モードで開いた場合、共有先ファイルには自動的に最新情報が反映されます。この場合、[リソース共有元に変更を反映] は使用できません。

ページの先頭へ

リソースの共有をやめる

プロジェクトがリソース共有元または別のプロジェクト ファイルのリソースを共有している場合、プロジェクトをそのファイルから切り離すことができます。リソース共有元または別のプロジェクト ファイルを切り離しても、作業中のプロジェクト ファイルに割り当てられているリソースはそのまま残りますが、リソース共有元または別のファイルに含まれている他のリソースは使用できなくなります。ファイルのリソースが共有されているリソース共有元から、すべてのファイルを切り離すこともできます。

注: 通常、タスクの割り当て共有先ファイルを切断した後に、 リソース プール内で保持する必要はありません。ただし、リソース プールからリソース共有元が表示されていないときに、共有先ファイルを切断する場合、または共有先ファイルを切断した後は、リソース共有元を保存しない場合は、割り当てが保持されます。プールから保持されている割り当てを削除するには、リソース共有元のファイル、およびすべてのタスクの割り当て情報内から共有先ファイルを切断して、は、共有先ファイルに影響を与えずにリソース共有元から削除されます。リソース プールに残っているタスクが既に場合、は、リソース共有元を共有先ファイルを再接続し、もう一度接続または切断します。

作業中の共有先ファイルをリソース共有元から切り離す

共有先ファイルと接続してリソースを共有していたリソース共有元などのファイルから、作業中の共有先ファイルを切り離すことができます。

  1. 共有しているリソースが含まれているリソース共有元を開きます。

  2. [リソース共有元を開く] ダイアログ ボックスで、[リソース情報についての変更が追加できるように、リソース共有元を編集可能モードで開く] をクリックします。リソース共有元を編集可能モードで開くと、他のユーザーがリソース共有元を更新できなくなることに注意してください。

  3. プロジェクトを開きます。

  4. プロジェクトを開いた状態で、[ツール] メニューの [リソースの共有化] をポイントし、[リソースの共有] をクリックします。

  5. [現在のプロジェクトのリソースを使用する] をクリックし、[OK] をクリックします。

  6. [保存 ボタンの画像 ] をクリックします。

  7. [ウィンドウ] メニューで、リソース共有元ファイルをクリックします。

  8. [ファイル] メニューで、 ボタンの画像保存] をクリックします。

リソース共有元ファイルからすべての共有先ファイルを切り離す

リソース共有元ファイルをすべての共有先ファイルから切り離すことができます。

  1. リソース共有元ファイルを開きます。

  2. [リソース共有元を開く] ダイアログ ボックスで、[リソース情報についての変更が追加できるように、リソース共有元を編集可能モードで開く] をクリックします。リソース共有元を編集可能モードで開くと、他のユーザーがリソース共有元を更新できなくなることに注意してください。

  3. [ツール] メニューの [リソースの共有化] をポイントし、[リソースの共有] をクリックします。

  4. 一部のファイルを切り離すには、[リソースの共有] ダイアログ ボックスでファイルを選択し、[開く] をクリックします。

    すべてのファイルを切り離すには、[リソースの共有] ダイアログ ボックスで [すべて開く] をクリックします。

    Microsoft Office Project 2007は、すべての共有先ファイルをマスター プロジェクトを一時的に統合します。

  5. [ウィンドウ] メニューで、リソース共有元ファイルをクリックします。

  6. [ツール] メニューの [リソースの共有] をポイントし、[リソースの共有] をクリックします。

  7. [リソース共有先のリンク] ボックスで、リソース共有元から切り離すファイルを選択します。

    複数のファイルを選択するには、Ctrl キーを押しながら各ファイルをクリックします。すべてのファイルを選択するには、Shift キーを押しながら最初と最後のファイルをクリックします。

  8. [リンクの解除] をクリックします。

    Office Project 2007 により、リソース共有元へのリンクが解除されたファイルが更新されます。

    注: リソース共有元のリソースに割り当てられたタスクを含むプロジェクトでは、割り当てが保持されます (ただし、これ以降に加えられた変更はリソース共有元に反映されません)。切り離されたプロジェクトからリソース共有元の他のリソースにアクセスすることはできなくなります。

  9. [保存] をクリックします。

  10. [ウィンドウ] メニューで、各共有先ファイルを選択し、[保存 ボタンの画像 ] をクリックします。

  11. [ウィンドウ] メニューで、一時的に統合していたマスタ プロジェクトを選択します。

  12. [ファイル] メニューの [閉じる] をクリックします。

    注: このファイルに加えた変更は保存しないでください。変更を保存すると、一時マスタ プロジェクト ファイルが保存されます。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×