ユーザー設定フィルターを作成する

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに英語の記事があります。

Project では、ビューにフィルターをかけて、自分にとって最も重要なタスクやマイルストーン、その他の情報だけを表示することができます。 プロジェクトのタスクまたはリソースにフィルターを適用するには、タスクの特定の側面を表示するための事前定義されたフィルターと、[ z0z_] の3つの方法があります。 これらのフィルターのいずれもニーズに合わない場合は、新しいフィルターを作成するか、既存のフィルターを変更することができます。

  • 定義済みフィルター    これらは Project に同梱されているフィルターです。 これは、未完了のタスクや、割り当て超過のリソースなど、タスクまたはリソースをすばやくフィルター処理するために使用されます。

  • ユーザー設定フィルター    これらは、プロジェクトのニーズに合わせて設計されたフィルターです。

  • オートフィルター    これらの設定をオンにすると、シートビューの各列の上部に矢印として表示されます。 これらを使用して、列の項目にすばやくフィルターを適用します。

この記事の内容

タスクまたはリソースをフィルター処理する

オートフィルターを使用する

タスクまたはリソースをフィルター処理する

プロジェクト内の特定の種類の情報のみを表示する必要がある場合があります。 たとえば、プロジェクトのマイルストーンのみを表示したり、まだ開始していないタスクを表示したりすることができます。 プロジェクトに多くのタスクがあり、多くのリソースが含まれている場合、フィルターは特定の範囲の情報を表示するのに非常に便利です。 フィルターを使用すると、興味のある情報だけを表示し、残りの部分は非表示にすることができます。

定義済みのプロジェクトフィルターを使用して、タスクまたはリソースのデータをフィルター処理することができます。 目的に合ったフィルターがない場合は、新しいフィルターを作成するか、既存のフィルターを変更することができます。

フィルターを適用または削除する

  1. [表示] タブの [データ] グループで、[フィルター] ボックスの一覧からフィルターを選びます。

    リストにないフィルターを適用するには、[その他のフィルター] を選択し、次のいずれかの操作を行います。

    • タスクフィルターを選択するには、[タスク] を選択し、[フィルター ] リストでフィルター名を選択して、[適用] を選択します。

    • リソースフィルターを選択するには、[リソース] を選択し、[フィルター ] リストでフィルター名を選択して、[適用] を選択します。

      注: タスクフィルターをタスクビューに適用することはできません。

  2. 対話型フィルターを適用する場合は、要求された値を入力して、[ OK]を選択します。

  3. フィルターを無効にするには、フィルターの一覧で [フィルターなし] を選択します。

強調表示を使用して、フィルター処理されたタスクに色を適用する

タスクまたはリソースをフィルター処理するときに、強調表示を適用できます。 強調表示されたタスクまたはリソースには、フィルター処理されていないタスクが表示されますが、色は異なります。

  1. [表示] タブの [データ] グループで、[フィルター] ボックスの一覧からフィルターを選択し、[その他のフィルター] を選択します。

  2. [フィルター] リストでフィルターを選択し、[強調表示] を選択します。

ヒント:  強調表示されているタスクに別の色を適用するには、別のテキストスタイルを使用します。 [書式] タブを選択し、[テキストのスタイル] を選択します。 [設定の対象] リストで、[強調表示されているタスク] を選択し、書式設定オプションを選択します。

ユーザー設定フィルターを作成する

  1. [表示] タブの [データ] グループで、[フィルター] の横にある矢印を選択し、[その他のフィルター] を選択します。

    ユーザー設定フィルターを作成する方法を示す、Project のリボン

  2. 作成するフィルターの種類に応じて、[タスク] または [リソース] を選び、[新規] を選びます。

  3. 新しいフィルターの名前を入力します。 そのフィルターを [データ] グループ リストに含める場合は [メニューに表示する] を選択します。

  4. [かつ/または] 列で [かつ] を選択して、複数のフィルター条件に一致する結果を表示します。 [または] を選択すると、どれか 1 つの条件を満たす行が表示されます。

    フィルターで取得したい結果の種類に応じて [かつ] あるいは [または] を選択する。

  5. [フィールド名] 列で、フィルターをかけるフィールドを選択します。

  6. [テスト] 列で、[フィールド名] 列に選択した内容と次の手順で選択する [] 列をどのように一致させるかを指定します。

  7. [] 列で、使用する値を選択するか、または新しい値を入力します。

    [テスト] 列で [と等しい] または [と等しくない] を選んだ場合は、[] 列に (リストからオプションを選ぶ代わりに) ワイルドカード文字を入力することもできます。 たとえば、疑問符 (?) を入力すると、任意の 1 文字に一致します。 アスタリスク (*) を入力すると、任意の文字数の任意の文字に一致します。 ワイルドカードを使用する場合は、[フィールド名] 列で選んだ内容が、数値 ([期間] など) ではなく文字列 ([名前] など) を含んでいることを確認してください。

  8. フィルターに別の行を追加するには (さらに、フィルターを適用する別のフィールド名を選択するには)、[行の挿入] を選択します。 空の行を追加することにより、複数の行をグループ化できます。 空の行に [かつ] あるいは [または] を追加して、1 つのグループを別のグループに対してフィルタリングします。

  9. 完了したら、[保存] を選びます。

ヒント: すべてのフィルターをすばやく削除するには、F3 キーを使います。 タスク フィルターはタスク ビューでしか動作せず、リソース フィルターはリソース ビューでしか動作しないので、注意してください。

既存のフィルターを変更する

  1. [表示] タブの [データ] グループで、[フィルター] ボックスの一覧を選択し、[その他のフィルター] を選択します。

  2. 次のいずれかの操作を行います。

    • タスクフィルターを変更するには、[タスク] を選択し、変更するフィルターを選択して、[編集] を選択します。

    • リソースフィルターを変更するには、[リソース] を選択し、変更するフィルターを選択して、[編集] を選択します。

  3. [フィルターの定義] ダイアログボックスのコントロールを使用して、フィルターの設定を変更します。

オートフィルターを使用する

任意のシートビューで、オートフィルターをフィールドに適用することができます。 project では、標準フィルターに加えて、シートビューの各列の一番上にオートフィルターが表示されます。

オートフィルターを適用または削除する

  1. [表示] タブの [データ] グループで、フィルターリストの矢印を選択し、[オートフィルターの表示] を選択します。

  2. 表示する情報が含まれている列見出しの横にある [オートフィルター] 矢印を選び、テーブルをフィルター処理する値を選びます。
    オートフィルターの矢印とフィールドの見出しが青色に変わります。

  3. 他の列の値に基づいて追加の条件を適用するには、他の列の手順2を繰り返します。

  4. 特定の行に対するフィルターを削除するには、そのフィールドのオートフィルターリストの [すべてのフィルターをクリア] を選択します。

  5. オートフィルターをオフにするには、[オートフィルターの表示] をもう一度選びます。

    注:  ビューのいずれかの行で情報が変更された場合は、矢印を選んでフィルター処理の値を再度選ぶと、オートフィルターの設定を更新できます。

ユーザー設定のオートフィルターを作成する

  1. オートフィルターを表示する。

  2. オートフィルターの矢印を選び、[フィルター] をポイントして、[カスタム] を選びます。

  3. 最初のボックスで使用する演算子を選択し、2番目のボックスで、照合する値を入力するか選択します。

    たとえば、日付フィールド内の特定の日付に一致させるには、最初のボックスでequals演算子を選択し、2番目のボックスで一致させる日付を選択します。

  4. オートフィルターに2つの条件を適用するには、次のいずれかの操作を行います。

    • 両方の条件を満たすビューの行を表示するには、ボックスの2行目で目的の演算子と値を選び、[ and] を選びます。

    • 1つの条件または別の条件に一致する行をビューに表示するには、ボックスの2行目で目的の演算子と値を選び、またはを選びます。

  5. オートフィルターの設定を保存するには、[保存] を選びます。

    既に定義済みのフィルターが適用されているビューの場合は、オートフィルターに設定した条件が、現在のフィルターの追加条件として含まれます。 オートフィルター設定を保存すると、ファイル内の他のフィルターと共にフィルターが保存され、[その他のフィルター ] ダイアログボックスでのみ使用できるようになります。

新しいプロジェクトでオートフィルターを自動的に有効にする

  1. [ファイル] タブで、[オプション] を選択します。

  2. [詳細設定] を選び、[全般] セクションで、[新しいプロジェクトに対してオートフィルターを設定する] チェックボックスをオンにします。

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×