ユーザー設定フィルターを作成する

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに英語の記事があります。

Project では、ビューにフィルターをかけて、自分にとって最も重要なタスクやマイルストーン、その他の情報だけを表示することができます。 タスクをフィルター処理する 3 つの方法はあります。 またはプロジェクトのリソースには、タスク、およびリソースの特定の側面を表示するための定義済みのフィルターが用意されています。 これらのフィルターがない目的に合わない場合は、新しいフィルターを作成または既存のフィルターを変更できます。

  • 定義済みのフィルター    これらは、プロジェクトに付属するフィルターです。 タスクまたはタスクを完了すると、割り当て超過のリソースなどのリソースをすばやくフィルター処理するために使用します。

  • ユーザー設定フィルター    プロジェクトを所有しているをデザインするフィルターです。

  • オート フィルター    これらが点灯している場合は、[シート ビュー内の各列の上部にある矢印として表示されます。 列内のアイテムをすばやくフィルター処理するのには、これらを使用します。

この記事の内容

フィルターのタスクまたはリソース

オート フィルターを使用します。

フィルターのタスクまたはリソース

プロジェクト内で特定の種類の情報のみを表示したい場合があります。 たとえば、可能性があるプロジェクトのマイルス トーンのみを表示または開始していないタスクを参照してください。 プロジェクトにはさまざまなタスクがあり、必要な情報をフィルターと特定の範囲の情報を表示するために役立ちます。 フィルターを使用すると、興味のある情報だけを表示して、残りの部分を非表示にすることができます。

プロジェクトの定義済みのフィルターを使用して、タスクまたはリソースのデータをフィルター処理できます。 フィルターの目的に合わない場合は、新しいフィルターを作成または既存のフィルターを変更できます。

適用するか、フィルターを削除します。

  1. [表示] タブの [データ] グループで、フィルターの一覧にフィルターを選択します。

    一覧に表示されていないフィルターを適用するには、その他のフィルター] を選択し、[次のいずれかの操作します。

    • タスクのフィルターを選択するには、[タスク] を選びますフィルターリストで、フィルターの名前を選択、[適用] を選びます。

    • リソースのフィルターを選択と、[リソースを選択し、フィルターリストで、フィルターの名前を選択し、[適用] を選びます。

      注: タスク ビューには、リソース ビューにフィルターをタスクまたはリソースのフィルターを適用することはできません。

  2. 対話型フィルターを適用する場合は、指定された値を入力し、[ ok]

  3. フィルターをオフにするには、フィルターの一覧でフィルターなし] を選びます。

蛍光ペンを使用してフィルターが適用されたタスクに色を適用します。

タスクまたはリソースをフィルター処理、ときに蛍光ペンを適用できます。 強調表示されたタスクまたはリソースには、タスクのフィルター以外ではなく、別の色が表示されます。

  1. [表示] タブの [データ] グループで、フィルター一覧に、フィルターを選択し、その他のフィルターします。

  2. フィルター リストでフィルターを選択し、強調表示します。

ヒント:  強調表示されたタスクには、別の色を適用するには、別のテキスト スタイルを使用します。 書式] タブを選択し、[文字列のスタイルを選択します。 変更する項目] ボックスの一覧で強調表示されているタスクを選択し、[し、書式設定オプションを選択します。

ユーザー設定フィルターを作成する

  1. [表示] タブの [データ] グループで、フィルター] の横にある矢印をクリックし、[その他のフィルターを選択します。

    ユーザー設定フィルターを作成する方法を示す、Project のリボン

  2. タスクまたはリソース(フィルターの種類によって作成する)] を選択し、[新規作成] を選びます。

  3. 新しいフィルターの名前を入力します。 そのフィルターを [データ] グループ リストに含める場合は [メニューに表示する] を選択します。

  4. [かつ/または] 列で [かつ] を選択して、複数のフィルター条件に一致する結果を表示します。 [または] を選択すると、どれか 1 つの条件を満たす行が表示されます。

    フィルターで取得したい結果の種類に応じて [かつ] あるいは [または] を選択する。

  5. [フィールド名] 列で、フィルターをかけるフィールドを選択します。

  6. [テスト] 列で、[フィールド名] 列に選択した内容と次の手順で選択する [] 列をどのように一致させるかを指定します。

  7. [] 列で、使用する値を選択するか、または新しい値を入力します。

    [テスト] 列で [と等しい] または [と等しくない] を選んだ場合は、[] 列に (リストからオプションを選ぶ代わりに) ワイルドカード文字を入力することもできます。 たとえば、疑問符 (?) を入力すると、任意の 1 文字に一致します。 アスタリスク (*) を入力すると、任意の文字数の任意の文字に一致します。 ワイルドカードを使用する場合は、[フィールド名] 列で選んだ内容が、数値 ([期間] など) ではなく文字列 ([名前] など) を含んでいることを確認してください。

  8. 別の行をフィルターに追加する (およびに基づいてフィルター処理を別のフィールド名を選択)、[行の挿入] を選びます。 空の行を追加することにより、複数の行をグループ化できます。 空の行に [かつ] あるいは [または] を追加して、1 つのグループを別のグループに対してフィルタリングします。

  9. 完了したら、[保存] を選びます。

ヒント: すべてのフィルターをすばやく削除するには、F3 キーを使います。 タスク フィルターはタスク ビューでしか動作せず、リソース フィルターはリソース ビューでしか動作しないので、注意してください。

既存のフィルターを変更します。

  1. [表示] タブの [データ] グループで、フィルター リストを選択し、[、[その他のフィルターを選択します。

  2. 次のいずれかの操作を行います。

    • タスクのフィルターを変更するには、[タスク] を選びます、変更するフィルターを選択、し、[編集] をクリックします。

    • リソースのフィルターを変更するには、[リソース] を選びます、変更するフィルターを選択、し、[編集] をクリックします。

  3. フィルターの定義] ダイアログ ボックスで、コントロールを使用して、フィルターの設定を変更します。

オート フィルターを使用します。

任意のシート ビュー内のフィールドには、オート フィルターを適用できます。 に加えて、標準的なフィルターは、プロジェクトは、オート フィルターのシート ビュー内の各列の上部に表示されているを提供します。

適用して、オート フィルターを削除します。

  1. [表示] タブの [データ] グループで、フィルターの一覧] の矢印をクリックし、[オート フィルターの表示] を選びます。

  2. オート フィルターを表示するには、必要な情報を含む列見出しの横にある矢印をクリックし、テーブルをフィルターする値を選択します。
    オート フィルターの矢印とフィールドの見出しは青にします。

  3. 別の列の値に基づいて、追加の条件を適用するには、その他の列の手順 2 を繰り返します。

  4. 特定の行をフィルター処理するには、そのフィールドのオート フィルターの一覧ですべてのフィルターのクリア] を選びます。

  5. オート フィルターをオフにする] をもう一度表示オート フィルター ] を選びます。

    注:  ビュー内の行のいずれかで情報を変更する場合は、矢印を選んで、もう一度フィルター値を選択して、オート フィルターの設定を更新できます。

ユーザー設定のオート フィルターを作成します。

  1. オート フィルターを表示します。

  2. オート フィルターの矢印をクリックし、フィルター] をポイントし、[ユーザー設定] を選びます。

  3. 最初のボックスで使用しを入力するか、2 番目のボックスで、一致する値を選択する演算子を選択します。

    たとえば、[日] フィールドには、特定の日付を一致させるのには、最初のボックスでequals演算子を選択し、[2 番目のボックスに一致する日付を選択します。

  4. オート フィルターには、2 つの条件を適用するには、次のいずれかの操作を行います。

    • ビューの両方の条件に一致する行を表示するには、演算子と 2 行目のボックスに、目的の値を選択してを選びます。

    • ビューを 1 つの条件または別の条件を満たす行を表示するには、演算子と 2 行目のボックスに、目的の値を選択し、[または] を選びます。

  5. オート フィルター設定を保存するには、[保存] を選びます。

    ビューは、事前に定義されたフィルターが適用を既に持っている場合は、[オート フィルターを設定した条件が現在のフィルターに追加の条件として含まれます。 オート フィルターの設定を保存すると、フィルターは、ファイル内の他のフィルターと保存されは、[その他のフィルター ] ダイアログ ボックスでのみ提供されます。

新しいプロジェクトを自動的にオート フィルターを有効にします。

  1. [ファイル] タブで、[オプション] を選択します。

  2. 詳細設定] を選択し、[全般] セクションで設定オート フィルターで新しいプロジェクトのチェック ボックスをオンします。

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×