メニュー フォームが表示されない

Microsoft Office Access 2007 では、以前のバージョンの Access で作成されたデータベースを開くと、そのデータベースにメニュー フォーム (データベース内の移動に使用するボタンやリンクが付いたフォーム) が含まれている場合は、そのメニュー フォームの一部のコマンドが機能しないことがあります。特に、データベース ウィンドウを表示するコマンドが機能しなくなります。

Office Access 2007 には、ナビゲーション ウィンドウと呼ばれる新しい機能が用意されています。このペインはデータベース ウィンドウに置き換わるもので、メニュー フォームの代わりにウィンドウを使用できます。ナビゲーション ウィンドウは、Office Access 2007 で採用された新しいユーザー インターフェイス モデルで機能します。このモデル (シングル ドキュメント インターフェイス モデル) では、開いているすべてのオブジェクト (フォーム、レポートなど) が単一のウィンドウに配置され、各オブジェクトはタブに表示されます。複数のオブジェクトを開いている場合、開いているオブジェクトを切り替えるにはタブを使用します。次の図は、タブの標準的なセットを示しています。

Access 2007 データベースの [オブジェクト] タブ

メニュー フォームとは異なり、ナビゲーション ウィンドウは非表示にしない限りは表示されたままです。 ボタンの画像 (シャッター バーを開く/閉じる) を使用するか、F11 キーを押すと、ウィンドウの表示と非表示を切り替えることができます。データベースを開いたときにナビゲーション ウィンドウが既定で表示されないようにする場合は、プログラム オプションを設定します。

この記事の内容

メニュー フォーム使用時のオプション

ナビゲーション ウィンドウでオブジェクトのユーザー設定のグループを作成する

ナビゲーション ウィンドウを開く、閉じる

ナビゲーション ウィンドウを無効にする

メニュー用フォーム ビルダを使用してメニュー フォームを作成または変更する

メニュー フォーム使用時のオプション

Office Access 2007 では、メニュー フォームに対して次のいずれかの操作を実行できます。

  • ナビゲーション ウィンドウでオブジェクトのユーザー設定のカテゴリとグループを作成     特定の時点で使用する、または特定のデータベースと共に使用するテーブル、フォーム、レポート、およびその他のオブジェクトのみを含むユーザー設定のグループを作成できます。マクロを構築したり、Visual Basic for Applications (VBA) コードを記述したりしなくても、ユーザー設定のグループを作成できます。この記事の後半では、ナビゲーション ウィンドウでオブジェクトのユーザー設定のグループを作成する方法について説明しています。

    ナビゲーション ウィンドウの使用の詳細については、「ナビゲーション ウィンドウの概要」を参照してください。

  • 既存のメニュー フォームを通常どおり実行     メニュー フォームの使用の継続を選択した場合、データベース ウィンドウの表示などのサポートされていないアクションを無効にすることを検討してください。起動時にメニュー フォームが表示されるようにデータベースを構成した場合、Office Access 2007 がサポートしなくなったコマンドを除き、そのメニュー フォームは通常どおり表示されて実行されます。引き続き、メニュー用フォーム ビルダを使用してメニュー フォームの作成、変更、および削除は可能なため、この記事の後半の手順では、メニュー用フォーム ビルダの使用方法について説明します。

  • メニュー フォームとして機能するフォームを手動で作成    必要に応じて、データベース コンポーネントを起動するボタンおよび埋め込みマクロを追加して、フォームが起動時に表示されるように設定できます。

    埋め込みマクロの構築方法の詳細については、「Access 2007 マクロの基本」を参照してください。フォームの作成方法の詳細については、「フォームを作成する」を参照してください。スタートアップ フォームの設定方法の詳細については、「カレント データベース カテゴリ (Access オプション)」にある [アプリケーション オプション] セクションの [フォームの表示] オプションについての説明を参照してください。

ページの先頭へ

ナビゲーション ウィンドウでオブジェクトのユーザー設定のグループを作成する

ユーザー設定のグループは、Office Access 2007 のメニュー フォームとデータベース ウィンドウの両方に相当し、それらに置き換わるものです。ユーザー設定のグループを作成する処理は、次のような手順になります。

  • まず、ユーザー設定のカテゴリを作成します。[ユーザー設定] というカテゴリが自動的に作成されます。そのカテゴリの名前を変更して、必要に合わせてグループを追加または削除できます。または、いつでも新しいカテゴリを作成できます。

  • 新しいカテゴリを作成したら、そのカテゴリのグループを 1 つまたは複数作成します。

  • [ナビゲーション オプション] ダイアログ ボックスを閉じ、ナビゲーション ウィンドウで、ユーザー設定のグループに割り当てるデータベース オブジェクトをドラッグするか、コピーして貼り付けます。オブジェクトの設定全体は、[割り当てられていないオブジェクト] と呼ばれるグループに存在します。ユーザー設定のカテゴリを作成すると、そのグループが自動的に作成されます。

    注: ユーザー設定のグループにデータベース オブジェクトを追加すると、そのオブジェクトへのショートカットが作成されます。オブジェクト自体は移動またはコピーされません。ユーザー設定のグループ内のショートカットの名前変更や削除を行っても、それらの変更はオブジェクト自体には適用されず、そのオブジェクトのショートカットにだけ適用されます。

  • ユーザー設定のグループまたはグループを作成し終わったら、表示しない [割り当てられていないオブジェクト] グループや他のグループを非表示にできます。

ユーザー設定のカテゴリを作成する

  1. ナビゲーション ウィンドウの上部でメニューを右クリックし、[ナビゲーション オプション] をクリックします。

  2. [ナビゲーション オプション] ダイアログ ボックスの [カテゴリ] ウィンドウの下で、[項目の追加] をクリックします。新しいカテゴリがセクションに表示されます。次の図は、新しいユーザー設定のカテゴリが表示された [カテゴリ] ウィンドウを示しています。

    ナビゲーション ウィンドウの新しいユーザー設定のカテゴリ

  3. 新しいカテゴリの名前を入力し、Enter キーを押します。

    可能であれば、データベースを使用する人がわかりやすい名前を付けてください。名前を付けたら、[のグループ] セクションの標題がその名前に合わせて変更されている点に注意してください。たとえば、新しいカテゴリに "My Switchboard" という名前を付けた場合、標題は ["My Switchboard" のグループ] となります。さらに、[のグループ] セクションに [割り当てられていないオブジェクト] というグループが含まれていることにも注意してください。このグループは既定で作成されます。このグループには、データベース内のすべてのオブジェクトが含まれており、このグループのオブジェクトを使用してユーザー設定のグループを作成します。

ユーザー設定のカテゴリを作成したら、そのカテゴリのグループを 1 つまたは複数作成します。作成できるグループ数に制限はありません。[ナビゲーション オプション] ダイアログ ボックスを開いたままにし、次の手順に従ってください。

ユーザー設定のグループを作成する

  1. [のグループ] セクションの下で、[グループの追加] をクリックし、グループの名前を入力して Enter キーを押します。この処理は、必要なだけ繰り返すことができます。たとえば、"My Switchboard" には 3 つのグループ (Data Entry Forms、Reports、および Queries) を含めることができます。ユーザーの必要や自分の好みによって、この段階で追加するグループが決まります。

  2. [割り当てられていないオブジェクト] の横にあるチェック ボックスをオンのままにし、[OK] をクリックします。[ナビゲーション オプション] ダイアログ ボックスが閉じ、新しいユーザー設定のグループがナビゲーション ウィンドウに追加されますが、新しいグループは表示されません。

  3. 次の手順に従って、新しいグループを表示し、オブジェクトをグループに追加します。

ユーザー設定のグループにオブジェクトを追加する

  1. ナビゲーション ウィンドウの上部にあるメニューをクリックし、新しいカテゴリをクリックします。カテゴリに作成されたグループが、[割り当てられていないオブジェクト] グループと共にメニューに表示されます。

  2. [割り当てられていないオブジェクト] で、ユーザー設定のグループで使用する項目を選択し、それらをそのグループに移動します。選択した項目を移動する方法にはいくつかあります。

    • 項目を個別にドラッグ アンド ドロップする。

    • Ctrl キーを押しながら複数の項目をクリックして、それらをユーザー設定のグループにドラッグする。

    • 選択された項目のいずれかを右クリックし、[グループに追加] をポイントしてユーザー設定のグループの名前をクリックする。

完了したら、ナビゲーション ウィンドウで [割り当てられていないオブジェクト] グループを表示したままにしたり、非表示にしたりできます。

[割り当てられていないオブジェクト] グループを非表示にする

  1. ナビゲーション ウィンドウの上部でメニューを右クリックし、[ナビゲーション オプション] をクリックします。

  2. [<カテゴリ> のグループ] ウィンドウで、[割り当てられていないオブジェクト] チェック ボックスをオフにします。

既存のユーザー設定のグループ内のオブジェクトを使用して新しいユーザー設定のグループを作成する

注: この方法を使用するには、前のセクションの手順に従って、まずユーザー設定のカテゴリを作成し、次にグループ オブジェクトを作成します。

  1. ナビゲーション ウィンドウでユーザー設定のカテゴリとグループが開いた状態で、新しいグループに配置するオブジェクトを右クリックします。

  2. [グループに追加] をポイントし、[新しいグループ] をクリックします。

    新しいグループがナビゲーション ウィンドウに表示されます。次の図は、標準的な新しいグループを示しています。

    ナビゲーション ウィンドウの新しいユーザー設定のグループ

  3. 新しいグループの名前を入力して Enter キーを押し、必要に応じて追加のショートカットを新しいグループにドラッグします。

ページの先頭へ

ナビゲーション ウィンドウを開く、閉じる

既定では、ナビゲーション ウィンドウは Office Access 2007 でデータベース (以前のバージョンの Access で作成されたデータベースを含む) を開いたときに表示されます。次の一連の手順は、各アクションを行う方法を示しています。

ウィンドウの表示と非表示を切り替える

  • ナビゲーション ウィンドウの [シャッター バーを開く/閉じる] をクリックします。

    ボタンの画像

    ショートカット キーの使用  F11 キーを押します。

注: ナビゲーション ウィンドウが非表示の場合は、縦方向の [ナビゲーション ウィンドウ] というテキストをクリックしても表示できます。

ページの先頭へ

ナビゲーション ウィンドウを無効にする

注: ナビゲーション ウィンドウは、フォーム、従来のメニュー フォーム、またはデータベース内のオブジェクトを起動する方法が他にある場合のみ非表示にすることをお勧めします。

ナビゲーション ウィンドウが既定で表示されないようにする

  1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックし、[Access のオプション] をクリックします。

    [Access のオプション] ダイアログ ボックスが表示されます。

  2. [カレント データベース] をクリックし、[ナビゲーション] の下の [ナビゲーション ウィンドウを表示する] チェック ボックスをオンまたはオフにします。このオプションは既定ではオンになっています。

詳細情報

ナビゲーション ウィンドウの使用の詳細については、「ナビゲーション ウィンドウの概要」を参照してください。

ページの先頭へ

メニュー用フォーム ビルダを使用してメニュー フォームを作成または変更する

メニュー フォームをすばやく簡単に作成する必要がある場合は、メニュー用フォーム ビルダを使用します。操作を行う際には、メニュー フォームが常に表示されているとは限らず (その他のウィンドウによって、メニュー フォームが非表示になる可能性がある)、ナビゲーション ウィンドウとは異なり、新しいシングル ドキュメント作業モデルをサポートしていないことに留意してください。

次のセクションの各手順では、メニュー フォームの作成、カスタマイズ、および削除の方法について説明します。

メニュー フォームを作成する

  1. [データベース ツール] タブの [データベース ツール] で [メニュー用フォーム ビルダ] をクリックします。

    注: メニュー フォームを作成するかどうかを確認するメッセージが表示された場合は、[はい] をクリックします。

  2. [新規作成] をクリックします。

    [新規作成] ダイアログ ボックスが表示されます。

  3. 新しいメニュー フォームの名前を入力し、[OK] をクリックします。

    [メニュー名] ボックスの一覧にメニュー フォームが追加されます。

  4. 新しいメニュー フォームをクリックし、[編集] をクリックします。

    [メニュー用フォームの編集] ダイアログ ボックスが表示されます。

  5. [新規作成] をクリックします。

    [メニュー項目の編集] ダイアログ ボックスが表示されます。

  6. [テキスト] ボックスに最初のメニュー フォームの名前を入力し、[コマンド] ボックスの一覧からコマンドを選択します。

    たとえば、[テキスト] ボックスに「Customer Data」と入力し、[コマンド] ボックスの一覧の [追加モードでフォームを開く] をクリックします。

    注: 他のメニュー フォームに分岐するメニュー フォームを作成するには、[コマンド] ボックスの一覧の [別のメニューに移動する] をクリックし、一覧からメニュー フォームを選択するか、他のメニュー フォームの名前を入力します。

  7. 選択したコマンドに応じて、[コマンド] ボックスの一覧の下に別の一覧が表示されます。たとえば、[レポートを開く] をクリックした場合、開いているデータベースのレポートの一覧が表示されます。必要に応じて、この一覧から項目を選択します。

  8. 手順 5. ~ 7. を繰り返してすべての項目をメニュー フォームに追加し、メニュー フォームの作成が完了したら [閉じる] をクリックします。

注: 

  • データベースを開いたときにメニュー フォームが開くようにするには、[メニュー用フォーム ビルダ] ダイアログ ボックスでメニュー フォーム名をクリックし、[既定にする] をクリックします。

  • メニュー用フォーム ビルダを使用してメニュー フォームを作成すると、フォームに表示されるボタンと処理内容を表す Switchboard Items テーブルが作成されます。メニュー フォームを手動で変更すると、アプリケーションが機能しなくなる可能性があります。

メニュー フォームを変更する

  1. [データベース ツール] タブの [データベース ツール] で [メニュー用フォーム ビルダ] をクリックします。

  2. [メニュー用フォーム ビルダ] ダイアログ ボックスで、編集するメニュー フォームを選択し、[編集] をクリックします。

  3. 変更するメニュー フォームの項目をクリックし、次のいずれかの操作を行います。

    項目のテキスト、項目により実行されるコマンド、項目をクリックしたときに開く (または実行される) オブジェクトを変更するには、[編集] をクリックします。

    項目を追加するには、[新規作成] をクリックし、項目のテキストを入力し、[コマンド] ボックスでコマンドをクリックします。クリックしたコマンドに応じて、[コマンド] ボックスの下に別のボックスが表示されます。必要に応じて、このボックスの項目をクリックします。たとえば、[コマンド] ボックスでフォーム コマンドの 1 つをクリックした場合は、開くフォームの名前をクリックします。

    項目を削除するには、[削除] をクリックします。

    項目を移動するには、[上に移動] または [下に移動] をクリックします。

  4. メニュー フォームの変更が完了したら、[閉じる] をクリックします。

メニュー フォームを削除する

  1. [データベース ツール] タブの [データベース ツール] で [メニュー用フォーム ビルダ] をクリックします。

  2. [メニュー用フォーム ビルダ] ダイアログ ボックスで、削除するメニュー フォームを選択し、[削除] をクリックします。

  3. [閉じる] をクリックします。

ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×