スキップしてメイン コンテンツへ

マクロ プロジェクトにデジタル署名を追加する

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに英語の記事があります。

この記事では、証明書 を使用して マクロ プロジェクト にデジタル署名を行う方法について説明します。 デジタル証明書を持っていない場合は、取得する必要があります。 自分のコンピューターでマクロ プロジェクトをテストするために、SelfCert.exe ツールを使用して、独自の自己署名証明書を作成することも可能です。

デジタル証明書は、商用証明機関 (CA)、または社内のセキュリティ管理者や情報技術 (IT) 担当者から取得することができます。

Microsoft 製品を対象としたサービスを提供する証明機関の詳細については、「Microsoft ルート証明書プログラムのメンバー」の一覧を参照してください。

ユーザーが作成するデジタル証明書は、正式な信頼できる証明機関から発行されるものではないため、そのような証明を使って署名されたマクロ プロジェクトは自己署名のプロジェクトと呼ばれます。 Microsoft Office で自己署名証明書が信頼されるのは、自己署名証明書がコンピューターの [証明書 - 現在のユーザー] ストアの [信頼されたルート証明機関] に追加されている場合のみです。

自己署名証明書の作成方法については、次のセクションを参照してください。

  1. C:\Program Files (x86) \Microsoft Office\root\Office16します。

  2. SelfCert.exe をクリックします。 [デジタル証明書の作成] ボックスが表示されます。

  3. [証明書の名前] ボックスに、証明書のわかりやすい名前を入力します。

  4. [OK] をクリックします。

  5. [SelfCert 成功] というメッセージが表示されたら、[OK] をクリックします。

  1. C:\Program Files\Microsoft Office\<Office のバージョン>\ に移動します。

  2. SelfCert.exe をクリックします。 [デジタル証明書の作成] ボックスが表示されます。

  3. [証明書の名前] ボックスに、証明書のわかりやすい名前を入力します。

  4. [OK] をクリックします。

  5. [SelfCert 成功] というメッセージが表示されたら、[OK] をクリックします。

  1. [スタート] ボタン、[すべてのプログラム] をポイントMicrosoft Office] をクリックしておよびMicrosoft Office ツール] をクリックし、[ VBA プロジェクトのデジタル証明書] をクリックします。
    [デジタル証明書の作成] ボックスが表示されます。

  2. [証明書の名前] ボックスに、証明書のわかりやすい名前を入力します。

  3. [OK] をクリックします。

  4. [SelfCert 成功] というメッセージが表示されたら、[OK] をクリックします。

[デジタル証明書の作成] ダイアログ

個人証明書ストアで証明書を確認するには、次の操作を行います。

  1. Internet Explorer を開きます。

  2. [ツール] メニューの [インターネット オプション] をクリックし、[コンテンツ] タブをクリックします。

  3. [証明書] をクリックし、[個人] タブをクリックします。

  1. 署名するマクロ プロジェクトが含まれたファイルを開きます。

  2. [開発] タブの [コード] で [Visual Basic] をクリックします。

    注: [開発] タブが表示されていない場合は、[ファイル] タブをクリックします。 [オプション] をクリックします。 [リボンのユーザー設定] をクリックします。 [リボンのユーザー設定] の一覧で、[開発] をクリックし、[OK] をクリックします。

  3. Visual Basic で、[ツール] メニューの [デジタル署名] をクリックします。

  4. [デジタル署名] ダイアログが表示されます。

  5. 証明書を選択し、[OK] をクリックします。

    注: デジタル証明書を選択していない場合や、別のデジタル証明書を使用する場合は、[選択] をクリックします。 証明書を選択し、[OK] をクリックします。

    注: 

    • マクロのみソリューションのテストが完了し、分布の準備ができるように署名することをお勧めします。 署名されたマクロ プロジェクト内のコードの変更方法、デジタル署名は削除されます。 ただし場合は、コンピューター上のプロジェクトに署名を使用していた有効なデジタル証明書がある場合は、マクロ プロジェクトが自動的に再署名を保存するとします。

    • ソリューションのユーザーが誤ってマクロ プロジェクトを変更したり、署名を無効にしたりするのを防ぐには、プロジェクトをロックしてからマクロ プロジェクトに署名します。 デジタル署名は、プロジェクトが署名後に改ざんされていないことを署名者が保証するためのものです。 デジタル署名はプロジェクトの作成者を証明するものではありません。 したがって、マクロ プロジェクトをロックしても、別のユーザーがデジタル署名を他の署名に置き換えるのを防ぐことはできません。 企業の管理者は、ユーザーがコンピューターで実行するマクロを管理できるように、テンプレートとアドインに再署名できます。

    • マクロ プロジェクトにコードを追加するアドインを作成する場合、プロジェクトがデジタル署名されているかどうかを判別し、処理を続行する前に、そのユーザーに、署名されているプロジェクトを変更した場合の結果を通知できるようにしておくことが必要です。

    • マクロにデジタル署名する際に時刻のスタンプを入手場合は、署名の証明書の有効期限が切れた、または後に、署名が取り消されました、他のユーザーが、署名を検証することができます。 時刻のスタンプをせずにマクロをサインインしている場合、署名は、証明書の有効期間中に有効なは残ります。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×