マクロを記録する

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。簡単に参照できるように、こちらに英語の記事があります。

Microsoft Office Project で同じ作業を繰り返し実行する場合は、マクロを使って作業を自動化すると便利です。マクロとは、モジュールに保存される一連のコマンドおよび関数で、作業中にいつでも実行できます。

  1. [表示] タブの [マクロ] をクリックし、[マクロの記録] をクリックします。

    (Project 2007 では、[ツール] メニューの [マクロ] をポイントし、[新しいマクロの記録] をクリックします。

  2. [マクロ名] ボックスにマクロの名前を入力します。

    マクロ名の先頭は文字である必要があります。2 番目以降の文字には、文字、数字、またはアンダースコア (_) を使用できます。スペースは使用できません。マクロ名を単語で区切るときはアンダースコアを使用します。

  3. ショートカット キーを使ってマクロを実行するには、[ショートカット キー] ボックスに半角のアルファベットまたはキーの組み合わせを入力します。

    ショートカット キーには、Ctrl + 文字キーまたは Ctrl + Shift + 文字キーを使用できます。文字キーはキーボード上の任意のアルファベット キーです。ショートカット キーに数字や特殊文字は使用できません。Microsoft Office Project で既に使用されているキーの組み合わせを指定することはできません。

  4. [マクロの保存先] ボックスの一覧から、マクロを保存する場所を選択します。

    • Project を使用中、常にそのマクロを実行できるようにするには、[グローバル ファイル] をクリックします。

    • 現在のプロジェクトでのみマクロを使用できるようにするには、[作業中のプロジェクト] をクリックします。

  5. マクロに説明を付けるには、[説明] ボックスに説明を入力します。

  6. マクロでは列 (フィールド) の位置が絶対参照で記録されるため、マクロを使ってセルを選択すると、アクティブ セルの位置にかかわらず常に同じ列が選択されます。マクロを記録するときに、アクティブ セルの位置に関係する列を選択する場合は、[列の参照形式] の [相対参照] をクリックします。

    反対に、マクロでは行の位置が相対参照で記録されるため、マクロを使ってセルを選択すると、アクティブ セルの位置に関係する行が選択されます。マクロを実行するときに、アクティブ セルの位置に関係なく行を選択する場合は、[行の参照形式] の [絶対参照 (ID)] をクリックします。

    注: これらの設定は、その設定自体を変更するか Project を閉じるまでの間、マクロ記録中に使用され続けます。

  7. [OK] をクリックし、マクロに記録する操作を行います。

  8. 記録するすべての操作を完了したら、[表示] タブの [マクロ] をクリックし、[レコーディングの停止] をクリックします。

    (Project 2007 では、[ツール] メニューの [マクロ] をポイントし、[レコーディングの停止] をクリックします。

セキュリティ メモ: マクロにはウイルスが含まれていることがあるので、実行する場合は十分に注意してください。実行する場合は、コンピューターで最新のウイルス対策ソフトウェアを実行する、マクロのセキュリティ レベルを高に設定する、[組み込み済みのアドインとテンプレートをすべて信頼する] チェック ボックスをオフにする、デジタル署名を使用する、信頼できる発行元のリストを保持するという予防策を講じてください。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×