マクロを記録する

Microsoft Office Project で繰り返しタスクを実行する場合は、マクロを使用してタスクを自動化できます。 マクロとは、 モジュール に保存され、タスクを実行する必要があるときにいつでも実行できる一連のコマンドと関数のことです。

  1. [表示] タブで、[マクロ]、[マクロの記録] の順に選択します。

    (Project 2007 の場合は、[ツール] メニューの [マクロ] をポイントし、[新しいマクロの記録] を選択します)。

  2. [マクロ名] ボックスに、 マクロの名前を入力します。

    2 番目以降の文字には、文字、数字、またはアンダースコア (_) を使用できます。 その他の文字には、文字、数字、またはアンダースコア文字を使用できます。 空白スペースはマクロ名に使用できませんが、アンダースコアは単語の区切り文字として適切に機能します。

  3. ショートカット キーを押してマクロを実行できるようにするには、[ショートカットキー ] ボックスに文字またはキーの組み合わせを入力します。

    CTRL キーを押しながら文字 (小文字) または CTRL キーと SHIFT キーを押しながら文字 (大文字の場合) を使用できますが、文字はキーボード上の文字キーですが、数字や特殊文字は使用できません。 Microsoft Office Project で既に使用されているキーの組み合わせを使用することはできません。

  4. [マクロの保存先] ボックスの一覧で、マクロを保存する場所を選択します。

    • Project を使用するときに常にマクロを使用できるようにするには、[グローバルファイル] を選択します。

    • 現在のプロジェクトでのみマクロを使用できるようにするには、[このプロジェクト] を選択します。

  5. マクロの説明を含めるには、[説明] ボックスに説明を入力します。

  6. マクロの記録中にセルを選択すると、列への絶対参照が記録されるため、マクロは、最初に選択されたセルに関係なく、同じ列 (フィールド) を実行するたびに選択します。 マクロを実行したときにアクティブセルの位置に関係なく列が選択されるようにするには、[列参照] の [相対参照] を選択します。

    逆に、マクロでは行の相対的な参照が記録されるため、マクロを実行しても、アクティブセルの位置に関係なく行が選択されます。 マクロで常に同じ行を選択する場合は、最初に選択されているセルに関係なく、[行の参照] の下の [絶対 (ID) ] を選択します。

    注: Project では、設定を変更するか Project を閉じるまで、マクロの記録中にこれらの設定を使い続けることができます。

  7. [ OK] を選択し、記録する操作を実行します。

  8. 記録するすべての操作を完了したら、[表示] タブで [マクロ] を選択し、[記録終了] を選択します。

    (Project 2007 の場合は、[ツール] メニューの [マクロ] をポイントして、[記録終了] を選択します)。

セキュリティ メモ: マクロにはウイルスが含まれていることがあるので、実行する場合は十分に注意してください。 実行する場合は、コンピューターで最新のウイルス対策ソフトウェアを実行する、マクロのセキュリティ レベルを高に設定する、[組み込み済みのアドインとテンプレートをすべて信頼する] チェック ボックスをオフにする、デジタル署名を使用する、信頼できる発行元のリストを保持するという予防策を講じてください。

注:  このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 情報が役に立ったかどうか、ご意見をお寄せください。 参考までに、こちらから英語の記事をお読みいただけます。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×