マクロを作成、実行、編集、または削除する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

頻繁に行う作業で時間を節約するために、そのような作業の手順をマクロとして記録できます。その後、記録した作業を実行するとき、マクロを有効にすれば、ユーザーに代わって記録された手順を実行します。

Word

Word 2016 for Mac のマクロを作成するキーボード ショートカットが、マクロを実行して不要になったマクロを削除します。

  1. [表示]、[マクロ]、[マクロの記録] の順にクリックします。

    [表示] タブで [マクロ] をクリックし、[マクロの記録] をクリックしてマクロの作成を開始します。
  2. マクロの名前を入力するか、Word が提案した名前をそのまま利用します。

    [マクロ名] にマクロの名前を入力するか、Word により提供される汎用の名前を使用します。
  3. 作成した新しい文書でこのマクロを使用するには、[マクロの保存先] 一覧で [すべての文書 (Normal)] が選択されていることを確認します。

  4. [キーボード] をクリックし、マクロにキーの組み合わせを割り当てます。

    Word に [キーボードのユーザー設定] ダイアログ ボックスが表示されます。

  5. [新しいショートカット キーを押してください] ボックスにキーの組み合わせを入力します。

    Word では、キーの組み合わせにコマンドやマクロがあらかじめ割り当てられている場合は、そのキーの組み合わせを押すと、コマンドやマクロが表示されます。

    キーの組み合わせを押すと、そのキーの組み合わせに現在割り当てられているコマンドやアクションがあれば、それが Word に表示されます。

  6. 選択したキーの組み合わせが既に割り当てられている場合、[新しいショートカット キーを押してください] からその組み合わせを削除し、新しい組み合わせを選択してください。

    割り当てられていないキーの組み合わせが見つかったら、次の手順に進みます。

    Word では、コマンドまたはマクロに割り当てられていないキーの組み合わせが押されたことが認識されます。
  7. 新しい文書でこのキーボード ショートカットを使用するには、[変更の保存先] 一覧でグローバル テンプレートの [Normal.dotm] を選択します。

    [Normal.dotm] を選択して、作成した新しいドキュメントでマクロが利用できるようにします。
  8. [割り当て] をクリックします。

  9. マクロを記録する準備ができたら、[OK] をクリックします。

  10. コマンドをクリックするか、タスクの各手順のキーを押します。

    Word はクリックとキーボード操作を記録しますが、マウスで選択したテキストは記録しません。マクロを記録しながらテキストを選択するには、キーボードを使用します。

  11. 記録を停止するには、[表示]、[マクロ]、[記録終了] の順にクリックします。

    マクロの記録を停止するには、[マクロ] メニューの [記録の終了] をクリックします。

マクロを実行するには、割り当てられているショートカット キーを押すか、[マクロ] 一覧からマクロを実行します。

  1. [表示]、[マクロ]、[マクロの表示] の順にクリックします。

    [マクロの表示] をクリックして、現在のドキュメントに関連付けられているマクロの表示および編集を行います。
  2. [マクロ名] にあるリストで、実行するマクロを選択します。

  3. [実行] をクリックします。

    マクロ名でマクロ選択した後、[実行] をクリックしてマクロを実行します。

  1. [表示]、[マクロ]、[マクロの表示] の順にクリックします。

    [マクロの表示] をクリックして、現在のドキュメントに関連付けられているマクロの表示および編集を行います。
  2. [マクロの保存先] に指定されている場所に削除するマクロの場所が含まれていることを確認します。

    マクロ一覧から表示したいマクロの場所を選択します。

    この一覧には現在のウィンドウで開いている文書、グローバル テンプレート、Word コマンドが含まれます。

  3. [マクロ名] で、削除するマクロを選択し、一覧の下の [-] 記号をクリックします。

    削除するマクロを選択し、一覧の下の [-] 記号をクリックします。
  4. Word がマクロの削除の確定を求めたら、[はい] をクリックします。

Excel

Excel 2016 for Mac でマクロを作成するキーボード ショートカットが、マクロを実行してマクロを削除する必要がなくなったをします。

マクロを記録するときに、マクロ記録レコードすべての手順に必要を実行するマクロを実行するアクションです。次の手順では、テキストまたはセルまたはワークシートのセルを選択するコマンドをリボンやメニューの書式、セル、行、または列を選択して、マウスをドラッグをクリックすると数値の入力を含めることができます。

注: 記録、作成すると、マクロと、その他の高度な機能を削除するコマンドをリボンの[開発] タブにも利用します。詳細については、[開発] タブを使用して、 [開発] タブを作成または削除する Excel 2016 for Mac のマクロを使用するを参照してください。

  1. ツールを選択する >マクロ>新しいレコード

    [ツール]、[マクロ]、[新しいマクロを記録します。

  2. [マクロ名] ボックスにマクロ名を入力します。

    マクロの名前、場所、およびショートカット キーを入力します。

  3. マクロのキーボード ショートカットを作成するには、 Option + Cmd ] ボックスに文字を入力します。

  4. ドロップダウン リストから、マクロの保存場所を選択します。

    マクロを保存するには

    クリックする対象

    文書で、マクロを作成します。

    作業中のブック

    開いているすべてのドキュメントに保存する

    新しいブック

    Excel で常にこのマクロを使用できるようにする

    個人用マクロ ブック

  5. (オプション)マクロの説明を追加します。

  6. 記録する準備ができたら、[ OKを] をクリックします。

  7. コマンドをクリックするか、タスクの各手順のキーを押します。

  8. 記録を停止するには、 [ツール] >マクロ>記録終了します。(この手順はいないマクロに記録する。)

    レコーディングの停止] を選択

マクロを実行するにはに割り当てられているショートカット キーを押すか、[マクロ] ダイアログ ボックスで、マクロを実行します。

  1. [表示] タブの [マクロの表示] をクリックします。

  2. ポップアップ メニューで [マクロ] をクリックし、 [このブックを選択します。

  3. 一覧からマクロを選び、[実行] をクリックします。

    Excel for Mac の [マクロ] ダイアログ

  1. ツールを選択する >マクロ>マクロ

    マクロを選択し、[マクロ] を選びます

  2. 削除するマクロを選択し、マイナス記号キーを押します。

    マクロ名を選択し、マイナス記号を選択

  3. 確認メッセージが表示されます。[はい削除を確定する] をクリックします。

    削除を確認します。

[開発] タブからマクロを削除することもできます。

  1. [開発] タブで、[マクロ] をクリックします。

  2. 一覧で、削除するマクロをクリックし、削除ボタンをクリックします。

    マクロを選んでマイナス記号をクリックして削除する

Word

繰り返し行う操作を自動化するため、Word で簡単にマクロを作成することができます。 また、Microsoft Visual Basic for Applications の Visual Basic エディター を使用すると、独自のマクロ スクリプトを記述したり、マクロの一部または全部を新しいマクロにコピーしたりすることができます。

マクロを記録するアクションを実行するマクロを完了するために必要なすべての手順が記録されます。ただし、記録を停止する] タブに戻り、ナビゲーションは記録の手順では含まれません。

  1. [開発] タブで、[Visual Basic] の [記録] をクリックします。

    Word の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. [マクロ名] ボックスにマクロ名を入力します。

  3. [マクロの保存先] ポップアップ メニューで次のいずれかの項目をクリックします。

    マクロの保存方法

    クリックする対象

    現在マクロを作成しているドキュメントに保存する

    [ドキュメント名] (ドキュメント)

    開いているすべてのドキュメントに保存する

    すべてのドキュメント (標準)

  4. [OK] をクリックして、記録する操作を実行します。

  5. [開発] タブで、[Visual Basic] の [停止] をクリックします。

組み込みの Visual Basic Editor を使用してマクロを作成することができます。

  1. [開発] タブで、[Visual Basic] の [エディター] をクリックします。

    Word の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. モジュールを挿入する必要がある場合は、Visual Basic Editor で [挿入] メニューの [モジュール] をクリックします。

  3. モジュールのコード ウィンドウで、使用するマクロ コードを入力または貼り付けます。

  4. 終了したら、[Word] メニューの [終了して Microsoft Word へ戻る] をクリックします。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    Word の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧で、実行するマクロをクリックし、[実行] をクリックします。

マクロを編集するには、Visual Basic エディター を使用します。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    Word の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧で、編集するマクロをクリックし、[編集] をクリックします。

    Visual Basic Editor が開きます。

  3. 必要な変更を行います。

  4. 終了したら、[Word] メニューの [終了して Microsoft Word へ戻る] をクリックします。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    Word の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧でコピー元のマクロをクリックし、[編集] をクリックします。

    Visual Basic Editor が開きます。

  3. Visual Basic Editor のコード ウィンドウで、マクロのコピーする行を選びます。

    ヒント: マクロ全体をコピーする場合は、Sub 行と End Sub 行も選びます。

  4. [編集] メニューの [コピー] をクリックします。

  5. コード ウィンドウの [プロジェクト] ボックスで、コード配置先モジュールをクリックします。

  6. [編集] メニューの [貼り付け] をクリックします。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    Word の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧で、削除するマクロをクリックし、[削除] をクリックします。

PowerPoint

繰り返しの作業を自動化するには、PowerPoint でのマクロを作成するのにはアプリケーションの Visual Basic を使用することができます。

組み込みの Visual Basic Editor を使用してマクロを作成することができます。

  1. [開発] タブで、[Visual Basic] の [エディター] をクリックします。

    PowerPoint の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. モジュールを挿入する必要がある場合は、Visual Basic Editor で [挿入] メニューの [モジュール] をクリックします。

  3. モジュールのコード ウィンドウで、使用するマクロ コードを入力または貼り付けます。

  4. 終了したら、[PowerPoint] メニューの [終了して Microsoft PowerPoint へ戻る] をクリックします。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    PowerPoint の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧で、実行するマクロをクリックし、[実行] をクリックします。

マクロを編集するには、Visual Basic エディター を使用します。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    PowerPoint の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧で、編集するマクロをクリックし、[編集] をクリックします。

    Visual Basic Editor が開きます。

  3. 必要な変更を行います。

  4. 終了したら、[PowerPoint] メニューの [終了して Microsoft PowerPoint へ戻る] をクリックします。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    PowerPoint の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧でコピー元のマクロをクリックし、[編集] をクリックします。

    Visual Basic Editor が開きます。

  3. Visual Basic Editor のコード ウィンドウで、マクロのコピーする行を選びます。

    ヒント: マクロ全体をコピーする場合は、Sub 行と End Sub 行も選びます。

  4. [編集] メニューの [コピー] をクリックします。

  5. コード ウィンドウの [プロジェクト] ボックスで、コード配置先モジュールをクリックします。

  6. [編集] メニューの [貼り付け] をクリックします。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    PowerPoint の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧で、削除するマクロをクリックし、[削除] をクリックします。

Excel

繰り返し行う操作を自動化するため、Excel で簡単にマクロを作成することができます。 また、Microsoft Visual Basic for Applications の Visual Basic エディター を使用すると、独自のマクロ スクリプトを記述したり、マクロの一部または全部を新しいマクロにコピーしたりすることができます。

マクロで実行する操作の完了に必要なすべてのステップが記録されます。 なお、記録を終了するための操作は記録されません。

  1. [開発] タブで、[Visual Basic] の [記録] をクリックします。

    Excel の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. [マクロ名] ボックスにマクロ名を入力します。

    ヒント: このマクロのショートカット キーを作成するには、[Option+Cmd+] ボックスに文字を入力します。

  3. [マクロの保存先] ポップアップ メニューで次のいずれかの項目をクリックします。

    マクロの保存方法

    クリックする対象

    現在マクロを作成しているドキュメントに保存する

    作業中のブック

    開いているすべてのドキュメントに保存する

    新しいブック

    Excel で常にこのマクロを使用できるようにする

    個人用マクロ ブック

    個人用マクロ ブックにあるユーザー/ユーザー名/ライブラリ/アプリケーション サポート/Microsoft/Office/Excel です。

  4. [OK] をクリックして、記録する操作を実行します。

  5. [開発] タブの [Visual Basic] の [記録] をもう一度クリックします。

組み込みの Visual Basic Editor を使用してマクロを作成することができます。

  1. [開発] タブで、[Visual Basic] の [エディター] をクリックします。

    Excel の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. モジュールを挿入する必要がある場合は、Visual Basic Editor で [挿入] メニューの [モジュール] をクリックします。

  3. モジュールのコード ウィンドウで、使用するマクロ コードを入力または貼り付けます。

  4. 終了したら、[Excel] メニューの [終了して Microsoft Excel へ戻る] をクリックします。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    Excel の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧で、実行するマクロをクリックし、[実行] をクリックします。

    ヒント: ショートカット キーを使用してマクロを実行するには、Option + コマンド + <ショートカット キー作成時に入力した文字> を押します。

マクロを編集するには、Visual Basic エディター を使用します。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    Excel の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧で、編集するマクロをクリックし、[編集] をクリックします。

    Visual Basic Editor が開きます。

  3. 必要な変更を行います。

  4. 終了したら、[Excel] メニューの [終了して Microsoft Excel へ戻る] をクリックします。

この手順を完了すると、このマクロを含むブックを開いたときにマクロが自動実行されるようになります。

  1. [開発] タブで、[Visual Basic] の [記録] をクリックします。

    Excel の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. [マクロ名] ボックスに「Auto_Open」と入力します。

  3. [マクロの保存先] ポップアップ メニューで次のいずれかの項目をクリックします。

    マクロの保存方法

    クリックする対象

    現在マクロを作成しているドキュメントに保存する

    作業中のブック

    開いているすべてのドキュメントに保存する

    新しいブック

    Excel で常にこのマクロを使用できるようにする

    個人用マクロ ブック

  4. [OK] をクリックして、記録する操作を実行します。

  5. [開発] タブの [Visual Basic] の [記録] をもう一度クリックします。

  6. [ファイル] メニューの [名前を付けて保存] をクリックします。

  7. [形式] ポップアップ メニューで [Excel マクロ有効ブック (.xlsm)] をクリックし、[保存] をクリックします。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    Excel の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧でコピー元のマクロをクリックし、[編集] をクリックします。

    Visual Basic Editor が開きます。

  3. Visual Basic Editor のコード ウィンドウで、マクロのコピーする行を選びます。

    ヒント: マクロ全体をコピーする場合は、Sub 行と End Sub 行も選びます。

  4. [編集] メニューの [コピー] をクリックします。

  5. コード ウィンドウの [プロジェクト] ボックスで、コード配置先モジュールをクリックします。

  6. [編集] メニューの [貼り付け] をクリックします。

  1. [開発] タブで、[Visual Basic] の [マクロ] をクリックします。

    Excel の [開発] タブの [Visual Basic] グループ

    [開発] タブが使用できない場合

    1. リボンの右側にある アクション ポップアップ メニュー をクリックし、[リボンの環境設定] をクリックします。

    2. [ユーザー設定] の [開発] チェック ボックスをオンにします。

  2. 一覧で、削除するマクロをクリックし、[削除] をクリックします。

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×