プロジェクト内のタスクをリンクする

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに英語の記事があります。

プロジェクト内の任意の2つのタスクをリンクして、その関係 (タスクの依存関係とも呼ばれます) を示すことができます。 プロジェクトスケジュールの依存関係: タスクをリンクすると、先行タスクに加えたすべての変更は後続タスクに影響し、次のタスクに影響します。

目的に合ったトピックをクリックしてください

リンク タスク

  1. [>ガントチャート表示] を選びます。

    [表示] タブの [タスク ビュー] グループ。

  2. [タスク名] 列の中で、リンクさせるタスクを Ctrl キーを押しながらクリックします。

  3. タスク>リンクタスクを選択します。

    [タスク] タブのスケジュール グループ内にある [リンク]

リンクを削除するには、2つのリンクされたタスクを選択し、[タスク>タスクのリンクを解除] を選択します(z0z_)

既定では、Project で簡単な終了-開始タスクリンクが作成されます。つまり、最初のタスク (_ z0z_) は、2番目のタスク (_ z1z_) を開始する前に終了する必要があります。

Project Online サブスクライバーを使用している場合、リンクする特定のタスクを選択して、[先行タスク] または [後続タスク] 列のドロップダウンボックスを使用することもできます。

  1. [>ガントチャート表示] を選びます。

  2. [先行タスク] または [後続タスク] 列を見つけて、リンクするタスクのセルを選択します。

    注: 既定では、後継列は表示されません。 表示するには、行の最後の列に移動し、[新しい列の追加] を選択します。 [後続タスク] を選びます。

  3. すべてのタスクの階層リストで、上または下にスクロールして目的のタスクを見つけ、その横にあるチェックボックスをオンにして、ドロップダウンボックスの外側の任意の場所をクリックします。 リンクしているタスクのタスク ID が、セルに表示されます。

リンク先のタスクがリンク元のタスクの近くにない場合は、リンク先からリンクを選ぶと特に便利です。

リンクされたタスクの間にタスクを挿入する

Project をセットアップすると、リンクされたタスクの間に新しいタスクを挿入したときに、新しいタスクが自動的に周囲のタスクにリンクされます。

  1. [ファイル]、[オプション] の順に選びます。

  2. [ project のオプション] ダイアログボックスで、[スケジュール] を選択し、[プロジェクト] セクションのスケジュールオプションにスクロールします。

  3. [挿入または移動したタスクを自動的にリンクする] チェック ボックスを選びます。

  4. 新しいタスクを挿入します。

ネットワーク ダイアグラム内のタスクをリンクする

  1. [ビュー >ネットワークダイアグラム] を選びます。

    [表示] タブ上の [ネットワーク ダイアグラム] の画像。

  2. [先行タスク] ボックスの中央をポイントします。

  3. 後続タスクとなるネットワーク ダイアグラム ボックスにドラッグし、マウス ボタンを離します。

    ネットワーク ダイアグラム上のリンクされた 2 つのタスクの画像

予定表内のタスクをリンクする

  1. [ビュー]、[カレンダー] の順に選択します。

    [表示] タブ、[タスク ビュー] グループ、[予定表]。

  2. 先行タスクの予定表バーをポイントします。

  3. 後続タスクの予定表バーにドラッグし、マウス ボタンを離します。

手動でスケジュールされたタスクをリンクする

手動スケジュール タスクを他のタスクにリンクすると、手動でスケジュールしたタスクは他のタスクに自動的に関連付けられます。

手動でスケジュールしたタスクが別のタスクにリンクされている場合は、そのタスクを移動しないように Project を構成することもできます。

  1. [ファイル]、[オプション] の順に選びます。

  2. [ project のオプション] ダイアログボックスで、[スケジュール] を選択し、[プロジェクト] セクションのスケジュールオプションにスクロールします。

  3. [リンクの編集時に手動でスケジュールされたタスクを更新する] チェックボックスをオフにします。

手動でスケジュールされたタスクと、自動的にスケジュールされたタスクについてはこちらを参照してください。

タスクをリンクする他の方法

  • あるプロジェクト全体が完了するのを待たなければならないタスクがある場合は、マスター プロジェクトを設定する方法もあります。

  • ある 1 つのタスクが他のタスクとどのように関連しているのかを確認するには、タスク パスを使います。

ページの先頭へ

タスクの依存関係を変更または削除する

タスクをリンクして _ z0z_を作成すると、必要に応じて、次のいずれかの操作を行って、依存関係を簡単に変更または削除できます。

タスクの依存関係のリンクの種類を変更する

既定では、Project は、タスクを [終了-開始] 依存関係にリンクします。 ただし、[タスク情報] ダイアログボックスの [詳細設定] タブで、タスクの依存関係の種類を簡単に変更することができます。 [タスク情報] ダイアログボックスを開くには、変更するリンクの種類を持つタスクの名前をダブルクリックします。

注: 外部タスクへのリンクをダブルクリックすると、そのタスクを含むプロジェクトが開きます (プロジェクトが使用可能な場合)。 外部にリンクされたタスクは、タスク リストで淡色表示されます。 外部タスクのリンクの種類を変更する場合は、外部リンクされたタスクをダブルクリックして、そのタスクを含むプロジェクトを開き、次の手順を実行して、リンクされたタスクを変更します。 たとえば、project Z のタスク A を project 5 のタスク1にリンクした場合、タスク1の [タスク情報] でリンクの種類を変更できます。

  1. [>ガントチャート表示] を選びます。

  2. 変更するリンク線をダブルクリックします。

    リンク線をダブルクリックする

    ボタン イメージ

    リンクの種類を変更するには、ここをダブルクリックします。

  3. タスクの依存関係の種類を変更するには、[種類] ボックスの一覧から別の種類を選択します。

別のタスクにリンクする

現在、誤ったタスクにリンクされているタスクがある場合は、適切な依存関係を反映するようにリンクを簡単に変更できます。

  1. [>ガントチャート表示] を選びます。

  2. タスクリストで、リンクを変更するタスクを選びます。

  3. [タスク] タブの [プロパティ] グループで、[情報] を選びます。

  4. [先行タスク] タブの [タスク名] 列で、リンクしてはいけないタスクを選び、一覧からタスクを選んで、適切な依存関係を特定します。

  5. [種類] 列と [間隔] 列で、リンクの種類、ラグタイム、またはリードタイムを変更します。

    ヒント: リードタイムを入力するには、[間隔] 列に負の値を入力します。たとえば、2日間のリードタイムがある場合は、「 – 2 」と入力します。

タスクのすべての依存関係を削除する

タスクが他のタスクに依存しなくなった場合は、タスクのすべての依存関係を一度に削除できます。

  1. [>ガントチャート表示] を選びます。

  2. [タスク名] フィールドで、リンクを解除するタスクを選びます。

    連続して表示されていない複数のタスクを選ぶには、CTRL キーを押しながら各タスクを選びます。 連続して表示されているタスクを選択するには、最初のタスクを選択し、shift キーを押しながら、リストで選択する最後のタスクを選びます。

  3. [タスク] タブの [スケジュール] グループで、[タスクのリンクを解除] を選択します。

    タスクは、他のタスクや制約へのリンクに基づいて再スケジュールされます。

注: タスクリンクを削除すると、2つのタスク間の依存関係が削除されます。タスク間のリンク線によって示されます。 プロジェクトのアウトライン構造の一部としてタスクまたはサブタスクの階層構造を変更する場合は、タスクリンクを削除するのではなく、タスクのレベルを上げる必要があります。

特定のタスクの依存関係を削除する

タスクが複数のタスクにリンクしていて、一部のリンクを削除する必要がある場合は、[タスク情報] ダイアログボックスで、削除するリンクを選択できます。

  1. [>ガントチャート表示] を選びます。

  2. タスクリストで、依存関係を削除するタスクを選びます。

  3. [タスク] タブの [プロパティ] グループで、[情報] を選びます。

  4. [先行タスク] タブで、削除する依存関係を選び、DELETE キーを押します。

トラブルシューティング

タスクをリンクしたにもかかわらず、後続タスクが移動しない場合は、次のような原因が考えられます。

  • タスクに実績(z0z_ _ _ _ _ _ _ _ _ _ _ _ _})または達成率などの実績が適用されている場合、タスクは実際に開始された日より前の日付よりも前に再スケジュールすることはできません。 進捗状況を入力せず、タスクに柔軟性のないz0z_を使用している場合、 制約は _ z1z_ に優先されます。

    たとえば、[指定日以後に開始] (SNET) という制約が7月1日に設定されている場合、タスクはその日付に関連付けられています 。このタスクは、6月28日に終了し、後続タスクが7月1日以前に開始できる場合でも、以前の日付に再スケジュールされません。

  • Project では、" z0z_" のグラフ部分にマウスポインターをドラッグしてタスクを作成すると、開始日を基点にスケジュールされているプロジェクトのタスクに [指定日以後に開始] 制約が設定されます。 _ z0z_からスケジュールされているプロジェクトの場合、タスクに [指定日以後に終了] (FNLT) という制約が設定されます。

  • 後続タスクが完了した場合、リンクは反映されず、移動しません。

次に、考えられる解決策をいくつか紹介します。

  • タスクの制約をより柔軟にリセットするには、タスクを選択し、[情報] を選択して、[詳細設定] タブを選択します。 [制約タイプ] リストで、[できるだけ早く] を選択します。 タスクの開始日は、タスクの依存関係に基づいて Project によってスケジュールされます。

  • すべてのタスクの強い制約をタスクの依存関係から上書きするには、[ファイル>オプション>スケジュール] を選択します。 [スケジュールオプション] セクションで、[タスクの制約の指定日を常に優先する] チェックボックスをオフにします。

以下の手順は Microsoft Project 2007 に固有のものです。

目的に合ったトピックをクリックしてください

タスクのリンクについて

Project でタスクをリンクするとき、既定のリンクの種類は "終了-開始" です。 ただし、"終了-開始" リンクではうまくいかない場合があります。 Project には他にもタスクのリンクの種類があるので、現実に即してプロジェクトをモデル化できます。

リンクの種類

使用例

説明

[終了-開始] (FS)

[終了 - 開始] リンクの画像

タスク B はタスク A に依存しているため、タスク A が終了するまでは、タスク B を開始することはできません。

たとえば、"基礎の掘り込み" と "コンクリートの流し込み" という 2 つのタスクがある場合、"コンクリートの流し込み" タスクは "基礎の掘り込み" タスクが完了するまで開始できません。

[開始-開始] (SS)

[開始 - 開始] リンクの画像

タスク B はタスク A に依存しているため、タスク A が開始されるまでは、タスク B を開始することはできません。

依存する側のタスクは、依存される側のタスクが開始された後であれば、いつでも開始できます。 開始-開始 (SS) 型のリンクでは、両方のタスクを同時に開始する必要はありません。

たとえば、「コンクリートの流し込み」と「コンクリートのならし」という 2 つのタスクがある場合、「コンクリートのならし」タスクは、「コンクリートの流し込み」タスクが開始されるまで、開始できません。

[終了-終了] (FF)

[終了-終了] タスク リンクの画像

タスク B はタスク A に依存しているため、タスク A が終了するまでは、タスク B を終了することはできません。

依存する側のタスクは、依存される側のタスクが終了した後であれば、いつでも終了できます。 [終了-終了] (FF) 型のリンクでは、両方のタスクを同時に終了する必要はありません。

たとえば、2 つのタスク "配線" と "電気設備検査" がある場合、"電気設備検査" タスクは "配線" タスクが完了するまで完了できません。

[開始-終了] (SF)

[終了 - 開始] タスク リンクの画像

タスク B はタスク A に依存しているため、タスク A が開始されるまでは、タスク B を終了することはできません。

依存する側のタスクは、依存される側のタスクが開始された後であれば、いつでも終了できます。 [開始-終了] (SF) 型のリンクでは、依存する側のタスクの終了と依存される側の開始が同時に起こる必要はありません。

たとえば、建設プロジェクトの屋根トラスは別の場所で造られます。 プロジェクトには、"トラス運搬" と "屋根組み立て" の 2 つのタスクがあります。 "トラス運搬" タスクが開始するまで、"屋根組み立て" タスクを完了することはできません。

リンクされたタスクの間にタスクを挿入するときは、新しいタスクを自動的にリンクすることも、まったくリンクしないこともできます。

  • 新しいタスクをリンクするには、新しいタスクを追加するタスクを選択し、[挿入] メニューの [新しいタスク] を選択します。

    注: これでも問題が解決しない場合は、[ツール] メニューの [オプション] を選択し、[スケジュール] タブを選択します。 [挿入または移動したタスクを自動的にリンクする] チェック ボックスがオンになっていることを確認します。

  • 新しいタスクをリンクせずに追加するには、新しいタスクを同時に実行するタスクを選択し、ドラッグして新しいタスクをネットワークダイアグラムの空白部分に作成します。

ガント チャート ビューを使ってタスクをリンクする

  1. [表示] メニューの [ガントチャート] を選択します。

  2. [タスク名] フィールドで、リンクする複数のタスクを、リンクする順序で選びます。

    • 隣接していないタスクを選ぶには、CTRL キーを押しながら、リンクするタスクを選択します。

    • 隣接するタスクを選ぶには、shift キーを押しながら、リンクする最初と最後のタスクを選択します。

  3. [タスクのリンク] を選択します(z0z_)

    既定では、"終了-開始" リンクが作成されます。 このタスク リンクは、"開始-開始"、"終了-終了"、または "開始-終了" に変更できます。

ネットワーク ダイアグラム ビューを使ってタスクをリンクする

  1. [表示] メニューの [ネットワークダイアグラム] をクリックします。

  2. 先行タスクのボックスの中央にポインターを移動します。

  3. 後続タスクのボックスまでドラッグします。

カレンダー ビューを使ってタスクをリンクする

  1. [表示] メニューの [予定表] を選びます。

  2. 先行タスクのカレンダー バーにポインターを移動します。

  3. 後続タスクのカレンダー バーまでドラッグします。

自動リンクを有効または無効にする

既定では、リンクされたタスクの間にタスクを挿入すると、新しいタスクは自動的に前後のタスクとリンクされます。 たとえば、終了-開始でリンクされた 3 つのタスクがある場合、それらの間に新しいタスクを追加すると、新しいタスクは上および下のタスクと終了-開始でリンクされます。

このオプションを無効にして、新しいタスクを挿入しても前後のタスクと自動的にリンクされないようにすることができます。 無効にした自動リンクは簡単に有効に戻すことができます。

  1. [ツール] メニューの [オプション] を選択し、[スケジュール] タブを選択します。

  2. 自動リンクを無効にするには、[挿入または移動したタスクを自動的にリンクする] チェック ボックスをオフにします。

    自動リンクを有効にするには、[挿入または移動したタスクを自動的にリンクする] チェック ボックスをオンにします。

ページの先頭へ

タスクの依存関係を変更または削除する

タスクをリンクして _ z0z_を作成すると、必要に応じて、次のいずれかの操作を行って、依存関係を簡単に変更または削除できます。

タスクの依存関係のリンクの種類を変更する

既定では、Project は、タスクを [終了-開始] 依存関係にリンクします。 ただし、[タスク情報] ダイアログボックスの [詳細設定] タブで、タスクの依存関係の種類を簡単に変更することができます。 [タスク情報] ダイアログボックスを開くには、変更するリンクの種類を持つタスクの名前をダブルクリックします。

注: 外部タスクへのリンクをダブルクリックすると、そのタスクを含むプロジェクトが開きます (プロジェクトが使用可能な場合)。 外部にリンクされたタスクは、タスク リストで淡色表示されます。 外部タスクのリンクの種類を変更する場合は、外部リンクされたタスクをダブルクリックして、そのタスクを含むプロジェクトを開き、次の手順を実行して、リンクされたタスクを変更します。 たとえば、project Z のタスク A を project 5 のタスク1にリンクした場合、タスク1の [タスク情報] でリンクの種類を変更できます。

  1. [>ガントチャート表示] を選びます。

  2. 変更するリンク線をダブルクリックします。

    リンク線をダブルクリックする

    ボタン イメージ

    リンクの種類を変更するには、ここをダブルクリックします。

  3. タスクの依存関係の種類を変更するには、[種類] ボックスの一覧から別の種類を選択します。

別のタスクにリンクする

現在、誤ったタスクにリンクされているタスクがある場合は、適切な依存関係を反映するようにリンクを簡単に変更できます。

  1. [>ガントチャート表示] を選びます。

  2. タスクリストで、リンクを変更するタスクを選びます。

  3. [タスク情報] を選択します(z0z_)

  4. [先行タスク] タブの [タスク名] 列で、リンクしてはいけないタスクを選び、一覧からタスクを選んで、適切な依存関係を特定します。

  5. [種類] 列と [間隔] 列で、リンクの種類、ラグタイム、またはリードタイムを変更します。

    ヒント: リードタイムを入力するには、[間隔] 列に負の値を入力します。たとえば、2日間のリードタイムがある場合は、「 – 2 」と入力します。

タスクのすべての依存関係を削除する

タスクが他のタスクに依存しなくなった場合は、タスクのすべての依存関係を一度に削除できます。

  1. [>ガントチャート表示] を選びます。

  2. [タスク名] フィールドで、リンクを解除するタスクを選びます。

    連続して表示されていない複数のタスクを選択するには、CTRL キーを押しながら各タスクをクリックします。 連続して表示されているタスクを選ぶには、最初のタスクをクリックし、shift キーを押しながら、リストで選択する最後のタスクをクリックします。

  3. [タスクのリンクを解除] を選びます(z0z_)

    タスクは、他のタスクや制約へのリンクに基づいて再スケジュールされます。

注: タスクリンクを削除すると、2つのタスク間の依存関係が削除されます。タスク間のリンク線によって示されます。 プロジェクトのアウトライン構造の一部としてタスクまたはサブタスクの階層構造を変更する場合は、タスクリンクを削除するのではなく、タスクのレベルを上げる必要があります。

特定のタスクの依存関係を削除する

タスクが複数のタスクにリンクしていて、一部のリンクを削除する必要がある場合は、[タスク情報] ダイアログボックスで、削除するリンクを選択できます。

  1. [>ガントチャート表示] を選びます。

  2. タスクリストで、依存関係を削除するタスクを選びます。

  3. [タスク情報] を選択します(z0z_)

  4. [先行タスク] タブで、削除する依存関係を選び、DELETE キーを押します。

トラブルシューティング

タスクをリンクしたにもかかわらず、後続タスクが移動しない場合は、次のような原因が考えられます。

  • タスクに実績(z0z_ _ _ _ _ _ _ _ _ _ _ _ _})または達成率などの実績が適用されている場合、タスクは実際に開始された日より前の日付よりも前に再スケジュールすることはできません。 進捗状況を入力せず、タスクに柔軟性のないz0z_を使用している場合、 制約は _ z1z_ に優先されます。

    たとえば、[指定日以後に開始] (SNET) という制約が7月1日に設定されている場合、タスクはその日付に関連付けられています 。このタスクは、6月28日に終了し、後続タスクが7月1日以前に開始できる場合でも、以前の日付に再スケジュールされません。

  • Project では、" z0z_" のグラフ部分にマウスポインターをドラッグしてタスクを作成すると、開始日を基点にスケジュールされているプロジェクトのタスクに [指定日以後に開始] 制約が設定されます。 _ z0z_からスケジュールされているプロジェクトの場合、タスクに [指定日以後に終了] (FNLT) という制約が設定されます。

  • 後続タスクが完了した場合、リンクは反映されず、移動しません。

  • プロジェクトの計算モードManualに設定した場合、後続タスクは移動されません。

次に、考えられる解決策をいくつか紹介します。

  • タスクの制約をより柔軟にリセットするには、タスクを選択し、[タスク情報_ 0 z_] を選び、[詳細設定] タブを選択します。 [制約タイプ] リストで、[できるだけ早く] を選択します。 タスクの開始日は、タスクの依存関係に基づいて Project によってスケジュールされます。

  • すべてのタスクの強い制約をタスクの依存関係から上書きするには、[ツール] メニューの [オプション] を選択し、[スケジュール] タブを選択します。 [スケジュールオプション] セクションで、[タスクの制約の指定日を常に優先する] チェックボックスをオフにします。

  • 計算を自動に設定するには、[ツール] メニューの [オプション] を選択し、[計算] タブを選択します。 [ Microsoft Office Project の計算方法] セクションの [計算モード] の横にある [手動] を選びます。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×