プロジェクトのリソースを切り替える

リソースの切り替えウィザードを使用すると、あるリソースを別のリソースに置き換えることができます。

この記事の内容

リソースの切り替えの概要

リソースの切り替えを準備する

リソースを切り替える

リソースの切り替えの概要

リソースの切り替えウィザードを使用すると、プロジェクトのタスクに必要なスキル、エンタープライズ リソース共有元のリソースのスキル、およびそれらのリソースの利用可能時間を基に、1 つ以上のプロジェクトに対して、エンタープライズ リソースまたは標準リソースの割り当てや置き換えを行うことができます。このウィザードでは、プロジェクトのグループ (ポートフォリオ) 間でリソースを割り当てたときの効果を分析することもできます。

リソースの切り替えウィザードを使用すると、次の操作を行うことができます。

  • 標準リソースを稼動可能なリソースに置き換える。

  • プロジェクトのポートフォリオ間でリソースの割り当てを最適化するために、既存のリソースを他のリソースに置き換える。

  • 使用可能なリソースの中から必要な条件を満たすものを見つけ、タスクに割り当てる。

ページの先頭へ

リソースの切り替えを準備する

リソースの切り替えウィザードを実行する前に、組織のリソース スキルが設定されていることを確認し、これらのスキルとスキル コードを調べ、必要な場合は、RBS 値をタスクに適用して、要求されるスキルに基づいて自動的にリソースをタスクに割り当てます。

リソース スキルがリソースに割り当てられたことを確認する

リソースの切り替えウィザードを実行する前に、サーバー管理者によって Microsoft Office Project Server 2007 で次のタスクが完了されていることを確認します。

  • エンタープライズ リソース共有元が作成されていること。

  • リソース スキル用のエンタープライズ リソース ユーザー設定フィールドが定義されていること。このスキル ベースのユーザー設定フィールドには、多くの場合、組織の RBS コードが含まれます。エンタープライズ リソース ユーザー設定フィールドは、エンタープライズ グローバル テンプレートに作成されます。

  • エンタープライズ リソース アウトライン コードを使用して、適切なリソース スキルが割り当てられていること。これらの割り当ては、エンタープライズ リソース共有元を使用するか、直接 Office Project Server 2007 を使用して、リソースを開いて変更することにより作成されます。

リソース スキル コードを確認する

リソースを切り替えるプロジェクトで、リソースのスキルが識別されることを確認します。

  1. [表示] メニューの [リソース シート] をクリックします。

  2. [表示] メニューの [テーブル] をポイントし、[入力] (またはその他のテーブル) をクリックします。

  3. 定義済みスキルのフィールドまたは RBS フィールドの列を挿入する位置の右側の列をクリックします。

  4. [挿入] メニューの [] をクリックします。

  5. [フィールド名] ボックスの一覧で、定義済みスキルのフィールドまたは RBS フィールドをクリックします。

    必要に応じて、設定されているユーザー設定フィールドの名前とスキル コードをサーバー管理者に確認してください。リソース リストを調べ、切り替える標準リソースとその他のリソースを中心に、各リソースにスキル コードが入力されていることを確認します。

割り当てコードを入力する

リソースの切り替えウィザードを使用してプロジェクトのタスクを配分する場合は、[タスク配分状況] ビューを使用して RBS コードをプロジェクトのタスクに追加します。次に、リソースの切り替えウィザードでリソースをプロジェクトに追加して、適切なタスクに自動的にリソースを割り当てます。

  1. プロジェクトの [表示] メニューの [タスク配分状況] または [リソース配分状況] をクリックします。

  2. [表示] メニューの [テーブル] をポイントし、[入力] (またはその他のテーブル) をクリックします。

  3. 定義済みスキルのフィールドまたは RBS フィールドの列を挿入する位置の右側の列をクリックします。

  4. [挿入] メニューの [] をクリックします。

  5. [フィールド名] ボックスの一覧で、定義済みスキルのフィールドまたは RBS フィールドの名前をクリックします。

    必要に応じて、設定されているユーザー設定フィールドの名前とスキル コードをサーバー管理者に確認してください。

  6. リソースの切り替えウィザードでリソースを配分するそれぞれの割り当てに対して、適切なスキル コードまたは RBS コードを入力します。

スキル コードまたは RBS コードの入力が完了したら、リソースの切り替えウィザードを実行できます。ウィザードを実行すると、特定のタスクで要求されるスキルに適合するリソースが、それらのタスクに自動的に割り当てられます。

ページの先頭へ

リソースを切り替える

  1. リソースを切り替えるエンタープライズ プロジェクトを開きます。

  2. [ツール] メニューの [リソースの切り替え] をクリックします。

  3. [プロジェクトの選択] ページで、リソースの切り替えウィザードで配分する 1 つまたは複数のエンタープライズ プロジェクトを選択します。

    現在開いているエンタープライズ プロジェクトが一覧で表示されます。

  4. [次へ] をクリックします。

  5. [リソースの選択] ページで [選択したプロジェクト内] をクリックして、複数のプロジェクト間でリソースを置き換えるように指定します。

    このオプションは、前の [プロジェクトの選択] ページで複数のプロジェクトを選択した場合に使用します。

  6. 手動でリソースを選択するには、[以下に指定] をクリックし、[追加] をクリックして、表示されるエンタープライズ リソースから選択します。

    1. [リソース切り替えの作成元] ダイアログ ボックスで、左側の [エンタープライズ リソース] テーブルのリソースを選択し、[追加] をクリックします。

      選択したリソースが、右側の [プロジェクトのリソース] テーブルに追加されます。

      ヒント: [既存のフィルタ] ボックスの一覧で適用するフィルターをクリックすると、特定の種類のリソースのみが表示されます。[エンタープライズ リソース] 列に、フィルタ処理されたエンタープライズ リソースの一覧が表示されます。プロジェクト チームに既に割り当てられているリソースは、すべて [プロジェクトのリソース] 列に表示されます。

    2. [OK] をクリックし、リソースの切り替えウィザードのページに戻ります。

      [プロジェクトのリソース] テーブルに一覧表示されていたリソースが、[リソースの選択] ページのテーブルに追加されます。

  7. [リソースの選択] ページで、選択したリソースをテーブルから削除するには、削除するリソースを選択し、[削除] をクリックします。

    この操作は、[以下に指定] を選択し、リソースの切り替えに使用するリソース一覧を作成して調整するときに実行できます。

  8. リソースの切り替えウィザードで、既に本予約になっているリソースに加えて仮予約のリソースも割り当てる場合は、[仮予約のリソースがタスクに割り当てられるようにする] チェック ボックスをオンにします。

  9. リソースの切り替えウィザードで、特定の日付またはそれ以降に開始するタスクのリソースのみを切り替える場合は、[リソースの割り当て基準日] にその日付を入力します。

    既定では、[リソースの割り当て基準日] は現在の日付に設定されます。当面は割り当てをそのままにしておき、数か月以上先になってから、リソースの切り替えウィザードを使用してさらに割り当てを配分する場合は、この設定が役立ちます。

  10. [次へ] をクリックします。

  11. [関連プロジェクトの選択] ページで、関連プロジェクトを確認します。

    これらのプロジェクトには、選択したプロジェクトとの間にプロジェクト間のリンクまたはリソース共有元の依存関係が設定されています。このページで選択したプロジェクトは、リソースの切り替えを使用してリソースを再配分するプロジェクトに追加されます。

    注: 関連プロジェクトが選択されたかどうかにかかわらず、リソースの切り替えウィザードでは、リソースの残存余力を計算するとき、常に関連プロジェクトのリソースの割り当てが考慮されます。

  12. [次へ] をクリックします。

  13. [スケジュール オプションの選択] ページでは、リソースの切り替えを選択した各プロジェクトが選択されます。配分先プロジェクトの優先度を指定します。

  14. [オプション] 列で、使用するリソースのグループを指定します。プロジェクト自体にあるリソース、または [リソースの選択] ページで指定したエンタープライズ リソース共有元にあるリソースの中から選択します。

  15. [次へ] をクリックします。

  16. [リソースの切り替え] ページで、選択した内容のサマリーを確認します。変更する必要がある場合は、[戻る] をクリックして、該当するページに移動します。Project でプロジェクトのリソースを検索する準備ができたら、[実行] をクリックします。

  17. [結果のレビュー] ページで、リソースの切り替え処理の結果を確認します。

    このページには、割り当てと、それぞれの割り当て用にスキル プロファイルに基づいて検索されたリソースの両方が表示されます。この時点では、割り当ては実際には変更されていません。ここに表示されるのは割り当て案です。

  18. [次へ] をクリックします。

  19. [更新するオプションの選択] ページで、ウィザードの結果に基づいてプロジェクトを更新するかどうかを指定します。

    更新する代わりに、ウィザードの構成と結果をファイルに保存して、後で使用することもできます。この方法を選択した場合は、結果を適用するまでプロジェクトは更新されません。

  20. [次へ] をクリックします。

  21. [完了] ページで、推奨事項を確認し、[完了] をクリックします。

  22. ウィザードを完了して閉じた後、[タスク配分状況] ビュー、[リソース配分状況] ビュー、または [リソース シート] ビューを使用して割り当てを確認します。[リソース シート] ビューで、切り替えられたリソースの情報を確認することもできます。変更結果が適切であれば、プロジェクトを保存して変更を確定します。変更結果を破棄するには、変更を保存しないでプロジェクトを閉じるか、[名前を付けて保存] コマンドを使用して別の名前でファイルを保存します。

    ヒント: ウィザードを完了して閉じた後、プロジェクトの平準化を検討します。これにより、リソース配分とプロジェクト終了日の両方に対して、ウィザードによるリソース割り当てがどのように影響するかを確認できます。

ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×