プレゼンテーション内で Adobe Macromedia Flash アニメーションを再生する

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

Adobe Macromedia Flash を使用して作成され、.swf 拡張子が付いた Shockwave ファイルとして保存されたアニメーションを使っている場合は、 PowerPointプレゼンテーション内のファイルを再生できます。

PowerPoint 2010 以降でプレゼンテーションに Flash ファイルを追加するには、スライドに目的のファイルを埋め込むか、またはスライド上で目的のファイルとのリンクを設定します。

注: 

  • PowerPoint で Flash を使用した場合、特殊効果 (影、反射、光彩効果、ぼかし、面取り、3-D 回転)、フェードおよびトリミング機能、および共有と配布を容易にするための対象ファイルの圧縮機能を使用できないなどの制限が生じることがあります。

  • 64 ビット版の PowerPoint 2010 には、32 ビット版の QuickTime または Flash との互換性がありません。64 ビット版の QuickTime または Flash をインストールするか、32 ビット版の PowerPoint 2010 をインストールする必要があります。

Flash ファイルを埋め込む

  1. 標準表示モードで、ビデオを埋め込むスライドをクリックします。

  2. [挿入] タブの [メディア] グループで [ビデオ] の下にある矢印をクリックし、さらに [このコンピューター上のビデオ] または [ファイルからビデオ] をクリックします。

  3. [ビデオの挿入] ダイアログ ボックスで、ビデオを埋め込むには、をクリックし、[挿入] をクリックします。

  4. Flash アニメーションをプレビューするには、ビデオ ツールの [書式] タブで [再生] をクリックします。

Flash ファイルにリンクする

  1. 標準表示の [スライド] タブで、ビデオまたはアニメーション GIF のファイルを追加するスライドをクリックします。

  2. [挿入] タブの [メディア] グループで、[ビデオ] の下の矢印をクリックします。

  3. [このコンピューター上のビデオ] または [ファイルからビデオ] をクリックし、リンクを設定するファイルを見つけてクリックします。

  4. [挿入] の下向き矢印をクリックし、さらに [ファイルにリンク] をクリックします。

    重要: リンクの破損に伴うさまざまな問題を事前に回避するためにも、プレゼンテーションと同じフォルダー内にビデオをコピーしたうえで、そのビデオをリンク先として設定することをお勧めします。

  5. Flash アニメーションをプレビューするには、ビデオ ツールの [書式] タブで [再生] をクリックします。

PowerPoint 2007 で .swf ファイルを追加するには、Shockwave Flash Object や Adobe Macromedia Flash Player といった ActiveX コントロールを使用します。Flash ファイルを再生するには、スライドに ActiveX コントロールを追加し、そこから Flash ファイルへのリンクを作成します。

ActiveX コントロールのセキュリティ設定は、セキュリティ設定と2007 Microsoft Office systemプログラムのプライバシー設定を確認できるセキュリティ センター] にあります。Active X コントロールの実行を許可するセキュリティ設定を調整する必要があります。セキュリティ センターで、ActiveX の設定は、すべての2007 Office リリース製品に適用されます。たとえば、PowerPoint の設定を変更すると、その設定もセキュリティ センターを使って他の Office プログラムの変更されます。Active X コントロールと設定の変更の詳細については、有効にするか Office ファイルで ActiveX 設定を無効にするを参照してください。

重要: 

  • お使いのコンピューターでプレゼンテーションをフラッシュ ファイルを再生するには、Shockwave Flash オブジェクトを登録する必要があります。[開発] タブの [コントロール] グループで、Shockwave Flash オブジェクトを登録するかどうかを確認するには、コントロールの選択 ボタンの画像 をクリックします。場合は、Shockwave Flash オブジェクトは、コントロールの一覧が表示されたら、お使いのコンピューターに登録されています。登録されていない場合は、お使いのコンピューターで、Shockwave Flash オブジェクトを登録するサイト Adobe Web サイトから、Flash Player の最新バージョンのダウンロードをします。

  • 複雑なアニメーションを適切に実行するには、Shockwave Flash オブジェクトの以前のバージョンがコンピューターで登録されていても、Flash Player の最新バージョンをインストールします。

プレゼンテーションに Flash ファイルを追加する

  1. Flash Player をコンピューターにインストールします。

  2. PowerPoint の標準表示で、アニメーションを再生するスライドを表示します。

  3. Microsoft Office ボタン Office ボタンの画像 をクリックし、[PowerPoint のオプション] をクリックします。

  4. [一般] をクリックし、[PowerPoint の使用に関する基本オプション] の [[開発] タブをリボンに表示する] チェック ボックスをオンにしてから [OK] をクリックします。

  5. [開発] タブの [コントロール] グループで、[その他のコントロール ボタンの画像 ] をクリックします。

  6. コントロールのリストで [Shockwave Flash オブジェクト] をクリックし、[OK] をクリックしてからスライドにドラッグしてコントロールを描画します。

    サイズ変更ハンドルをドラッグして、コントロールのサイズを変更します。

  7. Shockwave Flash オブジェクトを右クリックし、[プロパティ] をクリックします。

  8. [アルファベット順] タブの [ビデオ] プロパティをクリックします。

  9. 値の列 ([ビデオ] の横にある空白のセル) に、再生する Flash ファイルへの、ファイル名も含めた完全なドライブ パス (例: C\:MyFile.swf)、または URL (Uniform Resource Locator) を入力します。

  10. アニメーションの再生方法に関する特定のオプションを設定するには、次のうちいずれかを実行してから [プロパティ] ダイアログ ボックスを閉じます。

    • スライドが表示されたときにファイルを自動的に再生するには、[再生中] プロパティを [はい] に設定します。Flash ファイルに開始と巻き戻しのコントロールが組み込まれている場合は、[再生中] プロパティを [いいえ] に設定できます。

    • アニメーションを繰り返し再生しない場合は、[ループ] プロパティを [いいえ] に設定します。

スライド ショー表示でアニメーションをプレビューする

  • [表示] タブの [プレゼンテーションの表示] グループで、[スライド ショー] をクリックして F5 キーを押します。

    スライド ショーを終了して標準表示に戻るには、ESC キーを押します。

注: 

  • PowerPoint 2007 では Flash ファイルは、写真や絵とは異なり、プレゼンテーションに埋め込まれるのではなく、常にプレゼンテーションにリンクされます。リンクされたファイルを挿入すると、PowerPoint は、ファイルの現在の場所へのリンクを作成します。そのファイルを後で別の場所に移動すると、ファイルを再生しようとしても PowerPoint はファイルを特定できなくなります。Flash ファイルを挿入する前に、プレゼンテーションと同じフォルダーに Flash ファイルをコピーすることをお勧めします。Flash ファイルをプレゼンテーションのフォルダーに保存している限り、そのフォルダーを別のコンピューターに移動したりコピーしたりしても、PowerPoint は Flash ファイルへのリンクを作成して、Flash ファイルを特定できます。CD にパッケージ化する機能を使用して、リンクされたファイルをプレゼンテーションと同じフォルダーに確実に保存することもできます。この機能では、すべてのファイルがプレゼンテーションとともに 1 つの場所 (CD またはフォルダー) にコピーされ、ファイルのすべてのリンクが自動的に更新されます。別のコンピューターでプレゼンテーションするか、プレゼンテーションをメールで送信する場合、リンクされたファイルがプレゼンテーションに含まれるときには、リンクされたファイルをプレゼンテーションとともにコピーする必要があります。

  • ここで説明するサード パーティ製品は、Microsoft と関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×