プレゼンテーション内で Adobe Macromedia Flash アニメーションを再生する

PowerPoint for Office 365, PowerPoint 2019, PowerPoint 2016, PowerPoint 2013, PowerPoint 2010

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに英語の記事があります。

Adobe Macromedia Flash を使用して作成され、.swf 拡張子が付いた Shockwave ファイルとして保存されたアニメーションを使っている場合は、 PowerPointプレゼンテーション内のファイルを再生できます。

埋め込みまたはリンクするスライド上のファイルをPowerPoint 2010と以降のバージョンのプレゼンテーションに Flash ファイルを追加します。

注: 

  • Flash PowerPoint、これらを圧縮する (影、反射、光彩、ぼかし、面取り、および [3-D 回転) などの特殊効果、フェードとトリミング機能、および機能を使用することができないなどを使用する場合、いくつかの制限にすることがあります。ファイルを簡単に共有および配布します。

  • PowerPoint 2010 64 ビット バージョンは、32 ビット バージョンの QuickTime または Flash と互換性がありません。 QuickTime または Flash の 64 ビット版またはPowerPoint 2010の 32 ビット版をインストールする必要がありますか。

Flash ファイルを埋め込む

  1. 標準表示モードで、ビデオを埋め込むスライドをクリックします。

  2. [挿入] タブの [メディア] グループで [ビデオ] の下にある矢印をクリックし、さらに [このコンピューター上のビデオ] または [ファイルからビデオ] をクリックします。

  3. [ビデオの挿入] ダイアログ ボックスで、埋め込むビデオを探してクリックし、[挿入] をクリックします。  

    確認するには、その .swf のファイルが] ダイアログ ボックスの一覧に表示するには、すべてのファイルに ( [挿入] ボタン) を超えるファイル フィルターを変更します。

    [ビデオの挿入] ダイアログ ボックスでファイルの種類のフィルターには、「すべてのファイル」オプションがあります。
  4. Flash アニメーションをプレビューするには、ビデオ ツールの [書式] タブで [再生] をクリックします。

Flash ファイルにリンクする

  1. 標準表示の [スライド] タブで、ビデオまたはアニメーション GIF のファイルを追加するスライドをクリックします。

  2. [挿入] タブの [メディア] グループで、[ビデオ] の下の矢印をクリックします。

  3. [このコンピューター上のビデオ] または [ファイルからビデオ] をクリックし、リンクを設定するファイルを見つけてクリックします。

    確認するには、その .swf のファイルが] ダイアログ ボックスの一覧に表示するには、すべてのファイルに ( [挿入] ボタン) を超えるファイル フィルターを変更します。

    [ビデオの挿入] ダイアログ ボックスでファイルの種類のフィルターには、「すべてのファイル」オプションがあります。
  4. [挿入] の下向き矢印をクリックし、さらに [ファイルにリンク] をクリックします。

    重要: リンクの破損に伴うさまざまな問題を事前に回避するためにも、プレゼンテーションと同じフォルダー内にビデオをコピーしたうえで、そのビデオをリンク先として設定することをお勧めします。

  5. Flash アニメーションをプレビューするには、ビデオ ツールの [書式] タブで [再生] をクリックします。

Adobe Macromedia Director ビデオ

PowerPointプレゼンテーションに Adobe Macromedia Director ビデオ ファイルを挿入することはできません。

PowerPoint 2007 で .swf ファイルを追加するには、Shockwave Flash Object や Adobe Macromedia Flash Player といった ActiveX コントロールを使用します。 Flash ファイルを再生するには、スライドに ActiveX コントロールを追加し、そこから Flash ファイルへのリンクを作成します。

ActiveX コントロールのセキュリティ設定はセキュリティ センターにあり、そこには 2007 Microsoft Office system プログラムのセキュリティ設定とプライバシー設定があります。 ActiveX コントロールを動作させるには、セキュリティ設定を調整しなければならないことがあります。 セキュリティ センターの ActiveX 設定は、すべての 2007 Office リリース 製品に適用されます。 たとえば、PowerPoint で設定を変更すると、その設定は、セキュリティ センターを使用するその他の Office プログラムでも変更されます。 Active X コントロールと設定の変更の詳細については、有効にするか Office ファイルで ActiveX 設定を無効にするを参照してください。

重要: 

  • Flash ファイルをプレゼンテーション内で再生するには、Shockwave Flash オブジェクトをコンピューターで登録する必要があります。 [開発] タブの [コントロール] グループで、Shockwave Flash オブジェクトを登録するかどうかを確認するには、コントロールの選択 ボタンの画像 をクリックします。 Shockwave Flash オブジェクトがコントロールのリストに表示される場合、Shockwave Flash オブジェクトはコンピューターで登録されています。 登録されていない場合は、Adobe Web サイトから Flash Player の最新バージョンをダウンロードして、Shockwave Flash オブジェクトをコンピューターで登録します。

  • 複雑なアニメーションを適切に実行するには、Shockwave Flash オブジェクトの以前のバージョンがコンピューターで登録されていても、Flash Player の最新バージョンをインストールします。

プレゼンテーションに Flash ファイルを追加する

  1. Flash Player をコンピューターにインストールします。

  2. PowerPoint の標準表示で、アニメーションを再生するスライドを表示します。

  3. Microsoft Office ボタン Office ボタンの画像 をクリックし、[PowerPoint のオプション] をクリックします。

  4. [一般] をクリックし、[PowerPoint の使用に関する基本オプション] の [[開発] タブをリボンに表示する] チェック ボックスをオンにしてから [OK] をクリックします。

  5. [開発] タブの [コントロール] グループで、[その他のコントロール ボタンの画像 ] をクリックします。

  6. コントロールのリストで [Shockwave Flash オブジェクト] をクリックし、[OK] をクリックしてからスライドにドラッグしてコントロールを描画します。

    サイズ変更ハンドルをドラッグして、コントロールのサイズを変更します。

  7. Shockwave Flash オブジェクトを右クリックし、[プロパティ] をクリックします。

  8. [アルファベット順] タブの [ビデオ] プロパティをクリックします。

  9. 値の列 ([ビデオ] の横にある空白のセル) に、再生する Flash ファイルへの、ファイル名も含めた完全なドライブ パス (例: C\:MyFile.swf)、または URL (Uniform Resource Locator) を入力します。

  10. アニメーションの再生方法に関する特定のオプションを設定するには、次のうちいずれかを実行してから [プロパティ] ダイアログ ボックスを閉じます。

    • スライドが表示されたときにファイルを自動的に再生するには、[再生中] プロパティを [はい] に設定します。 Flash ファイルに開始と巻き戻しのコントロールが組み込まれている場合は、[再生中] プロパティを [いいえ] に設定できます。

    • アニメーションを繰り返し再生しない場合は、[ループ] プロパティを [いいえ] に設定します。

スライド ショー表示でアニメーションをプレビューする

  • [表示] タブの [プレゼンテーションの表示] グループで、[スライド ショー] をクリックして F5 キーを押します。

    スライド ショーを終了して標準表示に戻るには、ESC キーを押します。

注: 

  • PowerPoint 2007 では Flash ファイルは、写真や絵とは異なり、プレゼンテーションに埋め込まれるのではなく、常にプレゼンテーションにリンクされます。 リンクされたファイルを挿入すると、PowerPoint は、ファイルの現在の場所へのリンクを作成します。 そのファイルを後で別の場所に移動すると、ファイルを再生しようとしても PowerPoint はファイルを特定できなくなります。 Flash ファイルを挿入する前に、プレゼンテーションと同じフォルダーに Flash ファイルをコピーすることをお勧めします。 Flash ファイルをプレゼンテーションのフォルダーに保存している限り、そのフォルダーを別のコンピューターに移動したりコピーしたりしても、PowerPoint は Flash ファイルへのリンクを作成して、Flash ファイルを特定できます。 CD にパッケージ化する機能を使用して、リンクされたファイルをプレゼンテーションと同じフォルダーに確実に保存することもできます。 この機能では、すべてのファイルがプレゼンテーションとともに 1 つの場所 (CD またはフォルダー) にコピーされ、ファイルのすべてのリンクが自動的に更新されます。 別のコンピューターでプレゼンテーションするか、プレゼンテーションをメールで送信する場合、リンクされたファイルがプレゼンテーションに含まれるときには、リンクされたファイルをプレゼンテーションとともにコピーする必要があります。

  • ここで説明するサード パーティ製品は、Microsoft と関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×