フォーム データを電子メール メッセージで送信する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

フォーム テンプレートにセカンダリ送信データ接続を追加して、ユーザーが電子メール メッセージでフォーム データを送信できるよう構成できます。フォームの送信先となる電子メール アドレス、電子メール メッセージの件名、およびフォーム名は、静的な値、フォーム内のデータに基づく値、または数式を使用して指定できます。また、フォームを電子メール メッセージの本文内に表示するか、メッセージの添付ファイルとして表示するかも指定できます。

電子メール メッセージの添付ファイルとしてフォームを送信するようフォーム テンプレートを構成する場合は、電子メール メッセージにフォーム テンプレートを添付することもできます。フォームとフォーム テンプレートを電子メール メッセージに添付すると、電子メールの受信者のコンピュータにそのフォーム テンプレートがキャッシュされていなくても、受信者は確実に Microsoft Office InfoPath でフォームを開くことができます。受信者が添付ファイルを開くには、受信者のコンピュータに InfoPath がインストールされている必要があります。

ユーザーがフォーム データを電子メール メッセージとして送信すると、InfoPath によってフォーム データを伴う電子メール メッセージが作成され、データ接続の作成時に指定した電子メールの受信者にそのメッセージが送信されます。入力済みのフォームを受け取ったユーザーが Microsoft Office Outlook 2007 を使用している場合、そのユーザーは、受信したすべての InfoPath フォームを格納するフォルダを受信トレイに追加して、フォーム内のデータを Outlook の列に表示するようそのフォルダを構成できます。

送信データ接続を追加したら、ユーザーがフォーム データを送信できるようにフォーム テンプレートを構成します。その結果、[標準] ツールバーに [送信] ボタンが、[ ファイル] メニューに [送信] コマンドが自動的に追加されます。また、次のようにフォーム テンプレートの送信オプションをカスタマイズすることもできます。

  • [標準] ツールバーの [送信] ボタンおよび [ファイル] メニューの [送信] コマンドに表示されるテキストを変更します。

  • [標準] ツールバーの [送信] ボタンおよび [ファイル] メニューの [送信] コマンドに対応するキーボード ショートカットを変更します。

  • ユーザーがフォームを送信したときに表示される、ユーザー設定のメッセージを作成します。

  • フォームの送信後にフォームを開いたままにしておくか、フォームを閉じるか、または新しい空白のフォームを開くかを指定します。

ページの先頭へ

送信データ接続を追加する

  1. [ツール] メニューの [送信オプション] をクリックします。

  2. [送信オプション] ダイアログ ボックスで、[ユーザーによるこのフォームの送信を許可する] チェック ボックスをオンにします。

  3. [フォームのデータを単一の宛先に送信する] をクリックし、ボックスの一覧の [電子メール] をクリックします。

  4. [追加] をクリックします。

  5. データ接続ウィザードで、該当するボックスに、受信者の電子メール アドレス、電子メール メッセージに表示する件名、および使用する序文を入力し、[次へ] をクリックします。

    ヒント: [序文] ボックス以外の各ボックスには、フィールドを指定するか、値を作成するための数式を使用することもできます。

    操作方法

    1. [数式の挿入] 数式ボタン をクリックします。

    2. [数式の挿入] ダイアログ ボックスで、次のいずれかの操作を実行します。

      • 数式内でフィールドを使用する場合は、[フィールドまたはグループの挿入] をクリックし、[フィールドまたはグループの選択] ダイアログ ボックスで使用するフィールドをクリックして、[OK] をクリックします。

      • 数式内で関数を使用する場合は、[関数の挿入] をクリックし、[関数の挿入] ダイアログ ボックスで使用する関数をクリックして、[OK] をクリックします。

        ヒント: 関数にパラメータが必要な場合は、[関数の挿入] ダイアログ ボックスで関数をクリックして [OK] をクリックした後、[数式の挿入] ダイアログ ボックスの [数式] ボックスで、追加した関数をダブルクリックし、フィールドまたはグループをクリックします。[参照] セクションで関数に関する詳細へのリンクを探します。

      • 数式に値または算術演算子を挿入するには、その値または演算子を表す記号を [数式] ボックスに入力します。

    演算

    記号

    加算

    +

    減算

    -

    乗算

    *

    除算

    /

    • 注: 数式に除算 (/) 演算子を使用する場合は、必ず除算演算子の前後にスペースを挿入します。除算演算子の前後にスペースがない場合、InfoPath では、"/" が除算演算子ではなく、XPath の場所の段階を表す区切りとして解釈される場合があります。

    • 関数の構文が正しいかどうかを確認するには、[数式の挿入] ダイアログ ボックスの [数式の確認] をクリックします。

      数式の詳細については、[参照] セクションのリンクを参照してください。

  6. ウィザードの次のページで、次のいずれかの操作を行います。

    1. フォームを電子メール メッセージの本文内に表示するには、[フォームの作業中のビューのみを送信し、添付ファイルを送信しない] をクリックします。

    2. フォーム データを電子メール メッセージの添付ファイルとして送信するには、[フォーム データを添付ファイルとして送信する] をクリックし、[ユーザーがフォームを開くことができるように、フォーム テンプレートを添付する] チェック ボックスをオンにして、[添付ファイル名] ボックスにフォームの名前を入力します。各フォーム名が一意になるように数式を使用することもできます。

      操作方法

      1. [数式の挿入] 数式ボタン をクリックします。

      2. [数式の挿入] ダイアログ ボックスで、次のいずれかの操作を実行します。

        • 数式内でフィールドを使用する場合は、[フィールドまたはグループの挿入] をクリックし、[フィールドまたはグループの選択] ダイアログ ボックスで使用するフィールドをクリックして、[OK] をクリックします。

        • 数式内で関数を使用する場合は、[関数の挿入] をクリックし、[関数の挿入] ダイアログ ボックスで使用する関数をクリックして、[OK] をクリックします。

          ヒント: 関数にパラメータが必要な場合は、[関数の挿入] ダイアログ ボックスで関数をクリックして [OK] をクリックした後、[数式の挿入] ダイアログ ボックスの [数式] ボックスで、追加した関数をダブルクリックし、フィールドまたはグループをクリックします。[参照] セクションで関数に関する詳細へのリンクを探します。

        • 数式に値または算術演算子を挿入するには、その値または演算子を表す記号を [数式] ボックスに入力します。

      演算

      記号

      加算

      +

      減算

      -

      乗算

      *

      除算

      /

      • 注: 数式に除算 (/) 演算子を使用する場合は、必ず除算演算子の前後にスペースを挿入します。除算演算子の前後にスペースがない場合、InfoPath では、"/" が除算演算子ではなく、XPath の場所の段階を表す区切りとして解釈される場合があります。

      • 関数の構文が正しいかどうかを確認するには、[数式の挿入] ダイアログ ボックスの [数式の確認] をクリックします。

        数式の詳細については、[参照] セクションのリンクを参照してください。

      注: フォーム データを電子メール メッセージの添付ファイルとして受け取ったユーザーがこの添付ファイルを開くには、そのユーザーのコンピュータに InfoPath がインストールされている必要があります。

  7. [次へ] をクリックします。

  8. ウィザードの次のページで、[このデータ接続の名前を入力してください] ボックスに、この送信データ接続のわかりやすい名前を入力します。

  9. [概要] の情報が正しいことを確認し、[完了] をクリックします。

    1. ユーザーがフォームに入力する時に [標準] ツールバーに表示される [送信] ボタンの名前と、[ファイル] メニューに表示される [送信] コマンドの名前を変更するには、[送信オプション] ダイアログ ボックスの [キャプション] ボックスに新しい名前を入力します。

      ヒント: このボタンとコマンドにショートカット キーを割り当てる場合は、キーボード ショートカットとして使用する文字の前にアンパサンド (&) を入力します。たとえば、[送信] ボタンのキーボード ショートカットとして ALT+B を割り当てるには、「Su&bmit」と入力します。

  10. ユーザーがフォームに入力する時に [送信] コマンドまたは [標準] ツールバーの [送信] ボタンを使用できないようにする場合は、[送信メニューおよび送信ツール バーを表示する] チェック ボックスをオフにします。

    1. 既定では、ユーザーがフォームを送信した後もそのフォームは開いたままになり、フォームの送信が正常に終了したかどうかを示すメッセージが表示されます。この既定の動作を変更するには、[詳細設定] をクリックし、次のいずれかの操作を行います。

      • ユーザーが入力済みのフォームを送信した後で、そのフォームを閉じるか新しい空のフォームを作成する場合は、[送信後] ボックスの一覧で目的のオプションをクリックします。

      • フォームが正常に送信されたかどうかを示すメッセージを独自に作成する場合は、[ユーザー設定のメッセージを使用する] チェック ボックスをオンにし、[成功時] と [失敗時] の両方のボックスにそれぞれメッセージを入力します。

        ヒント: [失敗時] ボックスのメッセージには、フォームを送信できなかった場合の対処法を含めます。たとえば、フォームを保存したうえで関係者に問い合わせるようにユーザーに促すメッセージを入力できます。

      • ユーザーがフォームを送信した後に確認メッセージを表示しない場合は、[成功時および失敗時にメッセージを表示する] チェック ボックスをオフにします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×