フォーム データを複数の場所に送信する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

ユーザーが [送信] をクリックしたときに複数の場所にフォーム データが送信されるように、フォーム テンプレートをデザインできます。

この記事の内容

概要

手順 1: 送信データ接続を追加します。

手順 2: 送信を許可するフォーム テンプレートを構成します。

概要

ユーザーが複数の場所にフォーム データを送信できるようにするには、フォームの送信先とするそれぞれの場所について、データを送信するセカンダリ データ接続をフォーム テンプレートに追加する必要があります。すべての送信データ接続を追加したら、ルールを使用して、ユーザーが複数の場所にフォーム データを送信できるようにフォーム テンプレートを構成します。その結果、ユーザーがフォームに入力するときに [基本コントロール] ツールバーに [送信] ボタンが追加され、[ファイル] メニューに [送信] コマンドが追加されます。フォーム データは、動作規則の一覧に表示された順序でセカンダリ データ接続に送信されます。すべての送信データ接続を同時に使用するように動作規則を構成することはできません。

ユーザーがフォーム データを送信できるようにフォーム テンプレートを構成するときに、次のように送信設定をカスタマイズすることもできます。

  • [標準] ツールバーの [送信] ボタンおよび [ファイル] メニューの [送信] コマンドに表示されるテキストを変更します。

  • [標準] ツールバーの [送信] ボタンおよび [ファイル] メニューの [送信] コマンドに対応するキーボード ショートカットを変更します。

  • ユーザーがフォームを送信したときに表示される、ユーザー設定のメッセージを作成します。

  • フォームが送信された後、フォームを開いたままにしておくか、フォームを閉じるか、または新しい空のフォームを開くかを指定します。

ページの先頭へ

手順 1: 送信データ接続を追加する

ユーザーが入力済みのフォームを複数の場所に送信できるように構成するには、必要な送信データ接続をフォーム テンプレートに追加します。次の場所へのデータ接続を追加できます。

  • Web サービス

  • Microsoft Windows SharePoint Services が実行されているサーバー上のドキュメント ライブラリ

  • 電子メール メッセージ内

    注: フォーム データを電子メール メッセージで送信するには、ユーザーのコンピュータに Microsoft Office Outlook がインストールされている必要があります。

以下の手順で、これらの場所に送信データ接続を追加する方法を示します。

Web サービスにデータを送信するデータ接続を追加する

  1. [ツール] メニューの [データ接続] をクリックします。

  2. [データ接続] ダイアログ ボックスで、[追加] をクリックします。

  3. データ接続ウィザードで、[新しいデータ接続先] をクリックし、[データの送信] をクリックします。次に、[次へ] をクリックします。

  4. ウィザードの次のページで、[Web サービスに送信] をクリックし、[次へ] をクリックします。

  5. ウィザードの次のページで、フォームの送信先とする Web サービスの場所を入力し、[次へ] をクリックします。

    Universal Description, Discovery, and Integration (UDDI) サーバーを検索する場合は、[UDDI の検索] をクリックして、検索する UDDI サーバーを入力し、プロバイダとサービスのどちらを検索の対象にするかを指定して、検索キーワードを入力し、[検索] をクリックします。検索キーワードに一致する Web サービスが [検索結果] の一覧に表示されます。

  6. ウィザードの次のページにある [処理を選択してください] ボックスの一覧で、フォーム データを受信する Web サービス処理をクリックし、[次へ] をクリックします。

  7. ウィザードの次のページで、次のいずれかの操作を行います。

    [フィールドまたはグループ内のデータを送信します。

    1. [パラメータ] ボックスの一覧で、フォームのデータを受信する Web サービスのパラメータをクリックします。

    2. [パラメータ オプション] の [フィールドまたはグループ] をクリックします。

    3. [データ ソース] ボタン変更] をクリックします。

    4. [フィールドまたはグループの選択] ダイアログ ボックスで、送信するデータが含まれるフィールドまたはグループをクリックし、[OK] をクリックします。

    5. [含める] ボックスで、[テキストと子要素のみ] をクリックし、フィールドまたはグループの内容と子要素のみを送信するか、または [選択した要素を含む XML サブツリー] をクリックし、フィールドまたはグループの内容と選択したフィールドまたはグループの両方を送信します。

    フォーム内のデータのすべてを送信します。

    1. [フォーム全体 (処理命令を含む XML ドキュメント)] をクリックします。

    文字列としてデータを送信します。

    1. [データを文字列として送信する] チェック ボックスをオンにします。

      通常、このチェック ボックスは、デジタル署名したデータを送信する場合にオンにします。ほとんどの場合はこのチェック ボックスをオフにします。

  8. [次へ] をクリックします。

  9. ウィザードの次のページで、[このデータ接続の名前を入力してください] ボックスに、この送信データ接続のわかりやすい名前を入力します。

  10. [概要] の情報が正しいことを確認し、[完了] をクリックします。

ドキュメント ライブラリにデータを送信するデータ接続を追加する

  1. [ツール] メニューの [データ接続] をクリックします。

  2. [データ接続] ダイアログ ボックスで、[追加] をクリックします。

  3. データ接続ウィザードで、[新しいデータ接続先] をクリックし、[データの送信] をクリックします。次に、[次へ] をクリックします。

  4. ウィザードの次のページで、[SharePoint サイトのドキュメント ライブラリに送信] をクリックし、[次へ] をクリックします。

  5. ウィザードの次のページにある [ドキュメント ライブラリ] ボックスに、SharePoint ドキュメント ライブラリの場所を入力します。

  6. [ファイル名] ボックスに、ドキュメント ライブラリ内でフォームを識別するために使用する名前を入力します。各フォーム名が一意になるように数式を使用することもできます。

    方法

    1. [数式の挿入] 数式ボタン をクリックします。

    2. [数式の挿入] ダイアログ ボックスで、次のいずれかの操作を実行します。

      • 数式内でフィールドを使用する場合は、[フィールドまたはグループの挿入] をクリックし、[フィールドまたはグループの選択] ダイアログ ボックスで使用するフィールドをクリックして、[OK] をクリックします。

      • 数式内で関数を使用する場合は、[関数の挿入] をクリックし、[関数の挿入] ダイアログ ボックスで使用する関数をクリックして、[OK] をクリックします。

        関数にパラメータが必要な場合は、[関数の挿入] ダイアログ ボックスで関数をクリックして [OK] をクリックした後、[数式の挿入] ダイアログ ボックスの [数式] ボックスで、追加した関数をダブルクリックし、フィールドまたはグループをクリックします。[参照] セクションで関数に関する詳細へのリンクを探します。

      • 数式に値または算術演算子を挿入するには、その値または演算子を表す記号を [数式] ボックスに入力します。

    演算

    記号

    加算

    +

    減算

    -

    乗算

    *

    除算

    /

    • 注: 数式に除算 (/) 演算子を使用する場合は、必ず除算演算子の前後にスペースを挿入します。除算演算子の前後にスペースがない場合、InfoPath では、"/" が除算演算子ではなく、XPath の場所の段階を表す区切りとして解釈される場合があります。

    • 関数の構文が正しいかどうかを確認するには、[数式の挿入] ダイアログ ボックスの [数式の確認] をクリックします。

      数式の詳細については、[参照] セクションのリンクを参照してください。

  7. ドキュメント ライブラリ内の同じ名前を持つ既存のフォームを上書きするには、[既存のファイルに上書きする] チェック ボックスをオンにします。

  8. [次へ] をクリックします。

  9. ウィザードの次のページで、[このデータ接続の名前を入力してください] ボックスに、この送信データ接続のわかりやすい名前を入力します。

  10. [概要] の情報が正しいことを確認し、[完了] をクリックします。

データを電子メール メッセージで送信するデータ接続を追加する

  1. [ツール] メニューの [データ接続] をクリックします。

  2. [データ接続] ダイアログ ボックスで、[追加] をクリックします。

  3. データ接続ウィザードで、[新しいデータ接続先] をクリックし、[データの送信] をクリックします。次に、[次へ] をクリックします。

  4. ウィザードの次のページで、[電子メール メッセージとして送信] をクリックし、[次へ] をクリックします。

  5. ウィザードの次のページで、メッセージの宛先の電子メール アドレス、メッセージに表示する件名、および適切なボックスに表示するテキストを入力し、[次へ] をクリックします。[序文] ボックス以外の各ボックスでは、数式を使用することもできます。

    方法

    1. [数式の挿入] 数式ボタン をクリックします。

    2. [数式の挿入] ダイアログ ボックスで、次のいずれかの操作を実行します。

      • 数式内でフィールドを使用する場合は、[フィールドまたはグループの挿入] をクリックし、[フィールドまたはグループの選択] ダイアログ ボックスで使用するフィールドをクリックして、[OK] をクリックします。

      • 数式内で関数を使用する場合は、[関数の挿入] をクリックし、[関数の挿入] ダイアログ ボックスで使用する関数をクリックして、[OK] をクリックします。

        関数にパラメータが必要な場合は、[関数の挿入] ダイアログ ボックスで関数をクリックして [OK] をクリックした後、[数式の挿入] ダイアログ ボックスの [数式] ボックスで、追加した関数をダブルクリックし、フィールドまたはグループをクリックします。[参照] セクションで関数に関する詳細へのリンクを探します。

      • 数式に値または算術演算子を挿入するには、その値または演算子を表す記号を [数式] ボックスに入力します。

    演算

    記号

    加算

    +

    減算

    -

    乗算

    *

    除算

    /

    • 注: 数式に除算 (/) 演算子を使用する場合は、必ず除算演算子の前後にスペースを挿入します。除算演算子の前後にスペースがない場合、InfoPath では、"/" が除算演算子ではなく、XPath の場所の段階を表す区切りとして解釈される場合があります。

    • 関数の構文が正しいかどうかを確認するには、[数式の挿入] ダイアログ ボックスの [数式の確認] をクリックします。

      数式の詳細については、[参照] セクションのリンクを参照してください。

  6. ウィザードの次のページで、次のいずれかの操作を行います。

    1. フォームを電子メール メッセージの本文内に表示するには、[フォームの作業中のビューのみを送信し、添付ファイルを送信しない] をクリックします。

    2. フォーム データを電子メール メッセージに添付ファイルとして送信] をフォームのデータを添付ファイルとして送信] をクリックし、[ユーザーがフォームを開くことができないフォーム テンプレートを添付する] チェック ボックスをオンし、[添付ファイル名] ボックスで、フォームの名前を入力します。フィールドを指定したり、数式を使用して、各フォーム名が一意であることを確認できます。このオプションは、フォーム テンプレートが自動的にセキュリティ レベルを決定するように構成またはが制限されたまたは完全信頼のセキュリティ レベルに構成されている場合にのみ使用可能なです。

      方法

      1. [数式の挿入] 数式ボタン をクリックします。

      2. [数式の挿入] ダイアログ ボックスで、次のいずれかの操作を実行します。

        • 数式内でフィールドを使用する場合は、[フィールドまたはグループの挿入] をクリックし、[フィールドまたはグループの選択] ダイアログ ボックスで使用するフィールドをクリックして、[OK] をクリックします。

        • 数式内で関数を使用する場合は、[関数の挿入] をクリックし、[関数の挿入] ダイアログ ボックスで使用する関数をクリックして、[OK] をクリックします。

          関数にパラメータが必要な場合は、[関数の挿入] ダイアログ ボックスで関数をクリックして [OK] をクリックした後、[数式の挿入] ダイアログ ボックスの [数式] ボックスで、追加した関数をダブルクリックし、フィールドまたはグループをクリックします。[参照] セクションで関数に関する詳細へのリンクを探します。

        • 数式に値または算術演算子を挿入するには、その値または演算子を表す記号を [数式] ボックスに入力します。

      演算

      記号

      加算

      +

      減算

      -

      乗算

      *

      除算

      /

      • 注: 数式に除算 (/) 演算子を使用する場合は、必ず除算演算子の前後にスペースを挿入します。除算演算子の前後にスペースがない場合、InfoPath では、"/" が除算演算子ではなく、XPath の場所の段階を表す区切りとして解釈される場合があります。

      • 関数の構文が正しいかどうかを確認するには、[数式の挿入] ダイアログ ボックスの [数式の確認] をクリックします。

        数式の詳細については、[参照] セクションのリンクを参照してください。

      添付ファイルとして送信されたフォーム データの受信者が添付ファイルを開くには、受信者のコンピュータに InfoPath がインストールされている必要があります。

  7. [次へ] をクリックします。

  8. ウィザードの次のページで、[このデータ接続の名前を入力してください] ボックスに、この送信データ接続のわかりやすい名前を入力します。

  9. [概要] の情報が正しいことを確認し、[完了] をクリックします。

ページの先頭へ

手順 2: 送信が可能になるようにフォーム テンプレートを構成する

必要なセカンダリ データ接続をフォーム テンプレートに追加したら、ユーザーがフォーム データを送信できるようにフォーム テンプレートを構成します。この構成を行うと、ユーザーがフォームに入力するとき、[ファイル] メニューには [送信] コマンドが、[標準] ツールバーには [送信] ボタンが追加されます。次に、ユーザーが [送信] をクリックしたときに発生するイベントを構成できます。そのためには、動作規則を追加して、ユーザーが [ファイル] メニューの [送信] コマンドまたは [標準] ツールバーの [送信] ボタンをクリックしたら、フォーム データが各送信データ接続に送信されるようにします。

同じダイアログ ボックスで、送信オプションも設定できます。

  1. [ツール] メニューの [送信オプション] をクリックします。

  2. [送信オプション] ダイアログ ボックスで、[ユーザーによるこのフォームの送信を許可する] チェック ボックスをオンにします。

    このチェック ボックスをオンにすると、ユーザーがフォームに入力するときに [標準] ツールバーに [送信] ボタンが追加され、[ファイル] メニューに [送信] コマンドが追加されます。

  3. [動作規則を使用してユーザー設定操作を実行する] をクリックし、[動作規則] をクリックします。

  4. [フォームを送信するための動作規則] ダイアログ ボックスの [追加] をクリックします。

  5. [動作の追加] をクリックします。

  6. [動作] ボックスの [データ接続を使用して送信する] をクリックし、[データ接続] ボックスの一覧でこの送信操作に使用するデータ接続をクリックし、[OK] をクリックします。

  7. フォーム テンプレートに追加した各送信データ接続に対して手順 5. ~ 6. を繰り返します。

  8. フォーム テンプレートのすべての送信データ接続に対する条件を追加したら、[OK] を 2 回クリックします。

    1. ユーザーがフォームに入力する時に [標準] ツールバーに表示される [送信] ボタンの名前と、[ファイル] メニューに表示される [送信] コマンドの名前を変更するには、[送信オプション] ダイアログ ボックスの [キャプション] ボックスに新しい名前を入力します。

      このボタンとコマンドにショートカット キーを割り当てる場合は、キーボード ショートカットとして使用する文字の前にアンパサンド (&) を入力します。たとえば、[送信] ボタンのキーボード ショートカットとして ALT+B を割り当てるには、「Su&bmit」と入力します。

  9. ユーザーがフォームを入力するときに [送信] コマンドおよび [標準] ツールバーの [送信] ボタンを使用できないようにするには、[送信メニューおよび送信ツール バーを表示する] チェック ボックスをオフにします。

    1. 既定では、ユーザーがフォームを送信した後もそのフォームは開いたままになり、フォームの送信が正常に終了したかどうかを示すメッセージが表示されます。この既定の動作を変更するには、[詳細設定] をクリックし、次のいずれかの操作を行います。

      • ユーザーが入力済みのフォームを送信した後で、そのフォームを閉じるか新しい空のフォームを作成する場合は、[送信後] ボックスの一覧で目的のオプションをクリックします。

      • フォームが正常に送信されたかどうかを示すメッセージを独自に作成する場合は、[ユーザー設定のメッセージを使用する] チェック ボックスをオンにし、[成功時] と [失敗時] の両方のボックスにそれぞれメッセージを入力します。

        [失敗時] ボックスのメッセージには、フォームを送信できなかった場合の対処法を含めます。たとえば、フォームを保存したうえで関係者に問い合わせるようにユーザーに促すメッセージを入力できます。

      • ユーザーがフォームを送信した後に確認メッセージを表示しない場合は、[成功時および失敗時にメッセージを表示する] チェック ボックスをオフにします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×