フォーム データをドキュメント ライブラリに送信する

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

You can store and organize all of your users' forms in a document library on a server that is running Microsoft Windows SharePoint Services. In the document library, users can fill out forms that are based on your form template, export data from completed forms to Microsoft Office Excel 2003 or Microsoft Office Excel 2007, or merge the data from several forms into one form.

To allow users to submit forms that are based on your form template to a document library, you can add a secondary data connection to your form template that submits the data. After you add the submit data connection, you can configure the form template to allow your users to submit their form data to the document library. When you do so, Microsoft Office InfoPath adds a Submit button to the Standard toolbar and a Submit command to the File menu on the form. You can also customize the submit options for your form template in the following ways:

  • Change the text that appears on the Submit button on the Standard toolbar and the Submit command on the File menu.

  • Change the keyboard shortcut for the Submit button on the Standard toolbar and the Submit command on the File menu.

  • Create custom messages to display to your users when they submit their forms.

  • Specify whether to leave the form open, close the form, or open another blank form after the form is submitted.

Add a submit data connection

  1. On the Tools menu, click Submit Options.

  2. In the Submit Options dialog box, select the Allow users to submit this form check box.

  3. Click Send form data to a single destination, and then click SharePoint document library in the list.

  4. [追加] をクリックします。

  5. In the Data Connection Wizard, in the Document library box, type the location of the SharePoint document library.

  6. In the File name box, type a name that will be used to identify the form in the document library.

    ヒント: You can also use a formula to ensure that each form name is unique.

    方法

    1. Click Insert Formula 数式ボタン .

    2. In the Insert Formula dialog box, do one of the following:

      • To use a field in the formula, click Insert Field or Group, click the field that you want to use in the Select a Field or Group dialog box, and then click OK.

      • To use a function in the formula, click Insert Function, select the function that you want to use in the Insert Function dialog box, and then click OK.

        ヒント: If the function requires parameters, select the function in the Insert Function dialog box, click OK, and then in the Formula box in the Insert Formula dialog box, double-click the function that you added, and click a field or group. Find links to more information about functions in the See Also section.

      • To insert a value or mathematical operator into the formula, type the value or the symbol for the mathematical operation in the Formula box.

    演算

    記号

    追加

    +

    Subtract

    -

    Multiply

    *

    Divide

    /

    • 注: If your formula uses the division (/) operator, make sure that there is a space before and after the division operator. If the division operator does not have a space before and after it, InfoPath may interpret "/" as a separator for XPath location steps rather than as a division operator.

    • To check the formula for the correct syntax, in the Insert Formula dialog box, click Verify Formula.

      Find links to more information about formulas in the See Also section.

  7. To overwrite any existing forms with the same name in the document library, select the Allow overwrite if file exists check box.

  8. [次へ] をクリックします。

  9. On the next page of the wizard, in the Enter a name for this data connection box, type a descriptive name for this submit data connection.

  10. Verify that the information is correct in the Summary section, and then click Finish.

    1. To change the name of the Submit button that appears on the Standard toolbar and the Submit command that appears on the File menu when users fill out the form, type the new name in the Caption box in the Submit Options dialog box.

      ヒント: If you want to assign a keyboard shortcut to this button and command, type an ampersand (&) before the character that you want to use as a keyboard shortcut. For example, to assign ALT+B as the keyboard shortcut for the Submit button and command, type Su&bmit.

  11. If you do not want people to use a Submit command or the Submit button on the Standard toolbar when they fill out your form, clear the Show the Submit menu item and the Submit toolbar button check box.

    1. By default, after users submit a form, InfoPath keeps the form open and displays a message to indicate if the form was successfully submitted. To change this default behavior, click Advanced, and then do one of the following:

      1. To close the form or create a new blank form after the user submits a completed form, click the option that you want in the After submit list.

      2. To create a custom message to indicate if the form was successfully submitted, select the Use custom messages check box, and then type your messages in the On success and On failure boxes.

        ヒント: Use a message in the On failure box to tell users what to do if they cannot submit their form. For example, you can suggest that users save their form and contact someone for further instructions.

      3. If you do not want to display a message after the user submits a form, clear the Show success and failure messages check box.

Top of Page

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×