ピボットテーブル レポートを使って外部テーブル データを Excel Services で利用できるようにする

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Excel Services で外部データ接続を基にしたテーブル データを使用する場合、外部データ範囲 (クエリ テーブルとも呼ばれます) は使用できません。多次元の階層型データを 1 つのテーブルや 2 次元テーブルにフラット化する、ピボットテーブル レポートを作成する必要があります。ここではその方法について説明します。

多次元データと二次元データの比較

1. 多次元のピボットテーブル レポートを

2. 2 次元のピボットテーブル レポートに変換して、

3. フラット化されたテーブル データを Excel Services で表示できるようにします。

目的に合ったトピックをクリックしてください

Excel Services で外部データ ソースへの接続をサポートする方法を学習します。

外部データに接続されているピボット テーブル レポートと外部データ範囲の違いについてください。

2 次元、表形式のピボット テーブル レポートを作成します。

ピボット テーブル レポートを作成して、外部データ ソースに接続

追加、レイアウト、および行ラベル] 領域でフィールドを配置します。

ピボット テーブル オプションを変更して、フィールドの設定

2 次元テーブルとピボット テーブル レポートをレイアウトする. します。

ピボット テーブル レポートのデザインをカスタマイズします。

ブックを Excel Services に発行します。

Excel Services による外部データ ソースへの接続のサポート

ピボットテーブル レポートは、大量の数値データを合計と総計に集約し、階層で構成された多次元データを操作するようにデザインされています。一方、外部データ範囲は、行と列の構造を持つ 2 次元テーブルで、集計されていない状態のソース データのレコードを表します。

Microsoft Query、データ接続ウィザードを使用して外部データに接続するときに、通常、外部データ範囲を作成します。唯一の例外は、外部データに接続されているピボット テーブル レポートを作成するとします。ピボット テーブル レポートでは、外部データ範囲は作成されません。この接続の作成方法の違いは、Excel Services がのみピボット テーブル レポートに基づく外部データ接続をサポートして、外部データ範囲をサポートしていないために、Excel Services にブックを発行するときに理解する必要があります。

ページの先頭へ

外部データに接続されたピボットテーブル レポートと外部データ範囲の違いについて

接続されているピボット テーブル レポートで操作すると 外部データのピボット テーブル レポートの動作と、外部データ範囲を注意すべき、次のような違いもあります。

データを左から右の順にグループ化およびサブグループ化するピボットテーブル レポート

通常、グループ化されたデータは、1 つまたは複数の列を基準にしてデータが並べ替えられています。たとえば、部門でグループ化されたすべての従業員を表示するには、最初に部門を基準にしてデータの並べ替えを実行し、次に従業員を基準にして並べ替えを実行します。またグループをネストにすることもできます (たとえば、製品群 > カテゴリ > 製品、または地理 > 国/地域 > 都道府県 > 市区町村など)。既定では、ピボットテーブル レポートは、関連するデータの表示、見出しと概要情報の表示、および関連する項目の展開や折りたたみを容易にするために、左から右の順にグループとサブグループ別に自動的に並べ替えられます。

データの製品ラインのグループ化し、カテゴリごとの各製品ラインで subgrouped

製品群

カテゴリ

商品

エンジン

航空機

翼搭載

尾部搭載

ブースタ

自動車

269 HP

454 HP

排気装置

旅客

高温

標準

SUV

左側の [行ラベル] 領域の列に一意の値を指定することで、データを自動的にフラット化できます。

ID 番号の列を追加してフラット化された同じ製品ラインのデータ

ID 番号

製品群

カテゴリ

商品

WM-345

エンジン

航空機

翼搭載

TM-231

エンジン

航空機

尾部搭載

BSTR-567

エンジン

航空機

ブースタ

6C-734

エンジン

自動車

269 HP

8C-121

エンジン

自動車

454 HP

MF-202

排気装置

旅客

高温

MF-321

排気装置

旅客

標準

MF-211

排気装置

SUV

列を表示しない場合は、列をピボットテーブル レポートに追加した後で、列を非表示にできます。列を選択して [ホーム] タブの [セル] で [書式] の横にある矢印をクリックし、[非表示/再表示] をポイントします。次に、[列を表示しない] をクリックします。

重要: ピボットテーブル レポートで、データ ソースから 2 つ以上の重複するデータ行が検出された場合、ピボットテーブル レポートに表示されるのは 1 行だけです。重複する行も含めてすべての行をピボットテーブル レポートに表示するには、データ ソースからインポートするテーブル、クエリ、またはビューに一意の値を含む列を追加する必要があります。データ ソースに一意の列がない場合はデータ ソースで追加できます。たとえば、オートナンバ型の列を Microsoft Office Access テーブルに、ID データ型の列を Microsoft SQL Server テーブルに、あるいは各レコードの一意の数値を表示する集計列をデータベース クエリまたはビューに追加できます。

セル データを編集して集計列を追加する

ブックを Excel Services に発行する前に外部データ範囲のデータを編集できますが、ピボットテーブル データは常に読み取り専用です。

外部データ範囲のセルをダブルクリックして編集モードに入ると、値を変更したり数式を入力したりできます。ただし、これはデータ ソースの元の値を変更しているのではありません。また、次にデータを更新したときに、外部データ範囲プロパティ [If the number of rows changes upon data refresh] の設定によっては新しい値が上書きされる可能性があることに注意してください。

ピボットテーブル レポートの [行ラベル] セルをダブルクリックすると、セルはその [行ラベル] の項目を展開するか折りたたみます。ピボットテーブル レポートを 2 次元テーブルにフラット化すると、セルの左側にあるグループ内のすべての行の値が非表示または再表示されます。

外部データ範囲を基にした Microsoft Office Excel テーブル内の任意の場所に集計列を追加することも、外部データ範囲に列を挿入して数式を入力することもできます。ピボットテーブル レポート内に集計列を挿入することはできません (集計フィールドは挿入できます)。ただし、ピボットテーブル レポートのすぐ左または右にデータや数式を入力する列を追加し、そこに入力した数式で、ピボットテーブル レポート内のセル参照を使用できます。

グラフを作成する

ピボット テーブル レポートのデータに基づくグラフを作成する場合は、標準のグラフと同様、ピボット グラフ レポートを作成できますが、いくつかを使用する必要があります。 以下の違い:

ユーザーとのやりとり     標準のグラフでは、表示するデータのビューごとに 1 つのグラフを作成しますが、ビューは対話型ではありません。ピボットグラフ レポートでは、1 つのグラフを作成し、表示するレポートのレイアウトまたは詳細を変更することで、データをさまざまな方法で対話的に表示できます。Excel Services では、ユーザーとブックのやりとりに基づいて標準のグラフとピボットグラフ レポートの両方を更新できますが、どちらのグラフも静的イメージとして表示されます。

グラフの種類     標準のグラフにおける既定の種類は集合縦棒グラフであり、項目ごとに値を比較します。ピボットグラフ レポートにおける既定の種類は積み上げ縦棒グラフであり、項目ごとに値の全体に対する割合を比較します。ピボットグラフ レポートは、XY (散布図)、株価チャート、またはバブル チャートを除く任意の種類に変更できます。

グラフの要素    ピボット グラフ レポートには、標準のグラフと同じ要素が含まれますが、それらが含まれるフィールドとアイテムを追加、回転、または削除して、データの別のビューを表示することができます。カテゴリ、系列、および標準のグラフのデータは、カテゴリ フィールド、一連のフィールドをピボット グラフ レポート内のフィールドの値です。ピボット グラフ レポートでは、レポートのフィルターを含めることもできます。これらの各フィールドには、標準のグラフの凡例のカテゴリのラベル] または [系列名として表示される項目が含まれています。

書式設定    多くの書式設定などの要素、レイアウト、およびスタイルは保持する最新の情報に更新ピボット グラフ レポートします。ただし、近似曲線、データ ラベル、 誤差範囲、およびその他のデータ系列の変更は保持されません。標準のグラフでは、この書式の適用後は失われません。

項目を移動またはサイズ変更する     ピボットグラフ レポートでは、凡例に関する複数のプリセット位置のいずれかを選択し、タイトルのフォント サイズを変更できますが、プロット エリア、凡例、グラフのタイトル、または軸ラベルを移動またはサイズ変更することはできません。標準のグラフでは、これらのすべての要素を移動およびサイズ変更できます。

使いたい場合に、ピボット グラフ レポートを作成した後は、標準のグラフに変換することができます。詳細については、「 anaylze ワークシート データをピボット テーブルを作成する、またはピボット グラフを作成する」を参照してください。

外部データ範囲のプロパティとピボットテーブル オプションを比較する

外部データ範囲とピボットテーブル レポートには、データの書式設定とレイアウトを制御し、データの動作を更新できるプロパティがあります。

外部データ範囲とピボットテーブル レポートの両方を使用すると、列の幅を調整し、外部データが更新されたときに、列の並べ替え、フィルタ、セルの書式設定、およびデータのレイアウトを保持できます。

外部データ範囲] でもがあるデータの最初の列と行番号を含むのオプション。ピボット テーブル レポートでのようなオプションはありません。セクションで、左から右の順序でデータをグループ化およびサブグループのピボット テーブル レポート、データ ソースで一意の列の追加についてのディスカッションを参照してください。

外部データ範囲を更新するときにデータ範囲の行数が変更された場合、次のオプションのいずれかを設定することで、既存のデータに対する処理を制御できます。

  • [新しいデータのセルを挿入し、使用されていないセルを削除する] (既定)

  • [新規データの行全体を挿入し、使用されていないセルはクリアする]

  • [既存のセルを新規データで上書きし、使用されていないセルはクリアする]

ピボット テーブル レポートを更新するときにだけもたらす 新しいデータ。ただし、することがあるメッセージが表示されたら、現在のレポートの下にある既存のセルを上書きするかどうかを決定するように求め。

データを抽出する

外部データ範囲とピボットテーブル レポートでデータを抽出する方法は非常に似ていますが、次のようないくつかの違いがあります。

  • 外部データ範囲は、[テキスト フィルタ]、[数値フィルタ]、および [日付フィルタ] を使用しますが、ピボットテーブル レポートは、[ラベル フィルタ]、[値フィルタ]、および [日付フィルタ] を使用します。

  • 外部データ範囲のフィルター] メニューの [常に有効な場合は、不要になったアイテムを削除してフィルター] メニューのことがない含まれます新しいアイテムに適用したフィルターを使用して更新操作の後がピボット テーブル レポートがこの動作を制御するオプション。詳細については、「ピボット テーブルの変更オプションとフィールドの設定」を参照してください。

  • ピボットテーブル レポートには、レポート フィルタ機能 (外部データ範囲では使用できません) があり、ユーザーはピボットテーブル レポート内のデータのサブセットを操作できます。

データを並べ替える

外部データ範囲では、最大 64 列を基準にして複数列の並べ替えを実行でき、任意の列を選択して 1 次並べ替えを実行し、他の任意の列を選択して 2 次並べ替えを実行できます。ただし、ピボットテーブル レポートでデータを並べ替える方法と、外部データ範囲を並べ替える方法は異なります。外部データ範囲とは異なり、ピボットテーブル レポートでは、1 次並べ替えでは左端の列を基準にした並べ替えだけを実行できます。2 次並べ替えでは、他の列で、すぐ左側の列を基準にした並べ替えを実行できます。つまり、1 次並べ替えと 2 次並べ替えは、左から右の順にのみ実行できます。

さらに、左側の最初の列として一意の値を持つ列を配置する場合、実際には行ごとに 1 つの 1 次グループを作成するため、実行できるのはその列を基準にした並べ替えのみです。必要に応じて、Excel でデータを事前に並べ替え、ブックを Excel Services に発行した後、Microsoft Office Excel Web Access Web パーツ ツール ウィンドウの [並べ替え] チェック ボックスをオフにすることで、並べ替えを無効にできます。

ハイパーリンクを使用する

外部データ範囲とは異なり、ピボットテーブル セルではアクティブ ハイパーリンクはサポートされていません。ハイパーリンクはテキストとして扱われ、Excel や Excel Services では、ハイパーリンクを介して Web ページまたはドキュメントに移動することはできません。

ページの先頭へ

2 次元の表形式ピボットテーブル レポートを作成する

多次元データを 2 次元の表形式ピボットテーブル レポートにフラット化するには、さまざまな手順を実行する必要があります。最適な結果を得るために、次の手順を順序どおりに実行してください。

ページの先頭へ

ピボットテーブル レポートを作成して、外部データ ソースに接続する

  1. 空白のセルを選択します。

  2. [挿入] タブの [テーブル] で [ピボットテーブル] をクリックし、[ピボットテーブル] をクリックします。

    Excel のリボンのイメージ

    [ピボットテーブルの作成] ダイアログ ボックスが表示されます。

  3. [外部データ ソースを使用] をクリックします。

  4. [接続の選択] をクリックします。

    [ 既存の接続] ダイアログ ボックスが表示されます。

  5. ダイアログ ボックスの上部にある [表示] ボックスの一覧で、必要な接続を含んでいる接続のカテゴリを選ぶか、[すべての接続] (既定) をクリックします。

  6. [接続の選択] ボックスの一覧から接続を選択し、[開く] をクリックします。

  7. 場所を入力します。次のいずれかの操作を行います。

    • セル A1 から始まる新しいワークシートにピボットテーブル レポートを配置するには、[新規ワークシート] をクリックします。

    • 既存のワークシートにピボットテーブル レポートを配置するには、[既存のワークシート] をクリックし、ピボットテーブル レポートを配置するセルの範囲の最初のセルを入力します。

      または、ダイアログ縮小 ボタン イメージ をクリックして] ダイアログ ボックスを一時的に非表示にし、ワークシートで、先頭のセルを選択し、[ダイアログ展開 ボタン イメージ をクリックします。

  8. [OK] をクリックします。

ピボットテーブル フィールド リストが表示され、空のピボットテーブル レポートが指定した場所に追加されます。

ページの先頭へ

[行ラベル] 領域でフィールドを追加、レイアウト、および配置する

フィールドを追加、レイアウト、および配置し、すべてのフィールドが [行ラベル] 領域に追加されるようにするには、ピボットテーブル フィールド リストを使用します。

  1. ピボットテーブル レポートをクリックします。

  2. 次の操作のいずれか、または複数の操作を行います。

    • レポートにフィールドを追加するには、次の操作のいずれか、または複数の操作を行います。

      • [フィールド リスト] のフィールド セクションで各フィールド名の横にあるチェック ボックスをオンにします。各フィールドは、レイアウト セクションの既定の領域に配置されますが、フィールドの配置を変更することもできます。

        既定では、非数値フィールドは [行ラベル] 領域に、数値フィールドは [値] 領域に、時刻/日付フィールドは [列ラベル] 領域に追加されます。

      • フィールドを [行ラベル] 領域に移動するには、フィールド名を右クリックし、ショートカット メニューの [行ラベルに追加] をクリックします。

        ヒント: フィールド名をクリックしたまま、フィールドをフィールド セクションからレイアウト セクションの領域にドラッグすることもできます。

    • フィールドを並べ替えるには、エリアの 1 つでフィールド名をクリックし、次のコマンドのいずれかを選択します。

上へ移動​​    

フィールドを領域内の 1 つ上の位置に移動します。

下へ移動​​    

フィールドを領域内の 1 つ下の位置に移動します。

先頭へ移動    

フィールドを領域の先頭に移動します。

末尾へ移動   

フィールドを領域の末尾に移動します。

行ラベルに移動    

フィールドを [行ラベル] 領域に移動します。

  • 削除するのには、 フィールド、フィールドには、レイアウトの領域にのいずれかの名前をフィールドの削除] をクリックしてしたり、フィールド セクションで、削除する各フィールド名の横にあるチェック ボックスをオフ] をクリックします。

    ヒント: レイアウト セクションでフィールド名をクリックしたまま、ピボットテーブル フィールド リストの外にフィールド名をドラッグすることもできます。

    注: フィールド セクションのチェック ボックスをオフにすると、レポートからフィールドのすべてのインスタンスが削除されます。

ページの先頭へ

ピボットテーブル オプションとフィールド設定を変更する

ピボットテーブル レポートと外部範囲の動作が同じになるように設定するには、次の操作を行います。

ピボット テーブル オプションを変更します。   

  1. ピボットテーブル レポートをクリックします。

  2. [オプション] タブの [ピボットテーブル] で [オプション] をクリックします。

    [ピボットテーブル オプション] ダイアログ ボックスが表示されます。

  3. 更新操作の後、列の幅を自動的に調整するには、[レイアウトと書式] タブをクリックし、[表示] セクションで [更新時に列幅を自動調整する] チェック ボックスをオンにします。

  4. データを更新するたびに書式設定を保持するには、[レイアウトと書式] タブをクリックし、[表示] セクションで [更新時にセル書式を保持する] チェック ボックスをオンにします。

  5. 無効になったアイテムが [フィルタ] メニューによって削除されるようにするには、更新操作の後、[データ] タブをクリックし、[1 フィールドに保持するアイテム数] ボックスの [なし] をクリックします。

フィールドの設定を変更します。   

  1. ピボットテーブル レポートをクリックします。

  2. フィルタが適用されているピボットテーブル レポートに新しいアイテムを追加するには、フィールドごとにセルを右クリックし、ショートカット メニューの [フィールドの設定] をクリックします。次に、[小計とフィルタ] タブをクリックし、[フィルタ] セクションの [新しいアイテムを手動フィルタに含める] チェック ボックスをオンにします。

ページの先頭へ

ピボットテーブル レポートを 2 次元テーブルとしてレイアウトする

ピボットテーブル レポートを 2 次元テーブルとしてレイアウトするには、次の操作を行います。

  1. ピボットテーブル レポートをクリックします。

  2. [デザイン] タブの [レイアウト] で [集計] をクリックし、[小計を表示しない] をクリックします。

  3. [デザイン] タブの [レイアウト] で [総計] をクリックし、[行と列の集計を行わない] をクリックします。

  4. [デザイン] タブの [レイアウト] で [レポートのレイアウト] をクリックし、[表形式で表示] をクリックします。

  5. [オプション] タブの [表示/非表示] で [フィールドの見出し] をクリックします。

ページの先頭へ

ピボットテーブル レポートのデザインをカスタマイズする

ピボット テーブルの組み込みスタイルとスタイルのオプションが 2 次元テーブルではなく、マルチ ディメンション データの設計されています。2 次元テーブル、これらのスタイルにレポートを統合します。 セルの罫線は表示されず、縞模様の行と [デザイン] タブの [ピボット テーブル スタイルのオプション] で[列の縞のチェック ボックスにセルの書式は影響しません。ただし、セルの枠線が各セルには、ピボット テーブル レポートを使用して条件付き書式縞模様の行や列を表示できるように、ピボット テーブル スタイルをカスタマイズできます。

ピボット テーブルのスタイルをカスタマイズします。   

  1. ピボットテーブル レポートをクリックします。

  2. [デザイン] タブの [ピボットテーブル スタイル] で使用するスタイルを選択し、次の操作を行います。

    1. 表示されたスタイルを右クリックし、ギャラリーをスクロールするか、またはスクロール バーの下部にある [その他] をクリックして使用可能なスタイルをすべて表示します。

    2. [複製] をクリックします。

      [ピボットテーブル クイック スタイルの変更] ダイアログ ボックスが表示されます。

    3. オプションで、[名前] ボックスに新しい名前を入力します。

    4. [テーブル要素] ボックスで [テーブル全体] をクリックし、[書式] をクリックします。

      [セルの書式設定] ダイアログ ボックスが表示されます。

    5. [罫線] タブをクリックし、セルの罫線を作成します。

    6. オプションで、[塗りつぶし] タブと [フォント] タブをクリックし、その他の変更を行います。

    7. [OK] を 2 回クリックします。

    8. スクロール バーの下部にある [その他] ボタンをクリックし、[ユーザー設定] カテゴリで、作成したピボットテーブル スタイルをクリックします。

条件付き書式を使用して行の縞模様または縞模様の列を表示します。   

  1. ピボットテーブル レポートのすべての列を選択します。

  2. [ホーム] タブの [スタイル] グループで [条件付き書式] の横にある矢印をクリックし、[ルールの管理] をクリックします。

    Excel のリボンのイメージ

    [条件付き書式ルールの管理] ダイアログ ボックスが表示されます。

  3. 条件付き書式を追加するには、[新規ルール] をクリックします。

    [新しい書式ルール] ダイアログ ボックスが表示されます。

  4. [ルールの種類を選択してください] の [数式を使用して、書式設定するセルを決定] をクリックします。

    1. [ルールの内容を編集してください] の [次の数式を満たす場合に値を書式設定] ボックスに数式を入力します。

    2. 次のいずれかを実行します。

      • 行を縞模様で表示するには、次の数式を入力します。

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A))

  • 列を縞模様で表示するには、次の数式を入力します。

=AND(MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  • 行と列を縞模様で表示するには、次の数式を入力します。

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A),MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  1. [書式] をクリックして、[セルの書式設定] ダイアログ ボックスを表示します。

  2. セルの値が条件を満たした場合に適用する表示形式、フォント、罫線、または塗りつぶしの形式を選択し、[OK] をクリックします。

    複数の書式を選択できます。選択した書式が、[プレビュー] ボックスに表示されます。

ページの先頭へ

ブックを Excel Services に発行する

  1. Office ボタンの画像Microsoft Office ボタンをクリックし、[発行] の横にある矢印をクリックして配布他のユーザーにドキュメントの下の [ Excel Services ] をクリックします。

  2. [ファイル名] ボックスにサーバーへのパスを入力し、ブックの候補の名前を受け入れるか、必要に応じて新しい名前を入力します。

    Windows Vista を実行しているコンピューターの場合    

    • [アドレス バー] で、ブックを使用するユーザーが利用できるネットワークの場所を選択し、[保存] をクリックします。

      Microsoft Windows XP を実行しているコンピューターの場合    

    • [保存先] ボックスで、ブックを使用するユーザーが利用できるネットワークの場所を選択し、[保存] をクリックします。

      たとえば、 http://サーバー/サイト/ファイル名を入力します。

      注: Excel がサーバーに発行できるブックは、Microsoft Office Excel 2007 XML ベースのファイル形式 (.xlsx) または Office Excel 2007 バイナリ ファイル形式 (.xlsb) だけです。

  3. [OK] をクリックします。

  4. ブックの表示可能な領域がブラウザに正しく表示されることを確認するには、[Open this workbook in my browser after I save] チェック ボックスをオンにします。

  5. [保存] をクリックします。

詳細については、「ブックを Excel Services に発行」を参照してください。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×