ピボットテーブルを使用して、Excel Services で使用できる外部データを作成する

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。簡単に参照できるように、こちらに英語の記事があります。

注: この記事は既に役割を終えており、間もなく提供終了となります。Microsoft では、「ページが見つかりません」の問題を避けるために既知のリンクを削除しています。このページへのリンクを作成された場合は、同様に、この問題を避けるためにリンクを削除してください。

Excel Servicesの外部データ接続に基づいてテーブルデータを操作する場合は、外部データ範囲 (クエリテーブルとも呼ばれます) を使用することはできません。多次元、階層データをテーブルに平坦化するピボットテーブル、または2つのディメンションを作成する必要があります。これを行う方法を次に示します。

多次元データと二次元データの比較

1. 多次元ピボットテーブルを変換します。

2次元のピボットテーブルに...

3. フラット化されたテーブル データを Excel Services で表示できるようにします。

目的に合ったトピックをクリックしてください

Excel Services による外部データ ソースへの接続のサポート

外部データに接続されたピボットテーブル レポートと外部データ範囲の違いについて

2 次元の表形式ピボットテーブル レポートを作成する

ピボットテーブル レポートを作成して、外部データ ソースに接続する

[行ラベル] 領域でフィールドを追加、レイアウト、および配置する

ピボットテーブル オプションとフィールド設定を変更する

ピボットテーブル レポートを 2 次元テーブルとしてレイアウトする

ピボットテーブル レポートのデザインをカスタマイズする

ブックを Excel Services に発行する

Excel Services による外部データ ソースへの接続のサポート

ピボットテーブルは、多くの数値データを合計および合計に集計し、階層構造に整理された多次元データを操作するように設計されています。一方、外部データ範囲は、行と列として構造化された2次元テーブルであり、ソースデータの集約レコードを表示します。

データ接続ウィザードまたは Microsoft Query を使用して外部データに接続する場合は、通常、外部データ範囲を作成します。この例外は、外部データに接続されているピボットテーブルを作成する場合のみです。ピボットテーブルでは、外部データ範囲は作成されません。excel services は、ピボットテーブルに基づいて外部データ接続のみをサポートし、外部データ範囲をサポートしていないため、ブックを excel services に発行するときに、接続の作成方法について理解しておく必要があります。

ページの先頭へ

外部データと外部データ範囲に接続されているピボットテーブルの違いについて説明します。

外部データに接続されているピボットテーブルを操作する場合、ピボットテーブルの動作と、注意する必要がある外部データ範囲の間には、次のような違いがあります。

ピボットテーブルグループとサブグループのデータを左から右に並べ替える

一般的に、グループ化されたデータは、1つ以上の列によってデータの並べ替えに基づいています。たとえば、すべての従業員を部門別にグループ化して表示する場合は、部門別にデータの並べ替えを行うことができます。また、従業員による第2の並べ替えを実行することも可能です。また、製品ライン、カテゴリ、製品、または地理、国/地域、都道府県、市区町村などのグループを入れ子にすることもできます。既定では、ピボットテーブルは、関連するデータを簡単に表示したり、見出しやサマリー情報を確認したり、関連アイテムを展開または折りたたむことができるように、左から右へのグループやサブ部門に自動的に並べ替えられます。

製品ラインごとにグループ化されたデータと、カテゴリ別の各製品ライン内の subgrouped

製品群

カテゴリ

製品

エンジン

航空機

翼搭載

尾部搭載

ブースタ

自動車

269 HP

454 HP

排気装置

旅客

高温

標準

SUV

左側の [行ラベル] 領域の列に一意の値を指定することで、データを自動的にフラット化できます。

ID-Num列を追加して、同じ製品ラインデータを平坦化する

ID 番号

製品群

カテゴリ

製品

WM-345

エンジン

航空機

翼搭載

TM-231

エンジン

航空機

尾部搭載

BSTR-567

エンジン

航空機

ブースタ

6C-734

エンジン

自動車

269 HP

8C-121

エンジン

自動車

454 HP

MF-202

排気装置

旅客

高温

MF-321

排気装置

旅客

標準

MF-211

排気装置

SUV

列を表示しない場合は、列をピボットテーブルに追加した後で、列を非表示にすることができます。(列を選択し、[ホーム] タブの [セル] グループで、[書式] の横にある矢印をクリックし、[非表示にする] をポイントして、[列の非表示] をクリックします。

重要: ピボットテーブルでデータソースから重複するデータ行が2つ以上検出された場合、ピボットテーブルには1行しか表示できません。ピボットテーブルに表示されているすべての行を重複している場合でも、データソースからインポートしたテーブル、クエリ、またはビューに一意の値を含む列を追加する必要があります。データソースに一意の列がない場合は、データソースに1つ追加できます。たとえば、AutoNum データ型を持つ列を microsoft Office Access テーブルに追加したり、id データ型が microsoft SQL Server テーブルに含まれる列を作成したり、レコードごとに一意の数値をデータベースクエリに表示したりすることができます。w.

セル データを編集して集計列を追加する

ブックを Excel Services に発行する前に外部データ範囲のデータを編集できますが、ピボットテーブル データは常に読み取り専用です。

外部データ範囲のセルをダブルクリックして編集モードに入ると、値を変更したり数式を入力したりできます。ただし、これはデータ ソースの元の値を変更しているのではありません。また、次にデータを更新したときに、外部データ範囲プロパティ [If the number of rows changes upon data refresh] の設定によっては新しい値が上書きされる可能性があることに注意してください。

ピボットテーブルの行ラベルセルをダブルクリックすると、その行ラベル内の項目がセルによって拡大または縮小されます。ピボットテーブルを2次元のテーブルに分割すると、グループ内のすべての行値がセルの左側に表示されなくなります。

外部データ範囲に基づく Microsoft Office Excel テーブル内の任意の場所に集計列を追加したり、外部データ範囲に列を挿入して数式を入力したりすることができます。集計列をピボットテーブル内に挿入することはできません (ただし、集計フィールドを挿入することはできます)。ただし、ピボットテーブルのすぐ左または右にデータまたは数式を入力する列を追加できます。また、入力された数式の中では、ピボットテーブル内のセル参照を使うことができます。

グラフを作成する

ピボットテーブルのデータに基づいてグラフを作成する場合は、標準のグラフと同様に動作するピボットグラフを作成できますが、 次のような違いがあります。

操作    標準グラフでは、表示するデータのビューごとに1つのグラフを作成しますが、ビューは対話型ではありません。ピボットグラフを使用すると、1つのグラフを作成し、レポートのレイアウトや表示される詳細を変更することによって、さまざまな方法でデータを対話的に表示することができます。Excel Services では、ブックのユーザー操作に基づいて標準のグラフとピボットグラフの両方を更新できますが、両方のグラフは静的な画像として表示されます。

グラフの種類    標準グラフの既定のグラフの種類は、複数のカテゴリの値を比較する集合縦棒グラフです。ピボットグラフの既定のグラフの種類は積み上げ縦棒グラフであり、各値の寄与度をカテゴリ全体に比較します。ピボットグラフを変更するには、散布図、在庫、バブルを除く任意のグラフの種類を選びます。

グラフ要素    ピボットグラフには、標準グラフと同じ要素が含まれていますが、データのさまざまなビューを表示するために追加、回転、または削除できるフィールドとアイテムも含まれています。標準グラフのカテゴリ、系列、データは、ピボットグラフのカテゴリフィールド、系列フィールド、および値フィールドです。ピボットグラフには、レポートフィルターを含めることもできます。これらの各フィールドには項目が含まれています。これは、標準グラフでは、凡例に分類ラベルまたは系列名として表示されます。

書式設定    要素、レイアウト、スタイルなど、ほとんどの書式設定は、ピボットグラフを最新の情報に更新するときに保持されます。ただし、近似曲線、データラベル、 誤差範囲、データ系列に対するその他の変更は保持されません。標準グラフでは、この書式設定が適用されても失われません。

アイテムを移動またはサイズ変更   する ピボットグラフでは、 プロット エリア、凡例、グラフタイトル、または軸ラベルを移動またはサイズ変更することはできませんが、凡例にはいくつかの既定の位置を選ぶことができます。また、タイトルのフォントサイズを変更することもできます。標準のグラフでは、これらの要素のすべてを移動したり、サイズを変更したりすることができます。

ピボットグラフを作成した後、必要に応じて、それを標準のグラフに変換することができます。詳細については、「ワークシートデータを anaylze にピボットテーブルを作成する」または「ピボットグラフを作成する」を参照してください。

外部データ範囲のプロパティとピボットテーブル オプションを比較する

外部データ範囲とピボットテーブルには、データの書式設定とレイアウトを制御するために使うことができるプロパティと、データの更新動作があります。

外部データ範囲とピボットテーブルの両方を使用すると、列の幅を調整したり、列の並べ替え、フィルター処理、セルの書式設定、外部データを更新した場合のデータのレイアウトを保持することができます。

外部データ範囲には、データの最初の列として行番号を含めるオプションもあります。ピボットテーブルでは、同様のオプションはありません。データソースに一意の列を追加する方法については、「ピボットテーブルグループとサブグループのデータを左から右に並べて表示する」を参照してください。

外部データ範囲を更新するときにデータ範囲の行数が変更された場合、次のオプションのいずれかを設定することで、既存のデータに対する処理を制御できます。

  • [新しいデータのセルを挿入し、使用されていないセルを削除する] (既定)

  • [新規データの行全体を挿入し、使用されていないセルはクリアする]

  • [既存のセルを新規データで上書きし、使用されていないセルはクリアする]

ピボットテーブルを更新すると、新しいデータのみが表示されます。ただし、現在のレポートの下にある既存のセルを上書きするかどうかを確認するメッセージが表示される場合があります。

データの抽出

外部データ範囲とピボットテーブルのデータをフィルター処理することはよく似ていますが、次のような違いがあります。

  • 外部データ範囲では、[テキストフィルター]、[数値フィルター]、[日付フィルター ] コマンドを使用しますが、ピボットテーブルでは、[ラベルフィルター]、[値フィルター]、および [日付フィルター ] コマンドが使用されます。

  • 外部データ範囲の [フィルター] メニューでは、無効になっている項目は常に削除されますが、フィルターメニューには更新操作後に適用したフィルターを含む新しいアイテムは含まれませんが、ピボットテーブルにはこの動作を制御するオプションがあります。詳細については、「ピボットテーブルのオプションとフィールドの設定を変更する」を参照してください。

  • ピボットテーブルには、ピボットテーブル内のデータのサブセットを操作できるレポートフィルター機能 (外部データ範囲には使用できません) があります。

データを並べ替える

外部データ範囲では、最大64列で複数列の並べ替えを実行することができます。1つ目の並べ替えとして任意の縦棒を選ぶことができ、他の列を2番目の並べ替えとして選ぶことができます。ただし、ピボットテーブルのデータを並べ替えるプロセスと外部データ範囲の並べ替えは異なります。外部データ範囲とは異なり、ピボットテーブルでは、左端の列に対してのみ主な並べ替えを実行できます。他のすべての列では、左側の列に基づいて二次的な並べ替えが実行されます。つまり、プライマリとセカンダリの並べ替えは、左から右の順序でのみ実行できます。

さらに、左側の最初の列として一意の値を持つ列を配置する場合、実際には行ごとに 1 つの 1 次グループを作成するため、実行できるのはその列を基準にした並べ替えのみです。必要に応じて、Excel でデータを事前に並べ替え、ブックを Excel Services に発行した後、Microsoft Office Excel Web Access Web パーツ ツール ウィンドウの [並べ替え] チェック ボックスをオフにすることで、並べ替えを無効にできます。

ハイパーリンクを使用する

外部データ範囲とは異なり、ピボットテーブル セルではアクティブ ハイパーリンクはサポートされていません。ハイパーリンクはテキストとして扱われ、Excel や Excel Services では、ハイパーリンクを介して Web ページまたはドキュメントに移動することはできません。

ページの先頭へ

2次元の表形式のピボットテーブルを作成する

多次元データを2次元の表形式のピボットテーブルに統合するには、いくつかの手順が必要です。最適な結果を得るには、次の手順を順番に実行します。

ページの先頭へ

ピボットテーブルを作成して外部データソースに接続する

  1. 空白のセルを選択します。

  2. [挿入] タブの [テーブル] で [ピボットテーブル] をクリックし、[ピボットテーブル] をクリックします。

    Excel のリボンのイメージ

    [ピボットテーブルの作成] ダイアログ ボックスが表示されます。

  3. [外部データ ソースを使用] をクリックします。

  4. [接続の選択] をクリックします。

    、 [既存の接続] ダイアログボックスが表示されます。

  5. ダイアログ ボックスの上部にある [表示] ボックスの一覧で、必要な接続を含んでいる接続のカテゴリを選ぶか、[すべての接続] (既定) をクリックします。

  6. [接続の選択] ボックスの一覧から接続を選択し、[開く] をクリックします。

  7. 場所を入力します。次のいずれかの操作を行います。

    • セル A1 から新しいワークシートにピボットテーブルを配置するには、[新しいワークシート] をクリックします。

    • 既存のワークシートにピボットテーブルを配置するには、[既存のワークシート] を選び、ピボットテーブルを配置するセル範囲の最初のセルを入力します。

      または、[ダイアログ ボタン イメージ の折りたたみ] をクリックしてダイアログボックスを一時的に非表示にし、ワークシートの最初のセルを選択して、[ダイアログ ボタン イメージ の展開] をクリックします。

  8. [OK] をクリックします。

ピボットテーブルのフィールドリストが表示された空のピボットテーブルが、入力した場所に追加されます。

ページの先頭へ

[行ラベル] 領域でフィールドを追加、レイアウト、および配置する

フィールドを追加、レイアウト、および配置し、すべてのフィールドが [行ラベル] 領域に追加されるようにするには、ピボットテーブル フィールド リストを使用します。

  1. ピボットテーブルをクリックします。

  2. 次の操作のいずれか、または複数の操作を行います。

    • レポートにフィールドを追加するには、次の操作のいずれか、または複数の操作を行います。

      • [フィールド リスト] のフィールド セクションで各フィールド名の横にあるチェック ボックスをオンにします。各フィールドは、レイアウト セクションの既定の領域に配置されますが、フィールドの配置を変更することもできます。

        既定では、非数値フィールドは [行ラベル] 領域に、数値フィールドは [値] 領域に、時刻/日付フィールドは [列ラベル] 領域に追加されます。

      • フィールドを [行ラベル] 領域に移動するには、フィールド名を右クリックし、ショートカット メニューの [行ラベルに追加] をクリックします。

        ヒント: フィールド名をクリックしたまま、フィールドをフィールド セクションからレイアウト セクションの領域にドラッグすることもできます。

    • フィールドを並べ替えるには、エリアの 1 つでフィールド名をクリックし、次のコマンドのいずれかを選択します。

上へ移動​​    

フィールドを領域内の 1 つ上の位置に移動します。

下へ移動​​    

フィールドを領域内の 1 つ下の位置に移動します。

先頭へ移動    

フィールドを領域の先頭に移動します。

末尾へ移動   

フィールドを領域の末尾に移動します。

行ラベルに移動    

フィールドを [行ラベル] 領域に移動します。

  • を削除するには フィールドで、いずれかのレイアウト領域でフィールド名をクリックし、[フィールドの削除] をクリックするか、[フィールド] セクションで、削除する各フィールド名の横にあるチェックボックスをオフにします。

    ヒント: レイアウト セクションでフィールド名をクリックしたまま、ピボットテーブル フィールド リストの外にフィールド名をドラッグすることもできます。

    注: フィールド セクションのチェック ボックスをオフにすると、レポートからフィールドのすべてのインスタンスが削除されます。

ページの先頭へ

ピボットテーブル オプションとフィールド設定を変更する

ピボットテーブルが外部範囲と同じように動作するようにするには、次の操作を行います。

ピボットテーブル オプションを変更する   

  1. ピボットテーブルをクリックします。

  2. [オプション] タブの [ピボットテーブル] で [オプション] をクリックします。

    [ピボットテーブル オプション] ダイアログ ボックスが表示されます。

  3. 更新操作の後、列の幅を自動的に調整するには、[レイアウトと書式] タブをクリックし、[表示] セクションで [更新時に列幅を自動調整する] チェック ボックスをオンにします。

  4. データを更新するたびに書式設定を保持するには、[レイアウトと書式] タブをクリックし、[表示] セクションで [更新時にセル書式を保持する] チェック ボックスをオンにします。

  5. 無効になったアイテムが [フィルタ] メニューによって削除されるようにするには、更新操作の後、[データ] タブをクリックし、[1 フィールドに保持するアイテム数] ボックスの [なし] をクリックします。

フィールド設定を変更する   

  1. ピボットテーブルをクリックします。

  2. 適用されたフィルターを使用してピボットテーブルに新しいアイテムを含めるには、各フィールドのセルを右クリックし、ショートカットメニューの [フィールドの設定] をクリックし、[集計とフィルター ] タブをクリックして、[フィルター ] セクションの [[手動フィルターに新しいアイテムを含める] チェックボックスをオンにします。

ページの先頭へ

ピボットテーブルを2次元のテーブルとしてレイアウトする

ピボットテーブルを2次元のテーブルとしてレイアウトするには、次の操作を行います。

  1. ピボットテーブルをクリックします。

  2. [デザイン] タブの [レイアウト] で [集計] をクリックし、[小計を表示しない] をクリックします。

  3. [デザイン] タブの [レイアウト] で [総計] をクリックし、[行と列の集計を行わない] をクリックします。

  4. [デザイン] タブの [レイアウト] で [レポートのレイアウト] をクリックし、[表形式で表示] をクリックします。

  5. [オプション] タブの [表示/非表示] で [フィールドの見出し] をクリックします。

ページの先頭へ

ピボットテーブルのデザインをカスタマイズする

組み込みのピボットテーブルスタイルとスタイルオプションは、多次元データ用に設計されています。2次元テーブルではありません。レポートを2次元のテーブルに統合すると、次のスタイル [デザイン] タブの [ピボットテーブルスタイルのオプション] グループの [セルの枠線と縞模様の縞模様の列を表示しない] チェックボックスは、セルの書式には影響しません。ただし、ピボットテーブルのスタイルをカスタマイズして、各セルにセルの枠線があり、ピボットテーブルで条件付き書式を使用して、縞模様の行や列を表示することができます。

ピボットテーブル スタイルをカスタマイズする   

  1. ピボットテーブルをクリックします。

  2. [デザイン] タブの [ピボットテーブル スタイル] で使用するスタイルを選択し、次の操作を行います。

    1. 表示されたスタイルを右クリックし、ギャラリーをスクロールするか、またはスクロール バーの下部にある [その他] をクリックして使用可能なスタイルをすべて表示します。

    2. [複製] をクリックします。

      [ピボットテーブル クイック スタイルの変更] ダイアログ ボックスが表示されます。

    3. オプションで、[名前] ボックスに新しい名前を入力します。

    4. [テーブル要素] ボックスで [テーブル全体] をクリックし、[書式] をクリックします。

      [セルの書式設定] ダイアログ ボックスが表示されます。

    5. [罫線] タブをクリックし、セルの罫線を作成します。

    6. オプションで、[塗りつぶし] タブと [フォント] タブをクリックし、その他の変更を行います。

    7. [OK] を 2 回クリックします。

    8. スクロール バーの下部にある [その他] ボタンをクリックし、[ユーザー設定] カテゴリで、作成したピボットテーブル スタイルをクリックします。

条件付き書式を使用して縞模様の行または縞模様の列を表示する   

  1. ピボットテーブル内のすべての列を選択します。

  2. [ホーム] タブの [スタイル] グループで [条件付き書式] の横にある矢印をクリックし、[ルールの管理] をクリックします。

    Excel のリボンのイメージ

    [条件付き書式ルールの管理] ダイアログ ボックスが表示されます。

  3. 条件付き書式を追加するには、[新規ルール] をクリックします。

    [新しい書式ルール] ダイアログ ボックスが表示されます。

  4. [ルールの種類を選択してください] の [数式を使用して、書式設定するセルを決定] をクリックします。

    1. [ルールの内容を編集してください] の [次の数式を満たす場合に値を書式設定] ボックスに数式を入力します。

    2. 次のいずれかの操作を行います。

      • 行を縞模様で表示するには、次の数式を入力します。

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A))

  • 列を縞模様で表示するには、次の数式を入力します。

=AND(MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  • 行と列を縞模様で表示するには、次の数式を入力します。

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A),MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  1. [書式] をクリックして、[セルの書式設定] ダイアログ ボックスを表示します。

  2. セルの値が条件を満たした場合に適用する表示形式、フォント、罫線、または塗りつぶしの形式を選択し、[OK] をクリックします。

    複数の書式を選択できます。選択した書式が、[プレビュー] ボックスに表示されます。

ページの先頭へ

ブックを Excel Services に発行する

  1. [ Microsoft Office ボタン Office ボタンの画像 ] をクリックし、[発行] の横にある矢印をクリックして、[他のユーザーにドキュメントを配布する] の [ Excel Services ] をクリックします。

  2. [ファイル名] ボックスにサーバーへのパスを入力し、ブックの候補の名前を受け入れるか、必要に応じて新しい名前を入力します。

    Windows Vista を実行しているコンピューターの場合    

    • [アドレス バー] で、ブックを使用するユーザーが利用できるネットワークの場所を選択し、[保存] をクリックします。

      Microsoft Windows XP を実行しているコンピューターの場合    

    • [保存先] ボックスで、ブックを使用するユーザーが利用できるネットワークの場所を選択し、[保存] をクリックします。

      たとえば、「 http://server/site/ファイル名」と入力します。

      注: Excel がサーバーに発行できるブックは、Microsoft Office Excel 2007 XML ベースのファイル形式 (.xlsx) または Office Excel 2007 バイナリ ファイル形式 (.xlsb) だけです。

  3. [OK] をクリックします。

  4. ブックの表示可能な領域がブラウザに正しく表示されることを確認するには、[Open this workbook in my browser after I save] チェック ボックスをオンにします。

  5. [保存] をクリックします。

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×