ピボットテーブルのデータを更新する

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。簡単に参照できるように、こちらに英語の記事があります。

いつでも、[更新] をクリックしてブック内のピボットテーブルのデータを更新できます。 データベース (SQL Server、Oracle、Access など)、Analysis Services キューブ、データ フィードなと、ソースとなるさまざまな種類の外部データに接続されたピボットテーブルのデータを更新できます。 同じまたは別のブックにあるソース テーブルから取得したデータも更新できます。 また、ブックを開いたときにピボットテーブルのデータを自動更新するように、ブックを設定することもできます。

既定では、ピボットテーブルは自動的に更新されることはありません。ただし、pivottable を含むブックを開いたときにピボットテーブルが自動的に更新されるように指定することはできます。

手動で更新する

  1. ピボットテーブル内の任意の場所をクリックし、リボンの [ピボットテーブル ツール] を表示します。

    ピボットテーブル ツール

  2. [分析]、[更新] の順にクリックするか、Alt キーを押しながら F5 キーを押します。

    [分析] タブの [更新]

    ヒント: ブック内のすべてのピボットテーブルを一度に更新するには、[分析]、[すべて更新] の順にクリックします。

予期したよりも更新に時間がかかる場合は、[分析]、[更新] 矢印、[データ更新の状況] の順にクリックして、更新の状況を確認します。

更新を中止するには、[更新の取り消し] をクリックします。

列幅やセルの書式設定が調整されないようにする

ピボットテーブル データを更新したときにデータの列幅やセルの書式設定が調整されないようにする場合は、次のオプションをオンにします。

  1. [分析]、[オプション] の順にクリックします。

    [分析] タブの [オプション]

  2. [レイアウトと書式] タブで、[更新時に列幅を自動調整する] ボックスと [更新時にセル書式を保持する] ボックスをオンにします。

ブックを開くときにデータを自動的に更新する

  1. ピボットテーブル内の任意の場所をクリックし、リボンの [ピボットテーブル ツール] を表示します。

    ピボットテーブル ツール

  2. [分析]、[オプション] の順にクリックします。

    [分析] タブの [オプション]

  3. [データ] タブで、[ファイルを開くときにデータを更新する] チェックボックスをオンにします。

手動で更新する

  1. ピボットテーブルの任意の場所をクリックします。

    これにより、ピボットテーブルツールが表示され、オプションと [デザイン] タブを追加できます。

  2. [オプション] タブの [データ] グループで、次のいずれかの操作を行います。

  3. データソースに一致するように情報を更新するには、[更新] ボタンをクリックするか、ALT キーを押しながら F5

    ピボットテーブルを右クリックし、[更新] をクリックすることもできます。

  4. ブック内のすべてのピボットテーブルを更新するには、[更新] ボタンの矢印をクリックし、[すべて更新] をクリックします。

    Excel のリボン イメージ

    予想よりも更新に時間がかかる場合は、[オプション]、[更新]、[状態を更新] の順にクリックして、更新の状態を確認します。

    更新を中止するには、[更新の取り消し] をクリックします。

列幅やセルの書式設定が調整されないようにする

ピボットテーブル データを更新したときにデータの列幅やセルの書式設定が調整されないようにする場合は、次のオプションをオンにします。

  1. [オプション]、[オプション] の順に選びます。

    [ピボットテーブル ツール] の [オプション] タブの [ピボットテーブル] グループ
  2. [レイアウトと書式] タブで、[更新時に列幅を自動調整する] ボックスと [更新時にセル書式を保持する] ボックスをオンにします。

ブックを開くときにピボットテーブルのデータを自動的に更新する

  1. ピボットテーブルの任意の場所をクリックします。

  2. [オプション] タブの [ピボットテーブル] グループにある [オプション] をクリックします。

    [ピボットテーブル ツール] の [オプション] タブの [ピボットテーブル] グループ

  3. [ピボットテーブルのオプション] ダイアログボックスの [データ] タブで、[ファイルを開くときにデータを更新する] チェックボックスをオンにします。

ピボットテーブルのデータソースに新しいデータを追加した場合は、そのデータソース上に構築されたすべてのピボットテーブルを更新する必要があります。ピボットテーブルを更新するには、ピボットテーブルの範囲内の任意の場所を右クリックし、[更新] を選びます。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×