ピボットグラフを作成する

次の例のように、集計されていない生データがあると、全体像を把握するのが難しい場合あります。多くの場合、まず最初に、ピボットテーブルを作成し、データを構造化された形式で集計して分析します。これは悪いことではありませんが、誰でも数字を見ただけですぐに状況を把握できるわけではありません。ピボットグラフは、データを視覚的に表現する優れた方法です。

家計データ

対応するピボットグラフ

月、カテゴリ、金額を示すピボットテーブル​​を作成するための家計データのサンプル

Excel のピボットグラフの例

普通のワークシート データだけがあってピボットテーブルがまだない場合は、データにお勧めのピボットグラフを選ぶと、Excel が関連するピボットテーブルを自動的に作成します。手順は次のとおりです。

  1. データ内の任意の場所をクリックします。

  2. [挿入] タブの [グラフ] グループで、[おすすめグラフ] を選びます。

    [挿入] タブの [おすすめグラフ] ボタン

  3. [おすすめグラフ] タブで、上部のピボットグラフ アイコン ピボットグラフ インジケーター ボタン が付いているいずれかのグラフを選びます。ピボットグラフのプレビューがプレビュー ウィンドウに表示されます。

    おすすめのピボットグラフを示す [グラフの挿入] ダイアログ ボックス

  4. お好みのピボットグラフが見つかったら、[OK] をクリックします。ピボットテーブルとピボットグラフの両方を含む新しいワークシートが自動的に作成されます。

  5. ピボットグラフをピボットテーブルの横に配置してピボット データとグラフの両方を見ることができるようにしたり、グラフだけを見たい場合はデータに重ねてピボットグラフを配置したりすることができます。

  6. 次に、ピボットグラフの書式を設定することができます。

おすすめグラフ オプションを試してみて、適切なものが見つからなかった場合は、独自のグラフを作ることができます。

  1. ワークシート データ内のセルを選び、[挿入]、[ピボットグラフ]、[ピボットグラフ] の順に移動します。

  2. ピボットグラフを配置する場所の指定を求めるダイアログが表示されます。一般に、[新しいワークシート] を選ぶことをお勧めします。そうすれば、ワークシート上の他のものに影響を与えることなく、目的の外観のグラフにする方法を試してみることができます。

    Excel で挿入 > ピボットグラフ オプション
  3. [OK] をクリックすると、空のピボットテーブルとピボットグラフを含む新しいワークシートが追加されます。

    空のピボットグラフが現れ、ピボットグラフ内のフィールドを追加したり再配置したりできるように [フィールド リスト] が表示されます。

  4. [フィールド リスト] で、ピボットグラフに表示するフィールドを選びます。

    フィールド セクションと領域セクションの表示された [フィールド リスト]

  5. 次に、ピボットグラフの書式を設定することができます。

ピボットテーブルを事前に作成して適切に設定している場合は、この方法を使うと最も完全なピボットグラフが自動的に作成されます。

  1. ピボットテーブル範囲内の任意のセルを選びます。

  2. [ピボットテーブル ​​ツール]、[分析]、[ピボットグラフ] の順に移動します。

  3. 目的のグラフの種類を選んで、[OK] をクリックします。

    基にしたピボットテーブルと同じシートに、新しいピボットグラフが配置されます。この例では、標準的な [縦棒] グラフを選びます。どのグラフの種類にすればよいかわからない場合は、種類を 1 つずつ選ぶと、[グラフの挿入] ウィンドウにリアルタイムのプレビューが表示されます。

    グラフの種類のリアルタイム プレビューと縦棒グラフが選択されているピボットグラフの例

    ピボットテーブルのデータをサポートしていないグラフがありますが、そのようなグラフを選択すると、Excel がそのことを通知します。

  4. 次に、ピボットグラフの書式を設定することができます。

  1. [データ]、[その他のデータソース] の順にクリックして、使用するデータ ソースを選びます。たとえば、[Analysis Services] を選択すれば、オンライン分析処理 (OLAP) のキューブ ファイルに接続できます。

    [データ] タブの [その他のデータ ソース] ボタン

  2. データ接続ウィザードの指示に従って操作し、[完了] をクリックします。

  3. [データのインポート] ダイアログ ボックスで、[ピボットグラフ] を選び、データを置く場所を指定してから [OK] をクリックします。

    空のピボットグラフが現れ、ピボットグラフ内のフィールドを追加したり再配置したりできるように [フィールド リスト] が表示されます。

  4. [フィールド リスト] で、ピボットグラフに表示するフィールドを選びます。

    フィールド セクションと領域セクションの表示された [フィールド リスト]

  5. 次に、ピボットグラフの書式を設定することができます。

  1. [挿入]、[ピボットグラフ] の順にクリックします。

    [挿入] タブの [ピボットグラフ] ボタン

  2. [ピボットグラフの作成] ダイアログ ボックスで、[外部データ ソースを使用] をクリックし、[接続の選択] をクリックします。

  3. [既存の接続] ダイアログ ボックスの [接続] タブで、使用する接続をダブルクリックします。

  4. [OK] をクリックします。

    空のピボットグラフが現れ、ピボットグラフ内のフィールドを追加したり再配置したりできるように [フィールド リスト] が表示されます。

  5. [フィールド リスト] で、ピボットグラフに表示するフィールドを選びます。

フィールド セクションと領域セクションの表示された [フィールド リスト]

ピボットグラフを作成した後、その他の標準グラフで行えるのとほとんど同じようにグラフをカスタマイズできます。ピボットグラフを選ぶと、次のようになります。

  1. グラフの横にボタンが表示され、タイトルデータ ラベルなどのグラフ要素の追加と変更、ピボットグラフのグラフ スタイルや色の変更などを、標準のグラフで行うのと同じように簡単に行えます。

    フィールド ボタンとグラフ ツールを示すラベルが付加されたピボットグラフ

  2. フィールド ボタン - Excel では、ピボットテーブルのフィールドがピボットグラフ上にボタンとして自動的に表示されます。このボタンを使うと、1 つのピボットグラフをフィルター処理して、必要な詳細だけを表示することができます。フィールド ボタンの代わりにピボットテーブル スライサーを使って、複数のピボットテーブルとピボットグラフを一度にフィルター処理することもできます。これらを削除するには、ピボットテーブルまたはピボットグラフをクリックし、リボンの [分析] タブで、[フィールド リスト] ボタンをオフにします。

  3. リボンに [ピボットグラフ ツール] が表示されます。[分析] タブ、[デザイン] タブ、および [書式] タブで、ピボットグラフで作業したり、ピボットグラフをカスタマイズしたりするためのオプションを選べます。

    リボン上の [ピボットグラフ ツール]

  4. ピボットグラフをその基になっているピボットテーブルと同じワークシート上に置く必要はないので、意図したとおりのピボットグラフができたら、切り取って別の場所に貼り付けることができます。

  5. 不要になったピボットグラフを削除するには、グラフを選んでから Delete キーを押します。

Mac でピボットグラフを作成するには、最初にピボットテーブルを作成してから、グラフを挿入する必要があります。その後は、[ピボットテーブルのフィールド] の一覧でフィールドを変更すると、グラフはピボットグラフのように動作します。 

  1. まだない場合は、ピボットテーブルを作成します。 

  2. ピボットテーブル内の任意のセルを選びます。

  3. [挿入] タブのボタンをクリックして、棒グラフ、折れ線グラフ、円グラフ、またはレーダー チャートを挿入します。他の種類のグラフは現時点ではピボットテーブルで動作しないことに注意してください。たとえば、ツリーマップ図、統計グラフ、複合グラフは、ピボットテーブルではまだ機能しません。

  4. 棒グラフ、折れ線グラフ、円グラフ、またはレーダー チャートを挿入した後は、[ピボットテーブルのフィールド] の一覧を使ってフィールドを変更または移動してピボットできます。

  5. また、ピボットテーブルのデータをフィルター処理したり、スライサーを使ったりすることもできます。その場合、グラフもフィルター処理されます。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

関連トピック

ピボットテーブルを作成する
フィールド リストを使ってピボットテーブル内でフィールドを配置する
スライサーを使用してデータをフィルター処理する
日付をフィルター処理するためのピボットテーブル タイムラインを作成する

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×