ビューを切り替えるためのボタンを追加する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft Office InfoPath では、同じフォーム テンプレートのさまざまなビューを作成できます。ビューは、フォーム テンプレートにデータを表示する別の方法です。フォーム テンプレートに基づくフォームに入力するときは、ユーザーがフォームに表示されるデータの量を選択するビューを切り替えることができます。たとえば、ステータス レポート フォーム テンプレートでビューの概要ビューをデザインできます。ユーザーは、どのような種類の情報を必要に応じて、確認する必要があるビューを選択できます。

動作規則に従って動作するようにビューをデザインすることはよくあります。動作規則を使用すると、フォームを入力するユーザーが実行したイベントやアクションに反応して、フォーム テンプレートの特定のタスクを自動化できます。たとえば、この記事では、フォーム テンプレートにボタンを挿入し、そのボタンがクリックされたときにビューを切り替える動作規則を作成する方法について説明します。

このトピックの内容

手順 1: 各ビューのボタンを挿入します。

手順 2: ビューを切り替えるルールを作成します。

手順 3: ユーザーの操作性をテストします。

手順 1: 各ビューにボタンを追加する

注: 次の手順を完了するには、既存のビューが 2 つあるフォーム テンプレートが必要です。ビューの作成の詳細については、[参照] にあるリンクを参照してください。

  1. [表示] メニューの [ビューの管理] をクリックします。

  2. [ビューの選択] で、ボタンを追加するビューをクリックします。

  3. フォーム テンプレートで、ボタンを挿入する場所にカーソルを置きます。

  4. [挿入] メニューの [コントロールの選択] をクリックするか、または Alt キーを押しながら I キーを押してから、C キーを押します。

  5. [コントロールの挿入] の [コントロール] 作業ウィンドウで、[ボタン] をクリックします。

  6. フォーム テンプレートで、挿入したボタンをダブルクリックします。

  7. [全般] タブをクリックします。

  8. [ラベル] ボックスで、ボタン上に表示する文字列を入力し、[OK] をクリックします。

  9. [表示] メニューの [ビューの管理] をクリックします。

  10. [ビューの選択] で、2 番目のビューの名前をクリックします。

  11. 手順 3. ~ 8. に従って、2 番目のビューにボタンを追加します。

ページの先頭へ

手順 2: ビューを切り替える動作規則を作成する

フォーム テンプレートの各ビューにボタンを追加したら、ユーザーがそれらのボタンをクリックしたときにビューを切り替える動作規則を作成する必要があります。

  1. [表示] メニューの [ビューの管理] をクリックします。

  2. [ビューの選択] で、処理対象のビューをクリックします。

  3. フォーム テンプレートで、前の手順で挿入したボタンをダブルクリックします。

  4. [全般] タブをクリックします。

  5. [動作] の一覧の [動作規則とユーザー設定コード] をクリックします。

  6. [動作規則] をクリックします。

  7. [動作規則] ダイアログ ボックスで [追加] をクリックします。

  8. [名前] ボックスに、動作規則の名前 (たとえば「ビュー 2 に切り替え」) を入力します。この名前は、デザイン モードでビューを操作するときに表示されます。フォームを入力するユーザーにはこの名前は表示されません。

  9. [動作の追加] をクリックします。

  10. [操作] ボックスの一覧で、[ビューを切り替える] をクリックします。

  11. [表示] ボックスの一覧で、切り替えるビューをクリックし、[OK] をクリックします。

  12. [OK] をクリックして、開いているダイアログ ボックスをすべて閉じます。

  13. [ビュー] 作業ウィンドウの [ビューの選択] で、2 番目のビューをクリックします。

  14. 手順 3. ~ 12. に従って、2 番目のビューのボタンに動作規則を作成します。

ページの先頭へ

手順 3: ユーザーにとっての操作性のテスト

ビューにボタンを追加し、必要な動作規則を作成した後で、フォーム テンプレートをテストして、予期したとおりの動作かどうか確認することをお勧めします。

  1. 変更内容をテストするには、[標準] ツール バーの [プレビュー] をクリックするか、Ctrl キーと Shift キーを押しながら B キーを押します。

    注: プレビュー ウィンドウには、最後に操作していたビューが表示されます。

  2. ビューを切り替えるボタンが正常に動作することをテストするには、前の手順で作成したボタンをクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×