マクロを使って作業する

マクロを編集する

お使いのブラウザーは、ビデオをサポートしていません。Microsoft Silverlight、Adobe Flash Player、または Internet Explorer 9 をインストールします。

このビデオでは、Visual Basic Editor と呼ばれる特殊なテキスト エディターでマクロを編集する方法について説明します。Visual Basic のマクロを記録するプログラミング言語ではします。

最初に、[開発] タブを表示します。

[開発] タブの [リボンのでは、すべてのマクロ コマンドがします。

  • ファイルをクリックして、リボンに表示] >オプション>リボンのユーザー設定[開発] チェックし、 [OK] をクリックします。

  • [開発] タブの [コード] グループで、[マクロの記録] ボタン役に立つが他のいくつかのボタンです。

Visual Basic を使用してマクロを作成します。

  1. [開発] をクリックして > Visual Basicします。

  2. Visual Basic Editor で [挿入] メニューで、必要な場合は [モジュール] をクリックします。

    注: モジュールが、ブックのすべてのシートに自動的に作成されます。

  3. モジュールのコード ウィンドウで入力するか、使用するマクロ コードをコピーします。

  4. モジュール ウィンドウからマクロを実行するには、f5 キーを押します。

  5. Visual Basic Editor で [ファイル] メニューは、マクロの記述が終了したら、終了して Microsoft Excel へ戻るをクリックします。

マクロを編集します。

  1. [開発] タブの [コード] グループで、[マクロ] をクリックします。

  2. マクロ名] ボックスに、マクロを編集する] をクリックします。

  3. [編集] をクリックします。Visual Basic Editor が表示されます。

その他の必要な場合

作成、またはマクロを削除します。

マクロを編集します。

ボタンにマクロを割り当てる

作成して、1 つのブックで、すべてのマクロを保存します。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×