スキップしてメイン コンテンツへ

ヒストグラムを作成する

ヒストグラムは、頻度のデータを表示する縦棒グラフです。

注: このトピックでは、ヒストグラムの作成についてのみ説明します。 パレート図 (並べ替えられたヒストグラム) の詳細については、「パレート図を作成する」を参照してください。

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. [挿入]、[統計グラフの挿入]、[ヒストグラム] の順にクリックします。

    [統計グラフの挿入] ボタンからアクセスしたヒストグラム コマンド

    [おすすめグラフ] の [すべてのグラフ] タブを使用して、ヒストグラムを作成することもできます。

ヒント: 

  • グラフの外観をカスタマイズするには、[デザイン] タブと [書式] タブを使用します。

  • これらのタブが表示されない場合は、ヒストグラムの好きな場所をクリックして、[グラフ ツール] をリボンに追加します。

[グラフ ツール] の [デザイン] タブと [書式設定] タブ

  1. グラフの水平軸を右クリックして、[軸の書式設定]、[軸のオプション] の順にクリックします。

    ショートカット メニューの [軸の書式設定] コマンド
  2. 以下の表の情報を使って、[軸の書式設定] 作業ウィンドウで設定するオプションを選びます。

    オプション

    説明

    カテゴリ別

    カテゴリ (横軸) がテキストベースで、数値でない場合に、このオプションを選びます。 ヒストグラムによって同じカテゴリがグループ化され、数値軸の値が合計されます。

    ヒント: テキスト文字列の数を数えるには、列を追加して、「1」の値を入力し、ヒストグラムをプロットして、ビンを [項目別] に設定します。

    自動

    これは、ヒストグラムの既定の設定です。 ビンの幅は、スコットの正規化基準ルールを使用して計算されます。

    ビンの幅

    各範囲のデータ ポイントの数に正の 10 進数を入力します。

    ビンの数

    ヒストグラムのビンの数を入力します (ビンのオーバーフローとアンダーフローを含む)。

    ビンのオーバーフロー

    右側のボックスの値を上回るすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    ビンのアンダーフロー

    右側のボックスの値以下のすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    [軸の書式設定] 作業ウィンドウ

ヒント: ヒストグラム図と、統計データの視覚化の方法については、Excel チームによるヒストグラム図、パレート図、箱ひげ図に関するブログ投稿を参照してください。 また、このブログ投稿で説明されているその他の新しいグラフの種類も参照してください。

[自動] オプション (スコットの正規化基準ルール)   

自動化の数式オプション

スコットの正規化基準ルール (Scott’s normal reference rule) では、データ セットと比較した場合のヒストグラムの分散の偏りを最小化します。通常は分散データを想定しています。

[ビンのオーバーフロー] オプション   

オーバーフロー ビンの数式オプション

[ビンのアンダーフロー] オプション   

ビンのアンダーフローの数式オプション
  1. 分析ツールが読み込まれていることを確認します。 詳細については、「Excel で分析ツールを読み込む」参照してください。

  2. ワークシートで、入力データを 1 つの列に入力し、必要に応じて最初のセルにラベルを追加します。

    項目の合計値、テストの点数など、必ず定量的な数値データを使用します。 ヒストグラム ツールには、文字列として入力された識別番号などの定性的な数値データは使用できません。

  3. 次の列に、境界値を昇順で入力し、必要に応じて最初のセルにラベルを追加します。

    独自の境界値を使用すると、分析に役立つ可能性があります。 境界値を入力しなかった場合は、ヒストグラム ツールが入力範囲の最小値と最大値を開始点および終了点として使用し、境界値の間隔を均等に分散させます。

  4. [データ] > [データ分析] をクリックします。

    [データ分析] と [ソルバー]

  5. [ヒストグラム]、[OK] の順にクリックします。

    [データ分析] ダイアログ ボックス

  6. [入力] で、次の操作を行います。

    1. [入力範囲] ボックスに、入力番号が設定されているデータ範囲のセル参照を入力します。

    2. [データ区間] ボックスに、境界値が設定されている範囲のセル参照を入力します。

      ワークシートに列見出しを使用した場合は、見出しもセル参照に含めることができます。

      ヒント: 参照を手動で入力する代わりに、 [折りたたみ] ボタン をクリックしてダイアログ ボックスを一時的に縮小し、ワークシート上で範囲を選択することができます。 このボタンを再びクリックすると、ダイアログ ボックスが表示されます。

  7. セル参照に列ラベルを含めている場合は、[ラベル] ボックスをオンにします。

  8. [出力オプション] で、出力先を選びます。

    ヒストグラムは、同じワークシート上、現在のブックの新しいワークシート上、または新しいブックに出力することができます。

  9. 次のボックスを 1 つ以上オンにします。

    パレート図 (並べ替えられたヒストグラム) これにより、頻度の降順でデータが表示されます。

    累積比率     これにより累積パーセンテージが表示され、ヒストグラムグラフに累積パーセンテージの線が追加されます。

    グラフの出力     埋め込みヒストグラムのグラフが表示されます。

  10. [OK] をクリックします。

    ヒストグラムをカスタマイズする場合は、テキストのラベルを変更したり、ヒストグラムグラフ内の任意の場所をクリックして、グラフの右側にある [グラフ要素]、[グラフスタイル]、および [グラフフィルター ] ボタンを使用したりすることができます。

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. [挿入]、[グラフ] の順にクリックします。

    Word の [挿入] タブの [図] グループの [グラフ]
  3. [グラフの挿入] ダイアログ ボックスの [すべてのグラフ] で、[ヒストグラム] をクリックして、[OK] をクリックします。

ヒント: 

  • グラフの外観をカスタマイズするには、リボンにある [デザイン] タブと [書式] タブを使用します。

  • これらのタブが表示されない場合は、ヒストグラムの好きな場所をクリックして、[グラフ ツール] をリボンに追加します。

[グラフ ツール] の [デザイン] タブと [書式設定] タブ

  1. グラフの水平軸を右クリックして、[軸の書式設定]、[軸のオプション] の順にクリックします。

    ショートカット メニューの [軸の書式設定] コマンド
  2. 以下の表の情報を使って、[軸の書式設定] 作業ウィンドウで設定するオプションを選びます。

    オプション

    説明

    カテゴリ別

    カテゴリ (横軸) がテキストベースで、数値でない場合に、このオプションを選びます。 ヒストグラムによって同じカテゴリがグループ化され、数値軸の値が合計されます。

    ヒント: テキスト文字列の数を数えるには、列を追加して、「1」の値を入力し、ヒストグラムをプロットして、ビンを [項目別] に設定します。

    自動

    これはヒストグラムの既定の設定です。

    ビンの幅

    各範囲のデータ ポイントの数に正の 10 進数を入力します。

    ビンの数

    ヒストグラムのビンの数を入力します (ビンのオーバーフローとアンダーフローを含む)。

    ビンのオーバーフロー

    右側のボックスの値を上回るすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    ビンのアンダーフロー

    右側のボックスの値以下のすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    [軸の書式設定] 作業ウィンドウ

ヒント: ヒストグラム図と、統計データの視覚化の方法については、Excel チームによるヒストグラム図、パレート図、箱ひげ図に関するブログ投稿を参照してください。 また、このブログ投稿で説明されているその他の新しいグラフの種類も参照してください。

Excel for Mac でヒストグラムを作成するには、次の手順を実行します。

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. リボンで、[挿入] タブをクリックし、 統計グラフ アイコン ([統計] アイコン) をクリックして、[ヒストグラム] の下で [ヒストグラム] を選択します。

ヒント: 

  • グラフの外観をカスタマイズするには、[グラフのデザイン] タブと [書式] タブを使用します。

  • [グラフのデザイン] タブおよび [書式] タブが表示されない場合は、ヒストグラムの任意の場所をクリックして、それらをリボンに追加します。

Excel 2011 for Mac でヒストグラムを作成するには、サードパーティ製のアドインをダウンロードする必要があります。 参照:詳細については、「Excel 2011 for Mac で分析ツールが見つからない」を参照してください。

Excel Onlineでは、ヒストグラム (頻度のデータを表示する縦棒グラフ) は表示できますが、 Web 用 Excelでサポートされていない分析 Excel ツールが必要であるため、作成することはできません。

Excel デスクトップアプリケーションをお持ちの場合は、[ Excel で編集] ボタンを使ってデスクトップ上の Excel を開き、ヒストグラムを作成することができます。

[Excel で編集] ボタン

  1. タップして、データを選択します。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. スマートフォンを使用している場合は、[編集] アイコン [編集] アイコン をタップしてリボンを表示します。 [ホーム] をタップします。

  3. [挿入]、[グラフ]、[ヒストグラム] の順にタップします。

    必要に応じて、グラフの要素をカスタマイズできます。

    注: この機能は、Office 365 サブスクリプションを購入しているユーザーのみが使用できます。 Office 365 のサブスクライバーである場合は、最新バージョンの Office をインストールしているかどうかをご確認ください

    Office 365 または Excel の最新バージョンを試してみる

  1. タップして、データを選択します。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. 携帯電話を使用している場合は、編集アイコン [編集] アイコン をタップしてリボンを表示し、[ホーム] をタップします。

  3. [挿入]、[グラフ]、[ヒストグラム] の順にタップします。

Excelでヒストグラムを作成するには、2種類のデータ (分析するデータ) と、周波数を測定する間隔を表すビン番号を指定します。 ワークシートの 2 つの列にデータを整理する必要があります。 これらの列には、次のようなデータが含まれている必要があります。

  • 入力データ    これは、ヒストグラム ツールを使用して分析するデータです。

  • 区間番号    これらの番号は、データ分析で入力データを測定するためにヒストグラム ツールで使用する間隔を示します。

ヒストグラムツールを使用すると、 Excel は各データ区間のデータポイントの数をカウントします。 データ ポイントは、その数値がデータ区間の最小の境界値よりも大きく、最大の境界値以下である場合、特定の区間に含まれます。 Bin 範囲を省略すると、 Excel 入力データの最小値と最大値の間で均等に分散されたビンのセットが作成されます。

ヒストグラム分析の出力は、新規ワークシート (または新規ブック) に表示され、ヒストグラム テーブルおよびヒストグラム テーブル内のデータを反映する縦棒グラフが表示されます。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

注:  このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 情報が役に立ったかどうか、ご意見をお寄せください。 参考までに、こちらから英語の記事をお読みいただけます。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×