ハイパーリンクを変更および修正する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

ハイパーリンクの表示方法や移動先 (リンク先) は変更できます。ハイパーリンクが機能しない場合は、何が問題かを判断し、リンク先のアドレスを修正する必要があります。

注: ナビゲーション バーのハイパーリンクのテキストや順序を変更するには、[書式] メニューの [ナビゲーション バーのプロパティ] をクリックします。

目的に合ったトピックをクリックしてください

ハイパーリンクの表示方法を変更する

ハイパーリンク先を変更する

ハイパーリンクを通常のテキストに変更する

Web サイトを発行する前にハイパーリンクをテストする

機能しないハイパーリンクを修正する

ハイパーリンクの表示方法を変更する

ハイパーリンクの表示テキストを変更する

  1. 変更するハイパーリンク テキストをクリックします。

  2. 新しいテキストを入力し、Del キーまたは BackSpace キーを押して、元の文字を 1 つずつ削除します。

ハイパーリンク テキストから下線を削除する

  1. ハイパーリンク テキストを選択します。

    下線付きの文字のみを選択するには、下線付きの最後の文字の後ろをクリックし、カーソルを下線付きの最初の文字までドラッグします。

  2. [標準] ツールバーの ボタン イメージ (下線) をクリックします。

ハイパーリンクに使用する画像を変更する

  1. リンクされている画像を選択します。

  2. 画像を右クリックし、[図の変更] をポイントして、使用する新しい画像の場所をクリックします。たとえば、コンピュータに保存されているイメージを使用する場合は、[ファイルから] をクリックします。

  3. 使用する新しい画像を選択します。

ページの先頭へ

ハイパーリンク先を変更する

  1. 変更するハイパーリンクを右クリックし、[ハイパーリンクの編集] をクリックします。

    注: ショートカット メニューにスペル チェックのコマンドしか表示されない場合は、[すべて無視] をクリックし、ハイパーリンクをもう一度右クリックします。

  2. [ハイパーリンクの編集] ダイアログ ボックスの [アドレス] ボックスに、新しいハイパーリンク先を入力します。

ページの先頭へ

ハイパーリンクを通常のテキストに変更する

  • ハイパーリンクを右クリックし、[ハイパーリンクの削除] をクリックします。

ページの先頭へ

Web サイトを発行する前にハイパーリンクをテストする

Web サイトを発行する前に、ハイパーリンクをテストして、ハイパーリンクが機能することを確認できます。次のいずれかの操作を行います。

  • Web 文書を Web に発行する前に、Web 文書からハイパーリンクをたどるには、Ctrl キーを押しながら、リンクしたテキストまたは画像をクリックします。

  • [ファイル] メニューの [ブラウザでプレビュー] をクリックし、Web サイトのプレビューでハイパーリンクをクリックして、リンク先に移動します。

    注: Web サイトのプレビューでは、外部ファイルへのリンクをテストすることはできません。

  • Web サイトをローカル サーバーに発行して、ハイパーリンクをテストします。

    1. [ファイル] メニューの [Web サイトの作成] をクリックします。

    2. Web ホスティング サーバーに関する情報が表示された場合は [OK] をクリックします。

    3. [Web ページの作成] ダイアログ ボックスで、Web サイトをテストするローカル Web サーバーを探し、[保存] をクリックします。

ページの先頭へ

機能しないハイパーリンクを修正する

機能しないハイパーリンクを修正する一般的な方法をいくつか次に示します。

Publisher Web サイトの他のページに移動するハイパーリンクを修正する

  • 1 つのリンクが機能しない場合    ページを移動すると、Microsoft Office Publisher は、自動的にハイパーリンクを正しいページに更新します。それでもハイパーリンクが機能しない場合は、移動または削除されたブックマークを指していないことを確認します。ハイパーリンクを修正するには、次の操作を行います。

    1. ハイパーリンクを右クリックし、[ハイパーリンクの編集] をクリックします。

    2. [ハイパーリンクの編集] ダイアログ ボックスで、[このドキュメント内] をクリックし、リンク先として設定するページとブックマークをクリックします。

      目的のブックマークが削除されている場合は、[キャンセル] をクリックします。リンク先のページに移動してブックマークを挿入し、修正するハイパーリンクに戻ってハイパーリンクを編集します。

  • 多数のリンクが機能しない場合    多数のハイパーリンクが機能しない場合は、ファイルの一部が発行されていない可能性があります。既定では、Web サイトを発行すると、Publisher によって index_files というサブフォルダが指定されたファイルの場所にアップロードされます。このフォルダには、文書の最初のページ (Web サイトのホーム ページ) を除き、Web サイトに関連付けられたすべてのファイルが格納されます。最初のページには、関連付けられたページのサブフォルダを指すリンクが含まれます。このフォルダが使用できない場合、文書の他のページへのハイパーリンクは機能しなくなります。サード パーティのプログラムを使用して Web サイトをアップロードすると、サブフォルダが Web サーバーに自動的にアップロードされないことがあります。この場合は、サブフォルダを手動でアップロードしてください。

    注: 次回の Web サイトの発行時に、Publisher で index_files フォルダを作成するのではなく、Web サイトのすべてのファイルを 1 つのフォルダに発行するように設定を変更できます。Web 文書で、[ツール] メニューの [オプション] をクリックし、[Web] タブをクリックして、[関連ファイルを 1 つのフォルダに保存する] チェック ボックスをオフにします。

他の Web サイトに移動するハイパーリンクを修正する

他の Web サイトへのハイパーリンクが機能しない場合は、リンク先を参照します。リンク先ファイルがインターネット上にある場合は、Web ブラウザで検索します。ファイルがハード ディスクまたはネットワーク上にある場合は、Microsoft Windows エクスプローラで検索します。次に、Publisher の Web 文書で次の点をチェックします。

  • リンク先が移動されているか存在しない場合    ハイパーリンクを右クリックし、[ハイパーリンクの編集] をクリックします。[ハイパーリンクの編集] ダイアログ ボックスで、リンク先ページへのパスが正しいことを確認します。

  • テキストをハイパーリンクにしたつもりでも、外観がハイパーリンクに見えるだけの場合    テキストを選択し、[標準] ツールバーの ボタン イメージ (ハイパーリンクの挿入) をクリックして、テキストをハイパーリンクにします。

    ヒント: ハイパーリンクを 1 つだけ選択してから、[ハイパーリンクの挿入] をクリックしてください。複数のハイパーリンクを選択した場合、またはナビゲーション バーのハイパーリンクを選択した場合は、[ハイパーリンクの挿入] を使用できなくなることがあります。

  • リンク先にアクセスできない場合    リンク先がインターネット上にある場合は、インターネットに接続できることを確認します。リンク先がネットワーク上にある場合は、ネットワーク管理者に連絡して、リンク先ファイルへのアクセス権があることを確認します。

外部ファイルを開くハイパーリンクを修正する

Microsoft Office Word 文書、Microsoft Office Excel ワークシート、PDF ファイルなど、外部ファイルを開くハイパーリンクを Web ページ上に作成する場合は、次の点に注意してください。

ファイル名

リンク先の外部ファイルの名前には、スペースを含めず、小文字を使用することをお勧めします。

リンク先のファイル名にスペースが含まれていて、その名前を変更することができない場合は、Publisher でハイパーリンク アドレスのスペースが %20 に置き換えられていることを確認します。たとえば、ファイル名が my file.docx の場合、ハイパーリンク アドレスは my%20file.docx にする必要があります。

テスト

Web サイトのプレビューで外部ファイルへのリンクをテストすることはできませんが、文書では、リンクしたテキストや画像を Ctrl キーを押しながらクリックすることでハイパーリンクをテストできます。また、Web サイトをローカル サーバーに発行して、外部ファイルへのハイパーリンクをテストすることもできます。

重要: ローカル サーバーで外部ファイルへのリンクをテストする場合は、外部ファイルをそのローカル サーバーにコピーしてください。

アップロード

Web サイトを発行するときは、外部ファイルを手動でアップロードする必要があります。Publisher で自動的にアップロードされることはありません。外部ファイルを Web サーバーのどこに配置するかによって、パスの指定方法が決まります。次に例を示します。

  • ホーム ページから Web サーバー上の同じディレクトリに置かれているファイルにリンクする場合は、ファイル名のみをパスとして指定できます (myfile.docx など)。

  • ホーム ページとは別のディレクトリにあるファイルにリンクする場合は、パスにフォルダ名を含める必要があります (index_files/myfile.docx など)。

Web に発行する前に、このパスを決定して [ハイパーリンクの挿入] ダイアログ ボックスで入力する必要があります。ページの閲覧者が外部ファイルを開くときにクリックするテキストまたは画像を選択します。[挿入] メニューの [ハイパーリンク] をクリックします。[ハイパーリンクの挿入] ダイアログ ボックスで、[アドレス] ボックスに外部ファイルへのパスを入力します。

注: ハイパーリンクのパスを参照して [アドレス] ボックスに挿入した場合は、前に説明したように、ファイル名のみを入力するかフォルダとファイル名を入力して、パスを変更します。

ディスク上にあるファイルへのリンク パスを修正する

Web に発行する前に、別のコンピュータで Web サイトを表示できるように、Web サイトのファイルを CD や DVD などのディスクに配置することもできます。Web 文書のファイルを単にディスクにコピーしても、リンクは機能しません。代わりに、Web サイトを直接ディスクに発行します。その方法を次に示します。

Windows Vista の場合

  1. [ファイル] メニューの [Web サイトの作成] をクリックします。

  2. [アドレス バー] で、Web サイトを発行するディスクのドライブ (D:¥mywebsite など) をクリックします。

    Web サイトを新しいフォルダに追加する場合は、ツールバーの [新しいフォルダ] をクリックして新しいフォルダを作成し、新しいフォルダの名前を入力して、Enter キーを押します。

  3. [ファイル名] ボックスで、ホーム ページの既定の名前として [index] をクリックし、[保存] をクリックします。

    既定では "index.htm" が選択されます。ホーム ページの名前として "index" を使用すると、Web サイトにアクセスしやすくなり、Web サイトを構成しているファイルの一覧がユーザーに閲覧されるのを防止できます。

Windows XP の場合

  1. [ファイル] メニューの [Web サイトの作成] をクリックします。

  2. [保存先] ボックスの一覧で、Web サイトを発行するディスクのドライブ (D:¥mywebsite など) をクリックします。

    Web サイトを新しいフォルダーに追加する場合は、新しいフォルダーを追加する場所を右クリックし、[新規作成] をポイントし、[フォルダー] をクリックして新しいフォルダーを作成します。[ファイル名] ボックスに新しいフォルダーの名前を入力し、[開く] をクリックします。

  3. [ファイル名] ボックスで、ホーム ページの既定の名前として [index] をクリックし、[保存] をクリックします。

    既定では "index.htm" が選択されます。ホーム ページの名前として "index" を使用すると、Web サイトにアクセスしやすくなり、Web サイトを構成しているファイルの一覧がユーザーに閲覧されるのを防止できます。

表示されないハイパーリンクを修正する

次のいずれかが原因で発生する可能性があります。

  • ハイパーリンクが回転したテキスト ボックスまたはオートシェイプに含まれている    回転したテキスト ボックスやオートシェイプに含まれたハイパーリンクは正しく機能しません。それらのハイパーリンクは Web 文書で Ctrl キーを押しながらクリックした場合は機能しますが、Web プレビューでは正しく表示されるものの機能はせず、文書を Web に公開した場合も機能しません。Web 文書のハイパーリンクを復元するには、ハイパーリンクを含む回転したテキスト ボックスまたはオートシェイプを元の位置に戻します。

  • ハイパーリンクが飾り枠を持つテキスト ボックスまたはオートシェイプに含まれている    Web 文書では、飾り枠を持つテキスト ボックスやオートシェイプにハイパーリンクを含めた場合、それらのハイパーリンクは正しく機能しません。Web 文書のハイパーリンクを復元するには、ハイパーリンクを含むテキスト ボックスまたはオートシェイプから飾り枠を削除します。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×