ネットワーク ダイアグラムを書式設定する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

ネットワーク ダイアグラムボックス、または行にリンクされているノードを使用してプロジェクトのタスク間の依存関係が表示されます。ボックスのレイアウト、リンク線、およびビューに表示される情報のスタイルを調整することができます。

目的に合ったトピックをクリックしてください。

ボックスのレイアウトを調整します。

方法ボックス配置されていないか。

リンク線のスタイルを変更します。

どのようなタスクの情報の表示を変更します。

ボックスのレイアウトを調整する

によっては、プロジェクト、数のサマリー タスクおよびサブタスク、数とタスク リンクの種類の構造ネットワーク ダイアグラム] ボックスが配置できない期待どおりにします。別のボックスの配置方法を適用する、さまざまなレイアウト パラメーターの調整の 2 つの異なるリンク スタイルを適用して、レイアウトを変更することができます。

  1. [表示] メニューの [ネットワーク ダイアグラム] をクリックします。

  2. [書式] メニューの [レイアウト] をクリックします。

  3. [ボックスのレイアウト] の [配置] の一覧で、ボックスの配置方法をクリックします。

  4. 行および列について、横方向と縦方向の位置関係、間隔、高さ、および幅を対応するボックスで指定します。

    ボックス間の間隔を均等にするには、[高さ] ボックスおよび [] ボックスで [固定] をクリックします。

  5. サマリー タスクとサブタスクの位置関係を維持する場合は、[サマリーとサブタスクの位置関係を維持する] チェック ボックスをオンにします。

注: 

  • [ネットワーク ダイアグラム] ビューでタスクをグループ化している場合は、すべてのボックスが自動的に配置されます。ボックスを手動で配置すること、またはボックスの位置を手動で変更することはできません。サマリー タスクとサマリー タスクのサブタスクは、グループを適用する前に設定したオプションに従って配置されます。これらのオプションは、グループ化を解除するまで変更できません。

  • [ボックスのスタイル] ダイアログ ボックスは、マウスを使用して表示することもできます。[ネットワーク ダイアグラム] ビューの空白領域をダブルクリックするだけで、[ボックスのスタイル] ダイアログ ボックスが表示されます。

  • [オプション] の [ID 以外のフィールドを表示しない] チェック ボックスをオンにすると、行った変更の結果をより簡単に確認できます。

  • [レイアウト モード] の既定の選択である [すべてのボックスを自動的に配置する] ではネットワーク ダイアグラム ボックスを希望どおりに配置できない場合、それらを手動で配置する方法を使用できます。[手動でボックスを配置する] をクリックし、[OK] をクリックして、目的の場所にボックスをドラッグします。

  • ズーム インまたはズーム アウトを行うことで、[ネットワーク ダイアログ] ビューでプロジェクトの詳細または全体像を確認できます。[表示] メニューの [ズーム] をクリックします。[倍率] で、目的のパーセントをクリックするか、または [プロジェクト全体] をクリックしてウィンドウ内にプロジェクト全体を表示します。ビューを 75% 以下に縮小表示した状態で、ネットワーク ダイアグラム ボックス上にポインタを合わせると、そのタスクの詳細が 100% の倍率で表示されます。

ページの先頭へ

ボックスが希望どおりに配置されない場合

[ネットワーク ダイアグラム] ビューのレイアウト モードを変更し、手動によるボックスの配置を有効にすると、レイアウトを再適用するまで、Microsoft Office Project は、[レイアウト] ダイアログ ボックス ([書式] メニュー) の [ボックスのレイアウト] の設定に従ったネットワーク ダイアグラムの配置を行わなくなります。

[レイアウト] ダイアログ ボックスの [手動でボックスを配置する] をオンにすると、次のようにレイアウトを変更できます。

  • 手動で 1 つまたは複数のタスクを再配置する場合は、[レイアウトの更新] ([書式] メニュー) をクリックすることで、すべてのネットワーク ダイアグラム ボックスのレイアウトを、[レイアウト] ダイアログ ボックスで定義したレイアウトに変更できます。

  • 手動で 1 つのタスクを再配置する場合は、移動したそのタスクに関連する、リンクされているタスクまたはサブタスクのレイアウトを変更できます。タスクを右クリックし、ショートカット メニューの [後続タスクのレイアウトを更新] をクリックすると、事前に再配置したタスクの位置はそのままで、関連するタスクを移動できます。

  • 手動で複数のタスクを再配置する場合は、[レイアウト] ダイアログ ボックスで定義した位置にタスクを再配置できます。連続する複数のタスクを選択するには、最初のタスクをクリックし、Shift キーを押しながら最後のタスクをクリックします。連続していないタスクを選択するには、Ctrl キーを押しながら目的のタスクをクリックします。右クリックして、ショートカット メニューの [選択範囲のレイアウト] をクリックします。

  • ボタンの画像 レイアウト選択範囲を今すぐレイアウト ボタンの画像 ボタンが含まれるツール バーネットワーク ダイアグラムを表示するには、ツールバーのいずれかの背景を右クリックし、ショートカット メニューの [ネットワーク ダイアグラム] をクリックします。

  • 特定のボックス配置を使用して自動的にネットワーク ダイアグラム ボックスを再配置するには、[レイアウト] ([書式] メニュー) をクリックします。[レイアウト モード] で [すべてのボックスを自動的に配置する] をクリックします。[ボックスのレイアウト] の [配置] の一覧で配置方法を選択します。[] の [配置]、[間隔]、および [高さ] の各ボックスで、ネットワーク ダイアグラム ボックスの横方向の表示方法を選択します。[] の [配置]、[間隔]、および [] の各ボックスで、ネットワーク ダイアグラム ボックスの縦方向の表示方法を選択します。

注: [ネットワーク ダイアログ] ビューでグループが適用されると、指定したレイアウト オプションが有効になります。ただし、ボックスの配置オプションは変更できなくなります。レイアウトを変更する必要がある場合は、目的のレイアウト オプションを指定するために、ネットワーク ダイアグラムからグループ化を一時的に解除する必要があります。

ページの先頭へ

リンク線のスタイルを変更する

先行処理または後続処理タスクにリンクされているタスクが多があれば、リンク線は重複し、ネットワーク ダイアグラム ビューで読みにくくできます。リンク線のスタイルを変更しする方法に配置できます。リンク線で、タスクの依存関係のラベルを表示することもできます。

  1. [表示] メニューの [ネットワーク ダイアグラム] をクリックします。

  2. [書式] メニューの [レイアウト] をクリックします。

  3. 次のいずれかを実行します。

    • 先行タスク ボックスと後続タスク ボックスの間のリンク線を、直線の形式で表示するには、[リンクの表示形式] で [直線ライン] をクリックします。

    • 先行タスク ボックスと後続タスク ボックスの間のリンク線を、水平線セグメントと垂直線セグメントを直角に連結した形式で表示するには、[リンクの表示形式] で [直角ライン] をクリックします。

  4. リンクにラベルを表示するのには、タスクの依存関係と、潜在顧客またはラグ タイム (時間差)スタイルをリンクするには、[特定の行は、リンクのラベルを表示する]チェック ボックスを選択します。

  5. タスクが先行と後続のいずれであるかを示す矢印の付いたリンク線を表示するには、[リンクの表示形式] で [矢印を表示する] チェック ボックスをオンにします。

ヒント: [手動でボックスを配置する] がオンになっていて、タスクを手動で再配置した場合、移動したそのタスクに関連する、リンクされているタスクまたはサブタスクのレイアウトを変更できます。タスクを右クリックし、ショートカット メニューの [レイアウトの更新] をクリックすると、事前に再配置したタスクの位置はそのままで、関連するタスクを移動できます。

ページの先頭へ

表示するタスク情報を変更する

さまざまな情報ニーズを満たすために、ネットワーク ダイアグラム ボックスのタスク情報を変更し、最も重要な情報を表示できます。

  1. [表示] メニューの [ネットワーク ダイアグラム] をクリックします。

  2. [書式] メニューの [ボックスのスタイル] をクリックします。

  3. [次のスタイル設定] の一覧で、変更する内容および外観のあるタスク カテゴリをクリックします。

  4. [罫線] で、形状、色、幅、および目盛線の各オプションを選択し、必要な外観を作成します。

  5. 次のいずれかを実行します。

    • データ テンプレートを変更または作成するには、[その他のテンプレート] をクリックし、手順 6. に進みます。

    • 既存のテンプレートを適用するには、手順 12. に進みます。

  6. [データ テンプレート] ダイアログ ボックスで、次のいずれかを実行します。

    • 既存のテンプレートを編集するには、テンプレートを選択し、[編集] をクリックします。

    • 既存のテンプレートに基づいて新しいテンプレートを作成するには、既存のテンプレートを選択し、[コピー] をクリックします。

    • 新しいテンプレートを作成するには、[新規作成] をクリックします。

      注: 別のプロジェクトからテンプレートをインポートすることもできます。[データ テンプレート] ダイアログ ボックスで [インポート] をクリックし、[テンプレートのインポート] ダイアログ ボックスの [プロジェクト] で、テンプレートのインポート元のプロジェクトをクリックします。[テンプレート] ボックスで、目的のテンプレートをクリックし、手順 11. に進みます。

  7. [テンプレート名] ボックスに、新しいテンプレートまたは改訂したテンプレートの名前を入力します。

  8. [プレビューするタスクの ID] ボックスで、プレビュー ウィンドウに表示するタスクのタスク ID 番号を入力するか、タスク ID 番号をクリックします。

  9. セルの表示方法を変更するには、[セルのレイアウト] をクリックし、必要な表示オプションを選択し、[OK] をクリックします。

  10. [セルを選択] で、表示するフィールドを入力するか、該当フィールドをクリックします。

  11. [OK] をクリックし、[閉じる] をクリックします。

  12. 新しいテンプレートまたは改訂したテンプレートを適用するには、[テンプレート] ボックスの一覧でそのテンプレートをクリックします。

注: [ボックスのスタイル] ダイアログ ボックスは、マウスを使用して表示することもできます。[ネットワーク ダイアグラム] ビューの空白領域をダブルクリックするだけで、[ボックスのスタイル] ダイアログ ボックスが表示されます。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×