ドラフト: OLE オブジェクトを作成、変更、または削除する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft Office PowerPoint 2007、 Microsoft Office Word 2007、またはMicrosoft Office Outlook 2007のMicrosoft Office Excel 2007などの他のプログラムからのコンテンツを追加するのには、オブジェクトのリンクと埋め込み (OLE) を使用することができます。

目的に合ったトピックをクリックしてください。

OLE の詳細について

OLE を使用して別のプログラムのコンテンツをリンクするか埋め込む

OLE オブジェクトの表示方法を変更する

OLE プログラムのコンテンツを変更する

リンクを解除します。

リンク オブジェクトまたは埋め込みオブジェクトをダブルクリックすると "編集できません" というメッセージが表示される

オブジェクトを挿入しようとすると、"必要なアプリケーションを起動することはできません] メッセージが表示されます。

OLE の詳細について

OLE はさまざまなプログラムでサポートされていて、あるプログラムで作成されたコンテンツを別のプログラムで使用できるようにする機能です。たとえば、Excel 2007 のワークシートを PowerPoint 2007 のプレゼンテーションに挿入できます。挿入できるコンテンツの種類を確認するには、[挿入] タブの [テキスト] で [オブジェクト] をクリックします。使用しているコンピュータにインストールされているプログラムのうち、OLE オブジェクトをサポートしているプログラムだけが [オブジェクトの種類] ボックスに表示されます。目的のプログラムが表示されない場合は、挿入するコンテンツのコピー元のプログラムをインストールする必要があります。

ページの先頭へ

リンク オブジェクトまたは埋め込みオブジェクト

PowerPoint、Word、または OLE をサポートするその他のプログラム (Excel など) 間で情報をコピーする場合、リンク オブジェクトまたは埋め込みオブジェクトのどちらかとして情報をコピーできます。リンク オブジェクトと埋め込みオブジェクトの主な違いは、データの保存場所と、転送先ファイルにオブジェクトを配置した後のオブジェクトの更新方法です。埋め込みオブジェクトは挿入先のドキュメントに保存されるため、更新されません。リンク オブジェクトは別個のファイルのままであるため、更新できます。

Office for Windows ドキュメントのリンク オブジェクトと埋め込みオブジェクト
文書内のリンク オブジェクトと埋め込みオブジェクト

1. ソース ファイルへの接続がない埋め込みオブジェクト

2. ソース ファイルにリンクされているリンク オブジェクト

3. ソース ファイルがリンク オブジェクトを更新

PowerPoint 2007 の組み込みサウンド ファイルまたはリンクされたサウンド ファイルの詳細については、「プレゼンテーションに組み込み、またはリンクされたサウンド ファイル」を参照してください。

ページの先頭へ

リンク オブジェクトの使用が適している場合

ソース ファイルのデータが変更されたときに転送先ファイルの情報を更新する場合は、リンク オブジェクトを使用します。

リンク オブジェクトの場合、元の情報はソース ファイルに保存されたまま残ります。デスティネーション ファイルには、リンク元の情報が表示されますが、保存されるのは元のデータの場所だけです (Excel のグラフ オブジェクトの場合はサイズも保存されます)。元のデータへのリンクを維持するため、コンピュータまたはネットワークで引き続きソース ファイルが使用できる必要があります。

リンク先の情報は、ソース ファイルの元のデータを変更すると自動的に更新されます。たとえば、Word 文書の段落を選択し、その段落を PowerPoint プレゼンテーションにリンク オブジェクトとして貼り付けた場合、Word 文書で段落の情報を変更すると PowerPoint でその情報を更新できます。

ページの先頭へ

埋め込みオブジェクトの使用が適している場合

ソース ファイルのデータが変更されてもコピー先のデータを更新しない場合は、埋め込みオブジェクトを使用します。コピーしたときの状態のデータが、ドキュメントまたはプレゼンテーションにそのまま埋め込まれます。埋め込みオブジェクトとして情報をコピーすると、デスティネーション ファイルで必要なディスク領域はリンク オブジェクトの場合よりも多くなります。

ファイルが別のコンピュータで開かれたとき、埋め込みオブジェクトは、元のデータへアクセスできなくても表示できます。埋め込みオブジェクトにはソース ファイルへのリンクがないため、元のデータが変更されてもオブジェクトは更新されません。

ページの先頭へ

OLE を使用して別のプログラムのコンテンツをリンクするか埋め込む

別のプログラムのコンテンツのすべてまたは一部を、リンクまたは埋め込むことができます。

別のプログラムのコンテンツへのリンクを作成する

使用している 2007 Microsoft Office system アプリケーション

Outlook

PowerPoint

Word

Outlook

  1. リンク オブジェクトを配置する文書または電子メールの場所をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    Word のリボンの画像

  3. [ファイルから] タブをクリックします。

  4. [ファイル名] ボックスにファイルの名前を入力するか、[参照] をクリックして一覧からファイルを選択します。

    [参照] をクリックして目的のファイルを検索する場合、見つかったら [挿入] をクリックします。

  5. [リンク] チェック ボックスをオンにします。

  6. 次のいずれかの操作を行います。

    • コンテンツを表示するには、[アイコンで表示] チェック ボックスをオフにします。

    • アイコンを表示するには、[アイコンで表示] チェック ボックスをオンにします。

      既定のアイコン イメージまたはラベルを変更するには、[アイコンの変更] をクリックし、[アイコン] ボックスの一覧で希望するアイコンをクリックするか、[タイトル] ボックスにラベルを入力します。

PowerPoint

  1. リンク オブジェクトを配置するスライドの場所をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    PowerPoint のリボン イメージ

  3. [ファイルから] をオンにします。

  4. [ファイル名] ボックスにファイルの名前を入力するか、[参照] をクリックして一覧からファイルを選択します。

    [参照] をクリックして目的のファイルを検索する場合、見つかったら [OK] をクリックします。

  5. [リンク] チェック ボックスをオンにします。

  6. 次のいずれかの操作を行います。

    • コンテンツを表示するには、[アイコンで表示] チェック ボックスをオフにします。

    • アイコンを表示するには、[アイコンで表示] チェック ボックスをオンにします。

      既定のアイコン イメージまたはラベルを変更するには、[アイコンの変更] をクリックし、[アイコン] ボックスの一覧で希望するアイコンをクリックするか、[タイトル] ボックスにラベルを入力します。

注: [オブジェクト] コマンドではグラフィックまたは画像を挿入できません。グラフィックや画像を挿入するには、[挿入] タブの [] で [] をクリックします。

Word

  1. リンク オブジェクトを配置する文書または電子メールの場所をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    Word のリボンの画像

  3. [ファイルから] タブをクリックします。

  4. [ファイル名] ボックスにファイルの名前を入力するか、[参照] をクリックして一覧からファイルを選択します。

    [参照] をクリックして目的のファイルを検索する場合、見つかったら [挿入] をクリックします。

  5. [リンク] チェック ボックスをオンにします。

  6. 次のいずれかの操作を行います。

    • コンテンツを表示するには、[アイコンで表示] チェック ボックスをオフにします。

    • アイコンを表示するには、[アイコンで表示] チェック ボックスをオンにします。

      既定のアイコン イメージまたはラベルを変更するには、[アイコンの変更] をクリックし、[アイコン] ボックスの一覧で希望するアイコンをクリックするか、[タイトル] ボックスにラベルを入力します。

ページの先頭へ

別のプログラムのコンテンツを埋め込む

使用している 2007 Microsoft Office system アプリケーション

Outlook

PowerPoint

Word

Outlook

  1. 埋め込みオブジェクトを配置する文書または電子メールの場所をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    Excel のリボンのイメージ

  3. ドキュメントが未作成の場合は、[新規作成] タブをクリックし、[オブジェクトの種類] ボックスの一覧で、作成するオブジェクトの種類をクリックします。

    ドキュメントが既に存在している場合は、[ファイルから] タブをクリックし、[ファイル名] ボックスにファイルの名前を入力するか、[参照] をクリックして一覧からファイルを選択します。

  4. [リンク] チェック ボックスをオフにします。

  5. 次のいずれかの操作を行います。

    • コンテンツを表示するには、[アイコンで表示] チェック ボックスをオフにします。

    • アイコンを表示するには、[アイコンで表示] チェック ボックスをオンにします。既定のアイコン イメージまたはラベルを変更するには、[アイコンの変更] をクリックし、[アイコン] ボックスの一覧で希望するアイコンをクリックするか、[タイトル] ボックスにラベルを入力します。

PowerPoint

  1. 埋め込みオブジェクトを配置するスライドの場所をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    Excel のリボンのイメージ

  3. ドキュメントがまだない場合は、[新規作成] をオンにし、[オブジェクトの種類] ボックスの一覧で作成するオブジェクトの種類をクリックします。

    ドキュメントが既に存在している場合は、[ファイルから] をオンにし、[ファイル名] ボックスにファイルの名前を入力するか、[参照] をクリックして一覧からファイルを選択します。

  4. [リンク] チェック ボックスをオフにします。

  5. 次のいずれかの操作を行います。

    • コンテンツを表示するには、[アイコンで表示] チェック ボックスをオフにします。

    • アイコンを表示するには、[アイコンで表示] チェック ボックスをオンにします。既定のアイコン イメージまたはラベルを変更するには、[アイコンの変更] をクリックし、[アイコン] ボックスの一覧で希望するアイコンをクリックするか、[タイトル] ボックスにラベルを入力します。

Word

  1. 埋め込みオブジェクトを配置する文書または電子メールの場所をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    Excel のリボンのイメージ

  3. ドキュメントが未作成の場合は、[新規作成] タブをクリックし、[オブジェクトの種類] ボックスの一覧で、作成するオブジェクトの種類をクリックします。

    ドキュメントが既に存在している場合は、[ファイルから] タブをクリックし、[ファイル名] ボックスにファイルの名前を入力するか、[参照] をクリックして一覧からファイルを選択します。

  4. [リンク] チェック ボックスをオフにします。

  5. 次のいずれかの操作を行います。

    • コンテンツを表示するには、[アイコンで表示] チェック ボックスをオフにします。

    • アイコンを表示するには、[アイコンで表示] チェック ボックスをオンにします。既定のアイコン イメージまたはラベルを変更するには、[アイコンの変更] をクリックし、[アイコン] ボックスの一覧で希望するアイコンをクリックするか、[タイトル] ボックスにラベルを入力します。

ページの先頭へ

別のプログラムのコンテンツの一部をリンクするか埋め込む

使用している 2007 Microsoft Office system アプリケーション

Outlook

PowerPoint

Word

ページの先頭へ

Outlook

  1. Outlook 以外のプログラムから情報をリンクとしてコピーまたは埋め込みオブジェクトを選択します。

  2. [ホーム] タブの [クリップボード] で、[コピー] をクリックします。

    [ホーム] タブの [クリップボード]

  3. データを配置する文書または電子メールに切り替え、その情報を表示する場所をクリックします。

  4. [ホーム] タブの [クリップボード] グループで、[貼り付け] の下にある矢印をクリックし、[貼り付け] をクリックします。

  5. 次のいずれかの操作を行います。

    • リンク オブジェクトとしてデータを貼り付ける場合は、[リンク貼り付け] をクリックします。

    • 埋め込みオブジェクトとしてデータを貼り付ける場合は、[貼り付け] をクリックし、名前に "オブジェクト" が含まれる [貼り付ける形式] ボックスのエントリをクリックします。たとえば、Excel のワークシートからデータをコピーする場合、[Microsoft Office Excel ワークシート オブジェクト] をクリックします。

PowerPoint

  1. PowerPoint 以外のプログラムから情報をリンクとしてコピーまたは埋め込みオブジェクトを選択します。

  2. [ホーム] タブの [クリップボード] で、[コピー] をクリックします。

    [ホーム] タブの [クリップボード]

  3. データを配置するスライドに切り替え、その情報を表示する場所をクリックします。

  4. [ホーム] タブの [クリップボード] グループで、貼り付け] の下にある矢印をクリックし、[貼り付け] をクリックします。

  5. 次のいずれかの操作を行います。

    • リンク オブジェクトとしてデータを貼り付ける場合は、[リンク貼り付け] をクリックします。

    • 埋め込みオブジェクトとしてデータを貼り付ける場合は、[貼り付け] をクリックし、名前に "オブジェクト" が含まれる [貼り付ける形式] ボックスのエントリをクリックします。たとえば、Word の文書からデータをコピーする場合、[Microsoft Office Word 文書 オブジェクト] をクリックします。

Word

  1. Word 以外のプログラムから情報をリンクとしてコピーまたは埋め込みオブジェクトを選択します。

  2. [ホーム] タブの [クリップボード] で、[コピー] をクリックします。

    [ホーム] タブの [クリップボード]

  3. データを配置する文書または電子メールに切り替え、その情報を表示する場所をクリックします。

  4. [ホーム] タブの [クリップボード] グループで、貼り付け] の下にある矢印をクリックし、[貼り付け] をクリックします。

  5. 次のいずれかの操作を行います。

    • リンク オブジェクトとしてデータを貼り付ける場合は、[リンク貼り付け] をクリックします。

    • 埋め込みオブジェクトとしてデータを貼り付ける場合は、[貼り付け] をクリックし、名前に "オブジェクト" が含まれる [貼り付ける形式] ボックスのエントリをクリックします。たとえば、Excel のワークシートからデータをコピーする場合、[Microsoft Office Excel ワークシート オブジェクト] をクリックします。

ページの先頭へ

OLE オブジェクトの表示方法を変更する

リンク オブジェクトまたは埋め込みオブジェクトは、文書、スライド、または電子メール内で、ソース プログラムのデータとまったく同じように表示することも、アイコンとして表示することもできます。文書またはプレゼンテーションがオンラインで表示される場合で、印刷する予定がない場合は、オブジェクトをアイコンとして表示できます。これにより、オブジェクトが使用する表示領域が最小になります。ユーザーがアイコンをダブルクリックすると、データを表示できます。

  1. アイコンまたはオブジェクトを右クリックして [<オブジェクトの種類> オブジェクト] ([文書 オブジェクト] など) をポイントし、[変換] をクリックします。

  2. 次のいずれかの操作を行います。

    • コンテンツを表示するには、[アイコンで表示] チェック ボックスをオフにします。

    • アイコンを表示するには、[アイコンで表示] チェック ボックスをオンにします。

      既定のアイコン イメージまたはラベルを変更するには、[アイコンの変更] をクリックし、[アイコン] ボックスの一覧で希望するアイコンをクリックするか、[タイトル] ボックスにラベルを入力します。

ページの先頭へ

OLE プログラムのコンテンツを変更する

Word、PowerPoint、または Outlook で作業中に、別のプログラムからリンクしたコンテンツまたは埋め込んだコンテンツを変更できます。

ソース プログラムでリンク オブジェクトを変更する

使用している 2007 Microsoft Office system アプリケーション

Outlook

PowerPoint

Word

Outlook

  1. アイコンまたはオブジェクトを右クリックし、オブジェクトの種類のオブジェクト(たとえば、リンクされたワークシート オブジェクト) をポイントし、[リンク] をクリックします。

  2. [リンク元を開く] をクリックします。

  3. リンク オブジェクトに必要な変更を加えます。

ヒント: [リンクの設定] をクリックした後、[リンク元を開く] ではなく [リンク元の変更] をクリックして、ソース ファイルを変更することもできます。新しいソース ファイルを参照して [開く] をクリックします。

PowerPoint

  1. スライドでリンク オブジェクトをクリックします。

  2. Office ボタンの画像 (Microsoft Office ボタン) をクリックし、[配布準備] をポイントして、[ファイルへのリンクの編集] をクリックします。

    [ファイルへのリンクの編集] が表示されない場合は、[ドキュメントを配布するための準備作業] の一覧の下部にある下矢印をクリックし、リストの末尾までスクロールします。

    [準備] メニューの画像

  3. [リンク] の一覧でリンクをクリックし、[リンク元を開く] をクリックします。

  4. リンク オブジェクトに必要な変更を加えます。

  5. ソース プログラムを終了し、デスティネーション ファイルに戻ります。

Word

  1. アイコンまたはオブジェクトを右クリックし、オブジェクトの種類のオブジェクト(たとえば、リンクされたワークシート オブジェクト) をポイントし、[リンク] をクリックします。

  2. [リンク元を開く] をクリックします。

  3. リンク オブジェクトに必要な変更を加えます。

ヒント: [リンクの設定] をクリックした後、[リンク元を開く] ではなく [リンク元の変更] をクリックして、ソース ファイルを変更することもできます。新しいソース ファイルを参照して [開く] をクリックします。

ページの先頭へ

ソース プログラムで埋め込みオブジェクトを変更する

埋め込みオブジェクトを変更するには、オブジェクトをダブルクリックしてソース プログラムで開き、編集します。ソース プログラム (またはオブジェクトを編集できる別のプログラム) がコンピュータにインストール済みである必要があります。

  1. 埋め込みオブジェクトをダブルクリックして開きます。

  2. オブジェクトに必要な変更を加えます。

  3. 同一ウィンドウのプログラムでオブジェクトを編集している場合は、オブジェクトの外側の任意の場所をクリックすると転送先ファイルに戻ります。

    作成元のアプリケーションの独立したウィンドウでオブジェクトを編集した場合は、作成元アプリケーションを終了して、デスティネーション ファイルに戻ります。

注: ビデオ クリップやサウンド クリップなど、一部の埋め込みオブジェクトでは、オブジェクトをダブルクリックするとビデオやサウンドが再生され、アプリケーションは起動されません。これらの埋め込みオブジェクトを編集するには、アイコンまたはオブジェクトを右クリックし、[<オブジェクトの種類> オブジェクト] ([メディア クリップ オブジェクト] など) をポイントして、[編集] をクリックします。

ページの先頭へ

ソース プログラム以外のプログラムで埋め込みオブジェクトを編集する

  1. 編集する埋め込みオブジェクトを選択します。

  2. アイコンまたはオブジェクトを右クリックして [<オブジェクトの種類> オブジェクト] ([文書 オブジェクト] など) をポイントし、[変換] をクリックします。

  3. 次のいずれかの操作を行います。

    • 埋め込みオブジェクトを一覧で指定する種類に変換するには、[変換] をクリックします。

    • 埋め込みオブジェクトのファイル タイプを変更せずに、一覧で指定する種類で開くには、[内容をアクティブにする] をクリックします。

ページの先頭へ

リンクを解除します。

使用している 2007 Microsoft Office system アプリケーション

Outlook

PowerPoint

Word

ページの先頭へ

Outlook

  1. アイコンまたはオブジェクトを右クリックし、オブジェクトの種類のオブジェクト(たとえば、リンクされたワークシート オブジェクト) をポイントし、[リンク] をクリックします。

  2. [リンクの解除] をクリックします。

注: リンクされたオブジェクトへの接続を解除した後を裏返しファイルに接続し直す必要があります。

PowerPoint

  1. スライドでリンク オブジェクトをクリックします。

  2. Office ボタンの画像 (Microsoft Office ボタン) をクリックし、[配布準備] をポイントして、[ファイルへのリンクの編集] をクリックします。

    [ファイルへのリンクの編集] が表示されない場合は、[ドキュメントを配布するための準備作業] の一覧の下部にある下矢印をクリックし、リストの末尾までスクロールします。

    [準備] メニューの画像

  3. リンクの一覧では、リンクを選択し、[リンクの解除] をクリックします。

  4. [閉じる] をクリックします。

注: リンクされたオブジェクトへの接続を解除した後を裏返しファイルに接続し直す必要があります。

Word

  1. アイコンまたはオブジェクトを右クリックし、オブジェクトの種類のオブジェクト(たとえば、リンクされたワークシート オブジェクト) をポイントし、[リンク] をクリックします。

  2. [リンクの解除] をクリックします。

注: リンクされたオブジェクトへの接続を解除した後を裏返しファイルに接続し直す必要があります。

ページの先頭へ

リンク オブジェクトまたは埋め込みオブジェクトをダブルクリックすると "編集できません" というメッセージが表示される

このメッセージは、ソース ファイルまたはソース プログラムを開くことができない場合に表示されます。

ソース プログラムが使用できることを確認する     ソース プログラムがコンピュータにインストールされていない場合は、オブジェクトのファイル形式を、インストール済みのプログラムのファイル形式に変換します。

注: リンクまたはサード パーティ製のプログラムで作成されたオブジェクトを埋め込む場合は、OLE がサポートしているかを確認するには、まずそのプログラムのヘルプ ドキュメントを確認してください。

メモリに十分な空き領域があることを確認する     ソース プログラムを実行するのに十分なメモリの空き領域があることを確認します。必要に応じて、他のプログラムを閉じてメモリの空き領域を増やします。

すべてのダイアログ ボックスを閉じる     ソース プログラムが実行中の場合は、開いているダイアログ ボックスがないことを確認します。ソース プログラムに切り替え、開いているダイアログ ボックスをすべて閉じます。

ソース ファイルを閉じる     ソース ファイルがリンク オブジェクトである場合は、別のユーザーがそのファイルを開いていないことを確認します。

ソース ファイルの名前が変更されていないことを確認する     編集対象のソース ファイルがリンク オブジェクトである場合は、リンクが作成されたときと同じファイル名であること、および保存場所が変更されていないことを確認します。ソース ファイルを変更するには次の操作を行います。

使用している 2007 Microsoft Office system アプリケーション

Outlook

PowerPoint

Word

Outlook

  1. アイコンまたはオブジェクトを右クリックし、オブジェクトの種類のオブジェクト(たとえば、リンクされたワークシート オブジェクト) をポイントし、[リンク] をクリックします。

  2. [リンク元の変更] をクリックします。

  3. 新しいソース ファイルの場所を探し、リンクを再度接続します。

PowerPoint

  1. スライドでリンク オブジェクトをクリックします。

  2. Office ボタンの画像 (Microsoft Office ボタン) をクリックし、[配布準備] をポイントして、[ファイルへのリンクの編集] をクリックします。

    [ファイルへのリンクの編集] が表示されない場合は、[ドキュメントを配布するための準備作業] の一覧の下部にある下矢印をクリックし、リストの末尾までスクロールします。

    [準備] メニューの画像

  3. [リンク] の一覧でリンクをクリックし、[リンク元の変更] をクリックします。

  4. 新しいソース ファイルの場所を探し、リンクを再度接続します。

Word

  1. アイコンまたはオブジェクトを右クリックし、オブジェクトの種類のオブジェクト(たとえば、リンクされたワークシート オブジェクト) をポイントし、[リンク] をクリックします。

  2. [リンク元の変更] をクリックします。

  3. 新しいソース ファイルの場所を探し、リンクを再度接続します。

ページの先頭へ

オブジェクトを挿入しようとすると、"必要なアプリケーションを起動することはできません] メッセージが表示されます。

ソース プログラム開けない場合、おそらく、ウイルス対策プログラムなど、コンピューター上の別のプログラムから干渉の理由により、このメッセージが表示されます。エラー メッセージには、元のプログラムを修復するように求められます。ソース プログラムを修復した後に問題が解決しない場合は、オブジェクトを挿入する前に、Windows をセーフ モードで起動してみてください。詳細については、Windows のバージョンのヘルプ ドキュメントを参照してください。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×