データ ビューを作成する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

勤務先の会社では、大量のデータを収集し、保管しているとします。このデータを自分や自分の所属しているチームが簡単に利用し、操作できるようにするため、Microsoft SharePoint で構築したチーム サイト上に、追跡またはレポート アプリケーションを作成したいと考えています。それにはどこから手を付ければよいでしょうか。

Microsoft Office SharePoint Designer 2007 では、データ ビューと呼ばれる、ライブ データのカスタマイズされたビューをすばやく作成できます。データ ビューを使用すると、データ クエリや XML ドキュメント、Web サービス、SharePoint のリストやライブラリ、サーバーサイド スクリプトなど、さまざまなソースのデータを表示できます。

データ ビューをページに挿入する方法には、2 とおりあります。フォルダ一覧またはデータ ソース ライブラリから、Web サイト上の新しいまたは既存のページにデータ ソースをドラッグして、データ ビューを作成する方法が 1 つです。または、[データ ビューの挿入] コマンドを使用してデータ ビューを作成し、直ちに [データ ソースの詳細] 作業ウィンドウから表示したい列のみを挿入して、ビューの変更を行うこともできます。

この記事では、データ ビューを紹介します。また、データ ソースとして使用するサンプルの XML ファイルを作成する方法を説明し、その後、最初にドラッグ アンド ドロップによる方法、次に [データ ソースの詳細] 作業ウィンドウを使用する方法で、作成したデータを基にデータ ビューを作成する方法を説明します。この記事では、簡単にデータ ソースを作成し、理解できるように、データ ソースに .xml ファイルを使用しています。ただし、以下の手順は、どのデータ ソースに対しても適用できるもので、特に SharePoint リストのデータは、データ ビュー作成時のデータ ソースとして最も頻繁に利用されることが考えられます。

重要: この記事では、Windows SharePoint Services 3.0 を実行するサーバー上に配置された SharePoint サイトに、データ ビューを作成する方法を説明します。サイトが Windows SharePoint Services 3.0 を実行するサーバー上に配置されていない場合は、一部の機能が利用できない可能性があります。

この記事の内容

データ ビューとは何ですか。

サンプル データ ソースとして .xml ファイルを作成します。

データ ソースをページにドラッグしてデータ ビューを作成する.

データ ソースの詳細] 作業ウィンドウを使用してデータ ビューを作成する.

次のステップ

データ ビューとは

データ ビューは、Microsoft ASP.NET テクノロジを活用するデータ ソースのライブ、カスタマイズ可能なビューです。Office SharePoint Designer 2007では、拡張マークアップ言語 (XML) 形式のデータ ソースからデータを取得し、Extensible Stylesheet Language Transformations (Xslt) を使用してデータを表示します。Office SharePoint Designer 2007を使用して、データ ビューを変更することができます。データ ビューには、さまざまなデータベース クエリ、XML ドキュメント、Web サービス、SharePoint リスト、ライブラリ、およびサーバー サイド スクリプトを含めて、ソースからデータを表示できます。複数のデータ ソースからデータを表示するデータ ビューを作成することもできます。

データ ビューではデータがデータ ソースから取得されて、xslt でそのデータが表示される

データ ビューは、フィルタ、並べ替え、グループ化が可能な、データのライブ ビューを提供します。また、完全な WYSIWYG (what you see is what you get) 環境で、レイアウトを変更したり、スタイルを適用したり、条件付き書式を適用したりすることもできます。

データ ビューをページに挿入した後も WYSIWYG ツールOffice SharePoint Designer 2007でに使えるを追加または列を削除する、フォントの書式を変更または色を適用します。データ ビューの書式を設定するには、WYSIWYG Office SharePoint Designer 2007で利用できるツールを使用して、拡張スタイル シート言語 (XSL) を HTML に直接挿入されます。コード ビューで直接 XSL を編集することはできますが、XSL をすばやく適用するのには、 Office SharePoint Designer 2007し、XSL を知らなくても簡単に書式設定ツールを使用することができます。

ページの先頭へ

サンプル データ ソースとなる .xml ファイルを作成する

高級食品流通企業の Northwind Traders では、商品リストを XML 形式で管理しています。この商品リストには、在庫情報が含まれています。現在は、担当チームがレポートを印刷し、これを他のチームに配布することで、在庫を追跡しています。そこで、イントラネット サイト上にデータ ビューを作成して、会社の全チームがすばやく簡単に商品在庫情報を確認できるようにし、印刷された在庫レポートを用意しなくても済むようにしてはどうかと提案しました。

以下の手順では、データ ソースとして .xml ファイルを使用する必要があります。SharePoint サイトに .xml ファイルがない場合は、まずサンプルとして Northwind Traders 商品リストを作成する必要があります。リストを作成すると、データ ビューを使用してリストに含まれるデータのビューを作成することができます。

products.xml を作成する

  1. [ファイル] メニューの [サイトを開く] をクリックします。

  2. [サイトを開く] ダイアログ ボックスで、SharePoint サイトを参照して選択し、[開く] をクリックします。

  3. 入力を求められたら、[接続先] ダイアログ ボックスでユーザー名とパスワードを入力し、[OK] をクリックします。

  4. [ファイル] メニューの [新規作成] をクリックします。

  5. [新規作成] ダイアログ ボックスで、[テキスト ファイル] をダブルクリックします。

    Web サイトで新しいテキスト ファイルが開きます。

  6. 次のコードを選択し、Ctrl キーを押しながら C キーを押して、これをコピーします。

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. Office SharePoint Designer 2007 で、ページの先頭にカーソルを置き、Ctrl キーを押しながら V キーを押して、コピーしたコードをこのページに貼り付けます。

  8. [ファイル] メニューの [名前を付けて保存] をクリックします。

  9. 名前を付けて保存] ダイアログ ボックスのファイル名] ボックスに、 products.xmlを入力します。

  10. [ファイルの種類] ボックスの一覧で [XML] をクリックし、[保存] をクリックします。

ページの先頭へ


データ ソースをページにドラッグしてデータ ビューを作成する

データ ソースをページにドラッグすると、結果は、基本的な表の行ごとに表示されるデータ ソース内の先頭の 5 つのフィールドを使用してデータの既定のビューです。ただし、データ ビューでは完全にカスタマイズできます。データ ビューを挿入した後ために列を追加またはニーズに合わせてデータ ビューから列を削除する簡単にできます。詳細については、「データ ビューで列を変更する」を参照してください。

データ ビューは、Microsoft ASP.NET 2.0 テクノロジを基盤としています。データ ビューを作成するには、ASP.NET ページ (.aspx ファイル) を用意する必要があります。以下の例では、新しい ASP.NET ページを作成し、その後、データ ソースをページ上にドラッグしてデータ ビューを作成します。

  1. [ファイル] メニューの [新規作成] をクリックします。

  2. [新規作成] ダイアログ ボックスで、[ASPX] をダブルクリックします。

    FORM タグを含んだ新規ページが表示されます。

    ASP.NET の form タグ

  3. 次のいずれかを実行します。

    • [フォルダ一覧] からデータ ソース (この例では products.xml) を検索し、これをページ上にドラッグします。

    • [作業ウィンドウ] メニューの [データ ソース ライブラリ] をクリックします。[データ ソース ライブラリ] 作業ウィンドウで、データ ソース (この例では products.xml) を検索し、これをページ上にドラッグします。

      ページ上にデータ ビューが表示され、[データ ソースの詳細] 作業ウィンドウが開きます。

      データ ソースをドラッグして作成した、先頭の 5 フィールドを表示するデータ ビュー
      先頭の 5 フィールドが、基本的なテーブルのレイアウトで表示されます。

ページの先頭へ


[データ ソースの詳細] 作業ウィンドウを使用してデータ ビューを作成する

[データ ソースの詳細] 作業ウィンドウを使用してデータ ビューを作成するには、まずデータ ビューをページに挿入します。次に、SharePoint サイトで利用可能なデータ ソースを管理するための作業ウィンドウである [データ ソース ライブラリ] から、データ ソースを選択します。データ ソースを選択すると、[データ ソースの詳細] 作業ウィンドウが開きます。[データ ソースの詳細] 作業ウィンドウで、表示するフィールドを選択し、これらのフィールドをデータ ビューに挿入します。

データ ビューは、ASP.NET 2.0 テクノロジを基盤としています。データ ビューを作成するには、ASP.NET ページ (.aspx ファイル) を用意する必要があります。以下の例では、新しい ASP.NET ページを作成し、その後、[データ ソースの詳細] 作業ウィンドウを使用してデータ ビューを作成します。

  1. [ファイル] メニューの [新規作成] をクリックします。

  2. [新規作成] ダイアログ ボックスで、[ASPX] をダブルクリックします。

    FORM タグを含んだ新規ページが表示されます。

    ASP.NET の form タグ

  3. [データ ビュー] メニューの [データ ビューの挿入] をクリックします。

    ページ上に空のデータ ビューが表示され、[データ ソース ライブラリ] 作業ウィンドウが開きます。

    空のデータ ビュー

    データ ビューを挿入できたので、次はデータを追加します。

  4. [データ ソース ライブラリ] 作業ウィンドウで、データ ソースを検索してこれをクリックし、[データの表示] をクリックします。

    この例では、[XML ファイル] の [products.xml] をクリックし、[データの表示] をクリックします。[XML ファイル] が折りたたまれている場合は、正符号 (+) をクリックして、これを展開します。

  5. [データ ソースの詳細] 作業ウィンドウで、データ ビューに挿入するフィールドをクリックします。

    ヒント: 複数のフィールドを選択するには、Ctrl キーを押しながらフィールドをクリックします。

    この例では、ProductsRoot フォルダの [Products] にある [ProductName] をクリックします。Ctrl キーを押しながら、[UnitsInStock]、[UnitsOnOrder]、[ReorderLevel] をクリックします。

    [データ ソースの詳細] 作業ウィンドウで選択されたフィールド

  6. [選択したフィールドの挿入] をクリックし、[複数アイテム ビュー] をクリックして、選択したデータをデータ ビューに挿入します。

    注: [単一アイテム ビュー] を選択した場合は、データ ビューに 1 レコードのみが表示されます。[複数アイテム ビュー] を選択した場合は、各フィールドが列に割り当てられ、各列に見出しが付けられた状態で、複数のレコードが表示されます。

    [データ ソースの詳細] 作業ウィンドウで選択したフィールドが、テーブル形式で表示されます。

    データ ビューに表示された products.xml

    データ ビューを作成した後で、[書式設定] ツールバーなどの WYSIWIG ツールを使用して、フォントの変更、テキストの整列、色の適用などを行うことができます。新しい書式をデータ ビューのデータ要素に適用と、Office SharePoint Designer 2007 では、ページに関連付けられている XSLT スタイル シートが変更され、XML 内で同じレベルにあるすべてのデータにこの書式が適用されます。たとえば、上の図の例で [Chai] を選択し、[書式設定] ツールバーの [太字] をクリックすると、Office SharePoint Designer 2007 によって、この書式が ProductName フィールドに表示されるすべてのコンテンツに適用されます。

    ProductName フィールドのすべてのデータに適用された太字書式

ページの先頭へ


次に参照するトピック

データ ビューは、強力で、完全にカスタマイズ可能なライブ データのビューです。ここでは、データ ビューを作成する方法を学習しましたが、以下の操作についても学習されることをお勧めします。

  • データ ビューでデータをフィルター処理   データ ビュー内のデータを簡単にフィルター処理できます。詳細については、データ ビューでデータをフィルター処理を参照してください。

  • 並べ替えデータ ビューでデータをグループ化と    すばやく並べ替えるしたり、データ ビュー内のデータをグループ化できます。詳細については、次を参照してください。並べ替えデータ ビューでデータをグループ化とします。

  • 条件付き書式のデータ ビューに適用します。   データ ビュー内のデータが特定の条件を満たしている場合、データ ビューに特定書式を適用することができます。詳細については、条件付き書式のデータ ビューの適用を参照してください。

  • データ ビューで数式列を作成します。    スプレッドシートと同様に、データ ビューでその他の列の合計を計算の結果を表示する集計列を作成できます。たとえば、株価チャートの単位数で単価の積を求めるでき、別の列に、アイテムの合計値を表示できます。詳細については、データ ビューで数式列を作成するを参照してください。

  • データ ビューで列の変更   できますが、迅速かつ簡単に追加、削除、またはデータ ビューで列を配置します。詳細については、データ ビューで列を変更するを参照してください。

  • 単一のデータ ビューで複数のソースからデータを表示    2 つ以上の関連するデータ ソースにリンクし、1 つのデータ ビューでこれらのソースからデータを表示できます。詳細については、単一のデータ ビューで複数のソースからのデータの表示を参照してください。

  • データ ビューのサンプル データの表示    データ ビューのサンプル データを簡単に表示できます。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×