データ ソース ライブラリからデータ ソースを削除する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

不要になったデータ ソース接続は、データ ソース ライブラリから削除することができます。データ ソース ライブラリからデータ ソース接続を削除する方法は、データ ソースの種類や、データ ソースが置かれている場所によっても異なります。データ ソースの種類によっては、データ ソース ライブラリの [削除] コマンドが利用できません。この記事では、各種のデータ ソース接続を削除する方法について説明します。

重要: データ ソース接続をデータ ソース ライブラリから削除するということは、単にデータ ソース ライブラリに表示されているデータへの接続を削除するということです。データそのものには影響しません。

Microsoft SharePoint リストおよびライブラリ、ローカルの XML ファイルなど、データ ソース ライブラリから削除できないデータ ソース接続も存在します。SharePoint リストまたはライブラリ、あるいはローカルの XML ファイルを削除するには、元のソースをフォルダ一覧から削除する要があります。ただし、リスト、ライブラリ、XML ファイルの各データ ソース接続のコピーを削除することはできます。

目的に合ったトピックをクリックしてください

SharePoint リストまたはライブラリを削除します。

データベースへの接続を削除します。

XML ファイルを削除します。

サーバー サイド スクリプトを削除します。

XML Web サービスを削除します。

リンクされたデータ ソースを削除します。

SharePoint リストまたはライブラリを削除する

データ ソース ライブラリには、サイト内のすべての SharePoint リストまたはライブラリについて、対応するデータ ソース接続が既定で割り当てられます。このデータ ソース接続を削除するには、リストまたはライブラリそのものを削除するか、リストまたはライブラリがブラウザに表示されないようにするしかありません。ただし、データ ソース接続の "コピー" は削除できます。

リストまたはライブラリを削除する

SharePoint リストおよびライブラリでは、そのデータ ソース接続が、他のデータ ソース接続をコピーし、変更することによって作成されている場合に限り、[削除] コマンドを使用できます。

  1. データ ソース ライブラリが表示されていない場合は、[作業ウィンドウ] メニューの [データ ソース ライブラリ] をクリックします。

  2. データ ソース ライブラリで、削除するリストまたはライブラリをクリックし、[削除] をクリックします。

リストまたはライブラリを削除する

リストまたはライブラリを削除すると、そこに含まれているドキュメント、添付ファイル、およびサポート フォーム (AllItems.aspx や DispForm.aspx などのファイル) もすべて削除されます。データ ソース接続だけを削除し、リストまたはライブラリのデータを残しておく必要がある場合は、次のセクションに進み、リストまたはライブラリがブラウザに表示されないようにする手順を実行してください。

  1. [作業ウィンドウ] メニューの [フォルダ一覧] をクリックします。

  2. [フォルダ一覧] で、削除するリストまたはライブラリを右クリックし、ショートカット メニューの [削除] をクリックします。

リストまたはライブラリがブラウザに表示されないようにする

リストのプロパティを変更することによって、データ ソース ライブラリから SharePoint リストまたはライブラリを削除できます。ただし、この方法では、リストまたはライブラリがブラウザに表示されなくなるため、サイトの利用者が、リストまたはライブラリを閲覧できなくなります。リストまたはライブラリそのものを実際に削除することはせず、データ ソース接続として利用できなくすることが目的である場合に適した方法と言えます。

  1. [作業ウィンドウ] メニューの [フォルダ一覧] をクリックします。

  2. [フォルダ一覧] で、削除するリストまたはライブラリを右クリックし、ショートカット メニューの [プロパティ] をクリックします。

  3. [リストのプロパティ] ダイアログ ボックスの [設定] タブをクリックし、[ブラウザに表示しない] チェック ボックスをオンにします。

    ヒント: この時点でデータ ソース接続がデータ ソース ライブラリに表示されている場合は、[データ ソース ライブラリ] 作業ウィンドウの一番下に表示される [ライブラリの更新] をクリックしてください。

次の図は、お知らせリストがデータ ソース ライブラリに表示されないようにブラウザで非表示にした例です。

お知らせリストがデータ ソース ライブラリに表示されないようブラウザで非表示にした例

ページの先頭へ

データベース接続を削除する

  1. [作業ウィンドウ] メニューの [データ ソース ライブラリ] をクリックします。

  2. [データ ソース ライブラリ] 作業ウィンドウで、削除するデータベース接続をクリックし、[削除] をクリックします。

ページの先頭へ

XML ファイルを削除する

データ ソース ライブラリから XML ファイルを削除する方法は、その XML ファイルが外部のサイトに存在するか、ローカル サイトに存在するかによって異なります。ローカル サイトの XML ファイルは常にフォルダ一覧に表示され、データ ソース ライブラリには、対応するデータ ソース接続が既定で割り当てられます。この場合、データ ソース接続を削除するには、.xml ファイルそのものを削除する必要があります。

XML ファイルで [削除] コマンドを使用できるのは、次の場合に限られます。

  • XML ファイルが外部のサイトに存在する場合

  • 別のデータ ソース接続をコピーし変更することによって作成されたデータ ソースである場合

ローカルの XML ファイルを削除する

XML ファイルのデータ ソース接続をデータ ソース ライブラリから削除するには、元のファイルをフォルダ一覧から削除する必要があります。削除するファイルは、あらかじめエクスポートして別の場所に保存しておくことをお勧めします。

ローカルの XML ファイルをエクスポートする

  1. [作業ウィンドウ] メニューの [フォルダ一覧] をクリックします。

  2. [フォルダ一覧] で、エクスポートする .xml ファイルをクリックします。

  3. [ファイル] メニューの [エクスポート] をポイントして、[ファイル] をクリックします。

  4. [ファイルのエクスポート] ダイアログ ボックスで、現在とは異なる場所を指定し、[保存] をクリックします。

    注: フォルダ一覧に .xml ファイルが表示されないようにするには、ファイルを現在のサイトとは異なる場所に保存する必要があります。

ローカルの XML ファイルを削除する

  1. [作業ウィンドウ] メニューの [フォルダ一覧] をクリックします。

  2. [フォルダ一覧] で、削除する .xml ファイルを右クリックし、ショートカット メニューの [削除] をクリックします。

外部の XML ファイルを削除する

  1. [作業ウィンドウ] メニューの [データ ソース ライブラリ] をクリックします。

  2. [データ ソース ライブラリ] 作業ウィンドウで、削除する .xml ファイルをクリックし、[削除] をクリックします。

ページの先頭へ

サーバーサイド スクリプトを削除する

  1. [作業ウィンドウ] メニューの [データ ソース ライブラリ] をクリックします。

  2. [データ ソース ライブラリ] 作業ウィンドウで、削除するサーバーサイド スクリプトをクリックし、[削除] をクリックします。

ページの先頭へ

XML Web サービスを削除する

  1. [作業ウィンドウ] メニューの [データ ソース ライブラリ] をクリックします。

  2. [データ ソース ライブラリ] 作業ウィンドウで、XML Web サービスをクリックし、[削除] をクリックします。

ページの先頭へ

リンクされているデータ ソースを削除する

  1. [作業ウィンドウ] メニューの [データ ソース ライブラリ] をクリックします。

  2. [データ ソース ライブラリ] 作業ウィンドウで、リンクされているデータ ソースをクリックし、[削除] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×